Subject: [Iasa20] Magnus Westerlund's Discuss on draft-ietf-iasa2-rfc4071bis-08: (with DISCUSS)

From: Magnus Westerlund via Datatracker <[email-masked]>
Date: Tue, 09 Apr 2019 03:24:13 -0700

Magnus Westerlund has entered the following ballot position for
draft-ietf-iasa2-rfc4071bis-08: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-iasa2-rfc4071bis/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Having not followed this at all I do see some question marks in regards to the
IRTF that I would like to have clarification on thus the Discuss position.

Why isn't IRTF disucssed in this section, or having its own section of similar
nature?

4.6.  Relationship of the IETF LLC Board to the IETF Leadership

   The IETF LLC Board is directly accountable to the IETF community for
   the performance of the IASA 2.0.  However, the nature of the Board's
   work involves treating the IESG and IAB as major internal customers
   of the administrative support services.  The Board and the IETF
   Executive Director should not consider their work successful unless
   the IESG and IAB are also satisfied with the administrative support
   that the IETF is receiving.

Can someone please explain why the IETF LLC role for IRTF are almost not at all
described? For example is IRTF not a significant internal customer?

Also, what is the relation between the IRTF and IETF community? As the IETF
community does not appear to have a definition, it is not possible to determine
if IRTF is counted as part of the IETF community or not. In my thinking the
IETF and IRTF communities are not the same set, and it is not obvious that IETF
community is the super set.

I think some clarification on the IRTFs relation are needed in this document.

---

From: Ted Hardie <[email-masked]>
Date: Tue, 9 Apr 2019 08:56:48 -0700

Hi Magnus,

> https://datatracker.ietf.org/doc/draft-ietf-iasa2-rfc4071bis/
The administrative support for the IRTF has historically been bundled into
either the support of the IAB or to the meeting support (when the RGs are
meeting at the IETF meeting).   The IRTF chair, as a member of the IAB,
would be able to express concerns she or he had with the administrative
support services.

This doesn't mean that the LLC Board couldn't seek out the input of the
IRTF chair for direct discussion of concerns; this section describes what
the board must do, but doesn't limit them to only that.

> community is the super set.
I think we use IETF in two ways.  This first encompasses the set of working
groups and structures that support the standards process,  and the second
is used more broadly, to include the IAB, IRTF, Hackathon, RFC series and
other parts of the Internet technical community which are gathered here.  I
think when we say "IETF community", we generally mean the second, because
we have no better term.  We could change the title to say something like
"Relationship of the IETF LLC Board to the other Leadership groups", but I
am not personally sure that is an improvement.

> I think some clarification on the IRTFs relation are needed in this
I don't really want to open RFC 4440 or BCP 8 for this, so I would be
interested to know what you think the minimum clarification here would be.
Would adding the IRTF as an additional internal customer be sufficient?

Ted

>
>
>
> _______________________________________________
> iasa20 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iasa20
>

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Tue, 9 Apr 2019 12:02:41 -0400

On Tue, Apr 9, 2019 at 11:57 AM Ted Hardie <[email-masked]> wrote:

> I think we use IETF in two ways.  This first encompasses the set of
> working groups and structures that support the standards process,  and the
> second is used more broadly, to include the IAB, IRTF, Hackathon, RFC
> series and other parts of the Internet technical community which are
> gathered here.  I think when we say "IETF community", we generally mean the
> second, because we have no better term.  We could change the title to say
> something like "Relationship of the IETF LLC Board to the other Leadership
> groups", but I am not personally sure that is an improvement.
>
>

Yes, here in 4.6 we tried to talk about "major" internal customers with the
understanding that there are other not-as-major... I'd also be interested
in what a minimal clarification here that would be important to make in
this document. best, joe

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 9 Apr 2019 15:40:14 -0400

Hi Magnus,

> On Apr 9, 2019, at 6:24 AM, Magnus Westerlund via Datatracker <[email-masked]> wrote:
> 

While a lot of text in this document is new, it was influenced initially by RFC 4071. RFC 4071 mentions the IRTF once. Some clarification in 4071bis seems fine, but just wanted to point that out.

Alissa

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 10 Apr 2019 08:41:38 +0000

On 2019-04-09 18:03, Joseph Lorenzo Hall wrote:

On Tue, Apr 9, 2019 at 11:57 AM Ted Hardie <[email-masked]<mailto:[email-masked]>> wrote:
Hi Magnus,

On Tue, Apr 9, 2019 at 3:24 AM Magnus Westerlund via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Magnus Westerlund has entered the following ballot position for
draft-ietf-iasa2-rfc4071bis-08: Discuss

The administrative support for the IRTF has historically been bundled into either the support of the IAB or to the meeting support (when the RGs are meeting at the IETF meeting).   The IRTF chair, as a member of the IAB, would be able to express concerns she or he had with the administrative support services.

This doesn't mean that the LLC Board couldn't seek out the input of the IRTF chair for direct discussion of concerns; this section describes what the board must do, but doesn't limit them to only that.

I think we use IETF in two ways.  This first encompasses the set of working groups and structures that support the standards process,  and the second is used more broadly, to include the IAB, IRTF, Hackathon, RFC series and other parts of the Internet technical community which are gathered here.  I think when we say "IETF community", we generally mean the second, because we have no better term.  We could change the title to say something like "Relationship of the IETF LLC Board to the other Leadership groups", but I am not personally sure that is an improvement.

I understand that defining IETF community is potentially tricky and also not necessarily long term stable for things at the edge of that definition. I also don't think helps, as then you suddenly excluded the IRTF from the IETF community. I perceive the intention here is to count the IRTF as part of that second larger IETF community. Thus, it should be clear that they are included.

I don't really want to open RFC 4440 or BCP 8 for this, so I would be interested to know what you think the minimum clarification here would be.  Would adding the IRTF as an additional internal customer be sufficient?

Yes, here in 4.6 we tried to talk about "major" internal customers with the understanding that there are other not-as-major... I'd also be interested in what a minimal clarification here that would be important to make in this document. best, joe

I think if one include the IRTF as  major internal customers, I think that helps quite a lot to ensure that IRTF is included in the IETF community context.

Cheers

Magnus Westerlund

----------------------------------------------------------------------
Network Architecture & Protocols, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]<mailto:[email-masked]>
----------------------------------------------------------------------

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 10 Apr 2019 07:55:18 -0400

On Wed, Apr 10, 2019 at 4:41 AM Magnus Westerlund <
[email-masked]> wrote:

>>> Please refer to
>>> https://www.ietf.org/iesg/statement/discuss-criteria.html
>> The administrative support for the IRTF has historically been bundled
>> into either the support of the IAB or to the meeting support (when the RGs
>> are meeting at the IETF meeting).   The IRTF chair, as a member of the IAB,
> I understand that defining IETF community is potentially tricky and also
> not necessarily long term stable for things at the edge of that definition.
> I also don't think helps, as then you suddenly excluded the IRTF from the
> IETF community. I perceive the intention here is to count the IRTF as part
> of that second larger IETF community. Thus, it should be clear that they
> are included.
>
>
>
>>
> Yes, here in 4.6 we tried to talk about "major" internal customers with
> the understanding that there are other not-as-major... I'd also be
> interested in what a minimal clarification here that would be important to
> make in this document. best, joe
>
> I think if one include the IRTF as  major internal customers, I think that
> helps quite a lot to ensure that IRTF is included in the IETF community
> context.
>
To boil this down to text, would this be sufficient in your view, Magnus?:

OLD

NEW

The IETF LLC Board is directly accountable to the IETF community for
   the performance of the IASA 2.0.  However, the nature of the Board's
   work involves treating the IESG, IRSG, and IAB as major internal
customers
   of the administrative support services.  The Board and the IETF
   Executive Director should not consider their work successful unless
   the IESG, IRSG, and IAB are also satisfied with the administrative
support
   that the IETF is receiving.

-- 
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked], p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 10 Apr 2019 13:53:09 +0000

On 2019-04-10 13:55, Joseph Lorenzo Hall wrote:

OLD

NEW

The IETF LLC Board is directly accountable to the IETF community for
   the performance of the IASA 2.0.  However, the nature of the Board's
   work involves treating the IESG, IRSG, and IAB as major internal customers
   of the administrative support services.  The Board and the IETF
   Executive Director should not consider their work successful unless
   the IESG, IRSG, and IAB are also satisfied with the administrative support
   that the IETF is receiving.

On the high level principle this would be fine. However, it makes me ask the first question if IRSG is the right entity. It likely are, but I lack the insight into IRTF management to say that. Secondly, this will be the first mention of the IRSG in the document. So some introduction or at least reference appears to be needed.

Cheers

Magnus Westerlund

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 10 Apr 2019 14:36:23 +0000

> On the high level principle this would be fine. However, it makes me ask the first question if IRSG is the right entity. It likely are, but I lack the insight into IRTF management to say that. Seco…

[JL] I am not sure why we’d say IRSG instead of just IRTF, which is what we already say in 4.1 under the definition for the IETF LLC. Thus, my preference is IRTF (see below) to keep it simple & consistent. I think this also means we need to add the IRTF to the terminology section in 4.1.
The IETF LLC Board is directly accountable to the IETF community for
   the performance of the IASA 2.0.  However, the nature of the Board's
   work involves treating the IESG, IRTF, and IAB as major internal customers
   of the administrative support services.  The Board and the IETF
   Executive Director should not consider their work successful unless
   the IESG, IRTF, and IAB are also satisfied with the administrative support
   that the IETF is receiving.

---

From: "Leslie Daigle" <[email-masked]>
Date: Wed, 10 Apr 2019 10:46:56 -0400

Agreed with the point about “IRSG”.  The IRTF Steering Group is 
appointed and functions differently than the IAB or IESG.  I believe it 
is intended to “advise” the IRTF Chair.

So, I think the new text s/IRSG/IRTF/ is fine.

Leslie.

-- 

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------

On 10 Apr 2019, at 9:53, Magnus Westerlund wrote:

> On the high level principle this would be fine. However, it makes me 
> ask the first question if IRSG is the right entity. It likely are, but 
> I lack the insight into IRTF management to say that. Secondly, this 
> will be the first mention of the IRSG in the document. So some 
> introduction or at least reference appears to be needed.
>
> Cheers
>
> Magnus Westerlund
>
> SE-164 80 Stockholm, Sweden | mailto: 
> [email-masked]<mailto:[email-masked]>

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 10 Apr 2019 11:38:30 -0400

+1, sounds good

On Wed, Apr 10, 2019 at 10:47 AM Leslie Daigle <[email-masked]>
wrote:

> Agreed with the point about “IRSG”. The IRTF Steering Group is appointed
> and functions differently than the IAB or IESG. I believe it is intended to
> “advise” the IRTF Chair.
>
> ------------------------------
>
> Leslie Daigle
> On the high level principle this would be fine. However, it makes me ask
> the first question if IRSG is the right entity. It likely are, but I lack
> the insight into IRTF management to say that. Secondly, this will be the
> first mention of the IRSG in the document. So some introduction or at least
> reference appears to be needed.
>
> Cheers
>
> Magnus Westerlund
>
> SE-164 80 Stockholm, Sweden | mailto: [email-masked]

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 11 Apr 2019 07:42:25 +0000

Hi,

I am also fine with just saying IRTF. Will clear my discuss when incorporated.

Cheers

Magnus

On 2019-04-10 17:39, Joseph Lorenzo Hall wrote:
+1, sounds good

On Wed, Apr 10, 2019 at 10:47 AM Leslie Daigle <[email-masked]<mailto:[email-masked]>> wrote:

Agreed with the point about “IRSG”. The IRTF Steering Group is appointed and functions differently than the IAB or IESG. I believe it is intended to “advise” the IRTF Chair.

Leslie.

--

________________________________

Leslie Daigle

[email-masked]<mailto:[email-masked]>

OLD

NEW

Cheers

Magnus Westerlund

_______________________________________________
iasa20 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/iasa20

--
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005-3497
e: [email-masked]<mailto:[email-masked]>, p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

--

Magnus Westerlund

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Thu, 11 Apr 2019 06:10:55 -0400

Change was posted in the new -09

On Thu, Apr 11, 2019 at 03:42 Magnus Westerlund <
[email-masked]> wrote:

>> Ericsson AB                 | Phone  +46 10 7148287Torshamnsgatan 23 <https://maps.google.com/?q=Torshamnsgatan+23&entry=gmail&source=g>           | Mobile +46 73 0949079
> 1401 K ST NW STE 200, Washington DC 20005
> <https://maps.google.com/?q=1401+K+ST+NW+STE+200,+Washington+DC+20005&entry=gmail&source=g>
> -3497
> Ericsson AB                 | Phone  +46 10 7148287Torshamnsgatan 23 <https://maps.google.com/?q=Torshamnsgatan+23&entry=gmail&source=g>           | Mobile +46 73 0949079
Joseph Lorenzo Hall

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 11 Apr 2019 11:19:15 +0000

Thanks,

I missed that there where a new version. I have cleared.

Cheers

Magnus

On 2019-04-11 12:11, Joseph Lorenzo Hall wrote:
Change was posted in the new -09

On Thu, Apr 11, 2019 at 03:42 Magnus Westerlund <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Cheers

Magnus

Leslie.

--

Leslie Daigle

OLD

NEW

Cheers

Magnus Westerlund

Torshamnsgatan 23<https://maps.google.com/?q=Torshamnsgatan+23&entry=gmail&source=g>           | Mobile +46 73 0949079

--
Joseph Lorenzo Hall
Chief Technologist, Center for Democracy & Technology [https://www.cdt.org]
1401 K ST NW STE 200, Washington DC 20005<https://maps.google.com/?q=1401+K+ST+NW+STE+200,+Washington+DC+20005&entry=gmail&source=g>-3497
e: [email-masked]<mailto:[email-masked]>, p: 202.407.8825, pgp: https://josephhall.org/gpg-key
Fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871

--

Magnus Westerlund

Torshamnsgatan 23<https://maps.google.com/?q=Torshamnsgatan+23&entry=gmail&source=g>           | Mobile +46 73 0949079

--

Magnus Westerlund