Subject: [iccrg] PIE Simulation Code

From: Naeem Khademi <[email-masked]>
Date: Wed, 6 Mar 2013 21:31:46 +0100

Hi

Thanks a lot! that's a very good news as the folks can now start testing
PIE versus fq_codel and other AQMs. Any chance of a Linux module patch for
PIE some time soon?

Regards,
Naeem Khademi

---------- Forwarded message ----------
> From: Preethi Natarajan <[email-masked]>
> To: <[email-masked]>, <[email-masked]>
> Cc:
> Date: Wed, 06 Mar 2013 10:26:19 -0800
> Subject: [iccrg] PIE Simulation Code
> Hi all,
>
> Few weeks ago, the PIE (Proportional Integral Controller Enhanced) AQM
> scheme was described in this initial draft --
> http://tools.ietf.org/html/draft-pan-tsvwg-pie-00.
>
> As follow up, the corresponding pseudocode and ns-2 simulation code +
> README can be found here -- ftp://ftpeng.cisco.com/fred/ropan/
>
> Best,
> Preethi (on behalf of co-authors).
>
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg
>
>

---

From: Preethi Natarajan <[email-masked]>
Date: Wed, 06 Mar 2013 12:41:51 -0800

Hi Naeem,

Thanks for your interest.

Yes, we do have PIE implementation as a Linux module, and we plan to make
this publicly available. We are fielding a few legal issues on this front.
Hopefully we can get the code out in a few weeks.

Best,
Preethi

From:  Naeem Khademi <[email-masked]>
Date:  Wednesday, March 6, 2013 12:31 PM
To:  <[email-masked]>
Subject:  [iccrg]  PIE Simulation Code

Hi 

Thanks a lot! that's a very good news as the folks can now start testing PIE
versus fq_codel and other AQMs. Any chance of a Linux module patch for PIE
some time soon?   

Regards,
Naeem Khademi

> Few weeks ago, the PIE (Proportional Integral Controller Enhanced) AQM scheme
> was described in this initial draft --
> As follow up, the corresponding pseudocode and ns-2 simulation code + README
> can be found here -- ftp://ftpeng.cisco.com/fred/ropan/
> 
> Best,

_______________________________________________ iccrg mailing list
[email-masked] https://www.irtf.org/mailman/listinfo/iccrg