Subject: Re: [iccrg] The NorNet Research Testbed for Multi-Homed Systems

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 06 May 2013 16:42:52 +0200

Hi Dave,

Tirsdag 30. april 2013 05.20.25 skrev Dave Taht:
> Heh. RTTs in the 10+ second range at this concert...
> 
> http://www.nornet-testbed.no/2013/04/18/nornet-edge-observed-mobile-networks
> -during-justin-biber-concerts/
> 
> I have a ton of wired and wifi data from "the gathering" in oslo that
> I'm still sorting through, but the early wifi data was similarly
> awful. They tuned it up significantly by the last day of the show,
> however, and I'm still sorting through it.

This sounds very interesting. If you have found something interesting, please 
let us know!

-- 
Best regards / Mit freundlichen Grüßen / Med vennlig hilsen

=======================================================================
 Thomas Dreibholz

 Simula Research Laboratory
 Simula Innovation AS, Network Systems Group
 Visiting address: Martin Linges vei 17, 1364 Fornebu, Norway
 Mailing address:  P.O.Box 134, 1325 Lysaker, Norway
-----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://simula.no/people/dreibh
=======================================================================

---

From: Thomas Dreibholz <[email-masked]>
Date: Mon, 06 May 2013 16:47:28 +0200

Hi Dave,

Tirsdag 30. april 2013 05.10.11 skrev Dave Taht:
> oh, cool. Are you doing any work with the RITE people?

Do you mean RIPE?

Actually, we have also deployed a RIPE Atlas measurement node with our NorNet 
setup in Longyearbyen (Svalbard islands): http://www.nornet-testbed.no/2013/02/12/nornet-cooperates-with-ripe-ncc/ .

> On Tue, Apr 30, 2013 at 5:07 AM, Thomas Dreibholz <[email-masked]> 
wrote:
> > Hi all,
> > 
> > the Simula Research Laboratory in Fornebu, Norway (https://simula.no/) is
> > currently building up a large-scale Internet testbed for multi-homed
> > systems. Therefore, this could be of interest for all researchers doing
> > work on congestion control for multi-homed systems, i.e. particularly
> > also for multi- path transport protocols like MPTCP and CMT-SCTP.
> > 
> > Our website http://www.nntb.no/ now contains some up-to-date information
> > on
> > the NorNet project. The NorNet project is funded by the Research Council
> > of
> > Norway (Forskningsrådet) as part of the INFRASTRUKTUR programme and will
> > be an open platform for all researchers on multi-homed systems, probably
> > in a similar way as PlanetLab. Also, within the next few months --
> > possibly in the late summer/early autumn -- we will provide a workshop
> > for interested researchers at the Simula Research Laboratory in Fornebu.
> > More details will follow soon on our website.
> > 
> > 
> > Links:
> > - NorNet website: https://simula.no/
> > - Simula Research Laboratory: http://www.nntb.no/
> > - INFRASTRUKTUR (in Norwegian):
> > http://www.forskningsradet.no/servlet/Satellite?c=Nyhet&pagename=infrastru
> > ktur%2FHovedsidemal&cid=1253966339813

---

From: Michael Welzl <[email-masked]>
Date: Mon, 6 May 2013 20:45:31 +0200

I guess he means the RITE project:
http://riteproject.eu

On May 6, 2013, at 4:47 PM, Thomas Dreibholz <[email-masked]> wrote:

> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg

---

From: Dave Taht <[email-masked]>
Date: Mon, 6 May 2013 12:14:56 -0700

> I guess he means the RITE project:

Yes. They have a budget at least 4m euro larger than bufferbloat.net's,
there's a team of academics and researchers like Bob Briscoe on the case,
and they have a lovely website and have held meetings all over the place.

I don't know a lot about what they are up to but I expect great results any
day now. After it starts working out, their testbeds go up , and the papers
and research turn into code, I hope to be able to shut down things like the
cerowrt effort and just sit back and watch the internet get faster, boat
drink in hand.

> > setup in Longyearbyen (Svalbard islands):
http://www.nornet-testbed.no/2013/02/12/nornet-cooperates-with-ripe-ncc/ .

---

From: Michael Welzl <[email-masked]>
Date: Mon, 6 May 2013 21:27:23 +0200

On May 6, 2013, at 9:14 PM, Dave Taht <[email-masked]> wrote:

> Yes. They have a budget at least 4m euro larger than bufferbloat.net's, there's a team of academics and researchers like Bob Briscoe on the case, and they have a lovely website and have held meetings all over the place.

Not to mention the *true* celebrities like mice elf! Heck, even Justin Bieber wanted to join us, his argument being that he managed to influence Internet latency on several occasions, but we had to tell him to go away.

> I don't know a lot about what they are up to but I expect great results any day now. After it starts working out, their testbeds go up , and the papers and research turn into code, I hope to be able to shut down things like the cerowrt effort and just sit back and watch the internet get faster, boat drink in hand.

We have this plan to remove all the queues of the world, and packets too. We'll turn the Internet to a POTS-style network, which really had so much less latency!
AQM becomes pointless, because: what to control, when there are no more queues, let alone packets? It'll be fabulous, just wait   :-D

Cheers,
Michael

PS: it's a "normal" research project - most of us keep on doing what we were planning to do anyway, but together, and hopefully some good stuff will come from that, but most of us don't have world domination plans just yet  :-)     plus, give us some time please   :-)

PPS: some examples of work funded by RITE, even though not all current drafts say it (yet):
http://tools.ietf.org/id/draft-fairhurst-tcpm-newcwv-05.txt
http://tools.ietf.org/html/draft-ietf-tcpm-rtorestart-00
http://tools.ietf.org/html/draft-welzl-rmcat-coupled-cc-00
…and much more stuff will appear at http://riteproject.eu
As this work shows, our focus *is* on reducing latency, but this is not *only* AQM (although it's definitely a part of what we look at).