Subject: [iccrg] Workshop on Reducing Internet Latency - call for position papers

From: Matthew Ford <[email-masked]>
Date: Tue, 11 Jun 2013 12:20:42 +0100

I thought I had already posted this here, but don't see my earlier note in the archives. Anyway, the dates have now been finalised and this workshop will take place on 25-26 September in London.

Please note there are now less than two weeks to the deadline for submitting short position papers if you are interested in attending.

Regards,
Mat

Workshop on Reducing Internet Latency
=====================================
25 - 26 September 2013
London, England

Latency tends to have been sacrificed in favour of headline bandwidth in the way the Internet has been built. This two-day invitation-only workshop aims to galvanise action to fix that. All layers of the stack are in scope.
Latency is an increasingly important topic for networking researchers and Internet practitioners alike. Data from Google, Microsoft, Amazon and others indicate that latency increases for interactive Web applications result in less usage and less revenue from sales or advertising income. Whether trying to provide platforms for Web applications, high-frequency stock trading, multi-player online gaming or 'cloud' services of any kind, latency is a critical factor in determining end-user satisfaction and the success of products in the marketplace. Consequently, latency and variation in latency are key performance metrics for services these days.

But latency reduction is not just about increasing revenues for big business. Matt Mullenweg of WordPress motivates work on latency reduction well when he says, "My theory here is when an interface is faster, you feel good. And ultimately what that comes down to is you feel in control. The [application] isn’t controlling me, I’m controlling it. Ultimately that feeling of control translates to happiness in everyone. In order to increase the happiness in the world, we all have to keep working on this."

Invitations to attend the workshop will depend on receipt of a position paper. In a spirit of co- ordination across the industry, submissions are encouraged from developers and network operators as well as the research and standards communities.

A wide range of latency related topics are in scope including, but not limited to:
- surveys of latency across all layers
- analyses of sources of latency and severity/variability
- the cost of latency problems to society and the economy, or the value of fixing it
- principles for latency reduction across the stack
- solutions to reduce latency, including cross-layer
- deployment considerations for latency reducing technology
- benchmarking, accreditation, measurement and market comparison practices

Submissions
-----------
This is an invitation-only workshop. Prospective participants must submit short (up to 2 pages) position papers outlining their views on a specific aspect of the overall scope. The emphasis here is on relevance and brevity - you do not need to write a lot of text, just demonstrate that you have thought about the problem space and have something interesting to say on the topic.

Please send position papers in PDF format to: [email-masked]

Participant numbers will be limited to focus on discussion and identifying actions rather than slideware.
Accepted position papers will be made public. A report on the workshop will be published after participants have agreed the content. Therefore, it will be possible to state views during the workshop without them being publicly attributed.

Important Dates
---------------
Position paper submission deadline: 23 June 2013
Paper acceptance notification: 28 June 2013
Workshop dates: 9am, Wednesday 25th – 5pm, Thursday 26th September 2013

Program committee
-----------------
Mat Ford, Internet Society, co-chair
Bob Briscoe, BT, co-chair
Gorry Fairhurst, University of Aberdeen
Arvind Jain, Google
Jason Livingood, Comcast
Andrew McGregor, Google

Workshop venue and other details
--------------------------------
Venue: Hilton London Paddington Hotel, 146 Praed Street, LONDON W2 1EE, UK
Registration fee: There is no registration fee for the workshop.
Recommended accommodation: Hilton London Paddington, registration link will be supplied to accepted participants.

The workshop is sponsored by the Internet Society, the RITE project, Simula Research Labs and the TimeIn project.
The Internet Society will host a workshop dinner on the Wednesday evening.

---

From: Matt Mathis <[email-masked]>
Date: Tue, 11 Jun 2013 10:56:21 -0700

There is something about this workshop I don't understand:  Who is the
audience?

The way you have it set up, it is most likely that the attendees will all
be working on improving some aspect of latency, and they already understand
its importance.

The people who you really need to reach are the ones who own some key part
of the problem, but don't know it.  But by definition they will not be
present.

I suspect that everyone present will all be in violent agreement.    How
will this make the network better?

Thanks,
--MM--
The best way to predict the future is to create it.  - Alan Kay

Privacy matters!  We know from recent events that people are using our
services to speak in defiance of unjust governments.   We treat privacy and
security as matters of life and death, because for some users, they are.

On Tue, Jun 11, 2013 at 4:20 AM, Matthew Ford <[email-masked]> wrote:

> I thought I had already posted this here, but don't see my earlier note in
> the archives. Anyway, the dates have now been finalised and this workshop
> will take place on 25-26 September in London.
>
> Please note there are now less than two weeks to the deadline for
> submitting short position papers if you are interested in attending.
>
> Regards,
> Mat
>
> Latency tends to have been sacrificed in favour of headline bandwidth in
> the way the Internet has been built. This two-day invitation-only workshop
> aims to galvanise action to fix that. All layers of the stack are in scope.
> Latency is an increasingly important topic for networking researchers and
> Internet practitioners alike. Data from Google, Microsoft, Amazon and
> others indicate that latency increases for interactive Web applications
> result in less usage and less revenue from sales or advertising income.
> Whether trying to provide platforms for Web applications, high-frequency
> stock trading, multi-player online gaming or 'cloud' services of any kind,
> latency is a critical factor in determining end-user satisfaction and the
> success of products in the marketplace. Consequently, latency and variation
> in latency are key performance metrics for services these days.
>
> But latency reduction is not just about increasing revenues for big
> business. Matt Mullenweg of WordPress motivates work on latency reduction
> well when he says, "My theory here is when an interface is faster, you feel
> good. And ultimately what that comes down to is you feel in control. The
> [application] isn’t controlling me, I’m controlling it. Ultimately that
> feeling of control translates to happiness in everyone. In order to
> increase the happiness in the world, we all have to keep working on this."
>
> Invitations to attend the workshop will depend on receipt of a position
> paper. In a spirit of co- ordination across the industry, submissions are
> encouraged from developers and network operators as well as the research
> and standards communities.
>
> This is an invitation-only workshop. Prospective participants must submit
> short (up to 2 pages) position papers outlining their views on a specific
> aspect of the overall scope. The emphasis here is on relevance and brevity
> - you do not need to write a lot of text, just demonstrate that you have
> thought about the problem space and have something interesting to say on
> the topic.
>
> Accepted position papers will be made public. A report on the workshop
> will be published after participants have agreed the content. Therefore, it
> will be possible to state views during the workshop without them being
> publicly attributed.
>
> Important Dates
> ---------------
> Recommended accommodation: Hilton London Paddington, registration link
> will be supplied to accepted participants.
>
> The workshop is sponsored by the Internet Society, the RITE project,
> Simula Research Labs and the TimeIn project.
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg
>

---

From: John Leslie <[email-masked]>
Date: Tue, 11 Jun 2013 16:28:05 -0400

> There is something about this workshop I don't understand:  Who is the

   We'll have to let one (or more) of the organizers speak to that...

> The way you have it set up, it is most likely that the attendees will
> all be working on improving some aspect of latency, and they already
> understand its importance.

   Yes, but... They should leave with a better understanding of the
breadth of the issue -- better able to explain the issues in a way that
their listeners can grok.

   (I would like to hear more about how the organizers plan to publicize
the results, though...)

> The people who you really need to reach are the ones who own some key
> part of the problem, but don't know it.  But by definition they will
> not be present.

   That's not a bug; it's a feature... ;^)

> I suspect that everyone present will all be in violent agreement.

   I'd offer to bet a drink the next time we meet, but I don't know
when that will be. :^(

> How will this make the network better?

   Slowly... VERY slowly, I fear...

   But the issue isn't _whether_ less latency is good -- the issue is
"What are you going to do about it?"

   Alas, we don't have much shared vision of what to do about it.
Some folks believe ECN can help a lot; others insist it can never
work. Some folks believe CoDel can deploy painlessly; others insist
it would break something important. Some folks believe multiple
queues are essential to any solution; others believe they would
require keeping more state than routers can handle. Et cetera...

   Then, there are the physical devices needing to be upgraded.
Bean-counters _don't_ like upgrades, whether fork-lift or purely
software.

   The support costs threaten to overwhelm everything else: once
users _expect_ an improvement, the number of calls doubles several
times -- and training that many call-center personnel is IMHO an
unsolved problem.

   I'd encourage you to draft a "position paper" -- even if Google
isn't likely to fund the trip...

--
John Leslie <[email-masked]>

---

From: Matthew Ford <[email-masked]>
Date: Wed, 12 Jun 2013 16:29:02 +0100

Matt,

The expectation is that a report out of the workshop can serve to inform and influence those who are not present of any areas of strong consensus with regards to ways forward. Where clear messages are identified, we (ISOC) will promote them as best we can, and I would hope others attending and helping organise would do the same.

I'm not as confident as you that those present will all be in agreement, and I expect that sharing different perspectives on the best approaches to tackling different aspects of Internet latency in its broadest sense will also help to inform and influence those attending.

I hope that helps answer your question.

Mat

On 11 Jun 2013, at 18:56, Matt Mathis <[email-masked]> wrote:

> There is something about this workshop I don't understand:  Who is the audience?
> 
> The way you have it set up, it is most likely that the attendees will all be working on improving some aspect of latency, and they already understand its importance.
> 
> The people who you really need to reach are the ones who own some key part of the problem, but don't know it.  But by definition they will not be present.
> 
> I suspect that everyone present will all be in violent agreement.    How will this make the network better?
> 
> Thanks,
> --MM--
> Privacy matters!  We know from recent events that people are using our services to speak in defiance of unjust governments.   We treat privacy and security as matters of life and death, because for some users, they are.
> 
>

---

From: Matt Mathis <[email-masked]>
Date: Wed, 12 Jun 2013 10:06:05 -0700

Ok, appearing as an ISOC report has the potential to have the right kind of
impact in the wider community.   That is a very important detail that could
have been included in the announcement.

This thread caused me to reexamine my own assumptions and to try to imagine
what others might be thinking under different sets of assumptions.    Yes,
there are lots of partial solutions.   To make a long story short, (nearly)
all of them are optimal somewhere and all should be pursued.

I think I'll put the details into my position paper....

Thanks,
--MM--

On Wed, Jun 12, 2013 at 8:29 AM, Matthew Ford <[email-masked]> wrote:

> Matt,
>
> The expectation is that a report out of the workshop can serve to inform
> and influence those who are not present of any areas of strong consensus
> with regards to ways forward. Where clear messages are identified, we
> (ISOC) will promote them as best we can, and I would hope others attending
> and helping organise would do the same.
>
> I'm not as confident as you that those present will all be in agreement,
> and I expect that sharing different perspectives on the best approaches to
> tackling different aspects of Internet latency in its broadest sense will
> also help to inform and influence those attending.
>
> part of the problem, but don't know it.  But by definition they will not be
> present.
> >
> > I thought I had already posted this here, but don't see my earlier note
> in the archives. Anyway, the dates have now been finalised and this
> workshop will take place on 25-26 September in London.
> >
> > Latency is an increasingly important topic for networking researchers
> and Internet practitioners alike. Data from Google, Microsoft, Amazon and
> > This is an invitation-only workshop. Prospective participants must
> submit short (up to 2 pages) position papers outlining their views on a
> specific aspect of the overall scope. The emphasis here is on relevance and
> brevity - you do not need to write a lot of text, just demonstrate that you
> have thought about the problem space and have something interesting to say
> on the topic.
> >
> > Participant numbers will be limited to focus on discussion and
> identifying actions rather than slideware.

---

From: Dave Taht <[email-masked]>
Date: Mon, 17 Jun 2013 10:53:45 -0700

> I think I'll put the details into my position paper....

I am glad matt has reversed his position on attendance but I'm still
clueless as to what "a position" would be.

0) "Invitations to attend the workshop will depend on receipt of a
position paper. "

To me a position paper involves taking a position on something. It
generally helps to have a debate, pro/con when taking a position, in
order to achieve clarity, but that involves having two sides.

And at least in my case, I like to have data to take a position from,
and reproducible experiments from both (or more) sides in a debate.

One of the items that struck me in a previous post was a statement
along the lines of "oooh, creating demand for new stuff was bad, it
involved retraining customer service, etc, etc" - when my take on it
was the opposite - in that lowering latency on the internet will
improve productivity world-wide, sell tons of new hardware, and create
new markets.

Certainly I'm well aware of the cost of a fork-lift upgrade, but A) it
happens naturally over time and B) IMHO ipv6 costs more to deploy
hwwise.

So there is natural, pent up demand, for providing lower latency
services, and certainly I've been doing my best to stoke it, in the
hope that multiple companies would begin to address it with better
hardware, networks, and services.

So is that a "position" I should take in a paper? And someone should
take the opposite side that reducing latency would cost too much to
deploy and not tell the users about alternate solutions? And there
should be a debate?

1) Moving on to the AQM debate...

I have spent a great deal of time reasonably proving to myself that in
all cases drop tail was worse than codel. (A ton of others have
tackled the same question and came up empty, too) Judging from an
earlier post, some people consider that to be controversial (?) but
have presented no data, nor specific experiments to run.

2) In terms of the pie vs codel debate, nobody pushes codel standalone
but the pie folk. I have spent a great deal of time getting to where
pie could be analysed objectively too, and I'd expect to have
data/reproducible experiments by September on that front. Do I have a
position on it now? No!

It would be nice to have some more volunteer help in making the pie
experiments reproducible, and in creating more relevant benchmarks.
(I've already found two bugs in the "pie for linux" code drop, which
shouldn't be my job to fix, on the non-existent budget I have...)

So a big "position" I have is that better latency measurement tools
than rrul are needed, particularly those that test web, voip and
videoconferencing, while under a competing load. Darn short paper,
that....

But it's not taking the "position" that's the problem, it's finding
the funding, and I'd rather not argue the position with my best
collegiate debating tactics at hand... but do the damn science, right,
so that debating tactics become irrelevant.

3) "In a spirit of co- ordination across the industry, submissions are
encouraged from developers and network operators as well as the
research and standards communities."

So the chipset makers aren't welcome? They are the elephants in the
room and should be coaxed to attend. I fear with the huge number of hw
ip stack offloads, that with the ipv6 deployment, we will end up with
an even more brittle, middlebox laden network than what we have today,
and given the 15 year bug-ridden-and-ongoing experience with the ipv6
deployment... that software based networking equipment with a minimal
amount of hardware assistance should be preferred.

is that a position paper?

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 17 Jun 2013 19:27:35 +0000

On 6/17/13 1:53 PM, "Dave Taht" <[email-masked]> wrote:

>room and should be coaxed to attend.

I don't see any reason why they could not submit a position paper and be
considered -- I doubt the text was intended as exclusive.

- Jason

---

From: Mat Ford <[email-masked]>
Date: Tue, 18 Jun 2013 09:39:29 +0000

Hi,

>order to achieve clarity, but that involves having two sides.

I'm sorry if calling these things 'position papers' has been unhelpful.
And they are certainly not intended to help foster artificial debates. The
expectation is simply for a short paper outlining some aspect of the
workshop scope that is of particular interest to you, any opinions and
data you have to bring to bear on that aspect, and maybe your sense of
future directions/priorities for reducing Internet latency. These papers
are mostly to help the PC structure the agenda. Perhaps one way to think
about it is, if you were going to attend the workshop, what would you like
to talk about/hear from others?

>deploy and not tell the users about alternate solutions? And there

I think taking a view on deployability of solutions is certainly worth
including, but as I said above, there's no expectation that somebody write
down a counter-argument and we have a false debate.

>shouldn't be my job to fix, on the non-existent budget I have...)

Personally, I'm hoping to stay focussed on a picture bigger than 'this
algorithm is (fractionally) better than that one', unless there are real
implications for use cases or deployability resulting from algorithm
choice.

>videoconferencing, while under a competing load. Darn short paper,

They don't have to be long :)

>So the chipset makers aren't welcome?

As Jason already noted, the list wasn't intended to be exhaustive.

> They are the elephants in the

Definitely! And seriously, if you do have contacts with the chipset
vendors, please share and I'll do what I can to get them along - I agree
they are important and personally don't have the contacts, although others
on the PC may be working that angle.

Mat