Subject: [iccrg] Google IW=7 ?

From: Michael Welzl <[email-masked]>
Date: Thu, 6 Jun 2013 12:30:06 +0200

Hi,

It seems that, at least towards my host here in Oslo, Google uses an initial window of 7 these days...  why? Just carrying out measurements, or has 10 turned out to be too large?  :-D
Just curious, just asking...

Cheers,
Michael

---

From: Emmanuel Lochin <[email-masked]>
Date: Thu, 06 Jun 2013 13:35:38 +0200

> Just curious, just asking...

Hi Michael

FYI : 
http://blog.benstrong.com/2010/11/google-and-microsoft-cheat-on-slow.html

Emmanuel

>
> Cheers,
> Michael
>
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg

-- 
Emmanuel Lochin
Professeur ISAE - OSSI
Institut Supérieur de l'Aéronautique et de l'Espace (ISAE)
Issu du rapprochement SUPAERO et ENSICA
10 avenue Edouard Belin - BP 54032 - 31055 Toulouse cedex 4
Tel : 05 61 33 91 85 - Fax : 05 61 33 91 88
Web : http://personnel.isae.fr/emmanuel-lochin/
---
"This email and any attachments are confidential. They may contain legally privileged information or copyright material. You should not read, copy, use or disclose them without authorisation. If you are not an intended recipient, please contact us at once by return email and then delete both messages. We do not accept liability in connection with computer virus, data corruption, delay, interruption, unauthorised access or unauthorised amendment. This notice should not be removed"

---

From: 王国栋 <[email-masked]>
Date: Thu, 6 Jun 2013 21:01:01 +0800 (GMT+08:00)

I have discussed the relationship between the IW and the Slow Start. Suppose the IW is a, the round trip time is RTT, and we rewrite the Slow Start mechanism in the follows: 

cwnd = cwnd + m for each ACK's arrival (different from the default TCP: cwnd = cwnd + 1). 
Then we can get that 

cwnd(t) = a * (1+m)^(t/RTT), 

wich is different from the default TCP: cwnd(t) = 2^(t/RTT). We can find that the IW (a) has very important effect on the aggressiveness of TCP. If Google IW = 7, it means that the Google is 7 times of the aggressiveness than the Webs with standrad TCP.

I don't know if this can give any explanation to the reason why Google IW is set to be 7.

> -----原始邮件-----
> 发件人: "Michael Welzl" <[email-masked]>
> 发送时间: 2013年6月6日 星期四
> 收件人: [email-masked]
> 抄送: 
> 主题: [iccrg] Google IW=7 ?
> 
> Hi,
>

---

From: "Ilpo Järvinen" <[email-masked]>
Date: Thu, 6 Jun 2013 16:15:48 +0300 (EEST)

On Thu, 6 Jun 2013, Michael Welzl wrote:

> It seems that, at least towards my host here in Oslo, Google uses an 
> initial window of 7 these days...  why? Just carrying out measurements, 
> or has 10 turned out to be too large?  :-D

It used to be so that some default initial value for connection memory 
limits in Linux enforced smaller initial window that what CC allowed.
...I suppose that guys at Google should know this though since I think 
it was somebody from them who first discovered the issue, so in the end
it might not explain IW7.

-- 
 i.

---

From: Michael Welzl <[email-masked]>
Date: Thu, 6 Jun 2013 15:22:41 +0200

> it might not explain IW7.

... or maybe it takes some time to roll out a fix? Anyway, this might explain why I just saw the exact same thing with twitter  :-)

(I hope it's not something wrong about my measurement method - apologies to everyone for the noise in case it is!)

Cheers,
Michael

---

From: Michael Welzl <[email-masked]>
Date: Sun, 9 Jun 2013 14:21:27 +0200

interesting idea!
who is "we" - 163.com?

On Jun 9, 2013, at 8:47 AM, 刘泓昊 <[email-masked]> wrote:

> 
> different network condition will benefit form different initcwnd;
> 
> if you care it,don't believe anyone advice, measure it by youself,and you had better measure according to your online environment；
> 
> In fact， now we use adaptive initcwnd ，according to rtt;
> 
> At 2013-06-06 18:30:06,"Michael Welzl" <[email-masked]> wrote:
> >Hi,
> >