Subject: [iccrg] Interesting work on AQM for ICCRG

From: "Akhtar, Shahid (Shahid)" <[email-masked]>
Date: Tue, 23 Jul 2013 21:15:22 +0000

Hi All,

We wanted to let to you know that we have some interesting results and were hoping to present at this ICCRG meeting, but unfortunaley the agenda is full already. Below is an extended abstract of the work.

Shahid Akhtar
Alcatel-Lucent.
[email-masked]

An Evaluation of Various AQM techniques on Access Networks with Realistic Internet Traffic
Using NS2 we built a set of simulation scenarios for realistic Internet traffic. We tested AQM techniques for their ability to influence end-customer QoE. Based on data from recent measurements, there are three major types of traffic flowing through the Internet: HTTP web traffic, HTTP adaptive streaming (HAS) video traffic (e.g., from Netflix), and progressive download video traffic (e.g., from YouTube).
We modeled HTTP 1.1 and HTTP 2.0 web traffic using Internet statistics published by Google. We generated dynamic HAS traffic by implementing a HAS client that adjusts its rate according to network conditions. We modeled YouTube traffic with realtistic Pareto-based file size distribution and inter-request time distribution.
We used published research to convert data from the simulation traces into typical QoE metrics for the different types of traffic: Predicted Mean Opinion Score (P-MOS) for HAS traffic, page load time for HTTP web traffic, and percentage of time that 480p or 720p video can be played for YouTube traffic.
We used realstic mixes of the three types of traffic with different loading conditions to test various AQM techniques (several Random Early Detection (RED) configurations and CoDel) on access networks (CO-based DSL and Cable) under typical operating conditions.
We derived the following key observations from our experiments:
*       Most AQM configurations improved the performance of HAS significantly over Tail-Drop: AQM improves fairness and stability among HAS streams and avoids HAS stalls (underflow) in a majority of the cases where they would occur with Tail-Drop.
   *    Most AQM configurations improved Web traffic performance, enabling slightly higher throughput and significantly lower page download times (up to 40% reduction).
   *    However progessive download flows like YouTube showed better performance under Tail-drop conditions - both throughput and end-user QoE metrics
*       Using HTTP 2.0 based web traffic (instead of HTTP 1.1), we found that the page load times dramatically improved (50% lower), but there was a reduction in HAS and YouTube performance.
   *    The performance of one set of RED parameters consistently produced QoE in the top range amongst the scenarios. This indicates that it may be possible to improve user experience using specific fixed configurations in existing hardware.

---

From: David Ros <[email-masked]>
Date: Wed, 24 Jul 2013 07:40:35 +0200

On 23 juil. 2013, at 23:15, Akhtar, Shahid (Shahid) wrote:

> Using NS2 we built a set of simulation scenarios for realistic Internet traffic. We tested AQM techniques for their ability to influence end-customer QoE. Based on datafrom recent measurements, there are three major types of traffic flowing through the Internet: HTTP web traffic, HTTP adaptive streaming (HAS) video traffic (e.g., from Netflix), and progressive download video traffic (e.g., from YouTube).
> 	• Most AQM configurations improved the performance of HAS significantly over Tail-Drop: AQM improves fairness and stability among HAS streams and avoids HAS stalls (underflow) in a majority of the cases where they would occur with Tail-Drop.
> 	• Most AQM configurations improved Web traffic performance, enabling slightly higher throughput and significantly lower page download times (up to 40% reduction).
> 	• However progessive download flows like YouTube showed better performance under Tail-drop conditions - both throughput and end-user QoE metrics
> 	• Using HTTP 2.0 based web traffic (instead of HTTP 1.1), we found that the page load times dramatically improved (50% lower), but there was a reduction in HAS and YouTube performance.
> 	• The performance of one set of RED parameters consistently produced QoE in the top range amongst the scenarios. This indicates that it may be possible to improve user experience using specific fixed configurations in existing hardware.
>  

Hi,

Is there a draft / tech report on this available?

Thanks!

David

=================================================================
David ROS
http://www.rennes.enst-bretagne.fr/~dros/

I'd tell you a UDP joke, but you may not get it. -- Author unknown

---

From: "Robinson, Dave C (Dave)" <[email-masked]>
Date: Wed, 24 Jul 2013 08:52:48 +0000

David is at least interested in what we have to say :-)

-----Original Message-----
From: David Ros [mailto:[email-masked]] 
Sent: 24 July 2013 06:41
To: Akhtar, Shahid (Shahid)
Cc: [email-masked]; Benno, Steven (Steven); Francini, Andrea (Andrea); Robinson, Dave C (Dave); Sharpe, Randall B (Randy); Scharf, Michael (Michael)
Subject: Re: Interesting work on AQM for ICCRG

On 23 juil. 2013, at 23:15, Akhtar, Shahid (Shahid) wrote:

> An Evaluation of Various AQM techniques on Access Networks with 
> Realistic Internet Traffic Using NS2 we built a set of simulation scenarios for realistic Internet traffic. We tested AQM techniques for their ability to influence end-customer QoE. Based on datafrom recent measurements, there are three major types of traffic flowing through the Internet: HTTP web traffic, HTTP adaptive streaming (HAS) video traffic (e.g., from Netflix), and progressive download video traffic (e.g., from YouTube).

Hi,

Thanks!

David

---

From: "Akhtar, Shahid (Shahid)" <[email-masked]>
Date: Thu, 25 Jul 2013 14:12:01 +0000

Hi All,

This talk has been scheduled for the ICCRG in Vancouver in Nov. We will provide more details at that time.

Thanks.

-Shahid.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Akhtar, Shahid (Shahid)
Sent: Tuesday, July 23, 2013 4:15 PM
To: [email-masked]
Cc: Benno, Steven (Steven); Scharf, Michael (Michael); Sharpe, Randall B (Randy); Robinson, Dave C (Dave); David Ros; Francini, Andrea (Andrea)
Subject: [iccrg] Interesting work on AQM for ICCRG

Hi All,

Shahid Akhtar
Alcatel-Lucent.