Subject: Re: [iccrg] RG meeting in Berlin

From: David Ros <[email-masked]>
Date: Tue, 16 Jul 2013 10:04:27 +0200

Hi all,

There may still be room for one short (<= 10 min) talk in the next ICCRG meeting, in Berlin. 

If you'd like to give a talk, please send us no later than tomorrow, Wednesday 17:

- title
- speaker
- desired duration

The tentative agenda so far:

===

Emmanuel Lochin, FavorQueue: a Stateless Active Queue Management to Improve TCP Traffic Performance

David Hayes, An update about the TCP Evaluation Suite

Midori Kato, DCTCP implementation in FreeBSD

Pat Thaler and Rong Pan, The 802.1Qcu congestion notification algorithm

Douglas Leith, Congestion control in CTCP

Ramin Khalili, Congestion Control of Multipath TCP: Problems and Solutions

Philippe Cadro, Packet oriented QoS management model for a wireless Access Point

Mirja Kuehlewind, SimLib-QEMU: TCP Simulations integrating Virtual Machines

===

Thanks,

David

=================================================================
David ROS
http://www.rennes.enst-bretagne.fr/~dros/

I'd tell you a UDP joke, but you may not get it. -- Author unknown

---

From: Jim Gettys <[email-masked]>
Date: Tue, 16 Jul 2013 21:36:30 -0400

> If you'd like to give a talk, please send us no later than tomorrow,

Title: RRUL Rogues Gallery
Speaker: Jim Gettys (on behalf of Dave Taht)
Desired duration: 10 minutes

The RRUL test is useful for testing real hardware, systems and algorithms
under load, and has resulting in a number of "interesting" results, mostly
predictable, but some resembling the Chinese Curse and surprising.

> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg
>

---

From: Yuchung Cheng <[email-masked]>
Date: Wed, 17 Jul 2013 08:12:10 -0700

> If you'd like to give a talk, please send us no later than tomorrow, Wednesday 17:
Title: packetdrill: Scriptable Network Stack Testing, from Sockets to Packets
Speaker: Yuchung Cheng
Time: 20m

https://www.usenix.org/conference/atc13/packetdrill-scriptable-network-stack-testing-sockets-packets
is the tool that Google uses everyday to test its TCP stack  and
develop/debug new/old TCP features.

---

From: Michael Welzl <[email-masked]>
Date: Wed, 17 Jul 2013 17:26:51 +0200

Hi,

This proposal is coming very late, for an agenda that's really packed. Moreover, David's email very specifically said that we can only allow <= 10 minutes at this stage.

Given that the talk "Packet oriented QoS management model for a wireless Access Point" doesn't really seem to fit ICCRG (which only became clear when the i-d about it was posted), we will now:
- put this talk by Yuchung on the agenda
- remove the talk by Philippe (sorry)

and close the agenda for updates.

Cheers,
Michael (and David)

---

From: Dave Taht <[email-masked]>
Date: Wed, 17 Jul 2013 08:49:05 -0700

> develop/debug new/old TCP features.

VERY COOL.

sources are at:

https://code.google.com/p/packetdrill/

/me anticipates losing day to fiddling.

-- 
Dave Täht

Fixing bufferbloat with cerowrt: http://www.teklibre.com/cerowrt/subscribe.html