Subject: [iccrg] IETF87 meeting minutes for ICCRG session 1

From: Thomas Dreibholz <[email-masked]>
Date: Tue, 30 Jul 2013 10:38:53 +0200

ICCRG Session 1
Monday, July 29, 2013, 16:20-17:20, room Tiergarten 1/2

1. Presentation of Emmanuel Lochin:
"FavorQueue: a Stateless Active Queue Management to Improve TCP Traffic 
Performance"
- New proposed algorithm FavorQueue for packet enqueuing:
algorithm that favors certain packets depending on flow
Question from audience: difference details between CoDel and FavorQueue
- Results from ns-2 experiments: FavorQueue vs. Drop Tail
FavorQueue reduces latency
RTO recovery ratio improved
- Conclusions
Results and analysis available
ns-2 code available
- Questions:
Questions from Bob Briscoe about handling large and small flows
Question from Mirja Kühlewind about definition of latency in results
Questions from Alexander Zimmermann on statelessness and computational 
complexity
Questions from Agraval(?) on statelessness of the algorithm
Questions from Pat about fairness issues. There should be no impact.

2. Presentation of Midori Kato:
"DCTCP implementation in FreeBSD"
- Idea: update cwnd based on average fraction of ECN-marked segments
- Implemented in FreeBSD kernel, just 479 lines of code
- Implementation status
Some open points to be discussed.
- Open issue: cwnd behaviour on first ECN
- Performance with small queue size/large queue size
- Summary
- Questions:
Comments from Mirja Kühlewind on solution possibilities to reduce cwnd on first 
ECN
Need for looking at link utilisation and latency simultaneously.
Questions from Mitch from IBM on setting of ecn_thresh and queue length.
Comments from Michael Welzl on congestion marking parameter settings to not 
miss congestion events.
Comments from Bob Briscoe on ECN feedback.
Again Mirja Kühlewind on implementation details.
Question of Lars Eggert on possible IPR from Microsoft
Bob Briscoe on IPR
Randy Stewart on BSD implementation and IPR

3. Presentation of Yuchung Cheng:
"packetdrill: Scriptable Network Stack Testing, from Sockets to Packets"
- Test and development of networking stack today?
- Challenges of troubleshooting
- Proposal of tool "packetdrill" for scriptable network testing to reproduce 
problems in order to test changes
- Possibility to test protocol behaviour (e.g. TCP Fast RTX)
- Possibility to test new API functions
- Google uses tool to test Linux TCP
- Download URL: http://code.google.com/p/packetdrill/ ; license is GPLv2

-- 
Best regards / Mit freundlichen Grüßen / Med vennlig hilsen

=======================================================================
 Thomas Dreibholz

 Simula Research Laboratory
 Simula Innovation AS, Network Systems Group
 Visiting address: Martin Linges vei 17, 1364 Fornebu, Norway
 Mailing address:  P.O.Box 134, 1325 Lysaker, Norway
-----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://simula.no/people/dreibh
=======================================================================

---

From: Michael Welzl <[email-masked]>
Date: Tue, 30 Jul 2013 10:58:22 +0200

Hi all,

Thanks again to Thomas for taking these notes!
Everyone else, please let us have any comments / fixes you may have ASAP - it's good to do this while everyone's memory is still fresh  :)

Cheers,
Michael