Subject: [iccrg] ECN issues

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 24 Jun 2015 11:34:35 +0000

Hi

I wonder, is there any new data around that gives any ideas how large the issues with ECN really are ?.

Issues that I am interested are ECN black holes and faulty remarking of ECN fields

The last one I have seen is this paper by Mirja, Brian and Sebastian Neuner
http://www.ict-mplane.eu/sites/default/files/public/publications/311ecndeployment.pdf

Is there any new data available ?.

/Ingemar
=================================
Ingemar Johansson  M.Sc.
Senior Researcher

Ericsson AB
Wireless Access Networks
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

"No man has a good enough memory
  to be a successful liar"
    Abraham Lincoln<http://www.brainyquote.com/quotes/authors/a/abraham_lincoln.html>
=================================

---

From: Mirja Kühlewind <[email-masked]>
Date: Thu, 25 Jun 2015 19:30:33 +0200

Hi Ingemar,

there is a newer paper we published last year (and gave a quick presentation at the last ICCRG meeting):

http://wan.poly.edu/pam2015/papers/4.pdf

https://www.ietf.org/proceedings/92/slides/slides-92-iccrg-1.pdf

In the mean time we did more measurements using BitTorrent clients instead. The results are very similar. We might be able to quickly present some new results at the next session (if the session takes place and there is still space).

Does this help or are you looking for some specific information?

Mirja

> Am 24.06.2015 um 13:34 schrieb Ingemar Johansson S <[email-masked]>:
> 
> Hi
>  
> [email-masked]
> www.ericsson.com
>  
> “No man has a good enough memory
>   to be a successful liar”
>     Abraham Lincoln

---

From: Dave Taht <[email-masked]>
Date: Thu, 25 Jun 2015 10:49:48 -0700

In my case I just managed to show that congestive (rather than path)
loss can be a factor in the reliability of even a low rate, CS6
prioritized, link local multicast routing protocol (babel), over
present day linux wifi, even using a modern fq+aqm+ecn system.

Enabling ECN markings in babel and watching for CEs while under load, here:

http://snapon.lab.bufferbloat.net/~d/newrouters/linuxcap.cap

I am not sure where to go with that, but I am deploying it at a small
scale anyway, as gathering link local rtt information somewhat
passively at the moment and point of congestion is important to guide
my other work on wifi. No plans for a paper or presentation, it was
just "interesting", let me know if you have any ideas in addition to
this

http://lists.alioth.debian.org/pipermail/babel-users/2015-April/001974.html

as to where to go with it.

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 25 Jun 2015 19:02:25 +0000

Hi

And thanks all for the info both on and off list. I believe that I have enough information. The main objective for me was to get an understanding how serious the issues that various boxes in the middle (e.g NATs/FWs ) mess with the ECN bits really is. Seems to me, based on the info I received thus far that this is becoming more and more an non-issue ?. 

Realized that I have seen the below paper before,  somehow I mixed it up with the older paper, have to blame it on my own teflon-memory ... Thanks for refreshing my memory

/Ingemar

> -----Original Message-----
> From: Mirja Kühlewind [mailto:[email-masked]]
> Sent: den 25 juni 2015 19:31
> To: Ingemar Johansson S
> Cc: [email-masked]; [email-masked]; Bob Briscoe
> ([email-masked]); [email-masked]; Dave Taht
> ([email-masked]); [email-masked]
> Subject: Re: ECN issues
> 
> Hi Ingemar,
> 
> In the mean time we did more measurements using BitTorrent clients
> instead. The results are very similar. We might be able to quickly present
> some new results at the next session (if the session takes place and there is
> still space).
>

---

From: Michael Welzl <[email-masked]>
Date: Fri, 26 Jun 2015 09:01:13 +0200

[  Minus everyone but the Brian and ICCRG list, plus David  ]

Hi Mirja, all,

About this:

> On 25 Jun 2015, at 19:30, Mirja Kühlewind <[email-masked]> wrote:
> 
> Hi Ingemar,
> 

I guess you're referring to ICCRG? Then the answers are:
- yes, it will take place
- yes, there is still space
- indeed this is highly interesting for ICCRG folks I'd say, so please let us have a title. I guess I can give you 15 mins approximately, with exact duration TBD...

Cheers,
Michael

---

From: Mirja Kühlewind <[email-masked]>
Date: Mon, 29 Jun 2015 14:55:50 +0200

Hi Ingemar,

we did only test connection setup up and some small transmissions so far. We did not measurement anything with longer connection though. However, from these results I’d also say there are no mayor issues anymore. There are still some boxes that overwrite the IP ECN bits because they still think it’s part of the ToS field. However, those cases are rather easy to detect because all packets should have the same marking. Linux implements an easy fallback where ECN is disabled if the SYN is ECN marked. That’s probably not the perfect solution but mostly helps the problem.

Mirja

> Am 25.06.2015 um 21:02 schrieb Ingemar Johansson S <[email-masked]>:
> 
> Hi
>