Subject: Re: [iccrg] ECN issues

From: "Scheffenegger, Richard" <[email-masked]>
Date: Sun, 19 Jul 2015 08:21:12 +0000

Hi Ingemar,

I was to make that very same point; from my earlier collaboration with Mirja and Brians efforts, I think the prevalence of gear that still uses a notion of a TOS byte, and rewrites it for a L4 flow is actually higher than ECN impacting connection set up etc.

So, on some paths you may believe you negotiate ECN, but one half-link may bleach the IP-header ECN bits.

Again, this is detectable for the receiver (currently, no mechanism to convey this info back to a TCP sender), and affected sessions would revert back to loss-based CC.

Such ECN-unresponsive, loss-responsive flows may pose an issue to AQMs that do some differentiated handling of ECN vs non-ECN packets though...

Best regards,
  Richard

> -----Original Message-----
> From: iccrg [mailto:[email-masked]] On Behalf Of Mirja Kühlewind
> Sent: Montag, 29. Juni 2015 14:56
> To: Ingemar Johansson S
> Cc: [email-masked]; [email-masked]; Dave Taht ([email-masked]);
> Bob Briscoe ([email-masked]); [email-masked];
> [email-masked]
> Subject: Re: [iccrg] ECN issues
> 
> Hi Ingemar,
> 
> we did only test connection setup up and some small transmissions so far.
> We did not measurement anything with longer connection though. However,
> from these results I'd also say there are no mayor issues anymore. There
> are still some boxes that overwrite the IP ECN bits because they still
> think it's part of the ToS field. However, those cases are rather easy to
> detect because all packets should have the same marking. Linux implements
> an easy fallback where ECN is disabled if the SYN is ECN marked. That's
> probably not the perfect solution but mostly helps the problem.
> 
> Mirja
> 
> 
> > Am 25.06.2015 um 21:02 schrieb Ingemar Johansson S
> <[email-masked]>:
> >
> > Hi
> >
> > And thanks all for the info both on and off list. I believe that I have
> enough information. The main objective for me was to get an understanding
> how serious the issues that various boxes in the middle (e.g NATs/FWs )
> mess with the ECN bits really is. Seems to me, based on the info I
> received thus far that this is becoming more and more an non-issue ?.
> >
> > Realized that I have seen the below paper before,  somehow I mixed it
> > up with the older paper, have to blame it on my own teflon-memory ...
> > Thanks for refreshing my memory
> >
> > /Ingemar
> >
> >> -----Original Message-----
> >> From: Mirja Kühlewind [mailto:[email-masked]]
> >> Sent: den 25 juni 2015 19:31
> >> To: Ingemar Johansson S
> >> Cc: [email-masked]; [email-masked]; Bob Briscoe
> >> ([email-masked]); [email-masked]; Dave Taht
> >> ([email-masked]); [email-masked]
> >> Subject: Re: ECN issues
> >>
> >> Hi Ingemar,
> >>
> >> there is a newer paper we published last year (and gave a quick
> >> presentation at the last ICCRG meeting):
> >>
> >> http://wan.poly.edu/pam2015/papers/4.pdf
> >>
> >> https://www.ietf.org/proceedings/92/slides/slides-92-iccrg-1.pdf
> >>
> >> In the mean time we did more measurements using BitTorrent clients
> >> instead. The results are very similar. We might be able to quickly
> >> present some new results at the next session (if the session takes
> >> place and there is still space).
> >>
> >> Does this help or are you looking for some specific information?
> >>
> >> Mirja
> >>
> >>
> >>> Am 24.06.2015 um 13:34 schrieb Ingemar Johansson S
> >> <[email-masked]>:
> >>>
> >>> Hi
> >>>
> >>> I wonder, is there any new data around that gives any ideas how
> >>> large the
> >> issues with ECN really are ?.
> >>>
> >>> Issues that I am interested are ECN black holes and faulty remarking
> >>> of ECN fields
> >>>
> >>> The last one I have seen is this paper by Mirja, Brian and Sebastian
> >>> Neuner
> >>> http://www.ict-mplane.eu/sites/default/files/public/publications/311
> >>> ec
> >>> ndeployment.pdf
> >>>
> >>> Is there any new data available ?.
> >>>
> >>> /Ingemar
> >>> =================================
> >>> Ingemar Johansson  M.Sc.
> >>> Senior Researcher
> >>>
> >>> Ericsson AB
> >>> Wireless Access Networks
> >>> Labratoriegränd 11
> >>> 971 28, Luleå, Sweden
> >>> Phone +46-1071 43042
> >>> SMS/MMS +46-73 078 3289
> >>> [email-masked]
> >>> www.ericsson.com
> >>>
> >>> "No man has a good enough memory
> >>>  to be a successful liar"
> >>>    Abraham Lincoln
> >>> =================================
> 
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg

---

From: Brian Trammell <[email-masked]>
Date: Sun, 19 Jul 2015 10:45:20 +0200

> On 19 Jul 2015, at 10:21, Scheffenegger, Richard <[email-masked]> wrote:
> 
> Hi Ingemar,
> 

and taking at least one angry tweet I got after the ICCRG talk in Dallas as anecdata, at least some of this gear also uses the whole TOS byte for ECMP hashing. While this will break certain TCP anycast applications that don't make provision for state distribution (uninteresting), it may also increase the probability of reordering on marked traffic (somewhat more interesting).

<measurement-hat>
I suspect all this behavior is rare enough that measuring it actively would require a whole bunch of endpoints sending a whole bunch of traffic, though...
</measurement-hat>

cheers,

Brian