Subject: [iccrg] Experimental Specification of New Congestion Control Algorithms

From: Bob Briscoe <[email-masked]>
Date: Thu, 28 Mar 2019 07:45:23 +0100

ICCRG follks,

A propos of a dinner conversation last night, here's the IETF's 
currently agreed process for documenting congestion control algorithms, 
written by Lars Eggert when he was IRTF Chair (I think) and signed off 
by the IESG:

Eggert, L., "Experimental Specification of New Congestion Control 
Algorithms," IESG IETF Operational Note ion-tsv-alt-cc (July 2007)
https://www.ietf.org/iesg/statement/congestion-control.html

The motivation at that time was to give the IETF's stamp of approval (by 
publication of an RFC on the experimental track) to algorithms that it 
believed to be safe for experimentation on the public Internet, using 
the ICCRG as a pool of expert reviewers.

The output from the IESG was envisaged as a "write-up" of its 
expert-review (implying just as a report to the sponsoring IETF WG, not 
an RFC).

It identified tcpm as the WG that would be most likely to take-on the 
publication of the experimental RFC, but other WGs were envisaged as 
relevant.

It also encouraged informational documentation of algorithms that were 
already widely used (as has been done recently for Cubic and DCTCP). But 
that was a separate activity, with different intentions.

Bob

-- 
________________________________________________________________
Bob Briscoe                               http://bobbriscoe.net/

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 28 Mar 2019 08:02:16 +0100

For IETF process wonks, this was published as an IETF Operational Note 
(ION), which was a new series of IETF documents established as an 
experimental process by RFC4693 the year before (2006).

The following year (2008) RFC6393 ended the ION process experiment. I 
assume that just stopped further use of the process, rather than 
invalidating all the IONs that had been written. It also says nothing 
about why the process had been ended, or what process would replace it. 
No other RFC refers to RFC6393, so it seems this dark area of IETF 
process has quite a small following. But I'm sure someone will know a 
bit more than me.

Bob

On 28/03/2019 07:45, Bob Briscoe wrote:
> currently agreed process for documenting congestion control 
> algorithms, written by Lars Eggert when he was IRTF Chair (I think) 
> and signed off by the IESG:
>
> The motivation at that time was to give the IETF's stamp of approval 
> (by publication of an RFC on the experimental track) to algorithms 
> that it believed to be safe for experimentation on the public 
> Internet, using the ICCRG as a pool of expert reviewers.
>
> expert-review (implying just as a report to the sponsoring IETF WG, 
> not an RFC).
>
> already widely used (as has been done recently for Cubic and DCTCP). 
> But that was a separate activity, with different intentions.
>
>
>
> Bob
>
>

---

From: Michael Welzl <[email-masked]>
Date: Thu, 28 Mar 2019 08:17:25 +0100

Hi,

> On Mar 28, 2019, at 8:02 AM, Bob Briscoe <[email-masked]> wrote:
> 
> For IETF process wonks, this was published as an IETF Operational Note (ION), which was a new series of IETF documents established as an experimental process by RFC4693 the year before (2006).
> 
> The following year (2008) RFC6393 ended the ION process experiment. I assume that just stopped further use of the process, rather than invalidating all the IONs that had been written.

What makes you say that it stopped further use of the process?

> It also says nothing about why the process had been ended, or what process would replace it. No other RFC refers to RFC6393, so it seems this dark area of IETF process has quite a small following. But I'm sure someone will know a bit more than me.

Yes  :)

We kept the process going. See:
https://trac.ietf.org/trac/irtf/wiki/ICCRG <https://trac.ietf.org/trac/irtf/wiki/ICCRG>

As documented on this page, the process was successfully (i.e., the hand-over to TCPM happened and things finished there) used for Cubic, Compound TCP, new-cwv, and ABE.
The reviews the process talks about are at the respective sub-pages linked under the names of these proposals.

Three proposals entered the process but the process never finished because the authors gave up: HTCP, MulTFRC and LISA.  I’m sad to say that two out of these three are by my own group   :-)
Somebody should clean this page up a bit. E.g., the link to the old ION is broken.

Cheers,
Michael

---

From: "Scharf, Michael" <[email-masked]>
Date: Thu, 28 Mar 2019 07:34:22 +0000

As most of you will know, there is also process-related wording in the active TCPM charter (https://datatracker.ietf.org/wg/tcpm/about/):

TCPM also provides a venue for standardization of incremental
enhancements of TCP's standard congestion control. In addition,
TCPM may document alternative TCP congestion control algorithms
that are known to be widely deployed, and that are considered
safe for large-scale deployment in the Internet. Changes of algorithms
may require additional review by the IRTF Congestion Control
Research Group (ICCRG). Fundamental changes to TCP or its congestion
control algorithms (e.g., departure from loss-based congestion
control) will be handled by other working groups or will require
rechartering.

TCP's congestion control algorithms are the model followed by
alternate transports (e.g., SCTP or DCCP), which are standardized in
other working groups, such as the Transport Area WG (tsvwg). In the
past, the IETF has worked on several documents about algorithms that
are specified for multiple protocols (e.g., TCP and SCTP) in the
same document. Which WG shepherds such documents will be determined
on a case-by-case basis. In any case, the TCPM WG will remain in
close contact with other relevant WGs working on these protocols to
ensure openness and stringent review from all angles.

And, indeed, TCPM has followed this process e.g. for ABE recently.

Michael

> -----Original Message-----
> From: iccrg <[email-masked]> On Behalf Of Bob Briscoe
> Sent: Thursday, March 28, 2019 7:45 AM
> To: iccrg IRTF list <[email-masked]>; Jana Iyengar <[email-masked]>; tsv-
> [email-masked]
> Subject: [iccrg] Experimental Specification of New Congestion Control
> Algorithms
> 
> ICCRG follks,
> 
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg

---

From: Michael Welzl <[email-masked]>
Date: Thu, 28 Mar 2019 08:34:59 +0100

I just occurred to me that I even explained the process with a beautiful animation once. That was in the tsvarea meeting in Chicago, at IETF 98.
The animated version is here:
http://heim.ifi.uio.no/~michawe/research/publications/ietf98-tsvarea.pptx <http://heim.ifi.uio.no/~michawe/research/publications/ietf98-tsvarea.pptx>
and the pdf:
http://heim.ifi.uio.no/~michawe/research/publications/ietf98-tsvarea.pdf <http://heim.ifi.uio.no/~michawe/research/publications/ietf98-tsvarea.pdf>

> On Mar 28, 2019, at 8:17 AM, Michael Welzl <[email-masked]> wrote:
> 
> Hi,
> 
>> On Mar 28, 2019, at 8:02 AM, Bob Briscoe <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Michael Welzl <[email-masked]>
Date: Thu, 28 Mar 2019 08:37:29 +0100

Hmmm….

- charter text
- a brief description on the wiki, including concrete examples of the process in action, even including the not-so-distant past,
- a presentation with animations some IETF ago
- people’s memories

Bob, let me ask: at this dinner yesterday, how many beers did the people involved in the ICCRG process conversation have?   ;-)

> On Mar 28, 2019, at 8:34 AM, Scharf, Michael <[email-masked]> wrote:
>

---

From: "Scharf, Michael" <[email-masked]>
Date: Thu, 28 Mar 2019 07:43:18 +0000

Maybe let's repeat the presentation with animation in TCPM in Montreal? Perhaps people just have slept in that ICCRG talk? I of course expect that everybody always pays attention to every single word (and bit) in TCPM ;-)

Michael

> From: Michael Welzl <[email-masked]>
> Sent: Thursday, March 28, 2019 8:37 AM
> To: Scharf, Michael <[email-masked]>
> Cc: Bob Briscoe <[email-masked]>; iccrg IRTF list <[email-masked]>;
> Jana Iyengar <[email-masked]>; [email-masked]
> Subject: Re: [iccrg] Experimental Specification of New Congestion Control
> Algorithms
> 
> Hmmm….
> 
> - charter text
> - a brief description on the wiki, including concrete examples of the process
> in action, even including the not-so-distant past,
> Bob, let me ask: at this dinner yesterday, how many beers did the people
> involved in the ICCRG process conversation have?   ;-)
> 
> 
> 
> > As most of you will know, there is also process-related wording in the
> active TCPM charter (https://datatracker.ietf.org/wg/tcpm/about/):
> >
> >

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 28 Mar 2019 11:49:59 +0100

Michael,

On 28/03/2019 08:17, Michael Welzl wrote:
>> For IETF process wonks, this was published as an IETF Operational 
>> Note (ION), which was a new series of IETF documents established as 
>> an experimental process by RFC4693 the year before (2006).
>>
>> invalidating all the IONs that had been written.
>
This second mail was about the IETF's process experiment of using IETF 
Operational Notes (IONs) to describe process, not the congestion control 
process that the original ION created.

This second email was flagged at the start as "For IETF process wonks".

Bob

>
>
>> It also says nothing about why the process had been ended, or what 
>> process would replace it. No other RFC refers to RFC6393, so it seems 
>> this dark area of IETF process has quite a small following. But I'm 
>> sure someone will know a bit more than me.
>
> Yes  :)
>
> https://trac.ietf.org/trac/irtf/wiki/ICCRG
>
> As documented on this page, the process was successfully (i.e., the 
> hand-over to TCPM happened and things finished there) used for Cubic, 
> Compound TCP, new-cwv, and ABE.
> The reviews the process talks about are at the respective sub-pages 
> linked under the names of these proposals.
>
> Three proposals entered the process but the process never finished 
> because the authors gave up: HTCP, MulTFRC and LISA.  I’m sad to say 
> that two out of these three are by my own group   :-)