Subject: Re: [iccrg] New Version Notification for draft-balasubramanian-iccrg-ledbatplusplus-00.txt

From: Praveen Balasubramanian <[email-masked]>
Date: Mon, 22 Jul 2019 23:41:21 +0000

Hi, 

We have submitted the draft below.

https://www.ietf.org/id/draft-balasubramanian-iccrg-ledbatplusplus-00.txt 

Thanks

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, July 22, 2019 3:35 PM
To: Praveen Balasubramanian <[email-masked]>; Osman Ertugay <[email-masked]>; Daniel Havey <[email-masked]>
Subject: New Version Notification for draft-balasubramanian-iccrg-ledbatplusplus-00.txt

A new version of I-D, draft-balasubramanian-iccrg-ledbatplusplus-00.txt
has been successfully submitted by Praveen Balasubramanian and posted to the IETF repository.

Name:		draft-balasubramanian-iccrg-ledbatplusplus
Revision:	00
Title:		LEDBAT++: Congestion Control for Background Traffic
Document date:	2019-07-22
Group:		Individual Submission
Pages:		10
URL:            https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-balasubramanian-iccrg-ledbatplusplus-00.txt&amp;data=02%7C01%7Cpravb%40microsoft.com%7Cb60a23eb4b214f814e6808d70ef4c69b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994316788042519&amp;sdata=87IU%2FKrzc1j0ZVICsyXz15xnnIP9J2ViKHZ%2Fd3cYetQ%3D&amp;reserved=0
Status:         https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-balasubramanian-iccrg-ledbatplusplus%2F&amp;data=02%7C01%7Cpravb%40microsoft.com%7Cb60a23eb4b214f814e6808d70ef4c69b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994316788042519&amp;sdata=N0L2kfBY7kSlnd41Jq7%2BhWARQDsSUGAxIAPjmb%2BpaAA%3D&amp;reserved=0
Htmlized:       https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-balasubramanian-iccrg-ledbatplusplus-00&amp;data=02%7C01%7Cpravb%40microsoft.com%7Cb60a23eb4b214f814e6808d70ef4c69b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994316788042519&amp;sdata=ykGj6RbmkJGygjk0tA5gecGv06uyklgExb8hGdKuMxU%3D&amp;reserved=0
Htmlized:       https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-balasubramanian-iccrg-ledbatplusplus&amp;data=02%7C01%7Cpravb%40microsoft.com%7Cb60a23eb4b214f814e6808d70ef4c69b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994316788042519&amp;sdata=%2BM0S5HhOuCqRqar4Iwiikt69HVe8mXhKm14WN7793vo%3D&amp;reserved=0

Abstract:
   This experimental memo describes LEDBAT++, a set of enhancements to
   the LEDBAT (Low Extra Delay Background Transport) congestion control
   algorithm for background traffic.  The LEDBAT congestion control
   algorithm has several shortcomings that prevent it from working
   effectively in practice.  LEDBAT++ extends LEDBAT by adding a set of
   improvements, including reduced congestion window gain, modified
   slow-start, multiplicative decrease and periodic slowdowns.  This set
   of improvement mitigates the known issues with the LEDBAT algorithm,
   such as latency drift, latecomer advantage and inter-LEDBAT fairness.
   LEDBAT++ has been implemented as a TCP congestion control algorithm
   in the Windows operating system.  LEDBAT++ has been deployed in
   production at scale on a variety of networks and been experimentally
   verified to achieve the original stated goals of LEDBAT.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Michael Welzl <[email-masked]>
Date: Mon, 22 Jul 2019 20:24:05 -0400

Hi,

I think that LEDBAT++ is a great thing to do - I liked your presentations about it, and I like seeing this happening.
There are two points that I’d like to make:

1)
I remember that, already in your first presentation of LEDBAT++, you showed the problem of throwing away base delay and re-measuring it without giving the queue a chance to drain, leading to a growing measurement every 10 minutes. I may only have said it orally, or not at all…  I don’t remember. Anyway, now that there’s a document, I think it’s ok for me to mention that I do believe that we were the first to document this problem (and at least one other problem), in:

David Ros, Michael Welzl: "Assessing LEDBAT's Delay Impact", IEEE Communications Letters 17(5), pp. 1044-1047, 2013.

https://ieeexplore.ieee.org/document/6496997?tp=&arnumber=6496997&queryText=assessing%20ledbat%27s%20delay%20impact <https://ieeexplore.ieee.org/document/6496997?tp=&arnumber=6496997&queryText=assessing%20ledbat%27s%20delay%20impact>
http://heim.ifi.uio.no/~michawe/research/publications/ledbat-impact-letters.pdf <http://heim.ifi.uio.no/~michawe/research/publications/ledbat-impact-letters.pdf>

… which may be appropriate to cite.   (I don’t want to insist!  but at least I wanted to mention it once so you know that this exists.)

2)
When the LEDBAT WG started, David Ros and I were assigned to take the lead on the first milestone: a survey of LEDBAT’ish mechanisms out there. We wrote it, and it’s RFC 69297.
Then, we made an extended version, as a paper:

David Ros, Michael Welzl: "Less-than-Best-Effort Service: A Survey of End-to-End Approaches", IEEE Communications Surveys and Tutorials 15(2), pp.898-908, 2013.
https://ieeexplore.ieee.org/document/6226797?tp=&arnumber=6226797&contentType=Early%20Access%20Articles&searchField=Search_All&queryText=Less-than-Best-Effort%20Service:%20A%20Survey%20of%20End-to-End%20Approaches <https://ieeexplore.ieee.org/document/6226797?tp=&arnumber=6226797&contentType=Early%20Access%20Articles&searchField=Search_All&queryText=Less-than-Best-Effort%20Service:%20A%20Survey%20of%20End-to-End%20Approaches>
http://heim.ifi.uio.no/~michawe/research/publications/lbesurvey.pdf <http://heim.ifi.uio.no/~michawe/research/publications/lbesurvey.pdf>

… yet I believe this work was largely ignored when LEDBAT was designed. (frankly, I think the idea of this milestone influencing the design was "lip service" - we hadn’t even begun with the survey when the mechanism was basically presented as “this is what it is, now we can fine-tune it a little”.)

The number of other mechanisms out there, which we surveyed, is quite large, and some of these mechanisms contain good ideas. If you do me the favor of reading the survey to see if you find some inspiration for further design of LEDBAT++, I would feel that this work was a little less in vain  :-)

I’d also like to note that colleagues have done newer work on LBE after the survey. This one, for example:
http://dl.ifip.org/db/conf/networking/networking2017/1570334752.pdf <http://dl.ifip.org/db/conf/networking/networking2017/1570334752.pdf>
and this, before it, about CDG (which is available in Linux AFAIK):
http://dl.ifip.org/db/conf/networking/networking2017/1570350870.pdf <http://dl.ifip.org/db/conf/networking/networking2017/1570350870.pdf>

Cheers,
Michael

> On Jul 22, 2019, at 7:41 PM, Praveen Balasubramanian <pravb=[email-masked]> wrote:
> 
> Hi, 
> 
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg

---

From: Daniel Havey <[email-masked]>
Date: Tue, 23 Jul 2019 00:30:54 +0000

Cool, thanks Michael.  Will definitely take a look at the references 😉.

From: Michael Welzl <[email-masked]>
Sent: Monday, July 22, 2019 5:24 PM
To: Praveen Balasubramanian <pravb=[email-masked]>
Cc: [email-masked]; Daniel Havey <[email-masked]>; Osman Ertugay <[email-masked]>
Subject: Re: [iccrg] New Version Notification for draft-balasubramanian-iccrg-ledbatplusplus-00.txt

Hi,

1)

https://ieeexplore.ieee.org/document/6496997?tp=&arnumber=6496997&queryText=assessing%20ledbat%27s%20delay%20impact<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fieeexplore.ieee.org%2Fdocument%2F6496997%3Ftp%3D%26arnumber%3D6496997%26queryText%3Dassessing+ledbat%27s+delay+impact&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994382604207855&sdata=taKazLLhmNj55HnULPtUeLQ7NkFowiAXWSWlhM%2BYYqg%3D&reserved=0>
http://heim.ifi.uio.no/~michawe/research/publications/ledbat-impact-letters.pdf<https://nam06.safelinks.protection.outlook.com/?url=http:%2F%2Fheim.ifi.uio.no%2F~michawe%2Fresearch%2Fpublications%2Fledbat-impact-letters.pdf&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604207855&sdata=UdPUZpKqwpsIdvSnUjqMpUQwu%2BMDv5smTIv1QN1IV4s%3D&reserved=0>

2)

David Ros, Michael Welzl: "Less-than-Best-Effort Service: A Survey of End-to-End Approaches", IEEE Communications Surveys and Tutorials 15(2), pp.898-908, 2013.
https://ieeexplore.ieee.org/document/6226797?tp=&arnumber=6226797&contentType=Early%20Access%20Articles&searchField=Search_All&queryText=Less-than-Best-Effort%20Service:%20A%20Survey%20of%20End-to-End%20Approaches<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fieeexplore.ieee.org%2Fdocument%2F6226797%3Ftp%3D%26arnumber%3D6226797%26contentType%3DEarly+Access+Articles%26searchField%3DSearch_All%26queryText%3DLess-than-Best-Effort+Service%3A+A+Survey+of+End-to-End+Approaches&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604217848&sdata=9oCSaJv5OThmU84nb38qxvrP%2BQDBJzeXKx5FvZHK8Is%3D&reserved=0>
http://heim.ifi.uio.no/~michawe/research/publications/lbesurvey.pdf<https://nam06.safelinks.protection.outlook.com/?url=http:%2F%2Fheim.ifi.uio.no%2F~michawe%2Fresearch%2Fpublications%2Flbesurvey.pdf&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604227845&sdata=lCaKGTWAhdp8%2BtrXKU45b3fObS8Npq6KdQMlQgXoF7Y%3D&reserved=0>

I’d also like to note that colleagues have done newer work on LBE after the survey. This one, for example:
http://dl.ifip.org/db/conf/networking/networking2017/1570334752.pdf<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdl.ifip.org%2Fdb%2Fconf%2Fnetworking%2Fnetworking2017%2F1570334752.pdf&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604227845&sdata=csbQxrL62e6pT7xo9t9s%2F5Rm8ilO4EokAtyBpagBWPs%3D&reserved=0>
and this, before it, about CDG (which is available in Linux AFAIK):
http://dl.ifip.org/db/conf/networking/networking2017/1570350870.pdf<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdl.ifip.org%2Fdb%2Fconf%2Fnetworking%2Fnetworking2017%2F1570350870.pdf&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604237841&sdata=ELhs0%2FvncFf6r%2B3s0xWdFN7qajqzA2FObiWMu4fiuO4%3D&reserved=0>

Cheers,
Michael

On Jul 22, 2019, at 7:41 PM, Praveen Balasubramanian <pravb=[email-masked]<mailto:pravb=[email-masked]>> wrote:

Hi,

https://www.ietf.org/id/draft-balasubramanian-iccrg-ledbatplusplus-00.txt<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-balasubramanian-iccrg-ledbatplusplus-00.txt&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604237841&sdata=caNfRZBCOid0ijDHRVzNE54NswQazp6xvH9ixL1ghpo%3D&reserved=0>

Thanks

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Monday, July 22, 2019 3:35 PM
To: Praveen Balasubramanian <[email-masked]<mailto:[email-masked]>>; Osman Ertugay <[email-masked]<mailto:[email-masked]>>; Daniel Havey <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-balasubramanian-iccrg-ledbatplusplus-00.txt

Name:                  draft-balasubramanian-iccrg-ledbatplusplus
Revision:              00
Title:                      LEDBAT++: Congestion Control for Background Traffic
Document date:               2019-07-22
Group:                  Individual Submission
Pages:                   10
URL:            https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-balasubramanian-iccrg-ledbatplusplus-00.txt&amp;data=02%7C01%7Cpravb%40microsoft.com%7Cb60a23eb4b214f814e6808d70ef4c69b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994316788042519&amp;sdata=87IU%2FKrzc1j0ZVICsyXz15xnnIP9J2ViKHZ%2Fd3cYetQ%3D&amp;reserved=0<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-balasubramanian-iccrg-ledbatplusplus-00.txt&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604247835&sdata=J7CX%2FEWgx5Ocoyk0r1%2BRshQsv2JxO2SjgtcF9C%2BMX4w%3D&reserved=0>
Status:         https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-balasubramanian-iccrg-ledbatplusplus%2F&amp;data=02%7C01%7Cpravb%40microsoft.com%7Cb60a23eb4b214f814e6808d70ef4c69b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994316788042519&amp;sdata=N0L2kfBY7kSlnd41Jq7%2BhWARQDsSUGAxIAPjmb%2BpaAA%3D&amp;reserved=0<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-balasubramanian-iccrg-ledbatplusplus%2F&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604257833&sdata=uX5QGw9WUTAgzIKEhT%2FOhTnZNeEM3itME1HZjy9A264%3D&reserved=0>
Htmlized:       https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-balasubramanian-iccrg-ledbatplusplus-00&amp;data=02%7C01%7Cpravb%40microsoft.com%7Cb60a23eb4b214f814e6808d70ef4c69b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994316788042519&amp;sdata=ykGj6RbmkJGygjk0tA5gecGv06uyklgExb8hGdKuMxU%3D&amp;reserved=0<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-balasubramanian-iccrg-ledbatplusplus-00&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604257833&sdata=0gJL5R8Bsu6od1aY9Q6m5jfDdzlmC6T5tzl1NE5ZrbI%3D&reserved=0>
Htmlized:       https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-balasubramanian-iccrg-ledbatplusplus&amp;data=02%7C01%7Cpravb%40microsoft.com%7Cb60a23eb4b214f814e6808d70ef4c69b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994316788042519&amp;sdata=%2BM0S5HhOuCqRqar4Iwiikt69HVe8mXhKm14WN7793vo%3D&amp;reserved=0<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-balasubramanian-iccrg-ledbatplusplus&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C1%7C636994382604267826&sdata=kyrjr9YXtozl%2B0pPcvi5PtN9qJnHUH0%2BA3APkCRskOs%3D&reserved=0>

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org&data=02%7C01%7Cdahavey%40microsoft.com%7Cb4464cb24bc64967799b08d70f041931%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636994382604277822&sdata=6CYtA8WVD5y%2BJcpPG5ant%2FFImryDI4BdcpKtwa6qX3M%3D&reserved=0>.

The IETF Secretariat

_______________________________________________
iccrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/iccrg

---

From: Michael Welzl <[email-masked]>
Date: Mon, 22 Jul 2019 20:43:41 -0400

> When the LEDBAT WG started, David Ros and I were assigned to take the lead on the first milestone: a survey of LEDBAT’ish mechanisms out there. We wrote it, and it’s RFC 69297.

Tens of thousands of RFCs!  Holy cow!

=>  that should be RFC 6297  :-)

Cheers,
Michael