Subject: [iccrg] Congestion Control in Data Centers and HPC/RDMA environments

From: Paul Congdon <[email-masked]>
Date: Thu, 17 Oct 2019 10:54:56 -0700

Hello ICCRG,

Jana suggested that I email the group with this call for interest on
Congestion Control for Data Centers.  At the last several IETF meetings
I've hosted side meetings and presented to various groups about work going
on in Data Center congestion control and scaling HPC/RDMA networks.  We
have been searching for a permanent venue within the IETF for this work.
 ICCRG is primarily focused on end-to-end congestion control across the
vast and expansive Internet.   The data center, and in particular, the
HPC/RDMA data center network has much different characteristics.   So, the
question to ICCRG is this; is this topic of interest to ICCRG and should
the charter be expanded to include DC congestion control, or is this a good
topic for a new research item in IRTF?

Looking forward to hearing from you,
Thank you,
Paul Congdon

---

From: Michael Welzl <[email-masked]>
Date: Fri, 18 Oct 2019 07:30:59 +0200

Hi,

What about adding a statement like the following to the charter?

***
The ICCRG may also consider congestion and protocol performance problems in general IP networks, i.e., not only on the global Internet. One example of such IP networks are multi-tenant, heterogeneous datacenters, which in some sense represent a microcosm of the larger Internet; changes to the transport protocols being considered in that space are fundamental and can have broader implications.
***

(turns out that it’s already there:  https://datatracker.ietf.org/rg/iccrg/about/ <https://datatracker.ietf.org/rg/iccrg/about/> )

Cheers,
Michael

> On Oct 17, 2019, at 7:54 PM, Paul Congdon <[email-masked]> wrote:
> 
> Hello ICCRG,
> 
> Jana suggested that I email the group with this call for interest on Congestion Control for Data Centers.  At the last several IETF meetings I've hosted side meetings and presented to various groups about work going on in Data Center congestion control and scaling HPC/RDMA networks.  We have been searching for a permanent venue within the IETF for this work.   ICCRG is primarily focused on end-to-end congestion control across the vast and expansive Internet.   The data center, and in particular, the HPC/RDMA data center network has much different characteristics.   So, the question to ICCRG is this; is this topic of interest to ICCRG and should the charter be expanded to include DC congestion control, or is this a good topic for a new research item in IRTF?
> 
> _______________________________________________
> iccrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/iccrg

---

From: Paul Congdon <[email-masked]>
Date: Mon, 21 Oct 2019 08:11:28 -0700

Yes, you are correct.

"Because congestion control is typically a key function of transport
protocols, it is hard to separate other transport layer issues from
congestion control. Considerations for deployment of transport protocols
are therefore also considered within scope. The ICCRG may also consider
congestion and protocol performance problems in general IP networks, i.e.,
not only on the global Internet. One example of such IP networks are
multi-tenant, heterogeneous datacenters, which in some sense represent a
microcosm of the larger Internet; changes to the transport protocols being
considered in that space are fundamental and can have broader implications."

One question that came up in discussions with others is can the solution be
restricted to particular topologies and domains, such as datacenters, if
the solution is not deemed 'safe' to run across the Internet at large?

Sounds like such research is in scope from the above paragraph.

On Thu, Oct 17, 2019 at 10:31 PM Michael Welzl <[email-masked]> wrote:

> The ICCRG may also consider congestion and protocol performance problems
> in general IP networks, i.e., not only on the global Internet. One example
> of such IP networks are multi-tenant, heterogeneous datacenters, which in
> some sense represent a microcosm of the larger Internet; changes to the
> transport protocols being considered in that space are fundamental and can
> have broader implications.
> ***
>
> (turns out that it’s already there:
> https://datatracker.ietf.org/rg/iccrg/about/ )
>
> Cheers,
> Michael
>
>

---

From: Michael Welzl <[email-masked]>
Date: Mon, 21 Oct 2019 17:24:10 +0200

Yes, I’d say so. That was the point of adding this text when we did (many years ago).

Cheers
Michael 

Sent from my iPhone

> On 21 Oct 2019, at 17:11, Paul Congdon <[email-masked]> wrote:
> 
> 
> Yes, you are correct.
> 
> "Because congestion control is typically a key function of transport protocols, it is hard to separate other transport layer issues from congestion control. Considerations for deployment of transport protocols are therefore also considered within scope. The ICCRG may also consider congestion and protocol performance problems in general IP networks, i.e., not only on the global Internet. One example of such IP networks are multi-tenant, heterogeneous datacenters, which in some sense represent a microcosm of the larger Internet; changes to the transport protocols being considered in that space are fundamental and can have broader implications."
> 
> One question that came up in discussions with others is can the solution be restricted to particular topologies and domains, such as datacenters, if the solution is not deemed 'safe' to run across the Internet at large?
> 
>> (turns out that it’s already there:  https://datatracker.ietf.org/rg/iccrg/about/ )
>> 
>> Cheers,
>> Michael
>> 
>>

---

From: Yuchung Cheng <[email-masked]>
Date: Mon, 21 Oct 2019 12:58:31 -0700

> Jana suggested that I email the group with this call for interest on Congestion Control for Data Centers.  At the last several IETF meetings I've hosted side meetings and presented to various group…
+1

BBR is one example congestion control presented in ICCRG that attempts
to cover both sides (and also WAN between DCs).