Subject: [iccrg] Impact on traditional traffic modelling methodologies by QUIC/BBR

From: Thedin Guruge <[email-masked]>
Date: Fri, 18 Jun 2021 12:50:55 +0000

Hi All,

I have been following recent developments with both QUIC and BBR fronts and a have a question on how these latest developments relate to traditional traffic modelling methodologies.

I am making an assumption that, by and large, most current models rely on loss based congestion control as opposed to delay or hybrid. I am also making an assumption that QUIC/BBR will help with better utilising network link capacity vs. pure loss based congestion control algorithms.

I would like to find out if there’s been any thinking done on the fronts of impacts introduced on existing modelling methodologies, given we can expect substantial use of QUIC and BBR (both QUIC and TCP usage) in future?
And I apologise in advance if this topic has been discussed broadly with existing background content, if so, I’d appreciate if you could kindly point me at them.

Regards,

Thedin Guruge
Network & Service Architect | Chief Technology Office

---

From: Thedin Guruge <[email-masked]>
Date: Sat, 19 Jun 2021 00:49:20 +0000

Hi Narishma,

Thanks for this, I have been through a few papers that had studied differences in behaviour, throughput/performance, of loss/delay/hybrid CC as well.

I was however particularly interested in finding if there’d been any study on link utilisation impacts by hybrid or delay based CC, positive or negative impacts. Given there’d been claims in the industry that BBR based CC can increase throughput by ~20%.

So moving forward if we were to see a larger % of internet traffic composition made out of delay based CC, would it enable a scenario of better link utilisation, i.e. links to operate at higher levels yet not resulting in adverse customer experience? Unless it’s unlikely that we see delay based CC being dominant in future.

Regards,

Thedin Guruge
M +61 417 354 929 | E [email-masked]<mailto:[email-masked]>

From: Annapareddy, Narasimha <[email-masked]>
Date: Saturday, 19 June 2021 at 1:09 am
To: Thedin Guruge <[email-masked]>, iccrg IRTF list <[email-masked]>
Subject: [External] RE: Impact on traditional traffic modelling methodologies by QUIC/BBR
Thedin, here is some of our earlier work that touches on how to design delay based protocols so that they can compete with loss based protocols:

Kiran Kotla and A. L. Narasimha Reddy, Making a delay-based protocol adaptive to heterogenous enviornments<http://ecencesg.wpengine.com/wp-content/uploads/2012/04/reddy_papers/iwqos2008.pdf>, Proc. of IWQOS, June 2008.

Not quite you are looking for, but points to interactions of diverse protocols and how to design delay based protocols to compete against traditional TCP.

Narasimha Reddy

From: iccrg <[email-masked]> On Behalf Of Thedin Guruge
Sent: Friday, June 18, 2021 7:51 AM
To: iccrg IRTF list <[email-masked]>
Subject: [iccrg] Impact on traditional traffic modelling methodologies by QUIC/BBR

Hi All,

Regards,

Thedin Guruge