Subject: [icnrg] Draft proposal for ICN Conceptual Reference Model

From: Paulo Mendes <[email-masked]>
Date: Sat, 19 Jan 2013 23:52:17 +0000

Dear all

Following the discussion about the three first drafts of the ICNRG, and following Boerje invitation to start the survey document, I just posted in the twiki (ICN Survey Document page) the table of content of a draft aiming to describe a ICN conceptual reference model suitable for ICNRG work. At the bottom of the same page you can first the first draft with the posted table of content and some initial content to justify the table of content.

As I mentioned before, I don´t think that the draft should be only a survey of ICN solutions. The draft should try to come up with a conceptual reference model based on a clear applicability picture and highlighting the major conceptual building blocks that will then be detailed in the research challenges draft. 

As I mentioned in a previous email I'll not be able to be in Kista, but I hope you'll find time to discuss this document in the morning of the first day. If the RG chairs think important I can send to the mailing list a brief report about the status of the document some days before the meeting.

The first milestone is to get a stable table of content and a list of people that will like to contribute to the document, allocating names to sections.

Cheers
Paulo

-------------------------------------------------------------
Paulo Mendes, Ph.D
Scientific Director for Innovation of the Research Unit in Informatics Systems and Technologies (SITILabs)
Director of the Ph.D program on Informatics - New Media and Pervasive Systems (NEMPS)
Secretary of the ACM SIGCOMM Chapter - Portugal
Associated Professor at University Lusofona, Portugal
[email-masked]
http://siti.ulusofona.pt/~pmendes
Tel.: 217 50 50 22

---

From: Dirk Trossen <[email-masked]>
Date: Sun, 20 Jan 2013 12:08:40 +0000

Hi Paulo,

thanks for pushing this forward. I'm concerned that you are over-reaching the goal of the document if you indeed intend to cover a 'survey' (which is more than just listing the different approaches but also try to flesh out the commonalities and differences in a comprehensive manner) that leads to a reference model of some kind. Firstly, I'm not sure that reaching from a survey to a reference model conveys the right picture (since it might look like you simply throw in several ingredients to cook a large stew - pardon my picture here). Secondly, I'm not sure that the wider community is at the point to agree/converge towards a reference model (it is here where the survey should help by fleshing out the commonalities and differences). Thirdly, I'm not even convinced that a 'reference model' is a good idea to start with. I'd rather go for a set of well-articulated design choices, each of which has its particular reasoning. 

As a conclusion, I see a danger that this document might end up being overloaded in terms of objectives, which eventually might not help.

Best,

Dirk
On 19 Jan 2013, at 23:52, Paulo Mendes wrote:

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Paulo Mendes <[email-masked]>
Date: Sun, 20 Jan 2013 22:41:10 +0000

Hi Dirk

I fully agree that it is too soon for the wider community to converge to a reference model. But as a draft, this is a "living document": this is the document aims to be a tool to allow the community to converge to a reference model in the media term, but of course not in the first set of versions. Those should be used to flesh out commonalities in different points of view and to polish the relationship with the other two ICNRG drafts, with the right mindset.

As for the final shape of the draft, the reference model, it must be a good illustration of what the ICNRG community thinks the ICN concept should offer. We may end up with a unique view of ICN, or a set of well-articulated design choices as you mention (well-articulated is the key word). In my opinion this is not a decision to be taken now. We need to let the discussion flow and see were we'll be in 2 or 3 versions of the draft. 

I do not see were the overloading is: I think that ICNRG makes sense for the community to discuss about what ICN is (concept, applicability, challenges). This is why I'm proposing to work on a reference model, aiming to try to define the concept of ICN. This, together with a set of baseline scenarios (applicability) and a set of research challenges, may be a very good contribution of ICNRG to the wider community. Doing just a survey (identification of commonalities and differences between existing ICN proposal) is not interesting. For that you already have a set of contributions: the IEEE Commag paper that I refer in the paper; The doc that come out of Dagstuhl; The survey of mobility on ICN from G. Tyson et al; The paper from A. Ghodsi et al,; The paper from A. Haris; The technical report from M. Vahlenkamp; The paper from M. Faizul Bari, etc... 

Paulo

---

From: Karen Sollins <[email-masked]>
Date: Sun, 20 Jan 2013 17:30:00 -0800

HI Dirk and Paulo,

Although I also tend to want to think about something more general than what a survey will provide at first, I am concerned that the outline as it stands will not challenge us to find the significant differences.  For example, one of the things I have come to believe (having now written several of these sorts of summaries myself) is that the really interesting questions may start with the issue of what is trying to be achieved by a particular approach.  Different of these approaches (and I would expand the list beyond just the obvious group) are really starting from different objectives.  Hence a comparison of mechanism such as caching, naming, etc. is a bit moot, if one really wants to understand the larger differences among these approaches.  The particular mechanisms are artifacts that result from deeper differences among them. but only superficially indicative of the differences among.  Hence, for now, I would argue that a "deeper" survey will allow us to understand better the breadth of kinds of objectives these systems might have, which is a necessary precursor to a "reference model" or "architecture" or other similar framing concepts.  In fact, what we may find is that these approaches are so different from each other and may be defined for such different parts of an overall architecture, that one need not consider a direct comparison of them in the end.  I believe that a deeper level of survey will stand us in good stead.  It is quite possible that it will be only a precursor to something else interesting, but at this point I'd like to see this be a more thorough survey.

Privately, because I didn't know who might be doing this, I had sent a note to Dave Oran, since he was listed as coordinating this, offering to help/participate in writing this.  I am happy to be public about this, but I wanted to figure out who might be doing this, to figure out how best to offer to help and participate.

It is definitely useful to have a draft outline as a starting point for discussion about what should and should not go into the document.  Thank you.

			Cheers,
			Karen

>>> The first milestone is to get a stable table of content and a list of people that will like to contribute to the document, allocating names to sections.

Karen R. Sollins, Ph. D.
Principal Scientist
MIT Computer Science and Artificial Intelligence Laboratory
32 Vassar St.
Cambridge, MA 02139
P: +1 617 253 6006
F: +1 617 253 2673
E: [email-masked]

---

From: Karen Sollins <[email-masked]>
Date: Sun, 20 Jan 2013 17:31:38 -0800

By the way, I also cannot be in Sweden for the interim meeting.  I had hoped to, but it won't work out.

			Cheers,
			Karen

Karen R. Sollins, Ph. D.
Principal Scientist

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 21 Jan 2013 07:39:40 +0000

Hi Karen and Paulo

Very well said, exactly along the lines of my thinking. The survey papers of the recent past are not what I had in mind to repeat but approach an overview of the current choices and artefacts from their objectives, well formulated or not by their proponents, leading us to better understand these choices for any future consideration, e.g., in some form of reference model. One aspect is that the survey would not be limited to the typical academic publication paper sizes :-) 

Best

Dirk

Karen Sollins <[email-masked]> wrote:

>HI Dirk and Paulo,
>
>Although I also tend to want to think about something more general than
>what a survey will provide at first, I am concerned that the outline as
>it stands will not challenge us to find the significant differences. 
>For example, one of the things I have come to believe (having now
>written several of these sorts of summaries myself) is that the really
>interesting questions may start with the issue of what is trying to be
>achieved by a particular approach.  Different of these approaches (and
>I would expand the list beyond just the obvious group) are really
>starting from different objectives.  Hence a comparison of mechanism
>such as caching, naming, etc. is a bit moot, if one really wants to
>understand the larger differences among these approaches.  The
>particular mechanisms are artifacts that result from deeper differences
>among them. but only superficially indicative of the differences among.
>Hence, for now, I would argue that a "deeper" survey will allow us to
>understand better the breadth of kinds of objectives these systems
>might have, which is a necessary precursor to a "reference model" or
>"architecture" or other similar framing concepts.  In fact, what we may
>find is that these approaches are so different from each other and may
>be defined for such different parts of an overall architecture, that
>one need not consider a direct comparison of them in the end.  I
>believe that a deeper level of survey will stand us in good stead.  It
>is quite possible that it will be only a precursor to something else
>interesting, but at this point I'd like to see this be a more thorough
>survey.
>
>Privately, because I didn't know who might be doing this, I had sent a
>note to Dave Oran, since he was listed as coordinating this, offering
>to help/participate in writing this.  I am happy to be public about
>this, but I wanted to figure out who might be doing this, to figure out
>how best to offer to help and participate.
>
>It is definitely useful to have a draft outline as a starting point for
>discussion about what should and should not go into the document. 
>Thank you.
>
>			Cheers,
>			Karen
>
>> I fully agree that it is too soon for the wider community to converge
>to a reference model. But as a draft, this is a "living document": this
>is the document aims to be a tool to allow the community to converge to
>a reference model in the media term, but of course not in the first set
>of versions. Those should be used to flesh out commonalities in
>different points of view and to polish the relationship with the other
>two ICNRG drafts, with the right mindset.
>> 
>> As for the final shape of the draft, the reference model, it must be
>a good illustration of what the ICNRG community thinks the ICN concept
>should offer. We may end up with a unique view of ICN, or a set of
>well-articulated design choices as you mention (well-articulated is the
>key word). In my opinion this is not a decision to be taken now. We
>need to let the discussion flow and see were we'll be in 2 or 3
>versions of the draft. 
>> 
>> I do not see were the overloading is: I think that ICNRG makes sense
>for the community to discuss about what ICN is (concept, applicability,
>challenges). This is why I'm proposing to work on a reference model,
>aiming to try to define the concept of ICN. This, together with a set
>of baseline scenarios (applicability) and a set of research challenges,
>may be a very good contribution of ICNRG to the wider community. Doing
>just a survey (identification of commonalities and differences between
>existing ICN proposal) is not interesting. For that you already have a
>set of contributions: the IEEE Commag paper that I refer in the paper;
>The doc that come out of Dagstuhl; The survey of mobility on ICN from
>G. Tyson et al; The paper from A. Ghodsi et al,; The paper from A.
>Haris; The technical report from M. Vahlenkamp; The paper from M.
>Faizul Bari, etc... 
>> 
>> Paulo
>> 
>>> thanks for pushing this forward. I'm concerned that you are
>over-reaching the goal of the document if you indeed intend to cover a
>'survey' (which is more than just listing the different approaches but
>also try to flesh out the commonalities and differences in a
>comprehensive manner) that leads to a reference model of some kind.
>Firstly, I'm not sure that reaching from a survey to a reference model
>conveys the right picture (since it might look like you simply throw in
>several ingredients to cook a large stew - pardon my picture here).
>Secondly, I'm not sure that the wider community is at the point to
>agree/converge towards a reference model (it is here where the survey
>should help by fleshing out the commonalities and differences).
>Thirdly, I'm not even convinced that a 'reference model' is a good idea
>to start with. I'd rather go for a set of well-articulated design
>choices, each of which has its particular reasoning. 
>>> 
>>> As a conclusion, I see a danger that this document might end up
>being overloaded in terms of objectives, which eventually might not
>help.
>>> 
>>> Best,
>>> 
>>> Dirk
>>>> Following the discussion about the three first drafts of the ICNRG,
>and following Boerje invitation to start the survey document, I just
>posted in the twiki (ICN Survey Document page) the table of content of
>a draft aiming to describe a ICN conceptual reference model suitable
>for ICNRG work. At the bottom of the same page you can first the first
>draft with the posted table of content and some initial content to
>justify the table of content.
>>>> 
>>>> As I mentioned before, I don´t think that the draft should be only
>a survey of ICN solutions. The draft should try to come up with a
>conceptual reference model based on a clear applicability picture and
>highlighting the major conceptual building blocks that will then be
>detailed in the research challenges draft. 
>>>> 
>>>> As I mentioned in a previous email I'll not be able to be in Kista,
>but I hope you'll find time to discuss this document in the morning of
>the first day. If the RG chairs think important I can send to the
>mailing list a brief report about the status of the document some days
>before the meeting.
>>>> 
>>>> The first milestone is to get a stable table of content and a list
>of people that will like to contribute to the document, allocating
>names to sections.
>>>> 
>>>> Cheers
>>>> Paulo
>>>> 
>>>> Scientific Director for Innovation of the Research Unit in
>Informatics Systems and Technologies (SITILabs)
>> Scientific Director for Innovation of the Research Unit in
>Informatics Systems and Technologies (SITILabs)

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 21 Jan 2013 07:40:56 +0000

It seems that I will be in Sweden for the meeting, not sure though if I can stay for both days. Hence I can have an eye open for this.

Dirk

---

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Fri, 25 Jan 2013 09:02:19 +0000

Hi Paulo,

I am the co-author of ren-icn-content-retrieval<http://tools.ietf.org/html/draft-ren-icn-content-retrieval>, a survey draft discussing about content retrieval in the ICN. Thank you for your great effort in drafting the conceptual reference model of ICN and my team are very interested in joining your effort and making some contributions to the conceptual reference model.

The user-cases in 2.3 are very interesting, which inspired us to think that maybe a bigger picture of applying ICN is Internet of Things (IoT). Naming, information publication and searching are compulsory components in both ICN and IoT. If you think the same way, we would love to explore more and contribute to this section if it has not been taking up by others.

In section 3, besides the projects listed from section 3.1 to section 3.5, we are capable to add other projects such as MobilityFirst, XIA and CONET.

Most of the content in our ren-icn-content-retrieval<http://tools.ietf.org/html/draft-ren-icn-content-retrieval> are aligned well with your current layout in Section 4. We are in the middle of revision based on the feedback from peers in the ICNRG and the authors of some projects to make it well-articulated as mentioned by Dirk. If this task is still waiting for claiming, I am wondering if you can assign it to us.

Besides your current layout, we would like to propose a chapter discussing about the potential deployment of ICN. As we discussed in the mailing list of ICNRG before IETF85, it is a concern to most peers. We have been thinking and comparing the advantages and disadvantages of deploying ICN over IP, integrated with IP, and over SDN.

Thanks for reading this long email and we do hope that we can join your effort and make some contribution in ICN.

Cheers,
Will

From: [email-masked] [mailto:[email-masked]] On Behalf Of Paulo Mendes
Sent: Sunday, January 20, 2013 7:52 AM
To: icnrg
Subject: [icnrg] Draft proposal for ICN Conceptual Reference Model

Dear all

Cheers
Paulo

[email-masked]<mailto:[email-masked]>

---

From: Dirk Trossen <[email-masked]>
Date: Fri, 25 Jan 2013 10:32:54 +0000

Hi Will, all,

> Besides your current layout, we would like to propose a chapter discussing about the potential deployment of ICN. As we discussed in the mailing list of ICNRG before IETF85, it is a concern to most…

for this, it might be worthwhile to have a look at a report we did in the PSIRP project (the predecessor of the PURSUIT project) on deployment incentives, looking at industries that could drive native or overlay deployments. It's available at http://www.psirp.org/files/Deliverables/FP7-INFSO-ICT-216173-PSIRP-D4.6_FinalReportOnDeplIncBusinessModels.pdf

As for SDN deployments, we've recently looked at ways of doing this, trying to avoid scaling issues when mapping 'content flows' onto 'SDN flows'. Point here is to bind the mapping onto SDN to the connectivity between publishers and subscribers, not the content they are exchanging (since the 'flows' of content can be significantly larger than the actual connectivity relations in the network). You can find our ideas published as 

D. Syrivelis, G. Parisis, D. Trossen, P. Flegkas, V. Sourlas, T. Korakis, L. Tassiulas, Pursuing a Software-Defined Information-Centric Network, EWSDN 2012, IEEE, Darmstad Germany.

Best,

Dirk

---

From: Daniel Corujo <[email-masked]>
Date: Fri, 25 Jan 2013 10:58:43 +0000

Dear Will,

Kostas Pentikousis and I are assembling a IoT section in the Baseline Scenarios draft. Therein, we are already highlight, through existing state-of-the-art references, how the inherent ICN capabilities can benefit IoT deployments, as well as enhancing and create the opportunity for novel deployment scenarios to be conceived.

It would be interesting that both contributions could be complementary and somewhat aligned.

Best regards,

Daniel Corujo
[email-masked]
http://re.vu/dcorujo

On Jan 25, 2013, at 09:02 , Will Liu (Shucheng) wrote:

> Hi Paulo,
>  
> I am the co-author of ren-icn-content-retrieval, a survey draft discussing about content retrieval in the ICN. Thank you for your great effort in drafting the conceptual reference model of ICN and my team are very interested in joining your effort and making some contributions to the conceptual reference model.
>  
> Most of the content in our ren-icn-content-retrieval are aligned well with your current layout in Section 4. We are in the middle of revision based on the feedback from peers in the ICNRG and the authors of some projects to make it well-articulated as mentioned by Dirk. If this task is still waiting for claiming, I am wondering if you can assign it to us.
>

---

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Sat, 26 Jan 2013 02:02:58 +0000

Hi, Dirk,

Thanks for your comments. Indeed we have read both references that you pointed out and we think the forwarding design of ICN on SDN in your EWSDN 2012 paper is very neat. With the current several ongoing efforts in ICN community to implement ICN over SDN or design software designed ICN, we believe interoperability can be exploited and demonstrated.
Cheers,
Will

From: Dirk Trossen [mailto:[email-masked]] On Behalf Of Dirk Trossen
Sent: Friday, January 25, 2013 6:33 PM
To: Will Liu (Shucheng)
Cc: Paulo Mendes; 任婧; icnrg; Jianping Wang
Subject: Re: [icnrg] Draft proposal for ICN Conceptual Reference Model

Hi Will, all,

D. Syrivelis, G. Parisis, D. Trossen, P. Flegkas, V. Sourlas, T. Korakis, L. Tassiulas, Pursuing a Software-Defined Information-Centric Network, EWSDN 2012<http://www.ewsdn.org/>, IEEE, Darmstad Germany.

Best,

Dirk

Cheers,
Will

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Paulo Mendes
Sent: Sunday, January 20, 2013 7:52 AM
To: icnrg
Subject: [icnrg] Draft proposal for ICN Conceptual Reference Model

Dear all

Cheers
Paulo

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Sat, 26 Jan 2013 02:20:51 +0000

Hi, Daniel,

It is great to know that you have the same vision and we look forward to knowing more about the novel deployment scenarios that you are working on. 

Regards,
Shucheng LIU (Will)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Daniel Corujo
> Sent: Friday, January 25, 2013 6:59 PM
> To: Will Liu (Shucheng)
> Cc: icnrg; 任婧; Paulo Mendes; Jianping Wang; Konstantinos Pentikousis
> Kostas Pentikousis and I are assembling a IoT section in the Baseline
> Scenarios draft. Therein, we are already highlight, through existing
> state-of-the-art references, how the inherent ICN capabilities can benefit
> IoT deployments, as well as enhancing and create the opportunity for novel
> deployment scenarios to be conceived.
> 
> > I am the co-author of ren-icn-content-retrieval, a survey draft discussing
> about content retrieval in the ICN. Thank you for your great effort in drafting
> the conceptual reference model of ICN and my team are very interested in
> joining your effort and making some contributions to the conceptual
> reference model.
> >
> > The user-cases in 2.3 are very interesting, which inspired us to think that
> maybe a bigger picture of applying ICN is Internet of Things (IoT). Naming,
> information publication and searching are compulsory components in both
> ICN and IoT. If you think the same way, we would love to explore more and
> contribute to this section if it has not been taking up by others.
> >
> > In section 3, besides the projects listed from section 3.1 to section 3.5, we
> are capable to add other projects such as MobilityFirst, XIA and CONET.
> >
> > Most of the content in our ren-icn-content-retrieval are aligned well with
> your current layout in Section 4. We are in the middle of revision based on
> the feedback from peers in the ICNRG and the authors of some projects to
> make it well-articulated as mentioned by Dirk. If this task is still waiting for
> claiming, I am wondering if you can assign it to us.
> >
> > Besides your current layout, we would like to propose a chapter discussing
> about the potential deployment of ICN. As we discussed in the mailing list of
> ICNRG before IETF85, it is a concern to most peers. We have been thinking
> and comparing the advantages and disadvantages of deploying ICN over IP,
> integrated with IP, and over SDN.
> >
> > Thanks for reading this long email and we do hope that we can join your
> effort and make some contribution in ICN.
> >
> > Cheers,
> > Will
> >
> > Following the discussion about the three first drafts of the ICNRG, and
> following Boerje invitation to start the survey document, I just posted in the
> twiki (ICN Survey Document page) the table of content of a draft aiming to
> describe a ICN conceptual reference model suitable for ICNRG work. At the
> bottom of the same page you can first the first draft with the posted table of
> content and some initial content to justify the table of content.
> >
> > As I mentioned before, I don´t think that the draft should be only a survey
> of ICN solutions. The draft should try to come up with a conceptual
> reference model based on a clear applicability picture and highlighting the
> major conceptual building blocks that will then be detailed in the research
> challenges draft.
> >
> > As I mentioned in a previous email I'll not be able to be in Kista, but I hope
> you'll find time to discuss this document in the morning of the first day. If the
> RG chairs think important I can send to the mailing list a brief report about
> the status of the document some days before the meeting.
> >
> > The first milestone is to get a stable table of content and a list of people
> that will like to contribute to the document, allocating names to sections.
> >
> > Cheers
> > Paulo
> >
> > Scientific Director for Innovation of the Research Unit in Informatics
> > Systems and Technologies (SITILabs) Director of the Ph.D program on
> > Informatics - New Media and Pervasive Systems (NEMPS) Secretary of the
> > ACM SIGCOMM Chapter - Portugal Associated Professor at University
> > Lusofona, Portugal [email-masked]

---

From: "George C. Polyzos" <[email-masked]>
Date: Fri, 25 Jan 2013 23:30:08 -0800

Dear Will, Paulo, all,

Our lab is particularly interested in exploring the possibilities of using ICN as an enabling technology for a pervasive sensing architecture with focus on the IoT (and e-health). We participated in the FP7 project PSIRP and now participate in FP7 PURSUIT.

We believe that the IoT can be an ideal use case for demonstrating the applicability of ICN. Inspired by the PURSUIT ICN architecture, we have proposed an information lookup scheme for the IoT (http://mm.aueb.gr/publications/2012-IoT-SoS.pdf). Next week I am going to present an extension of this work that discusses context-based security for information look-up at the IEEE ICNC conference in San Diego.

More generally, we are currently working in two domains of ICN which we think will benefit an ICN IoT architecture. The first area concerns a scalable, distributed lookup service, based on hierarchical DHTs. This is a continuation of the work in: http://www.mm.aueb.gr/publications/2012_DHTNRS_NETWORKING.pdf. The second area concerns access control, and privacy preserving mechanisms. As far as access control is concerned, we are extending the work in http://mm.aueb.gr/publications/2012-icn12-fotiou.pdf that proposes a mechanism enabling multi-domain and distributed access control. As far as privacy is concerned, we are preparing a paper that explores the applicability of homomorphic encryption for preserving privacy (and we recently completed with other PURSUIT co-authors a survey of privacy issues in ICN).

My group would love to collaborate on these topics and contribute to relevant ICNRG documents.

Regards,

-GP

Prof. George C. Polyzos, Director

Mobile Multimedia Laboratory

Department of Informatics

Athens University of Economics and Business

47A Evelpidon Street

GR-11362 Athens, Greece

Tel.: +30 2108203650, assistant: +30 2108203646 Fax: +30 2108203325

Email: [email-masked], [email-masked], [email-masked]

http://mm.aueb.gr/

 

From: [email-masked] [mailto:[email-masked]] On Behalf Of Will Liu (Shucheng)
Sent: Friday, January 25, 2013 1:02 AM
To: Paulo Mendes
Cc: 任婧; icnrg; Jianping Wang
Subject: Re: [icnrg] Draft proposal for ICN Conceptual Reference Model

Hi Paulo,

I am the co-author of  <http://tools.ietf.org/html/draft-ren-icn-content-retrieval> ren-icn-content-retrieval, a survey draft discussing about content retrieval in the ICN. Thank you for your great effort in drafting the conceptual reference model of ICN and my team are very interested in joining your effort and making some contributions to the conceptual reference model. 

Most of the content in our  <http://tools.ietf.org/html/draft-ren-icn-content-retrieval> ren-icn-content-retrieval are aligned well with your current layout in Section 4. We are in the middle of revision based on the feedback from peers in the ICNRG and the authors of some projects to make it well-articulated as mentioned by Dirk. If this task is still waiting for claiming, I am wondering if you can assign it to us.

Cheers,

Will

From:  <mailto:[email-masked]> [email-masked] [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Paulo Mendes
Sent: Sunday, January 20, 2013 7:52 AM
To: icnrg
Subject: [icnrg] Draft proposal for ICN Conceptual Reference Model

Dear all

Cheers

Paulo

Paulo Mendes, Ph.D

 <mailto:[email-masked]> [email-masked]

 <http://siti.ulusofona.pt/~pmendes> http://siti.ulusofona.pt/~pmendes

Tel.: 217 50 50 22

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 27 Jan 2013 14:27:20 +0000

Hi,

On 01/26/2013 07:30 AM, George C. Polyzos wrote:

> As far as access control is concerned, we are extending the work in http://mm.aueb.gr/publications/2012-icn12-fotiou.pdf that proposes a mechanism enabling multi-domain and distributed access control. As far as privacy is concerned, we are preparing a paper that explores the applicability of homomorphic encryption for preserving privacy (and we recently completed with other PURSUIT co-authors a survey of privacy issues in ICN).
>

Access control in ICNs is an interesting topic. I think the
lack of a real authorization solution might be fatal to
some ICN "visions" and could mean that ICN is just a way to
better handle public information.

On the paper you mention, I don't see how that general idea
would work unless there are only authorized caches, which isn't
how most ICN approaches work. If anyone can act as a cache, it
seems that the scheme in that paper wouldn't work, or am I
missing something?

Considering FHE and ICN is also interesting and Elwyn Davies
has had a bit of a look at that. The really interesting thing
there I think is whether or not a practical FHE is required
before you can do authorization in ICNs. I suspect that might
be the case.

S.