Subject: Re: [icnrg] ICN access control and homomorphic encryption --was: Draft proposal for ICN Conceptual Reference Model

From: "George C. Polyzos" <[email-masked]>
Date: Wed, 30 Jan 2013 14:59:55 -0800

Dear Stephen,

We assume trusted relaying parties (caches).

[The access control scheme described in this paper considers two distinct roles: the relaying parties (caches, 'CDN' servers etc.) and the access control providers (decision makers). The latter decide if a user can access a piece of content stored in the former.]

Currently we are working on extending the scheme to lower the communication overhead, as well as, to be able to handle untrusted or unreliable caches (i.e., caches that do not always respect the decisions of the access control provider). For the latter we are examining various forms of encryption of the content.

Wrt fully homomorphic encryption (FHE), we are not aware of any efficient scheme. In our work we are considering partially homomorphic encryption, which still has non-negligible performance penalty.

Regards,

-GP

-----Original Message-----
From: Stephen Farrell [mailto:[email-masked]] 
Sent: Sunday, January 27, 2013 6:27 AM
To: [email-masked]
Cc: 'Will Liu (Shucheng)'; 'Paulo Mendes'; '任婧'; 'icnrg'; 'Jianping Wang'
Subject: Re: [icnrg] Draft proposal for ICN Conceptual Reference Model

Hi,

On 01/26/2013 07:30 AM, George C. Polyzos wrote:

> As far as access control is concerned, we are extending the work in http://mm.aueb.gr/publications/2012-icn12-fotiou.pdf that proposes a mechanism enabling multi-domain and distributed access control. As far as privacy is concerned, we are preparing a paper that explores the applicability of homomorphic encryption for preserving privacy (and we recently completed with other PURSUIT co-authors a survey of privacy issues in ICN).
>

Access control in ICNs is an interesting topic. I think the lack of a real authorization solution might be fatal to some ICN "visions" and could mean that ICN is just a way to better handle public information.

On the paper you mention, I don't see how that general idea would work unless there are only authorized caches, which isn't how most ICN approaches work. If anyone can act as a cache, it seems that the scheme in that paper wouldn't work, or am I missing something?

Considering FHE and ICN is also interesting and Elwyn Davies has had a bit of a look at that. The really interesting thing there I think is whether or not a practical FHE is required before you can do authorization in ICNs. I suspect that might be the case.

S.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 30 Jan 2013 23:15:50 +0000

Hi George,

> We assume trusted relaying parties (caches).

Ah. Fair enough. I guess that makes the scheme sort-of ICNish
in some sense. (Do we have a good set of definitions of what's
ICN and what's not?)

> Wrt fully homomorphic encryption (FHE), we are not aware of any efficient scheme. In our work we are considering partially homomorphic encryption, which still has non-negligible performance penalty.

That matches what we found too.

S.

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>