Subject: Re: [icnrg] Draft proposal for ICN Conceptual Reference Model

From: Paulo Mendes <[email-masked]>
Date: Fri, 1 Feb 2013 16:55:49 +0000

Hi Karen

See my comments inline..

On Jan 21, 2013, at 1:30 AM, Karen Sollins wrote:

> HI Dirk and Paulo,
> 
> Although I also tend to want to think about something more general than what a survey will provide at first, I am concerned that the outline as it stands will not challenge us to find the significant differences.  For example, one of the things I have come to believe (having now written several of these sorts of summaries myself) is that the really interesting questions may start with the issue of what is trying to be achieved by a particular approach.  Different of these approaches (and I would expand the list beyond just the obvious group) are really starting from different objectives.  Hence a comparison of mechanism such as caching, naming, etc. is a bit moot, if one really wants to understand the larger differences among these approaches.

I fully agree with what you are saying.. This is why I propose to start by analysis what each proposal tries to achieve: first by describing the target application areas that are the objective of each of the analysed proposals (section 2); and then by describing how each proposal aims to provide a ICN based solution for the target application areas (section 3). With this two sections we may find the following:
a) that most of the proposals have/or not the same applicability picture
b) how different proposals aims to propose an ICN solution for such applicability pictures

>  The particular mechanisms are artifacts that result from deeper differences among them. but only superficially indicative of the differences among.  Hence, for now, I would argue that a "deeper" survey will allow us to understand better the breadth of kinds of objectives these systems might have, which is a necessary precursor to a "reference model" or "architecture" or other similar framing concepts.

Exactly.. Maybe I should use the term "Analysis toward a reference model" or "Survey of Design choices" and not "Reference model" in section 4, since the idea is not to propose right now a reference model for ICN, but to analyse the similarities and differences of all the proposals (section 3) against what they aim to achieve (section 2) and start identifying, as Dirk called it, "design choices"
With section 4, we will have an idea about what seems to be a must for every ICN solution (at least to work on the described application areas), and what are optative functionality, depending on the application that the ICN solution will have. hence, section 4 aims to provide an initial analysis of design choices.. Maybe I should call section 4 just "survey of Design choices". It is the analysis to be described in section 4 that will provide the "deeper" technical survey that you are mentioning, IMO.

>  In fact, what we may find is that these approaches are so different from each other and may be defined for such different parts of an overall architecture, that one need not consider a direct comparison of them in the end.

Right.. This is what I mentioned before: we may end up finding for instance that all approaches aim completely different applications; or on the other extreme that all generically have the same applicability picture in mind but have completely different ICN approaches.. In both of these extreme cases we may end up identifying only optative design choices in section 4, and no common base-ground.

>  I believe that a deeper level of survey will stand us in good stead.  It is quite possible that it will be only a precursor to something else interesting, but at this point I'd like to see this be a more thorough survey.

This is IMO, the propose of the draft (maybe I've the revise the terminology :)): The pick up a set of ICN frameworks (I'm trying to avoid to mention only the same ones, and so I'm open to new pointers), to identify their propose (section 2); to describe how each one aims to provide an ICN solution for their applicability picture (section 3); to deeper analyse the similarities aiming to identify common base-ground for all identified applicability pictures (if possible) and optative functionality for each application target.

So, to make it clear. There is no intension to draft a reference model right now. As I mentioned in a previous email the idea with this draft is to "allow the community to converge to a reference model in the media term"..

> 
> Privately, because I didn't know who might be doing this, I had sent a note to Dave Oran, since he was listed as coordinating this, offering to help/participate in writing this.  I am happy to be public about this, but I wanted to figure out who might be doing this, to figure out how best to offer to help and participate.

This is very good, since I do not thing that this is a kind of document to be done by a single person.. It seems that we followed a similar path towards Dave :-).. I would be please to add you as author. I can keep the editor role if no one else steps forward :) ... In either case this document can grow very easily and so we need to be as precise as possible.

> 
> It is definitely useful to have a draft outline as a starting point for discussion about what should and should not go into the document.  Thank you.

I'll try to change the shape of the document based on comments received so far in order to have a stable ToC and propose before the Kista meeting.

Cheers
Paulo

> 
> 			Cheers,
> 			Karen
> 
> On Jan 20, 2013, at 2:41 PM, Paulo Mendes wrote:
> 
>> Hi Dirk
>> 
>> I fully agree that it is too soon for the wider community to converge to a reference model. But as a draft, this is a "living document": this is the document aims to be a tool to allow the community to converge to a reference model in the media term, but of course not in the first set of versions. Those should be used to flesh out commonalities in different points of view and to polish the relationship with the other two ICNRG drafts, with the right mindset.
>> 
>> As for the final shape of the draft, the reference model, it must be a good illustration of what the ICNRG community thinks the ICN concept should offer. We may end up with a unique view of ICN, or a set of well-articulated design choices as you mention (well-articulated is the key word). In my opinion this is not a decision to be taken now. We need to let the discussion flow and see were we'll be in 2 or 3 versions of the draft. 
>> 
>> I do not see were the overloading is: I think that ICNRG makes sense for the community to discuss about what ICN is (concept, applicability, challenges). This is why I'm proposing to work on a reference model, aiming to try to define the concept of ICN. This, together with a set of baseline scenarios (applicability) and a set of research challenges, may be a very good contribution of ICNRG to the wider community. Doing just a survey (identification of commonalities and differences between existing ICN proposal) is not interesting. For that you already have a set of contributions: the IEEE Commag paper that I refer in the paper; The doc that come out of Dagstuhl; The survey of mobility on ICN from G. Tyson et al; The paper from A. Ghodsi et al,; The paper from A. Haris; The technical report from M. Vahlenkamp; The paper from M. Faizul Bari, etc... 
>> 
>> Paulo
>> 
>> On Jan 20, 2013, at 12:08 PM, Dirk Trossen wrote:
>> 
>>> Hi Paulo,
>>> 
>>> thanks for pushing this forward. I'm concerned that you are over-reaching the goal of the document if you indeed intend to cover a 'survey' (which is more than just listing the different approaches but also try to flesh out the commonalities and differences in a comprehensive manner) that leads to a reference model of some kind. Firstly, I'm not sure that reaching from a survey to a reference model conveys the right picture (since it might look like you simply throw in several ingredients to cook a large stew - pardon my picture here). Secondly, I'm not sure that the wider community is at the point to agree/converge towards a reference model (it is here where the survey should help by fleshing out the commonalities and differences). Thirdly, I'm not even convinced that a 'reference model' is a good idea to start with. I'd rather go for a set of well-articulated design choices, each of which has its particular reasoning. 
>>> 
>>> As a conclusion, I see a danger that this document might end up being overloaded in terms of objectives, which eventually might not help.
>>> 
>>> Best,
>>> 
>>> Dirk
>>> On 19 Jan 2013, at 23:52, Paulo Mendes wrote:
>>> 
>>>> Dear all
>>>> 
>>>> Following the discussion about the three first drafts of the ICNRG, and following Boerje invitation to start the survey document, I just posted in the twiki (ICN Survey Document page) the table of content of a draft aiming to describe a ICN conceptual reference model suitable for ICNRG work. At the bottom of the same page you can first the first draft with the posted table of content and some initial content to justify the table of content.
>>>> 
>>>> As I mentioned before, I don´t think that the draft should be only a survey of ICN solutions. The draft should try to come up with a conceptual reference model based on a clear applicability picture and highlighting the major conceptual building blocks that will then be detailed in the research challenges draft. 
>>>> 
>>>> As I mentioned in a previous email I'll not be able to be in Kista, but I hope you'll find time to discuss this document in the morning of the first day. If the RG chairs think important I can send to the mailing list a brief report about the status of the document some days before the meeting.
>>>> 
>>>> The first milestone is to get a stable table of content and a list of people that will like to contribute to the document, allocating names to sections.
>>>> 
>>>> Cheers
>>>> Paulo
>>>> 
>>>> -------------------------------------------------------------
>>>> Paulo Mendes, Ph.D
>>>> Scientific Director for Innovation of the Research Unit in Informatics Systems and Technologies (SITILabs)
>>>> Director of the Ph.D program on Informatics - New Media and Pervasive Systems (NEMPS)
>>>> Secretary of the ACM SIGCOMM Chapter - Portugal
>>>> Associated Professor at University Lusofona, Portugal
>>>> [email-masked]
>>>> http://siti.ulusofona.pt/~pmendes
>>>> Tel.: 217 50 50 22
>>>> 
>>>> _______________________________________________
>>>> icnrg mailing list
>>>> [email-masked]
>>>> https://www.irtf.org/mailman/listinfo/icnrg
>>> 
>> 
>> -------------------------------------------------------------
>> Paulo Mendes, Ph.D
>> Scientific Director for Innovation of the Research Unit in Informatics Systems and Technologies (SITILabs)
>> Director of the Ph.D program on Informatics - New Media and Pervasive Systems (NEMPS)
>> Secretary of the ACM SIGCOMM Chapter - Portugal
>> Associated Professor at University Lusofona, Portugal
>> [email-masked]
>> http://siti.ulusofona.pt/~pmendes
>> Tel.: 217 50 50 22
>> 
>> _______________________________________________
>> icnrg mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/icnrg
> 
> Karen R. Sollins, Ph. D.
> Principal Scientist
> MIT Computer Science and Artificial Intelligence Laboratory
> 32 Vassar St.
> Cambridge, MA 02139
> P: +1 617 253 6006
> F: +1 617 253 2673
> E: [email-masked]
> 
> 

-------------------------------------------------------------
Paulo Mendes, Ph.D
Scientific Director for Innovation of the Research Unit in Informatics Systems and Technologies (SITILabs)
Director of the Ph.D program on Informatics - New Media and Pervasive Systems (NEMPS)
Secretary of the ACM SIGCOMM Chapter - Portugal
Associated Professor at University Lusofona, Portugal
[email-masked]
http://siti.ulusofona.pt/~pmendes
Tel.: 217 50 50 22

---

From: Paulo Mendes <[email-masked]>
Date: Fri, 1 Feb 2013 16:56:33 +0000

Hi Dirk

Maybe the used terminology (namely "Reference Model") was leading people to wrong directions. Please check the email that I just sent as a reply to Karen's email.. Actually I may say that the idea that I've for section 4 can be described as "an overview of the current choices and artefacts from their objectives" as you say... As said to Karen the propose is to be able at the end to identify what seem to be common design choices and optative functionality to solve the communication problem in different application areas by applying ICN.

Paulo

On Jan 21, 2013, at 7:39 AM, Dirk Trossen wrote:

> Hi Karen and Paulo
> 
> Very well said, exactly along the lines of my thinking. The survey papers of the recent past are not what I had in mind to repeat but approach an overview of the current choices and artefacts from their objectives, well formulated or not by their proponents, leading us to better understand these choices for any future consideration, e.g., in some form of reference model. One aspect is that the survey would not be limited to the typical academic publication paper sizes :-) 
> 
> 
> Best
> 
> Dirk
> 
> Karen Sollins <[email-masked]> wrote:
> HI Dirk and Paulo,
> 
> Although I also tend to want to think about something more general than what a survey will provide at first, I am concerned that the outline as it stands will not challenge us to find the significant differences.  For example, one of the things I have come to believe (having now written several of these sorts of summaries myself) is that the really interesting questions may start with the issue of what is trying to be achieved by a particular approach.  Different of these approaches (and I would expand the list beyond just the obvious group) are really starting from different objectives.  Hence a comparison of mechanism such as caching, naming, etc. is a bit moot, if one really wants to understand the larger differences among these approaches.  The particular mechanisms are artifacts that result from deeper differences among them. but only superficially indicative of the differences among.  Hence, for now, I would argue that a "deeper" survey will allow us to understand better the breadth of kinds of objectives these systems might have, which is a necessary precursor to a "reference model" or "architecture" or other similar framing concepts.  In fact, what we may find is that these approaches are so different from each other and may be defined for such different parts of an overall architecture, that one need not consider a direct comparison of them in the end.  I believe that a deeper level of survey will stand us in good stead.  It is quite possible that it will be only a precursor to something else interesting, but at this point I'd like to see this be a more thorough survey.
>

---

From: Paulo Mendes <[email-masked]>
Date: Fri, 1 Feb 2013 16:57:35 +0000

Hi Will

Thank you for your comments and pointers... I would like to start by clarifying that the proposed draft does NOT aim to draft an ICN reference model.. It seems that this was not clear.. It is still too soon to know what it may be... The propose of the draft is to survey what are the common design choice and optative artefacts used by different ICN approaches to tackle different, of the same, applicability picture.

As for IoT, not sure if we should refer to it.. I remind you that there is another draft (draft-pentikousis-icn-scenarios-01) aiming to describe any potential scenario for ICN.. In the draft that I proposed, the applicability pictures that are going to be analyzed are just the one that are tackle by current proposals.

As for the potential deployment of ICN, I do not think that this is the draft to do it.. Actually I think that it is too soon to talk about ICN deployment, since successful cases it will depend on the characteristics of the ICN solution(s) advertised by ICNRG and the type of application area. For instance, for me it is difficult at this point to understand if it is better to deploy ICN over IP or SDN, because I do not know what do you mean by "ICN". For instance if by ICN you mean a framework for general Internet communication (e.g. CCN), maybe IP is fine. if you mean a framework for opportunistic dynamic networks (e.g ICON), maybe SDN is better... I think that deployment study may be a draft by itself to be tackle later on during the current ICN charter..

Cheers
Paulo

On Jan 25, 2013, at 9:02 AM, Will Liu (Shucheng) wrote:

> Hi Paulo,
>  
> I am the co-author of ren-icn-content-retrieval, a survey draft discussing about content retrieval in the ICN. Thank you for your great effort in drafting the conceptual reference model of ICN and my team are very interested in joining your effort and making some contributions to the conceptual reference model.
>  
> The user-cases in 2.3 are very interesting, which inspired us to think that maybe a bigger picture of applying ICN is Internet of Things (IoT). Naming, information publication and searching are  compulsory components in both ICN and IoT. If you think the same way, we would love to explore more and contribute to this section if it has not been taking up by others.
>  
> In section 3, besides the projects listed from section 3.1 to section 3.5, we are capable to add other projects such as MobilityFirst, XIA and CONET.
>  
> Most of the content in our ren-icn-content-retrieval are aligned well with your current layout in Section 4. We are in the middle of revision based on the feedback from peers in the ICNRG and the authors of some projects to make it well-articulated as mentioned by Dirk. If this task is still waiting for claiming, I am wondering if you can assign it to us.
>  
> Besides your current layout, we would like to propose a chapter discussing about the potential deployment of ICN. As we discussed in the mailing list of ICNRG before IETF85, it is a concern to most peers. We have been thinking and comparing the advantages and disadvantages of deploying ICN over IP, integrated with IP, and over SDN.
>  
> Thanks for reading this long email and we do hope that we can join your effort and make some contribution in ICN.
>  
> Cheers,
> Will
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Paulo Mendes
> Sent: Sunday, January 20, 2013 7:52 AM
> To: icnrg
> Subject: [icnrg] Draft proposal for ICN Conceptual Reference Model
>  
> Dear all
>

---

From: Paulo Mendes <[email-masked]>
Date: Fri, 1 Feb 2013 17:02:08 +0000

Hi Daniel

As I mentioned to Will, in my opinion IoT can only be referenced to in the survey draft if there is some exiting ICN framework that targets that scenario...

Actually, and based on the current baseline scenario draft, I may be better to remove the Applicability picture section from the survey draft and point to the Baseline Scenarios draft for further details on specific scenarios.. If you agree with this, in the process of analyzing the applicability of some ICN proposal, I may point you to new scenarios to be included in the baseline scenario draft. As for the baseline scenario draft, it should point out to the survey draft for further details on current proposal. This will help to draw a clear line between the two drafts.

In addition to what I just mentioned I would say that we need to cross refer the two draft in what concerns the notion of ICN... At the moment it is difficult to me to understand what do you mean by "ICN capabilities", since the way the ICN topic is tackled by different approaches is may be so different that top be precise you need to say "ICN capabilities as described in XPTO".. 

Paulo

On Jan 25, 2013, at 10:58 AM, Daniel Corujo wrote:

> Dear Will,
> 
> Kostas Pentikousis and I are assembling a IoT section in the Baseline Scenarios draft. Therein, we are already highlight, through existing state-of-the-art references, how the inherent ICN capabilities can benefit IoT deployments, as well as enhancing and create the opportunity for novel deployment scenarios to be conceived.
> 
> It would be interesting that both contributions could be complementary and somewhat aligned.
> 
> Best regards,
> 
> Daniel Corujo
> [email-masked]
> http://re.vu/dcorujo
> 
> 
> On Jan 25, 2013, at 09:02 , Will Liu (Shucheng) wrote:
> 
>> Hi Paulo,
>>

---

From: Paulo Mendes <[email-masked]>
Date: Fri, 1 Feb 2013 17:02:17 +0000

Hi Will

With the new SDN research group at IRTF it may be a good idea to have later on a draft to tackle ICN deployment using SDN. The question right now, as I mentioned before is "what do we mean by ICN", since the nice paper that Dirk mentioned is specific for the Pursuit framework based on LIPSIN over Openflow.. This is just a good example to be later on analyzed since with we mean by ICN may not match 100% Pursuit and SDN in not only Openflow..

Paulo

On Jan 26, 2013, at 2:02 AM, Will Liu (Shucheng) wrote:

> Hi, Dirk,
> 
> Thanks for your comments. Indeed we have read both references that you pointed out and we think the forwarding design of ICN on SDN in your EWSDN 2012 paper is very neat. With the current several ongoing efforts in ICN community to implement ICN over SDN or design software designed ICN, we believe interoperability can be exploited and demonstrated.
> 
> Cheers,
> Will
>  
> From: Dirk Trossen [mailto:[email-masked]] On Behalf Of Dirk Trossen
> Sent: Friday, January 25, 2013 6:33 PM
> To: Will Liu (Shucheng)
> Cc: Paulo Mendes; 任婧; icnrg; Jianping Wang
> Subject: Re: [icnrg] Draft proposal for ICN Conceptual Reference Model
>  
> Hi Will, all,
>  
> for this, it might be worthwhile to have a look at a report we did in the PSIRP project (the predecessor of the PURSUIT project) on deployment incentives, looking at industries that could drive native or overlay deployments. It's available at http://www.psirp.org/files/Deliverables/FP7-INFSO-ICT-216173-PSIRP-D4.6_FinalReportOnDeplIncBusinessModels.pdf
>  
> As for SDN deployments, we've recently looked at ways of doing this, trying to avoid scaling issues when mapping 'content flows' onto 'SDN flows'. Point here is to bind the mapping onto SDN to the connectivity between publishers and subscribers, not the content they are exchanging (since the 'flows' of content can be significantly larger than the actual connectivity relations in the network). You can find our ideas published as 
>  
> D. Syrivelis, G. Parisis, D. Trossen, P. Flegkas, V. Sourlas, T. Korakis, L. Tassiulas, Pursuing a Software-Defined Information-Centric Network, EWSDN 2012, IEEE, Darmstad Germany.
>  
> Best,
>  
> Dirk 
> 
> 
>

---

From: Paulo Mendes <[email-masked]>
Date: Fri, 1 Feb 2013 17:05:24 +0000

Hi George

The IoT scenario is already mentioned in the Baseline scenarios.. In the survey draft the idea is to analyzed the capability of current solutions to operate on the mentioned scenarios.. We may finding out that almost no ICN framework is able to operate in a IoT, since only some of the required functionality is being tackled.. But we also have to consider that there may be different IoT with different requirements..

As for the solutions that you mention (data lookup scheme; data privacy) we can include them in the draft in order to understand if they are common design choices of any ICN proposal or just optative artifacts useful for specific application areas...  If you're available, I may go back to you on the matter in order to further analyze existing solution on these topics

Cheers
Paulo

On Jan 26, 2013, at 7:30 AM, George C. Polyzos wrote:

> Dear Will, Paulo, all,
>  
> Our lab is particularly interested in exploring the possibilities of using ICN as an enabling technology for a pervasive sensing architecture with focus on the IoT (and e-health). We participated in the FP7 project PSIRP and now participate in FP7 PURSUIT.
>  
> We believe that the IoT can be an ideal use case for demonstrating the applicability of ICN. Inspired by the PURSUIT ICN architecture, we have proposed an information lookup scheme for the IoT (http://mm.aueb.gr/publications/2012-IoT-SoS.pdf). Next week I am going to present an extension of this work that discusses context-based security for information look-up at the IEEE ICNC conference in San Diego.
>  
> More generally, we are currently working in two domains of ICN which we think will benefit an ICN IoT architecture. The first area concerns a scalable, distributed lookup service, based on hierarchical DHTs. This is a continuation of the work in:http://www.mm.aueb.gr/publications/2012_DHTNRS_NETWORKING.pdf. The second area concerns access control, and privacy preserving mechanisms. As far as access control is concerned, we are extending the work inhttp://mm.aueb.gr/publications/2012-icn12-fotiou.pdf that proposes a mechanism enabling multi-domain and distributed access control. As far as privacy is concerned, we are preparing a paper that explores the applicability of homomorphic encryption for preserving privacy (and we recently completed with other PURSUIT co-authors a survey of privacy issues in ICN).
>  
> My group would love to collaborate on these topics and contribute to relevant ICNRG documents.
>  
> Regards,
>  
> -GP
>  
>  
> Prof. George C. Polyzos, Director
> Mobile Multimedia Laboratory
> Department of Informatics
> Athens University of Economics and Business
> 47A Evelpidon Street
> GR-11362 Athens, Greece
>  
> Tel.: +30 2108203650, assistant: +30 2108203646 Fax: +30 2108203325
> Email: [email-masked], [email-masked],[email-masked]
> http://mm.aueb.gr/
>  
>  
>  
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Will Liu (Shucheng)
> Sent: Friday, January 25, 2013 1:02 AM
> To: Paulo Mendes
> Cc: 任婧; icnrg; Jianping Wang