Subject: [icnrg] IET86 meeting minutes

From: Damien Saucez <[email-masked]>
Date: Mon, 18 Mar 2013 22:39:36 +0100

ICNRG
=====
Agenda bashing

there will be side meetings during the week to work on the documents, see doodle on the wiki

first 1h-1h30 for the 3 documents, then follow with technical presentations

Report from ICNRG interim meeting
----------------------------------------------------
30 participants, days before: SAIL demo workshop (how ICN could be useful for multimedia consumption)

- we are missing a good publishing interface in today's Internet (you have to wait google to index you)

- we have to stop thinking in term of flow

- storage should also become first class citizen in ICN, not only names/content

report on current projects:
 - NDN implements traceroute
 - PURSUIT looks to combine ICN and SDN
 - NetInf implementation is available

brief summary on documents:
 - research challenges document
    - is is possible to have a common ICN model, and an API
    - for now security and naming taken together, but maybe it would be better to separate them

 - survey document
    - do we need yet another survey document?
          - a survey of survey?

 - baseline scenarios
   - do we have to cover topologies? long discussion and the conclusion is yes that would be helpful

 - ICN live streaming and interactive services (non cacheable objects)
   - request aggregation is necessary

 - ICN routing and congestion control
    - will scalable routing require to add back some host-centric information?

ICNRG Survey draft
-------------------------------
(none of the authors could come, so Dave is presenting)

what criteria to define something is related to ICN => need of taxonomy

what are the approaches for integrity, security, congestion control…

the aim is not to conclude on what is good design choice or not, but to enumerate the options, such that it will be possible to evaluate the design choices and point to research document to say what are the hard part to be solved

no need to skim over the document structure

Research challenge
----------------------------

Why? How? What?

there will be an update after the meeting

there is aspect common between proposition, but also some big differences

the document was originally called "problem statement" but the title would not be valid any longer (not anymore this in 1.5 years)

consensus that we have to describe the problem, not giving solution

how to work on a system that deals with names?

today, we have to use overlays

How to make device to device communications 

there is intrinsic multi path support in ICN, but what does it mean? How to take benefit of it?

do we rely on receiver-driven or/and router-driven in transport?

for in-network caching, do we follow on-path or off-path? what about content placement?

how to extend the routing/resolution system=> please discuss it during the side meeting

mobility management: it would be nice to put mobility natively in ICN. How complex to have mobility management

network management - > how to manage an ICN network

todo:
 - add a "problems today", 
 - align level of details between sections and "phrasing"
 - add other challenges (e.g., business model)

Thomas will work on mobility/security and Damien will work on security

who read the doc (and not in the .se meeting)? 2-3 people…

Please one comment or question/

- Glenn: have you taken into account that there is time duration in the distribution ?
    - Kostas: right, nothing prevent you to take this into account in the CS, but it could also be done 

- Bill: you shouldn't care where and how many instances cache, except maybe if you need it for integrity.
   - Kostas: integrity is already taken into account with signature
   - Kostas: you might be able to know the number of replicas and hits for example for counting the clicks

- Bill: that exists in real life as well for example with books.
   - Dave: the goal is to propose solutions that allows to spread bits, we don't want to have it explicitly, the problem is broader than caching
   - Ignacio: routing and security is ok, but also we have to make distinction legal/not-legal, storing or transporting bits is different
   - Borje : today we are already doing buffering in routers, we can legally do that for the duration necessary to forward

Baseline scenarios
---------------------------
who read the document? ~10

There is tons of documents on ICN but there is no real overlap in the way experiments are done (topologies, simulators, implementations…)

since last time: 
  - small update on social networking 
  - Internet of things and smart city is new

social networking naturally fits in ICN

how can we see if real-time really works? Yes, proof of concept have been provided but it would be nice to see if it really works better than today

in multi-access, we could leverage some "lower-layer" features to make it better

vanets has been added to content distribution. Interesting because in this case you definitely don't care about who is the origin of the information, it is the information that is of value

we need more input on EE and DTN. Please give input.

- Ali: have you looked on becknet (?) 
  - Kostas: it is not about energy or green, it is about being energy efficient network
  - Kostas: maybe you are the good one for contributing on that :-D
  - Dave: what we are more looking at is how to integrate metric to assess how ICN is energy efficient
  - Ali: you should look a the cost of green
  - Kostas: energy efficiency for IT vs IT for energy efficient

We do need to have topologies depicted in the document, not say use A or B, but provide topologies that can be useful to evaluate

What are the traffic patterns?

the topology given now is just an "hello world"

if you want to contribute, this is Section 3  that needs most of the effort!

- Borje: it becomes big, do we want to split it or keep it that way?

- Shen (?): what is the relation with the other baseline?
  - Borje: it will be discussed in Berlin (the author can't come) it is about how to do things

Management considerations
------------------------------------------

we know what operators want to do and not do in term of management

very important to consider operational matters if we want to have 

duality: can we use ICN to manage network and how to make ICN network manageable!

consider pure ICN universe so all facilities you have right now is not available as-is

figure too small on the screen, please look at the document!

Question?
     no questions

Container Assisted Naming schema for icm
----------------------------------------------------------------

How to name object is fundamental. Global scope or local scope?

different name components for different purposes

P:I:D naming schema

I: the identifier of the object (e.g., HMAC)
D: the domain that provides resolution from identifier to the real location of the object by routers
P: bind object with complete name for security purpose

description of the resolution mechanism

flexible, works with flat or non flat, enables security and trust check

next talk presents a particular implementation of the container based.

-Luigi: have you studied interaction with the cacheability. What if you have several domains?
 - Xinwen (?): to cache, we use I, so you can do the cache lookup based on I

Contained Assisted naming, routing, and resolution 
---------------------------------------------------------------------------

objective: improve routing scalability 

a container is an identifier of the "space" in which data is stored or can b accessed.

syntax of the name, container is optional 

example how to do forwarding: the router lookup its cache, if there is a mapping, it uses it, otherwise, it queries the resolution system

scaling routing using multi-level => FIB size = N(top-level containers) + N(popular containers)

- Dave: it looks, similar to PI and PA in IP, is that intentional?
  - yes, we followed the same idea

Questions?
 - none

Netinf Protocol update
---------------------------------
(Stephen Farrell had to present on behalf of the expected presenter )

code available on sourceforge.net/projects/netinf

questions?
 - no

- Borje: code also available on netinf.org
 - Stephen: many different source code we made are available, and tested for interop

- Dave: can someone work on a way to construct a good corpus that can be used to test different schemes?

- Allison : What corpus are you using?
   - Stephen: we just took German wikipedia, I will send a pointer to the list
   - Allison: I will send link for structured corpus on the list

Planing to meeting in Berlin
- Borje: le us know if you want to present

---

From: Börje Ohlman <[email-masked]>
Date: Tue, 19 Mar 2013 03:59:00 +0000

Damien,

Many thanks for taking the minutes.

      Börje

18 mar 2013 kl. 22:39 skrev "Damien Saucez" <[email-masked]<mailto:[email-masked]>>:

ICNRG
=====
Agenda bashing

 - survey document

 - baseline scenarios

ICNRG Survey draft

Research challenge

Why? How? What?

todo:

Baseline scenarios

since last time:

Question?
     no questions

P:I:D naming schema

Questions?
 - none

Netinf Protocol update

code available on sourceforge.net/projects/netinf<http://sourceforge.net/projects/netinf>

questions?
 - no

- Borje: code also available on netinf.org<http://netinf.org>
 - Stephen: many different source code we made are available, and tested for interop