Subject: Re: [icnrg] comments on the use of ICN for large scale disaster Scenario

From: Dessalegn Mequanint <[email-masked]>
Date: Thu, 18 Jul 2013 00:19:14 -0700 (PDT)

A couple of things:
Wouldn't it be nice to augment the use of ICN in a disastrous scenario with a high level/abstract architecture that constitute the fragmented networks. What about considering the following items in the event of a large scale disaster:
- complementing caching with prefetching (though due to scarcity of resources it might not be appealing but how about prefetching aggressively in the functional parts of the Infrastructure?), details of how prefetching could be important in the underlying scenario can be further specified or developed. 
- the use of agents(including human agents) in transporting data/information besides the use of telecommunication structure?

Dessalegn

________________________________
 From: "[email-masked]" <[email-masked]>
To: [email-masked] 
Sent: Tuesday, July 16, 2013 10:00 PM
Subject: icnrg Digest, Vol 16, Issue 10

----- Forwarded Message -----

If you have received this digest without all the individual message
attachments you will need to update your digest options in your list
subscription.  To do so, go to 

https://www.irtf.org/mailman/listinfo/icnrg

Click the 'Unsubscribe or edit options' button, log in, and set "Get
MIME or Plain Text Digests?" to MIME.  You can set this option
globally for all the list digests you receive at this point.

Send icnrg mailing list submissions to
    [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
    https://www.irtf.org/mailman/listinfo/icnrg
or, via email, send a message with subject or body 'help' to
    [email-masked]

You can reach the person managing the list at
    [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of icnrg digest..."

Today's Topics:

   1. FW: New Version Notification for
      draft-seedorf-icn-disaster-00.txt (Jan Seedorf)
Dear all,

We have submitted a draft that outlines some research challenges for disaster scenarios, and how ICN approaches could be a good match for addressing those challenges (see below). Comments are welcome, I hope that I can present the draft at the IETF-87 meeting, either on Sunday or on Wednesday during the ICNRG sessions.

- Jan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, July 15, 2013 3:41 PM
To: Dr.K.K.Ramakrishnan; Nicola Blefari Melazzi; Nicola Blefari-Melazzi; K.Ramakrishnan; Atsushi Tagami; Jan Seedorf; Mayutan Arumaithurai
Subject: New Version Notification for draft-seedorf-icn-disaster-00.txt

A new version of I-D, draft-seedorf-icn-disaster-00.txt
has been successfully submitted by Mayutan Arumaithurai and posted to the
IETF repository.

Filename:     draft-seedorf-icn-disaster
Revision:     00
Title:         Using ICN in disaster scenarios
Creation date:     2013-07-15
Group:         Individual Submission
Number of pages: 8
URL:            http://www.ietf.org/internet-drafts/draft-seedorf-icn-disaster-00.txt
Status:          http://datatracker.ietf.org/doc/draft-seedorf-icn-disaster
Htmlized:        http://tools.ietf.org/html/draft-seedorf-icn-disaster-00

Abstract:
   Information Centric Networking is a new paradigm where the network
   provides users with named content, instead of communication channels
   between hosts.  This document outlines some research directions for
   Information Centric Networking (ICN) with respect to applying ICN
   approaches for coping with natural or human-generated, large-scale
   disasters.

The IETF Secretariat

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Mayutan A." <[email-masked]>
Date: Thu, 18 Jul 2013 10:18:50 +0200

Thanks a lot Dessalegn for your feedback,
See inline for comments.

On Thu, Jul 18, 2013 at 9:19 AM, Dessalegn Mequanint
<[email-masked]>wrote:

> A couple of things:
> Wouldn't it be nice to augment the use of ICN in a disastrous scenario
> with a high level/abstract architecture that constitute the fragmented
> networks.
>

We  are currently working on such an architecture that consists of
fragmented networks. It is at an early stage and therefore didn't make into
the draft.

> What about considering the following items in the event of a large scale
> disaster:
> - complementing caching with prefetching (though due to scarcity of
> resources it might not be appealing but how about prefetching aggressively
> in the functional parts of the Infrastructure?), details of how prefetching
> could be important in the underlying scenario can be further specified or
> developed.
>

This is another scenario that we are considering. As you rightly pointed
out, when resources are scarce, more thought needs to put into
caching/prefetching mechanisms. E.g. prefetching might involve certain
heuristics that might be taxing on a device running on battery. But, one
could use such a mechanism for certain priority content.

> - the use of agents(including human agents) in transporting
> data/information besides the use of telecommunication structure?
>

:-) such a DTN scenario is also under consideration, where a human agent
(e.g. a doctor) who moves between multiple camps might also facilitate
connection between two fragmented networks.

> Dessalegn

The reason that we have omitted these scenarios from the current draft is
that these are work in progress and we wanted to come with more thought out
scenarios. Thanks a lot for your feedback and we could probably discuss it
on Sunday (Jan and I will be there)/Wednesday(Jan will be there) at the
ICNRG session.

Mayutan

>
>   ------------------------------
>  *From:* "[email-masked]" <[email-masked]>
> *To:* [email-masked]
> *Sent:* Tuesday, July 16, 2013 10:00 PM
> *Subject:* icnrg Digest, Vol 16, Issue 10
>
> We have submitted a draft that outlines some research challenges for
> disaster scenarios, and how ICN approaches could be a good match for
> addressing those challenges (see below). Comments are welcome, I hope that
> I can present the draft at the IETF-87 meeting, either on Sunday or on
> Wednesday during the ICNRG sessions.
>
> - Jan
>
> To: Dr.K.K.Ramakrishnan; Nicola Blefari Melazzi; Nicola Blefari-Melazzi;
> K.Ramakrishnan; Atsushi Tagami; Jan Seedorf; Mayutan Arumaithurai
> URL:
> http://www.ietf.org/internet-drafts/draft-seedorf-icn-disaster-00.txt
> Status:
> http://datatracker.ietf.org/doc/draft-seedorf-icn-disaster

---

From: Paulo Mendes <[email-masked]>
Date: Thu, 18 Jul 2013 15:10:07 +0100

Hello

If you are interested in the application of ICN to disruptive networking scenarios, you should check the the ICON framework that we created at SITILabs. ICON (Information and Context Oriented Networking) makes a combination of data centric networking with context awareness (social interaction, human behaviour), including a set of self-organized functionality for routing, in-network caching and resource discovery.

ICON is being developed to work on disruptive scenarios (DTN style), although IMO the framework can be also applied to less disruptive scenarios.

For general information you should check the webpage of the DTN-Amazon project in http://siti.ulusofona.pt/~dtnamazon

Currently the basic ICON framework is done (code will be available soon under LGPL). It was developed in C# over .NET to allow it to be available in windows, unix, windows phone, android, iphone without any porting effort. ICON was developed in a modular way, which means that it is easy to replace one component (e.g. routing) by a new module.

In terms of functionality, we have a social-aware opportunistic routing protocol done (evaluated in the ONE simulator) and it will be ported to ICON. The routing proposal, under publication, is quite similar, in terms of the utility functions to our dLife proposal (check my researchgate page for related papers - https://www.researchgate.net/profile/Paulo_Mendes6/ )

We are also finishing a ICON emulator that allow you to test a scenario with several virtual ICON nodes installed in the same or different machines.

If you're interested, just let me know.

Paulo Mendes

>   approaches for coping with natural or human-generated, large-scale

-------------------------------------------------------------
Paulo Mendes, Ph.D
Scientific Director for Innovation of the Research Unit in Informatics Systems and Technologies (SITILabs)
Director of the Ph.D program on Informatics - New Media and Pervasive Systems (NEMPS)
Secretary of the ACM SIGCOMM Chapter - Portugal
Associated Professor at University Lusofona, Portugal
[email-masked]
http://siti.ulusofona.pt/~pmendes
Tel.: 217 50 50 22