Subject: [icnrg] Proposed new work item: ICN and video distribution

From: Börje Ohlman <[email-masked]>
Date: Tue, 1 Oct 2013 08:18:05 +0000

In Berlin it was proposed that we should start a new ICNRG work item: ICN and video distribution. We (the ICNRG chairs) think this would be a good idea and would like to explore the interest for such work within the RG. We propose the following:

  1.  People interested in the subject: Give initial feedback to the mailing list. (ASAP)
  2.  Anyone interested in the subject is encouraged to offer input/presentations for the Vancouver meetings.
  3.  Assuming we get some input on the subject, we devote substantial discussion time on the subject at the Sunday working meeting
  4.  We present the results from the Sunday discussions at the regular ICNRG meeting as well as other additional presentations on the subject.
  5.  We discuss and decide continued activities, e.g. starting a new working document on the subject.

Some background and motivation:
Using ICN for point-to-multipoint video distribution is one of the most  obvious use cases for ICN. Even so it turns out, that when examining the topic in more detail, there are a lot of less obvious technical issues that needs to be dealt with to get the best out of the combination ICN and video. Examples of issues include:

  *   interactions between ICN and adaptive streaming (e.g. MPEG-DASH). How does the streaming application make a correct network conditions? Does it need understand if it is getting things from a cache nearby or if it has good connectivity to the source?
  *   Switching rate might mean switching from cached content to having to retrieve from the source. What is the right strategy in these situations.
  *   Should ICN caches download multiple rates, on it's own initiative, when it get's requests for only one rate initially? If so, how should that be done?
  *   How does video DRM work in ICN?
  *   Security of unmanaged caches
  *   Low-latency or realtime video with ICN -- any issues?

All type of feedback is welcome,

The ICNRG Chairs

---

From: Daniel Corujo <[email-masked]>
Date: Tue, 1 Oct 2013 10:46:32 +0100

Dear Börje and all chairs,

Under this subject, an important aspect in ICN video distribution, is the Quality of Experience perceived by the end-user. The associated considerations are especially important in an ever-growing increase in video-content access through wireless technologies, ranging from cellular to WLAN networks (check the Cisco Visual Networking Index). 
In this way, the dynamics of the wireless environments, and the associated heterogeneity, pose a complex challenge for assuring that the content reaches the user in an optimized way. As such, not only enhanced content-reaching procedures are needed (such as the ones provided by ICN), but also supportive measures making sure that the content is sent to the requester in the most optimal way (i.e., selected rate, selected codec, selected connection/technology/interface). In addition, aspects related to the characteristics of the content, as well as the current conditions of the wireless network, are all factors that can help to best decide how to best forward the content to the user (or, if available, optimally select the best content alternative, wether it is from cache or not).
It would be interesting to analyze how these supporting and optimization procedures could be realized using inherent ICN capabilities, instead of relying on external procedures.

We believe that this would be an interesting addition to this work item, with the capability of not only linking with existing working items, as well as other RGs (such as SDNRG).

Best regards,

Daniel Corujo, Ph.D.														
http://re.vu/dcorujo
Advanced Telecommunications and Networks Group - http://atnog.av.it.pt
Follow us - @ATNoG_ITAv

On Oct 1, 2013, at 09:18 , Börje Ohlman wrote:

> 	• People interested in the subject: Give initial feedback to the mailing list. (ASAP)
> 	• Anyone interested in the subject is encouraged to offer input/presentations for the Vancouver meetings.
> 	• Assuming we get some input on the subject, we devote substantial discussion time on the subject at the Sunday working meeting
> 	• We present the results from the Sunday discussions at the regular ICNRG meeting as well as other additional presentations on the subject. 
> 	• We discuss and decide continued activities, e.g. starting a new working document on the subject.
> 
> 	• interactions between ICN and adaptive streaming (e.g. MPEG-DASH). How does the streaming application make a correct network conditions? Does it need understand if it is getting things from a cache nearby or if it has good connectivity to the source? 
> 	• Switching rate might mean switching from cached content to having to retrieve from the source. What is the right strategy in these situations.
> 	• Should ICN caches download multiple rates, on it's own initiative, when it get's requests for only one rate initially? If so, how should that be done?
> 	• How does video DRM work in ICN?
> 	• Security of unmanaged caches
> 	• Low-latency or realtime video with ICN -- any issues?
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Stefan Lederer" <[email-masked]>
Date: Tue, 1 Oct 2013 13:40:12 +0200

Dear Börje, all, 

that's great! We (Institute of Information Technology at the University
Klagenfurt) are very interested in this topic and happy to contribute in
this work item. 

Maybe the adaptive streaming over ICN draft presented at the Berlin meeting
[1] is a good starting point. In the context of our adaptive streaming/DASH
research at [2], we did research on this topic is the past and provide also
tools such as libdash for CCN [3]. But of course, there are much more
aspects in the topic that adaptive video, e.g., real-time communication,
which also have to be covered in such a work item.   

[1]
http://users.soe.ucsc.edu/~cedric/papers/draft-video-streaming-over-ICN-00.t
xt, http://www.ietf.org/proceedings/87/slides/slides-87-icnrg-5.pdf 
[2] http://dash.itec.aau.at
[3] https://github.com/bitmovin/libdash/tree/CCN 

Best, 
Stefan

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
> Daniel Corujo
> Gesendet: Dienstag, 01. Oktober 2013 11:47
> An: Börje Ohlman
> Cc: Ashok Narayanan (ashokn); Dave Oran; icnrg; Dirk Kutscher
> Betreff: Re: [icnrg] Proposed new work item: ICN and video distribution
> 
> Under this subject, an important aspect in ICN video distribution, is the
Quality
> of Experience perceived by the end-user. The associated considerations are
> especially important in an ever-growing increase in video-content access
> through wireless technologies, ranging from cellular to WLAN networks
(check
> the Cisco Visual Networking Index).
> In this way, the dynamics of the wireless environments, and the associated
> heterogeneity, pose a complex challenge for assuring that the content
reaches
> the user in an optimized way. As such, not only enhanced content-reaching
> procedures are needed (such as the ones provided by ICN), but also
supportive
> measures making sure that the content is sent to the requester in the most
> optimal way (i.e., selected rate, selected codec, selected
> connection/technology/interface). In addition, aspects related to the
> characteristics of the content, as well as the current conditions of the
wireless
> network, are all factors that can help to best decide how to best forward
the
> content to the user (or, if available, optimally select the best content
> alternative, wether it is from cache or not).
> It would be interesting to analyze how these supporting and optimization
> procedures could be realized using inherent ICN capabilities, instead of
relying
> on external procedures.
> 
> We believe that this would be an interesting addition to this work item,
with the
> capability of not only linking with existing working items, as well as
other RGs
> (such as SDNRG).
> > In Berlin it was proposed that we should start a new ICNRG work item:
ICN
> and video distribution. We (the ICNRG chairs) think this would be a good
idea
> and would like to explore the interest for such work within the RG. We
propose
> the following:
> > 	• People interested in the subject: Give initial feedback to the
mailing
> list. (ASAP)
> > 	• Anyone interested in the subject is encouraged to offer
> input/presentations for the Vancouver meetings.
> > 	• Assuming we get some input on the subject, we devote substantial
> discussion time on the subject at the Sunday working meeting
> > 	• We present the results from the Sunday discussions at the regular
> ICNRG meeting as well as other additional presentations on the subject.
> > Using ICN for point-to-multipoint video distribution is one of the most
obvious
> use cases for ICN. Even so it turns out, that when examining the topic in
more
> detail, there are a lot of less obvious technical issues that needs to be
dealt
> with to get the best out of the combination ICN and video. Examples of
issues
> include:
> > 	• interactions between ICN and adaptive streaming (e.g. MPEG-DASH).
> How does the streaming application make a correct network conditions? Does
> it need understand if it is getting things from a cache nearby or if it
has good
> connectivity to the source?
> > 	• Switching rate might mean switching from cached content to having
> to retrieve from the source. What is the right strategy in these
situations.
> > 	• Should ICN caches download multiple rates, on it's own initiative,
> when it get's requests for only one rate initially? If so, how should that
be done?

---

From: Xiaoke Jiang <[email-masked]>
Date: Wed, 2 Oct 2013 09:36:56 +0800

Dear Börje, all,
    We (Network Architecture and IPv6 Lab, Tsinghua Univ.) are also working
on flow transmission. We now have three proposals:
1) Optimal Chunk Size: For application like live video conference, we
adjust the chunk size according to real-time packet loss. We build a model
to infer the optimal chunk size, which can minimize the latency and
maximize the payload ratio. This solution can work with Sliding Windows.

2) Conversational Channel:  One Interest - One Data model requests data at
the granularity of every chunk, however, for flow transmission, the
granularity can be extended to single file/flow, since those Interests for
the single file is very similar with each other and should be forwarded to
same producer, so we aggregate those similar Interest and build
"conversational" channel to carry on flow transmission. Conversational
channel is an obvious solution to support flow transmission, the obstacle
is to cope with side-effect, such as the potential vulnerabilities,
multiple consumer synchronization, and forwarding flexibility. Our solution
also fix or minimize these side-effects.
data chunk

3) The two proposal above aims at flow transmission, we also propose Named
Content Delivery Network (nCDN) to improve Content Distribution. nCDN is
built over TCP/UDP and can work cooperatively with traditional CDN. It
makes use of name-based routing, stateful forwarding to improve
the efficiency, flexibility, robustness of CDN.

I hope it helps.

thanks

My Regards,
------------------------------
 Xiaoke Jiang （蒋小可）

Ph.D Candidate,
Dept. of Computer Science and Technology,
Tsinghua University, P. R. China

On Tue, Oct 1, 2013 at 4:18 PM, Börje Ohlman <[email-masked]>wrote:

> ICN and video distribution. We (the ICNRG chairs) think this would be a
> good idea and would like to explore the interest for such work within the
> RG. We propose the following:
>
>    2. Anyone interested in the subject is encouraged to offer
>    3. Assuming we get some input on the subject, we devote substantial
>    4. We present the results from the Sunday discussions at the regular
>  obvious use cases for ICN. Even so it turns out, that when examining the
> topic in more detail, there are a lot of less obvious technical issues that
> needs to be dealt with to get the best out of the combination ICN and
> video. Examples of issues include:
>
>    - interactions between ICN and adaptive streaming (e.g. MPEG-DASH).
>    it need understand if it is getting things from a cache nearby or if it has
>    good connectivity to the source?
>    - Switching rate might mean switching from cached content to having to
>    retrieve from the source. What is the right strategy in these situations.
>    - Should ICN caches download multiple rates, on it's own initiative,
>    - How does video DRM work in ICN?
>    - Security of unmanaged caches
>    - Low-latency or realtime video with ICN -- any issues?
>
>

---

From: Andrea Detti <[email-masked]>
Date: Wed, 02 Oct 2013 15:26:46 +0200

Dear Börje, All,
We (University of Rome "Tor Vergata") are definitively interested in 
MPEG DASH video streaming over ICN.
We have currently used these two technologies in mobile environments 
[1][2], and have an implementation based on CCN of a HTTP/CCN proxy for 
MPEG DASH streaming.

Regarding the possible topic that may be of research interest, we are 
working on "load balancing". Today in Content Delivery Network (as far 
as I know) the selection of which server should address a user request 
is session-based, i.e. done at the start of the streaming session. In 
case of session-less approach like the receiver-driven one of CCN, we 
could have the opportunity to be more reactive to network condition.

I believe that this focussed topic may be part of a more general 
research area (Information Centric Video Delivery Network, may be a 
possible tag) driven by the following question: how can emerging Video 
Content Providers (e.g. NetFlix) use ICN/CCN technology to realize their 
distribution infrastructure (private or public) ? Are the expected 
performance, deployment cost, power consumption, etc., better than ones 
they can obtain using traditional HTTP means, like the one used by CDN 
provider (e.g. HTTP transparent proxy, routing by name e.g. via DNS or 
HTTP rewriting)?
My two cents,
Andrea

[1] A.Detti, B. Ricci, N. Blefari-Melazzi,"Peer-To-Peer Live Adaptive 
Video Streaming for Information Centric Cellular Networks", IEEE PIMRC 
2013,London, UK, 8-11 September 2013

[2] A.Detti, B. Ricci, N. Blefari-Melazzi, "Supporting mobile 
applications with Information Centric Networking: the case of P2P live 
adaptive video streaming", ACM SIGCOMM 2013, ICN workshop,Hong Kong, 
China, 12 August 2013

available at 
http://netgroup.uniroma2.it/people/faculties/andrea-detti/andrea-detti-pubs/

On 10/01/2013 10:18 AM, Börje Ohlman wrote:
> ICN and video distribution. We (the ICNRG chairs) think this would be 
> a good idea and would like to explore the interest for such work 
> within the RG. We propose the following:
>
> Using ICN for point-to-multipoint video distribution is one of the 
> most  obvious use cases for ICN. Even so it turns out, that when 
> examining the topic in more detail, there are a lot of less obvious 
> technical issues that needs to be dealt with to get the best out of 
> the combination ICN and video. Examples of issues include:
>
>   * interactions between ICN and adaptive streaming (e.g. MPEG-DASH).
>     How does the streaming application make a correct network
>     conditions? Does it need understand if it is getting things from a
>     cache nearby or if it has good connectivity to the source?
>   * Switching rate might mean switching from cached content to having
>   * Should ICN caches download multiple rates, on it's own initiative,
>     when it get's requests for only one rate initially? If so, how
>     should that be done?

-- 
---------------------------------------
  Andrea Detti, PhD
  Electronic Engineering Dept.
  University of Rome "Tor Vergata"
  Via del Politecnico 1, 00133 Roma, Italy
  Tel.: +39-06-7259-7445
  Fax : +39-06-7259-7435
  Email: [email-masked]
  Web: http://netgroup.uniroma2.it/people/faculties/andrea-detti/
---------------------------------------

---

From: Börje Ohlman <[email-masked]>
Date: Fri, 4 Oct 2013 12:20:05 +0000

Hi Daniel,

I think this sounds very interesting. Would you be interested in making a presentation of your ideas in Vancouver?

	Börje

---

From: Daniel Corujo <[email-masked]>
Date: Fri, 4 Oct 2013 13:26:20 +0100

Dear Borje,

Thank you! Unfortunately, I won't be able to make it to Vancouver this time. However, I can develop a set of slides and share it in the RG wiki for information, reference and ideas, if this sounds reasonable. Moreover, we are fully committed in providing a -02 version of the Management Considerations draft in the coming days.

Best regards,

Daniel Corujo, Ph.D.														
http://re.vu/dcorujo

---

From: Börje Ohlman <[email-masked]>
Date: Fri, 4 Oct 2013 12:31:06 +0000

HI Xiaoke,

I think you have some interesting ideas here. Would you be interested in presenting them in Vancouver?

Best regards,
Börje

On 2 okt 2013, at 03:36, Xiaoke Jiang <[email-masked]<mailto:[email-masked]>> wrote:

Dear Börje, all,
    We (Network Architecture and IPv6 Lab, Tsinghua Univ.) are also working on flow transmission. We now have three proposals:
1) Optimal Chunk Size: For application like live video conference, we adjust the chunk size according to real-time packet loss. We build a model to infer the optimal chunk size, which can minimize the latency and maximize the payload ratio. This solution can work with Sliding Windows.

2) Conversational Channel:  One Interest - One Data model requests data at the granularity of every chunk, however, for flow transmission, the granularity can be extended to single file/flow, since those Interests for the single file is very similar with each other and should be forwarded to same producer, so we aggregate those similar Interest and build "conversational" channel to carry on flow transmission. Conversational channel is an obvious solution to support flow transmission, the obstacle is to cope with side-effect, such as the potential vulnerabilities, multiple consumer synchronization, and forwarding flexibility. Our solution also fix or minimize these side-effects.
data chunk

3) The two proposal above aims at flow transmission, we also propose Named Content Delivery Network (nCDN) to improve Content Distribution. nCDN is built over TCP/UDP and can work cooperatively with traditional CDN. It makes use of name-based routing, stateful forwarding to improve the efficiency, flexibility, robustness of CDN.

I hope it helps.

thanks

My Regards,
________________________________
Xiaoke Jiang （蒋小可）

Ph.D Candidate,

On Tue, Oct 1, 2013 at 4:18 PM, Börje Ohlman <[email-masked]<mailto:[email-masked]>> wrote:
In Berlin it was proposed that we should start a new ICNRG work item: ICN and video distribution. We (the ICNRG chairs) think this would be a good idea and would like to explore the interest for such work within the RG. We propose the following:

The ICNRG Chairs

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Börje Ohlman <[email-masked]>
Date: Fri, 4 Oct 2013 12:32:51 +0000

Hi Andrea,

This also sounds very interesting. Would you be interested in making a presentation of this in Vancouver?

Börje

On 2 okt 2013, at 15:26, Andrea Detti <[email-masked]<mailto:[email-masked]>> wrote:

Dear Börje, All,
We (University of Rome "Tor Vergata") are definitively interested in MPEG DASH video streaming over ICN.
We have currently used these two technologies in mobile environments [1][2], and have an implementation based on CCN of a HTTP/CCN proxy for MPEG DASH streaming.

Regarding the possible topic that may be of research interest, we are working on "load balancing". Today in Content Delivery Network (as far as I know) the selection of which server should address a user request is session-based, i.e. done at the start of the streaming session. In case of session-less approach like the receiver-driven one of CCN, we could have the opportunity to be more reactive to network condition.

I believe that this focussed topic may be part of a more general research area (Information Centric Video Delivery Network, may be a possible tag) driven by the following question: how can emerging Video Content Providers (e.g. NetFlix) use ICN/CCN technology to realize their distribution infrastructure (private or public) ? Are the expected performance, deployment cost, power consumption, etc., better than ones they can obtain using traditional HTTP means, like the one used by CDN provider (e.g. HTTP transparent proxy, routing by name e.g. via DNS or HTTP rewriting)?
My two cents,
Andrea

[1] A.Detti, B. Ricci, N. Blefari-Melazzi,”Peer-To-Peer Live Adaptive Video Streaming for Information Centric Cellular Networks”, IEEE PIMRC 2013,London, UK, 8-11 September 2013

[2] A.Detti, B. Ricci, N. Blefari-Melazzi, “Supporting mobile applications with Information Centric Networking: the case of P2P live adaptive video streaming”, ACM SIGCOMM 2013, ICN workshop,Hong Kong, China, 12 August 2013

available at http://netgroup.uniroma2.it/people/faculties/andrea-detti/andrea-detti-pubs/

The ICNRG Chairs

 Email: [email-masked]<mailto:[email-masked]>

---

From: Börje Ohlman <[email-masked]>
Date: Fri, 4 Oct 2013 12:39:07 +0000

Hi again,

A pity that you won't make it to Vancouver. But sharing ideas via the Wiki or through drafts is also a good alternative. Especially that is an excellent to keep the work going also in-between meetings, so please do.  

For everyone else,
Please take the opportunity to comment on Daniels presentation and updated draft when they become available. It is good if we can have a discussion on the mailing list as preparations for the Vancouver meetings.

	Börje

---

From: "Jun Bi" <[email-masked]>
Date: Fri, 4 Oct 2013 23:36:01 +0800

Dear RG chairs,

I plan to attend Vancouver meeting. If time permitted, I can present the work  in my lab, what Xiaoke just mentioned. 

Best Regards,

Jun Bi

From: Börje Ohlman [mailto:[email-masked]] 
Sent: Friday, October 4, 2013 8:31 PM
To: Xiaoke Jiang
Cc: Jun Bi; icnrg; Ashok Narayanan (ashokn); Dave Oran; Dirk Kutscher
Subject: Re: [icnrg] Proposed new work item: ICN and video distribution

HI Xiaoke, 

Best regards,

Börje

On 2 okt 2013, at 03:36, Xiaoke Jiang <[email-masked] <mailto:[email-masked]> > wrote:

Dear Börje, all,

data chunk 

I hope it helps.

thanks

My Regards,

  _____  

Xiaoke Jiang （蒋小可）

Ph.D Candidate,

On Tue, Oct 1, 2013 at 4:18 PM, Börje Ohlman <[email-masked] <mailto:[email-masked]> > wrote:

The ICNRG Chairs

_______________________________________________
icnrg mailing list
[email-masked] <mailto:[email-masked]> 
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Jun Bi" <[email-masked]>
Date: Fri, 4 Oct 2013 22:59:26 +0800

Dear RG chairs,

Best Regards,

Jun Bi

HI Xiaoke, 

Best regards,

Börje

Dear Börje, all,

data chunk 

I hope it helps.

thanks

My Regards,

  _____  

Xiaoke Jiang （蒋小可）

Ph.D Candidate,

The ICNRG Chairs

---

From: Cedric Westphal <[email-masked]>
Date: Sat, 5 Oct 2013 00:14:26 +0000

Hi,

As part of this work item, I have uploaded our video over ICN draft to the wiki.
http://trac.tools.ietf.org/group/irtf/trac/attachment/wiki/icnrg/draft-video-streaming-over-ICN-00.txt
This was presented in Berlin and was shared to the mailing list in July. I believe it's a good starter for this conversation.
Best regards,

C.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Börje Ohlman
Sent: Tuesday, October 01, 2013 1:18 AM
To: icnrg
Cc: Ashok Narayanan (ashokn); Dave Oran; Dirk Kutscher
Subject: [icnrg] Proposed new work item: ICN and video distribution

The ICNRG Chairs

---

From: Daniel Corujo <[email-masked]>
Date: Thu, 10 Oct 2013 10:50:48 +0100

I have added a set of slides for Optimized video selection and reception on the new "ICN and Video Distribution" Work Item. Please feel free to comment on the mailing list!

Best regards,

Daniel Corujo, Ph.D.														
http://re.vu/dcorujo