Subject: [icnrg] Video streaming in ppsp and icnrg

From: Börje Ohlman <[email-masked]>
Date: Fri, 18 Oct 2013 14:04:27 +0000

If someone from ppsp would be interested to come to the ICNRG meeting on Sunday and present the video streaming work of ppsp this would be most welcome, for meeting details and registration please see http://trac.tools.ietf.org/group/irtf/trac/wiki/icnrg
(Anyone is of course welcome to attend the meeting even if you are not willing to make a presentation.)

I think it would be great to have a discussion on how the video streaming work in ppsp and icnrg relates to each other and which synergies could be possible.

Börje

On 17 okt 2013, at 18:13, Jeff Thompson <[email-masked]<mailto:[email-masked]>>
 wrote:

Is anyone from PPSP going to the ICNRG session on Sunday, Nov. 5?  They are also discussing video streaming with hash-based names.
"Adaptive Video Streaming over ICN"
http://users.soe.ucsc.edu/~cedric/papers/draft-video-streaming-over-ICN-00.txt

This doesn't seem to mention the video streaming with has-based names in the PPSPP draft (or vice versa).  What is the cross-pollination between PPSP and ICNRG?

Thanks,
- Jeff

Hi all,
   The ppsp session is scheduled on 1610-1840 at Plaza C on Tuesday,November 5, 2013. See you all in Vancouver.

BR
Yunfei&Ning

_______________________________________________
ppsp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ppsp

---

From: yunfei zhang <[email-masked]>
Date: Sun, 20 Oct 2013 20:35:29 +0800

Hi Borje,
    I may possibly have time to attend the ICNRG meeting and if I can
attend this meeting, I would be glad to introduce the progress of PPSP and
discuss the possbile cooperation.
      BR
      Yunfei

2013/10/18 Börje Ohlman <[email-masked]>

>  If someone from ppsp would be interested to come to the ICNRG meeting on
> Sunday and present the video streaming work of ppsp this would be most
> welcome, for meeting details and registration please see
> http://trac.tools.ietf.org/group/irtf/trac/wiki/icnrg
>  I think it would be great to have a discussion on how the video
> streaming work in ppsp and icnrg relates to each other and which synergies
> could be possible.
>
>  Börje
>
>  On 17 okt 2013, at 18:13, Jeff Thompson <[email-masked]>
>  wrote:
>
>  Is anyone from PPSP going to the ICNRG session on Sunday, Nov. 5?  They
> are also discussing video streaming with hash-based names.
> This doesn't seem to mention the video streaming with has-based names in
> the PPSPP draft (or vice versa).  What is the cross-pollination between
> PPSP and ICNRG?
>
> Thanks,
> - Jeff
>
>   Hi all,
>    The ppsp session is scheduled on 1610-1840 at Plaza C on
> Tuesday,November 5, 2013. See you all in Vancouver.
>
> BR
> Yunfei&Ning
>
>
> [email-masked]
> [email-masked]

---

From: yunfei zhang <[email-masked]>
Date: Sun, 20 Oct 2013 20:46:37 +0800

Hi Jeff,
    Thanks for the information. As discussed in the previous PPSP meeting,
the naming type of the video streaming is the premise but out of scope of
PPSP. We assume that the tracker/peer identifies the stream with well-known
naming solutions, including hash-based names.
     Another difference is that PPSP assumes running in the current
Internet and ICN may be a future internet implementation. So after
finishing the current tracker and peer protocol design, we may think about
how to incorpate with/import into ICN.

BR
Yunfei

2013/10/18 Jeff Thompson <[email-masked]>

---

From: Börje Ohlman <[email-masked]>
Date: Mon, 21 Oct 2013 14:08:56 +0000

Hi Yunfei,

If it is possible for you to attend our Sunday meeting it would be great to have a presentation of the current status of ppsp and then have an open discussion on how your work relates to what we are planning to do in the icnrg.

Börje

On 20 okt 2013, at 14:35, yunfei zhang <[email-masked]<mailto:[email-masked]>> wrote:

Hi Borje,
    I may possibly have time to attend the ICNRG meeting and if I can attend this meeting, I would be glad to introduce the progress of PPSP and discuss the possbile cooperation.
      BR
      Yunfei

2013/10/18 Börje Ohlman <[email-masked]<mailto:[email-masked]>>
If someone from ppsp would be interested to come to the ICNRG meeting on Sunday and present the video streaming work of ppsp this would be most welcome, for meeting details and registration please see http://trac.tools.ietf.org/group/irtf/trac/wiki/icnrg
(Anyone is of course welcome to attend the meeting even if you are not willing to make a presentation.)

Börje

Thanks,
- Jeff

Hi all,

BR
Yunfei&Ning

---

From: Johan Pouwelse <[email-masked]>
Date: Mon, 21 Oct 2013 16:15:30 +0200

Dear ICNRG and PPSP,

PPSP is designed from the start with ICN in mind. (more details below)

> http://users.soe.ucsc.edu/~cedric/papers/draft-video-streaming-over-ICN-00.txt

That is a nice document, it nails the real challenges very well
in my opinion. The best line I found was: "Naming of the data in DASH does
not necessarily follow the ICN convention of any of the ICN proposals."
I would propose a very generic solution: appending multiple
formats&bitrates into
a single file. Then you can use a simple content hash and byte
position for everything.

About ICN and PP2P..
We are now doing an ICN hardware implementation
on NetFPGA platform. All with the PPSP protocol.

Our Xilinx ICN hardware implementation of Libswift can parse
PPSP messages and SHA1 calulations. Msc thesis report .PDF:
http://repository.tudelft.nl/assets/uuid:1d235433-6f66-42a6-87b1-ef2843f0db38/gustavoverdugo_thesis.pdf
So there is some running code of ICN+PPSP...

For IETF 89 in London I would love to give a talk on this
in the ICNRG session.

> Another difference is that PPSP assumes running in the current Internet
> and ICN may be a future internet implementation.

The protocol now adopted by PPSP was designed by my team roughly
four years ago. However, the ICN part of the protocol is out of scope of PPSP.

Libswift is our reference implementation, it currently is deployed and in use
by 24000 Internet users. Documentation of the ICN part of Libswift:
www.pds.ewi.tudelft.nl/fileadmin/pds/reports/2011/PDS-2011-006.pdf

Greetings, johan.

On 20 October 2013 14:46, yunfei zhang <[email-masked]> wrote:
>      Another difference is that PPSP assumes running in the current Internet
> and ICN may be a future internet implementation. So after finishing the
> current tracker and peer protocol design, we may think about how to
> incorpate with/import into ICN.
>
>
> BR
> Yunfei
>
>> the PPSPP draft (or vice versa).  What is the cross-pollination between PPSP
>> and ICNRG?
>>
>> Thanks,
>> - Jeff
>>
>> Hi all,

---

From: yunfei zhang <[email-masked]>
Date: Tue, 22 Oct 2013 19:45:36 +0800

Hi Borje,
    I'll try to make it. I also discussed with Ning about this and he will
go there as well if there is no time conflict.

Yunfei

2013/10/21 Börje Ohlman <[email-masked]>

>  Hi Yunfei,
>
>  If it is possible for you to attend our Sunday meeting it would be great
> to have a presentation of the current status of ppsp and then have an open
> discussion on how your work relates to what we are planning to do in the
> icnrg.
>
>  Börje
>
>  On 20 okt 2013, at 14:35, yunfei zhang <[email-masked]> wrote:
>
>  Hi Borje,