Subject: Re: [icnrg] icnrg Digest, Vol 22, Issue 2

From: Dessalegn Mequanint <[email-masked]>
Date: Tue, 21 Jan 2014 04:04:46 -0800 (PST)

It sounds like a great idea to think of ICN management considerations at this early stage. However, wouldn't it be good to  think of other management considerations like 
- cache management related to both on demand caching as well as prefetching or active caching.  
- Context management this relates to Video Adaptation management- to adapt video contents to the various constraints, which could be considered as context information like devices characteristics, state of the underlying network, etc. need to be managed.

Kind regards,
Dessalegn

On Monday, January 20, 2014 11:01 PM, "[email-masked]" <[email-masked]> wrote:
 
----- Forwarded Message -----

Send icnrg mailing list submissions to
    [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
    https://www.irtf.org/mailman/listinfo/icnrg
or, via email, send a message with subject or body 'help' to
    [email-masked]

You can reach the person managing the list at
    [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of icnrg digest..."

Today's Topics:

   1. Comments to ICN Management Considerations draft
      (Flinck, Hannu (NSN - FI/Espoo))
   2. Re: Comments to ICN Management Considerations draft
      (Daniel Corujo)

 
Thank you for interesting draft that introduces MA – ME framework and interaction seemingly relevant for NDN.

After reading the document I am still looking for an answer to what needs to be managed in ICN network? The draft mentions strategy layer, faces and shows content store, PIT and FIB. A bit lengthier elaboration of their management needs would be beneficial.
 
Talking from NetInf background there are issues related to name space and scope management, i.e. how a name space is created and how its use is granted, who can publish and who can access a specific content. How much of network capacity including cache
capacity is allocated to particular type of content and how the publications are propagated across network?
 
I think that these issues are unique to ICN and belong to ICN Management Considerations.
 
Further, I suggest that we would build self-configuration functions in ICN from the very beginning
	* self-healing: e.g. how to recover when state if lost, or cache becomes unfunctional
	* self-optimization: e.g. automated load balancing and distribution of content as well as control signaling
	* key performance indicators: define a set of indicators based on which the user as well as network operator can conclude that the ICN system is healthy and performing its task.

Best regards
Hannu

  Dear Hannu,

Thank you very much for your comments and pointers. I consider them very valuable for the progression of this draft, which is under revision for the March IETF meeting.

We can provide more insight about the strategy layer, faces and other aspects that you highlighted, progressing their impact on ICN management, based on our studies did over CCNx.

In addition, I consider quite interesting the addition of “name space” and “scope management” for NetInf, and I think that they would be an awesome addition to the NetInf part of the draft, besides the more generic ICN management aspect of self-configuration (which could generate a new section on the draft).

Would you be interested in contributing to the draft, Hannu?

This invitation is also open to the remainder participants, particularly the ones who did research on management/control aspects of other ICN architectures.

Best regards,

Daniel Corujo, Ph.D.                                                        
http://re.vu/dcorujo
Advanced Telecommunications and Networks Group - http://atnog.av.it.pt
Follow us - @ATNoG_ITAv

On 20 Jan 2014, at 14:34 , Flinck, Hannu (NSN - FI/Espoo) <[email-masked]> wrote:

>  
>  
> Thank you for interesting draft that introduces MA – ME framework and interaction seemingly relevant for NDN.
>  
>  
> After reading the document I am still looking for an answer to what needs to be managed in ICN network? The draft mentions strategy layer, faces and shows content store, PIT and FIB. A bit lengthier elaboration of their management needs would be beneficial.
>  
> Talking from NetInf background there are issues related to name space and scope management, i.e. how a name space is created and how its use is granted, who can publish and who can access a specific content. How much of network capacity including cache capacity is allocated to particular type of content and how the publications are propagated across network?
>  
> I think that these issues are unique to ICN and belong to ICN Management Considerations.
>  
> Further, I suggest that we would build self-configuration functions in ICN from the very beginning
>     • self-healing: e.g. how to recover when state if lost, or cache becomes unfunctional
>     • self-optimization: e.g. automated load balancing and distribution of content as well as control signaling
>     • key performance indicators: define a set of indicators based on which the user as well as network operator can conclude that the ICN system is healthy and performing its task.
>  
>  
> Best regards
> Hannu
>  
>  
>  
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Dessalegn Mequanint <[email-masked]>
Date: Tue, 21 Jan 2014 04:06:39 -0800 (PST)

It sounds like a great idea to think of ICN management considerations at this early stage. However, wouldn't it be good to  think of other management considerations like 
- cache management related to both on demand caching as well as prefetching or active caching.  
- Context management this relates to Video Adaptation management- to adapt video contents to the various constraints, which could be considered as context information like devices characteristics, state of the underlying network, etc.

----- Forwarded Message -----

To subscribe or unsubscribe via the World Wide Web, visit
    https://www.irtf.org/mailman/listinfo/icnrg
or, via email, send a message
 with subject or body 'help' to
    [email-masked]

Today's Topics:

 

 

Best regards
Hannu

 Dear Hannu,

Best
 regards,

Daniel Corujo, Ph.D.                                                        
http://re.vu/dcorujo

On 20 Jan 2014, at 14:34 , Flinck, Hannu (NSN - FI/Espoo) <[email-masked]> wrote:

> After reading the document I am still looking for an answer
 to what needs to be managed in ICN network? The draft mentions strategy layer, faces and shows content store, PIT and FIB. A bit lengthier elaboration of their management needs would be beneficial.
>     •
 self-optimization: e.g. automated load balancing and distribution of content as well as control signaling