Subject: [icnrg] Comments to ICN Management Considerations draft

From: "Flinck, Hannu (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 20 Jan 2014 14:34:53 +0000

Thank you for interesting draft that introduces MA - ME framework and interaction seemingly relevant for NDN.

After reading the document I am still looking for an answer to what needs to be managed in ICN network? The draft mentions strategy layer, faces and shows content store, PIT and FIB. A bit lengthier elaboration of their management needs would be beneficial.

Talking from NetInf background there are issues related to name space and scope management, i.e. how a name space is created and how its use is granted, who can publish and who can access a specific content. How much of network capacity including cache capacity is allocated to particular type of content and how the publications are propagated across network?

I think that these issues are unique to ICN and belong to ICN Management Considerations.

Further, I suggest that we would build self-configuration functions in ICN from the very beginning
*       self-healing: e.g. how to recover when state if lost, or cache becomes unfunctional
*       self-optimization: e.g. automated load balancing and distribution of content as well as control signaling
*       key performance indicators: define a set of indicators based on which the user as well as network operator can conclude that the ICN system is healthy and performing its task.

Best regards
Hannu

---

From: Daniel Corujo <[email-masked]>
Date: Mon, 20 Jan 2014 15:01:34 +0000

Dear Hannu,

Thank you very much for your comments and pointers. I consider them very valuable for the progression of this draft, which is under revision for the March IETF meeting.

We can provide more insight about the strategy layer, faces and other aspects that you highlighted, progressing their impact on ICN management, based on our studies did over CCNx.

In addition, I consider quite interesting the addition of “name space” and “scope management” for NetInf, and I think that they would be an awesome addition to the NetInf part of the draft, besides the more generic ICN management aspect of self-configuration (which could generate a new section on the draft).

Would you be interested in contributing to the draft, Hannu?

This invitation is also open to the remainder participants, particularly the ones who did research on management/control aspects of other ICN architectures.

Best regards,

Daniel Corujo, Ph.D.														
http://re.vu/dcorujo
Advanced Telecommunications and Networks Group - http://atnog.av.it.pt
Follow us - @ATNoG_ITAv

On 20 Jan 2014, at 14:34 , Flinck, Hannu (NSN - FI/Espoo) <[email-masked]> wrote:

>  
>  
> Thank you for interesting draft that introduces MA – ME framework and interaction seemingly relevant for NDN.
>  
>  
> 	• self-healing: e.g. how to recover when state if lost, or cache becomes unfunctional
> 	• self-optimization: e.g. automated load balancing and distribution of content as well as control signaling
> 	• key performance indicators: define a set of indicators based on which the user as well as network operator can conclude that the ICN system is healthy and performing its task.
>  
>  
> Best regards
> Hannu
>  
>  
>  
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg