Subject: [icnrg] Draft minutes from ICNRG Meeting Monday March 3, at IETF-89

From: "Dave Oran (oran)" <[email-masked]>
Date: Tue, 4 Mar 2014 13:33:52 +0000

Please review - will be posted to proceedings at end of the week. Comments/edits to Dave Oran please.
—————

Regular ICNRG meeting @ IETF-89 in London in March 3-7th
	• Time: MONDAY, March 3, 2014
	• Location: Blenheim
Agenda
	• Report from the interim meeting (30 min)
	• ICN and video distribution (Cedric Westphal)
	• ICN and IoT (Ravi Ravindran)
	• Web traffic and CCN/NDN (Dave Oran)
	• Status of working documents (30 min)
	• ICN Baseline Scenarios (Kostas Pentikousis)
	• ICN Research Challenges (Dirk Kutscher)
	• ICN Management Considerations (Daniel Corujo) (20 min)
	• draft-corujo-icn-mgmt-03
	• Resource allocation/traffic engineering (Cedric Westphal) (20 min)
	• CCN packet formats (Diego Perino) (20 min)
	• ICN and mobility - overview and issues (Gareth Tyson) (20 min)
	• AOB and planning for Toronto meeting(s) (10 min)
ICNRG Administrativia

Börje Ohlman showed Note well slide and reminded about the mailing list, web and wiki of the group.

Report from the Sunday interim meeting

ICN and video distribution by Cedric Westphal
draft-video-streaming-over-ICN

Objective of the draft is to relate ICN with the video streaming as it is the dominant type of traffic. The purpose is to initiate discussion. ICN should provide as good as performance of video what we have today.
Version 01 has evolved a lot from version 0 that is visible in TOC and author list.
Expanded the scope of the document to cover other formats that DASH, in particular p2p. Also talks about IPTV and DRM.
Received a lot of feedback in the Sunday meeting, hoping that this leads to discussion at the mailing list as well.
How would video distribution look like over ICN? Is video at the application layer or at the architecuture layer? What are the abstarctions? Should we look at DRM at all?
See Cedric's slides to be posted to the Web about the further questions and join teh discussion.
Dirk K: we try to find the right scope to this discussion. If you could comment the draft and comment it to the authors that would be apprecated.

ICN-IoT by Ravi Ravindran

Provides a high level view of requirements for M2M over ICN.  The draft doesn’t assume any particular protocol. Looking for contributors to the draft.
Further work may include how to scale M2M over ICN.
Home networking use case targeted at the moment. Proposes CIBUS service layer for Name Management, Context Processing, Service Management. This is the main part of the document. CIBUS can handle heterogenity of the home devices.

Discussion on Sunday why to target Homenets? It is a good scenario that is simpler than industry automation. How can ICN deliver better experience? Sees opportunity in policy management in home networks.

Manuel: I have read most of the draft. There are few things that need more work. We need to related to 6LowPan more precishily.

A: Yes, there is a lot of work in this area. We need to look 6LowPAN closer. The architecture can be run on top of IP. Relates to the density of the deplyment.

Dirk K. This is interesting topic area, but need to understand what are the tangible benefits that ICN can provide.
Börje asks for input if this topics should be made as an official work item for the group. Provide comments in the list.

Web traffic and CCN/NDN (Dave Oran)

Sampling sites to understand traffic patterns, used Chrome dev tools.
Web sites are pretty complicated: couple of hundred objects on each page, on average. Objects come from tens of DNS domains. In the request messages there are hundreds of bytes, requests are frequently larger than responses.
Implications to NDN:
* carrying client-side cookies in the request are costly.
* Carrying client state in the requests makes the request client unique, which makes request aggregation challenging.
* how should client stack handle the interest
* state in middle boxes

NDN advantages:
* some rtt cost are eliminated due to caching
* eliminating tcp congestion

Are people interesting working with us with data collecting tools (scripts etc) and exchange measurement results?

Jan: We have done similar measurements. Content retrieval differes a lot what content and which sites are accessed (Amazon vs. Netflix)
Kostas: What Jan said is true. Personalization impacts a lot: not same objects in the response.
Dave: taking today´s web suite and sliding in ICN may not result in a whole lot gain, and may be worse.
Dave: The most valuable information from a business perspective for web applications is not what people get, but what they ask for.

Status of working documents by Kostas

No new scenarios has been indicated to be included in the base line scenarios draft.
Draft edited and updated based on discussion on Sunday. It seems stable and needs to move forward.

Börje: it is time to move to last call in the mailing list. Asks advice from Lars about the processes.

Lars: for research group no fixed processes, typically follow the IETF process, ie. last call. Then IRTF call.

ICN Research Challenges by Dirk K

Draft updated. New section on "Staleness".

To be done: Link and impact on IETF technologies. The authors believe, however, that this should be an other document than the research challenges document.

Dirk T.: Fundamentally different challenges come from dynamic objects that relate to computation. Dirk volunteers to suggest text about this.

Lars E. Before the IETF there was an IAB WS on privacy etc. there it was mentioned that technologies, like ICN, where you subscribe, potentially anonymously, to information could be a way for a future network to provide better anonymity than what is possible in today's Internet. It might be worth including something on this in the Challanges draft.

Ravi R. asks about the service layer challenges.
Dirk K.: we try to provide a summary of current hard reseach challenges, please submit if you have something specific.

Management Consideration by Daniel

Looks into management issues of content, video and network policies. Now at version 03 where comments have been taken in. Added new section on cache management. New section on “fine-grained management of resources".

There is not yet anything about security in the draft yet. Contributions welcomed.

Resource allocation/traffic engineering (Cedric Westphal)

Discussion on real ICN benefits and differnces to the current. ICN can extract meta-data from the network. Introduces a "Content Management Layer" between Forwarding layer nad Control Plane. This leads to fine-grained resouce allocation.

Dave: asks about the notion of "two end points" as there are no end points in the ICN, but requestors etc.
Cedric: This does not cover multiple source.
Dave: how to improve resource management by knowing flow sizes has been studied in Datacenter context - is there an isomorphism here to knowing object sizes?
Dirk T. You seem to argue for separate layer for resource allocation.
Cedric: this is just a starting point, isomorphic to DC flow management work.
George: agrees to emphasizing to look into relation with resource management. Notes that the presented simulations are more about path selection rather than resource allocation.
Dave: extracting QoS information from object name is ambiguous. Different clients may have very different QoS requirements for the same uderlying object(s)

CCN packet formats (Diego Perino)

Suggest generic packet format with fixed common header for fast access to critical fields.

ICN and mobility - overview and issues (Gareth Tyson)

ICN does not statical bind content to location.
George: When you move when access an object do you down load full object again?
Key future work: routing and management
George: supports ICN and mobility work.

AOB

---

From: "Flinck, Hannu (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 4 Mar 2014 13:43:08 +0000

Here is a spell checked version. Please use this for your review

Best regards
Hannu
----------------------

Regular ICNRG meeting @ IETF-89 in London in March 3-7th
	. Time: MONDAY, March 3, 2014
	. Location: Blenheim
Agenda
	. Report from the interim meeting (30 min)
	. ICN and video distribution (Cedric Westphal)
	. ICN and IoT (Ravi Ravindran)
	. Web traffic and CCN/NDN (Dave Oran)
	. Status of working documents (30 min)
	. ICN Baseline Scenarios (Kostas Pentikousis)
	. ICN Research Challenges (Dirk Kutscher)
	. ICN Management Considerations (Daniel Corujo) (20 min)
	. draft-corujo-icn-mgmt-03
	. Resource allocation/traffic engineering (Cedric Westphal) (20 min)
	. CCN packet formats (Diego Perino) (20 min)
	. ICN and mobility - overview and issues (Gareth Tyson) (20 min)
	. AOB and planning for Toronto meeting(s) (10 min)

ICNRG Administrativia

Objective of the draft is to relate ICN with the video streaming as it is the dominant type of traffic. The purpose is to initiate discussion. ICN should provide as good as performance of video what we have today.
Version 01 has evolved a lot from version 0 that is visible in TOC and author list.
Expanded the scope of the document to cover other formats that DASH, in particular p2p. Also talks about IPTV and DRM.
Received a lot of feedback in the Sunday meeting, hoping that this leads to discussion at the mailing list as well.
How would video distribution look like over ICN? Is video at the application layer or at the architecture layer? What are the abstractions? Should we look at DRM at all?
See Cedric's slides to be posted to the Web about the further questions and join the discussion.
Dirk K: we try to find the right scope to this discussion. If you could comment the draft and comment it to the authors that would be appreciated.

Provides a high level view of requirements for M2M over ICN.  The draft doesn't assume any particular protocol. Looking for contributors to the draft.
Further work may include how to scale M2M over ICN.
Home networking use case targeted at the moment. Proposes CIBUS service layer for Name Management, Context Processing, Service Management. This is the main part of the document. CIBUS can handle heterogeneity of the home devices.

Manuel: I have read most of the draft. There are few things that need more work. We need to related to 6LowPan more precisely.

A: Yes, there is a lot of work in this area. We need to look 6LowPAN closer. The architecture can be run on top of IP. Relates to the density of the deployment.

NDN advantages:

Jan: We have done similar measurements. Content retrieval differs a lot what content and which sites are accessed (Amazon vs. Netflix)
Kostas: What Jan said is true. Personalization impacts a lot: not same objects in the response.
Dave: taking today´s web suite and sliding in ICN may not result in a whole lot gain, and may be worse.
Dave: The most valuable information from a business perspective for web applications is not what people get, but what they ask for.

Lars: for research group no fixed processes, typically follow the IETF process, i.e. last call. Then IRTF call.

To be done: Link and impact on IETF technologies. The authors believe, however, that this should be another document than the research challenges document.

Lars E. Before the IETF there was an IAB WS on privacy etc. there it was mentioned that technologies, like ICN, where you subscribe, potentially anonymously, to information could be a way for a future network to provide better anonymity than what is possible in today's Internet. It might be worth including something on this in the Challenges draft.

Ravi R. asks about the service layer challenges.
Dirk K.: we try to provide a summary of current hard research challenges, please submit if you have something specific.

Looks into management issues of content, video and network policies. Now at version 03 where comments have been taken in. Added new section on cache management. New section on "fine-grained management of resources".

Discussion on real ICN benefits and differences to the current. ICN can extract meta-data from the network. Introduces a "Content Management Layer" between Forwarding layer and Control Plane. This leads to fine-grained resource allocation.

Dave: extracting QoS information from object name is ambiguous. Different clients may have very different QoS requirements for the same underlying object(s)

ICN does not statically bind content to location.
George: When you move when access an object do you down load full object again?
Key future work: routing and management
George: supports ICN and mobility work.

AOB

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of ext Dave Oran (oran)
Sent: Tuesday, March 04, 2014 3:34 PM
To: [email-masked]
Subject: [icnrg] Draft minutes from ICNRG Meeting Monday March 3, at IETF-89

-----