Subject: Re: [icnrg] ICNRG@IETF-91

From: Dirk Kutscher <[email-masked]>
Date: Thu, 6 Nov 2014 12:52:19 +0000

Hi all,

We have updated the agenda for ICNRG@IETF-91 -- please review.

https://datatracker.ietf.org/meeting/91/agenda/icnrg/

ICNRG Meeting @ IETF-91
Monday, November 10, 2014
15:20 -- 18:30
Room: Kahili (http://tools.ietf.org/agenda/91/venue/?room=kahili)

15:20 Welcome, Agenda Bashing, Status [Chairs] -- 15 min
      - Baseline Scenarios Status
      - ICN Challenges Last Call
      - Report from interim

15:35 Video Update [Cedric Westphal] -- 15 min
      https://tools.ietf.org/html/draft-irtf-icnrg-videostreaming

15:50 IoT Update [GQ Wang / Ravi Ravindran] -- 15 min
      http://tools.ietf.org/html/draft-zhang-iot-icn-challenges

16:05 Bloom Filter-based Name Resolution Update [Jungha Hong] -- 15 min
      https://tools.ietf.org/html/draft-hong-icnrg-bloomfilterbased-name-resolution

16:20 "CCN/NDN Protocol Wire Format and Functionality Considerations [GQ Wang] -- 15 min

16:35 QoE in ICN Discussion [Damien Saucez] -- 30 min

17:05 Demo: Web of Trust in ICN [Jan Seedorf] -- 15 min
      https://tools.ietf.org/html/draft-seedorf-icn-wot-selfcertifying-00

17:20 Wrap up

Best regards,
Dirk, Dave Börje

> -----Original Message-----
> From: icnrg [mailto:[email-masked]] On Behalf Of Dirk Kutscher
> Sent: Dienstag, 28. Oktober 2014 11:33
> To: [email-masked]
> Subject: Re: [icnrg] ICNRG@IETF-91
> 
> Hi all,
> 
> We have posted a draft agenda for ICNRG@IETF-91. Please let us know in
> case we missed something you want to propose additions.
> 
> https://datatracker.ietf.org/meeting/91/agenda/icnrg/
> 
> ICNRG Meeting @ IETF-91
> Monday, November 10, 2014
> 15:20 -- 18:30
> Room: Kahili (http://tools.ietf.org/agenda/91/venue/?room=kahili)
> 
> 15:20 Welcome, Agenda Bashing, Status [Chairs] -- 15 min
>       - Baseline Scenarios Status
>       - ICN Challenges Last Call
>       - Report from interim
> 
> 15:35 Video Update [Cedric Westphal] -- 15 min
>       https://tools.ietf.org/html/draft-irtf-icnrg-videostreaming
> 
> 15:50 IoT Update [GQ Wang / Ravi Ravindran] -- 15 min
>       http://tools.ietf.org/html/draft-zhang-iot-icn-challenges
> 
> 16:05 Bloom Filter-based Name Resolution Update [Jungha Hong] -- 15 min
>       https://tools.ietf.org/html/draft-hong-icnrg-bloomfilterbased-name-
> resolution
> 
> 16:20 ICN packet format [GQ Wang / Ravi Ravindran] -- 15 min
> 
> 16:35 QoE in ICN Discussion [Damien Saucez] -- 30 min
> 
> 17:05 Wrap up
> 
> 
> Thanks,
> Dirk, Dave, Börje
> 
> 
> 
> 
> 
> 
> 
> > -----Original Message-----
> > From: icnrg [mailto:[email-masked]] On Behalf Of Dirk Kutscher
> > Sent: Montag, 6. Oktober 2014 15:57
> > To: [email-masked]
> > Subject: [icnrg] ICNRG@IETF-91
> >
> > Hi all,
> >
> > At the interim meeting in Paris we talked about meeting at IETF-91. We
> > wanted to base this on offered contributions and interest of people to
> > attend.
> >
> > So, if people are planning to come and are interested to
> > present/discuss a particular topic, please let the chairs and/or this
> > list know so that we can progress the planning.
> >
> > Thanks,
> > Dirk, Börje, Dave
> >
> >
> >
> >
> > _______________________________________________
> > icnrg mailing list
> > [email-masked]
> > https://www.irtf.org/mailman/listinfo/icnrg
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: 허신영 <[email-masked]>
Date: Thu, 6 Nov 2014 23:55:38 +0000

Hello,

Please check this draft.
I was told I can present it. 
Maybe it is omitted.

The draft  is in the below.

Name:		draft-hur-icnrg-abstracted-network-api
 Revision:	01
 Title:		Abstracted Network API for ICN
 Document date:	2014-10-28
 Group:		Individual Submission
 Pages:		10
 URL:            http://www.ietf.org/internet-drafts/draft-hur-icnrg-abstracted-
 network-api-01.txt
 Status:         https://datatracker.ietf.org/doc/draft-hur-icnrg-abstracted-
 network-api/
 Htmlized:       http://tools.ietf.org/html/draft-hur-icnrg-abstracted-network-
 api-01
 Diff:           http://www.ietf.org/rfcdiff?url2=draft-hur-icnrg-abstracted-
 network-api-01
 
 Abstract:
                draft-hur-icnrg-abstracted-network-api-00.txt
 
 In information-centric networking (ICN), well designed API will play a 
 pivotal role in adopting ICN to applications. Traditional network API 
 – i.e., current Socket implementation - is coupled between 
 applications and underlying protocols, so it is hard to change one 
 without changing the other, thus it could be solved by redesigning the 
 network API in a way that decouples application-specific functions 
 from network specific functions. In this draft, we addressed the 
 network API modeling issues which can be also applied to the design of 
 ICN APIs and proposed iPlug and dSocket API which help injection of 
 applications’ intent and hide underlying network specific mechanisms, respectively.

Thanks,
Cinyoung Hur

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Dirk Kutscher
Sent: Thursday, November 06, 2014 9:52 PM
To: [email-masked]
Subject: Re: [icnrg] ICNRG@IETF-91

Hi all,

ICNRG Meeting @ IETF-91

17:20 Wrap up

Best regards,
Dirk, Dave Börje

> > At the interim meeting in Paris we talked about meeting at IETF-91. 
> > We wanted to base this on offered contributions and interest of 
> > people to attend.
> >
> > present/discuss a particular topic, please let the chairs and/or 
> > this list know so that we can progress the planning.
> >
> > Thanks,
> > Dirk, Börje, Dave
> >
> >
> >
> >

---

From: Ravi Ravindran <[email-masked]>
Date: Fri, 7 Nov 2014 02:11:26 +0000

Dear All,

A new version of the ICN-IoT draft ( "draft-zhang-iot-icn-01.txt" ) has been uploaded to the ICN-RG wiki. For folks following this draft, we have added more details to Section 5. Comments and suggestions are welcome. G.Q will summarize the changes at the meeting.

http://trac.tools.ietf.org/group/irtf/trac/attachment/wiki/icnrg/draft-zhang-iot-icn-challenges-01.txt

Regards,
Ravi

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Dirk Kutscher
Sent: Thursday, November 06, 2014 4:52 AM
To: [email-masked]
Subject: Re: [icnrg] ICNRG@IETF-91

Hi all,

ICNRG Meeting @ IETF-91

17:20 Wrap up

Best regards,
Dirk, Dave Börje

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 7 Nov 2014 07:47:05 +0000

Hi,

Thanks for the reminder -- Yes, I overlooked it, sorry.  You have your slot now.

ICNRG Meeting @ IETF-91

17:05 Abstracted Network API for ICN [Cinyoung Hur] --15 min

17:20 Demo: Web of Trust in ICN [Jan Seedorf] -- 15 min
      https://tools.ietf.org/html/draft-seedorf-icn-wot-selfcertifying-00

17:35 Wrap up

Best regards,
Dirk

> From: 허신영 [mailto:[email-masked]]
> Sent: Freitag, 7. November 2014 00:56
> To: Dirk Kutscher; [email-masked]
> Subject: RE: ICNRG@IETF-91
> 
> Hello,
> 
> Please check this draft.
>  In information-centric networking (ICN), well designed API will play a  pivotal
> role in adopting ICN to applications. Traditional network API  – i.e., current
> Socket implementation - is coupled between  applications and underlying
> protocols, so it is hard to change one  without changing the other, thus it
> could be solved by redesigning the  network API in a way that decouples
> application-specific functions  from network specific functions. In this draft,
> we addressed the  network API modeling issues which can be also applied to
> the design of  ICN APIs and proposed iPlug and dSocket API which help
> injection of  applications’ intent and hide underlying network specific
> mechanisms, respectively.
> 
> 
> Thanks,
> Cinyoung Hur
>