Subject: [icnrg] ICN Off-path Caching

From: Ibrahim ABDULLAHI <[email-masked]>
Date: Tue, 11 Nov 2014 21:07:04 +0800

Hi,
What do you think of the possibility of taking a good advantage of the Fog
computing concept to demonstrate the ICN Off-path caching.
Since the Fog concepts adds the processing, retrieval and forwarding
information/interests at edges, can these be demonstrated in ICN caching
off path.

cc: [email-masked] and team have been helpful.

-- 

*Regards.*

*​[email-masked] ​*

******************************************************************

*Ibrahim ABDULLAHI*

*B.Sc (UDU), M.Sc (ABU)*
*PhD Research Student, *

*InterNetworks Research Laboratory,*

*School of Computing; College of Arts and Sciences,*

*Universiti Utara Malaysia, UUM 06010 Sintok, Kedah, Darul Aman.*

*M A L A Y S I A (+60169290804)*

*http://uum.edu.my/index.php/en/ <http://uum.edu.my/index.php/en/> *

* NIGERIA: (+2348035991532) *

*Department of Mathematics/Computer Science.*

*Faculty of Natural Science, P.M.B 11*

*Ibrahim Badamasi Babangida University, Lapai.*

*Niger State. N I G E R I A*

*http://ibbu.edu.ng/ <http://ibbu.edu.ng/>*

******************************************************************

******************************************************************

---

From: David Oran <[email-masked]>
Date: Tue, 11 Nov 2014 09:40:44 -0500

There’s been a very large body of work on off-path caching at or near the edge. You might start by looking at the CoBlitz/CoDeen work from about 10 years ago:
http://codeen.cs.princeton.edu/coblitz/

Also, it would be useful to articulate what it is about fog at the edge which makes off-path (as opposed to edge or on-path) caching potentially attractive.

DaveO.

> On Nov 11, 2014, at 8:07 AM, Ibrahim ABDULLAHI <[email-masked]> wrote:
> 
> Hi, 
> What do you think of the possibility of taking a good advantage of the Fog computing concept to demonstrate the ICN Off-path caching. 
> Since the Fog concepts adds the processing, retrieval and forwarding information/interests at edges, can these be demonstrated in ICN caching off path. 
> 
> Regards.
> ​[email-masked] ​
> 
> 
> ****************************************************************
> Ibrahim ABDULLAHI 
> B.Sc (UDU), M.Sc (ABU)
> PhD Research Student, 
> InterNetworks Research Laboratory,
> School of Computing; College of Arts and Sciences,
> Universiti Utara Malaysia, UUM 06010 Sintok, Kedah, Darul Aman.
> M A L A Y S I A (+60169290804)
> http://uum.edu.my/index.php/en/ 
> 
>  NIGERIA: (+2348035991532) 
> Department of Mathematics/Computer Science.
> Faculty of Natural Science, P.M.B 11
> Ibrahim Badamasi Babangida University, Lapai. 
> Niger State. N I G E R I A
> http://ibbu.edu.ng/
> ****************************************************************
> ****************************************************************
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg