Subject: [icnrg] A Rationale for Fine-grained Intermediary-aware End-to-End Protocols

From: Dirk Kutscher <[email-masked]>
Date: Thu, 11 Dec 2014 12:20:06 +0000

Dear all,

I just wanted to bring this Internet Draft to your attention which has some relationship to ICN at large, as I believe.

It is related to the security vs in-network optimization discussion that we had at ICN-2014 and other occasions.

Abstract:
   A tremendous growth in different uses of the Internet has let to a
   growing need to protect data sent over public networks, including
   data sent via http.  Use of end-to-end TLS for the majority of
   traffic looks at first a most feasible response.  However, the web
   architecture has become more sophisticated and as it has now gone
   beyond the simple client-server model, the end-to-end used of TLS is
   increasingly showing its downside.  The end-to-end use of TLS
   excludes the use of beneficial intermediaries such as use of caches
   or proxies that provide instrumental services.  Then need for greater
   privacy seems to collide with the equally growing desire for better
   end-to-end performance and user experience.  As an example, the use
   of HTTP/TLS often appears to maximise the benefit for the combination
   of both.

   This document describes the above dichotomy and lays out a number of
   objectives of what can ideally be achieved, namely catering for
   sufficient security and privacy whilst providing users with the
   opportunity to make use of intermediaries' services where considered
   beneficial.  This document introduces a number of potential solutions
   towards use of suitable protocol mechanisms and data formats.  End-
   to-end protocols which are aware of intermediaries should enable
   users and/or content providers to exercise fine-grained control over
   what intermediaries should be able to do and what exposure to data or
   metadata they shall be permitted to get.  The document then
   highlights anticipated benefits to key stakeholders such as users,
   content providers and intermediaries.  As elements such as object
   security can play a useful role, this document encourages the
   analysis of related work to discern their applicability, limitations,
  and coverage of use cases.  Such an effort may us espouse innovation
   to frame an overall architecture and motivate more detailed work on
   protocols and mechanisms in the future.

https://datatracker.ietf.org/doc/draft-reschke-objsec/

Best regards,
Dirk

---

From: Marcus Ihlar <[email-masked]>
Date: Thu, 11 Dec 2014 20:44:06 +0000

Hi,
Great that you found our work :).
Even though it’s not written with ICN in mind there is probably a lot of common ground between our proposed work and the security issues related to the different flavours of ICN.

It would be really interesting to hear the views of the ICN community regarding these types of questions, especially since things like in-network caching seem to be inherent features of ICN architectures.

Is there any material available from the discussion at ICN-2014?

We have set up a mailing list for this work, feel free to join if you find it interesting.
https://www.ietf.org/mailman/listinfo/mcic

Best Regards
Marcus Ihlar

On 11 Dec 2014, at 13:20, Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Abstract:

Best regards,
Dirk

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 12 Dec 2014 14:57:41 +0000

Hi Marcus,

Thanks for following up. :)

The discussion at ICN-2014 mainly took place during the industry panel. One of the concerns that was expressed was exactly the question how operators of today's networks can perform performance enhancements, caching etc without breaking security, and whether ICN would be a better platform thanks to its explicit object naming and identification features.

The SIGCOMM web  server seems to be down at the moment. I'll be back with pointers later...

Also, the ICN community is currently discussing packet formats; mutable vs. immutable header and meta data fields is one topic.

On a related note, we are discussing an approach called Named Functions which is about having named functions in the network that can perform computations on named data objects in the network, potentially producing new data objects. This is early work but could be the basis for a more explicit (and secure) object transformation approach in operator networks.

Would be interested in other people's views on this.

Best regards,
Dirk

From: Marcus Ihlar [mailto:[email-masked]]
Sent: Donnerstag, 11. Dezember 2014 21:44
To: Dirk Kutscher
Cc: [email-masked]
Subject: Re: [icnrg] A Rationale for Fine-grained Intermediary-aware End-to-End Protocols

Hi,
Great that you found our work :).
Even though it's not written with ICN in mind there is probably a lot of common ground between our proposed work and the security issues related to the different flavours of ICN.

Best Regards
Marcus Ihlar

Dear all,

Abstract:

Best regards,
Dirk

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg