Subject: [icnrg] name-based app semantics vs. SPUD

From: Dirk Kutscher <[email-masked]>
Date: Wed, 25 Mar 2015 14:51:22 +0000

Hi,

For those who are currently in the SPUD session in the IETF, this is an interesting example to what extent you have to stretch Internet architecture and node requirements to achieve a subset of what ICN can do out of the box. :-)

https://datatracker.ietf.org/meeting/92/agenda/spud/

Best regards,
Dirk

---

From: Lixia Zhang <[email-masked]>
Date: Wed, 25 Mar 2015 11:28:19 -0700

> On Mar 25, 2015, at 7:51 AM, Dirk Kutscher <[email-masked]> wrote:
> 
> Hi,
> 

agree.
and one can probably say the same about TAPS 
Here is the pointer to Marie-Jose's presentation slides at TAPS (as she mentioned during our Sunday meeting:
http://tools.ietf.org/agenda/92/slides/slides-92-taps-4.pdf

Here is the pointer to the rest of the TAPS WG session:
http://tools.ietf.org/wg/taps/agenda?item=agenda-92-taps.html

FYI,
Lixia

---

From: Cedric Westphal <[email-masked]>
Date: Wed, 25 Mar 2015 19:42:46 +0000

Hi Dirk,

Very good pointer. I would argue that some of the semantics of SPUD are not "out of the box" features in ICN. For instance, the start/end semantics (which is the primary use case of SPUD) is supported in (some) ICN (flavor) only under the assumption of point-to-point connection between the client and the content. If content can be coming from multiple servers on multiple interface, then all bets are off! 

Best,

C.

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Dirk Kutscher
Sent: Wednesday, March 25, 2015 7:51 AM
To: [email-masked]
Subject: [icnrg] name-based app semantics vs. SPUD

Hi,

Best regards,
Dirk

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg