Subject: [icnrg] ICNRG Next steps discussion

From: Börje Ohlman <[email-masked]>
Date: Mon, 23 Mar 2015 15:09:37 +0000

We started the ICNRG Next steps discussion at the interim meeting on Sunday (in session 3 after lunch). Currently you find the draft notes at: https://neclab.titanpad.com/ICNRG-IETF92

We will follow up this discussion at the ICNRG meeting on Tuesday. Before then it would be great to have some discussion on the mailing list. Especially to give those of you that are not present here in Dallas a chance to contribute.

Basically we are looking for views on: What should ICNRG focus on? Which key issues are we missing? What should we maybe spend less effort on?

At the Sunday discussion some of the topics that where mentioned was:

  *   How do we deal with information specific metrics?
  *   Is there a new class of metrics that would help with routing protocols?
  *   Content discovery, Nearest replica routing
  *   Specification for experimentation. Baseline for forwarding architecture
  *   Need to rethink and recast apps that match better to ICN.

Some other topics that we have had on our list earlier but not that much work has materialized are:

  *   Access control
  *   Routing
  *   Mobility
  *   Transactional data
  *   Object security

Please feel free to express your views on this. Which topics do you want to add? Which do you think are the most important topics?

You are encouraged to send your views directly to the mailing list, but if you prefer you can also send them directly to the chairs.

Börje

---

From: Ravi Ravindran <[email-masked]>
Date: Mon, 23 Mar 2015 16:52:54 +0000

I would suggest two more areas:

Applications (Video streaming, Conferencing, IoT etc.) and
Protocol Wire Format

Regards,
Ravi

From: icnrg [mailto:[email-masked]] On Behalf Of Börje Ohlman
Sent: Monday, March 23, 2015 10:10 AM
To: icnrg
Subject: [icnrg] ICNRG Next steps discussion

  *   Access control
  *   Routing
  *   Mobility
  *   Transactional data
  *   Object security

Börje

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Tue, 24 Mar 2015 00:59:29 +0000

Probably two things that come to my mind:

1. IP backward compatibility -- what are the challenges for enabling edge
based ICN deployments -- addressing scalability?

2. Integrating with DTN would be an interesting problem space.

For info - We have an EU H2020 project that specifically looks at 1 and 2
for enabling low cost Internet access: http://rife-project.eu/about/

Regards

On 23 March 2015 at 15:09, Börje Ohlman <[email-masked]> wrote:

>  We started the ICNRG Next steps discussion at the interim meeting on
> Sunday (in session 3 after lunch). Currently you find the draft notes at:
> https://neclab.titanpad.com/ICNRG-IETF92
>
>  We will follow up this discussion at the ICNRG meeting on Tuesday.
> Before then it would be great to have some discussion on the mailing list.
> Especially to give those of you that are not present here in Dallas a
> chance to contribute.
>
>  Basically we are looking for views on: What should ICNRG focus on? Which
> key issues are we missing? What should we maybe spend less effort on?
>
>    - How do we deal with information specific metrics?
>    - Is there a new class of metrics that would help with routing
>    protocols?
>    - Content discovery, Nearest replica routing
>    - Specification for experimentation. Baseline for forwarding
>    architecture
>    - Need to rethink and recast apps that match better to ICN.
>
>
>    - Access control
>    - Routing
>    - Mobility
>    - Transactional data
>    - Object security
>  Please feel free to express your views on this. Which topics do you want
> to add? Which do you think are the most important topics?
>
>  You are encouraged to send your views directly to the mailing list, but
> if you prefer you can also send them directly to the chairs.
>
>  Börje
>
>
>
>
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>
>

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: "Trossen, Dirk" <[email-masked]>
Date: Tue, 24 Mar 2015 10:12:35 +0000

Arjuna

The first aspect has two faces: running ICN over IP, which the ICN community has been doing for some time in various ways. The RIFE project proposes something along the lines of previous PURSUIT work.

Another face is to enable backward compatibility of IP-based user equipment and applications/services over an ICN-enabled operator network. For this, H2020 started another project called POINT, which follows that line, also based on previous PURSUIT work.

Certainly an interesting angle to look at ICN, I.e., IP becomes your killer app ;-)

Best

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.
Shoreditch Business Center
64 Great Eastern Street
London,  EC2A 3QR
T: +44 20 7749 9178
[email-masked]
www.InterDigital.com<http://www.interdigital.com>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

________________________________
From: icnrg on behalf of Arjuna Sathiaseelan
Sent: Tuesday, March 24, 2015 12:59:29 AM
To: Börje Ohlman
Cc: icnrg
Subject: Re: [icnrg] ICNRG Next steps discussion

1. IP backward compatibility -- what are the challenges for enabling edge based ICN deployments -- addressing scalability?

For info - We have an EU H2020 project that specifically looks at 1 and 2 for enabling low cost Internet access: http://rife-project.eu/about/

Regards

On 23 March 2015 at 15:09, Börje Ohlman <[email-masked]<mailto:[email-masked]>> wrote:
We started the ICNRG Next steps discussion at the interim meeting on Sunday (in session 3 after lunch). Currently you find the draft notes at: https://neclab.titanpad.com/ICNRG-IETF92

  *   Access control
  *   Routing
  *   Mobility
  *   Transactional data
  *   Object security

Börje

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Daniel Corujo <[email-masked]>
Date: Tue, 24 Mar 2015 10:14:51 +0000

Dear all,

Please consider this topic: ICN operation in constrained devices.

Best regards,

Daniel Corujo, Ph.D., Research Fellow
Universidade de Aveiro, Portugal	
http://re.vu/dcorujo
Advanced Telecommunications and Networks Group - http://atnog.av.it.pt
Follow us - @ATNoG_ITAv

> On 23 Mar 2015, at 15:09 , Börje Ohlman <[email-masked]> wrote:
> 
> 	• How do we deal with information specific metrics?
> 	• Is there a new class of metrics that would help with routing protocols?
> 	• Content discovery, Nearest replica routing
> 	• Specification for experimentation. Baseline for forwarding architecture
> 	• Need to rethink and recast apps that match better to ICN.
> 
> 	• Access control
> 	• Routing
> 	• Mobility
> 	• Transactional data
> 	• Object security

---

From: "Trossen, Dirk" <[email-masked]>
Date: Tue, 24 Mar 2015 10:16:41 +0000

...BTW, I would have suggested a presentation in Dallas but timing didn't permit my attendance.

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

________________________________
From: icnrg on behalf of Trossen, Dirk
Sent: Tuesday, March 24, 2015 10:12:35 AM
To: Arjuna Sathiaseelan; Börje Ohlman
Cc: icnrg
Subject: Re: [icnrg] ICNRG Next steps discussion

Arjuna

Best

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.
Shoreditch Business Center
64 Great Eastern Street
London,  EC2A 3QR
T: +44 20 7749 9178
[email-masked]
www.InterDigital.com<http://www.interdigital.com<http://www.InterDigital.com<http://www.interdigital.com>>

Regards

  *   Access control
  *   Routing
  *   Mobility
  *   Transactional data
  *   Object security

Börje

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 24 Mar 2015 11:56:31 +0000

I guess the more complex content/video dissemination scenarios need be there since I raised them?

/mjm
Marie-Jose Montpetit, Ph.D.
[email-masked]
@SocialTVMIT

> On Mar 24, 2015, at 5:14 AM, Daniel Corujo <[email-masked]> wrote:
> 
> Dear all,
>

---

From: Börje Ohlman <[email-masked]>
Date: Tue, 24 Mar 2015 14:28:04 +0000

Do you have links for the projects you are referring to? Is the RIFE project an EU project?
If I search for POINT as an EU project I get:
http://www.point-eufp7.info
I assume that is not the one you are referring to, or?

	Börje

> On 24 mar 2015, at 11:12, Trossen, Dirk <[email-masked]> wrote:
> 
> Arjuna
>

---

From: Daniel Corujo <[email-masked]>
Date: Tue, 24 Mar 2015 14:29:42 +0000

For POINT:

http://www.point-h2020.eu/

> On 24 Mar 2015, at 14:28 , Börje Ohlman <[email-masked]> wrote:
>

---

From: Matthias Waehlisch <[email-masked]>
Date: Tue, 24 Mar 2015 09:30:59 -0500 (Central Sommerzeit)

Hi Boerje,

  I suppose he is referring to http://www.point-h2020.eu/ and 
http://rife-project.eu.

Cheers
  matthias

-- 
Matthias Waehlisch
.  Freie Universitaet Berlin, Inst. fuer Informatik, AG CST
.  Takustr. 9, D-14195 Berlin, Germany
.. mailto:[email-masked] .. http://www.inf.fu-berlin.de/~waehl
:. Also: http://inet.cpt.haw-hamburg.de .. http://www.link-lab.net

---

From: "Trossen, Dirk" <[email-masked]>
Date: Tue, 24 Mar 2015 14:32:22 +0000

My apologies for leaving the links out: https://www.point-h2020.eu/

Arjuna provided the link to the RIFE project. Both are recently started h2020 projects as part of the ict5 call (sorry of this means nothing for people outside the European funding scene).

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

________________________________
From: Börje Ohlman
Sent: Tuesday, March 24, 2015 2:28:04 PM
To: Trossen, Dirk
Cc: Arjuna Sathiaseelan; icnrg
Subject: Re: [icnrg] ICNRG Next steps discussion

        Börje

---

From: "Trossen, Dirk" <[email-masked]>
Date: Tue, 24 Mar 2015 14:33:13 +0000

Ha, slow in responding. All correct there ;-)

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

________________________________
From: Matthias Waehlisch
Sent: Tuesday, March 24, 2015 2:30:59 PM
To: Börje Ohlman
Cc: Trossen, Dirk; icnrg; Arjuna Sathiaseelan
Subject: Re: [icnrg] ICNRG Next steps discussion

Hi Boerje,

Cheers
  matthias

---

From: "Papadimitriou, Dimitri (Dimitri)" <[email-masked]>
Date: Tue, 24 Mar 2015 18:47:51 +0000

Hello,

Now that we have all links ;-) I would consider a more open question as of which role(s) IP may vs. must play in an ICN full vs. partial deployment, the latter could be further decomposed in localized (island) vs. sparse deployment. This shouldn't prevent investigating settings as those you outlined here below.

It would also be interesting to nail down the minimum "where" (spatial) information locally required compared to the current situation based on the initial objective of a system able to cope simultaneously with terminal and information mobility by transferring the decision process to the "what" (object).

Thanks,
-dimitri.

> -----Original Message-----
> From: icnrg [mailto:[email-masked]] On Behalf Of Trossen, Dirk
> Sent: Tuesday, March 24, 2015 3:33 PM
> To: Matthias Waehlisch; Börje Ohlman
> Cc: icnrg; Arjuna Sathiaseelan
> This e-mail is intended only for the use of the individual or entity to
> which it is addressed, and may contain information that is privileged,
> confidential and/or otherwise protected from disclosure to anyone other
> than its intended recipient. Unintended transmission shall not constitute
> waiver of any privilege or confidentiality obligation. If you received
> this communication in error, please do not review, copy or distribute it,
> notify me immediately by email, and delete the original message and any
> attachments. Unless expressly stated in this e-mail, nothing in this
> message or any attachment should be construed as a digital or electronic
> signature.
> 
> 
> .  Freie Universitaet Berlin, Inst. fuer Informatik, AG CST .  Takustr.
> 9, D-14195 Berlin, Germany .. mailto:[email-masked] ..
> http://www.inf.fu-berlin.de/~waehl
> > > The first aspect has two faces: running ICN over IP, which the ICN
> community has been doing for some time in various ways. The RIFE project
> proposes something along the lines of previous PURSUIT work.
> > >
> > > Another face is to enable backward compatibility of IP-based user
> equipment and applications/services over an ICN-enabled operator network.
> For this, H2020 started another project called POINT, which follows that
> line, also based on previous PURSUIT work.
> > >
> > > This e-mail is intended only for the use of the individual or entity
> to which it is addressed, and may contain information that is privileged,
> confidential and/or otherwise protected from disclosure to anyone other
> than its intended recipient. Unintended transmission shall not constitute
> waiver of any privilege or confidentiality obligation. If you received
> this communication in error, please do not review, copy or distribute it,
> notify me immediately by email, and delete the original message and any
> attachments. Unless expressly stated in this e-mail, nothing in this
> message or any attachment should be construed as a digital or electronic
> signature.
> > >
> > >
> > > 1. IP backward compatibility -- what are the challenges for enabling
> edge based ICN deployments -- addressing scalability?
> > >
> > > For info - We have an EU H2020 project that specifically looks at 1
> > > and 2 for enabling low cost Internet access:
> > > http://rife-project.eu/about/
> > >
> > > Regards
> > >
> > > On 23 March 2015 at 15:09, Börje Ohlman
> <[email-masked]<mailto:[email-masked]>> wrote:
> > > Sunday (in session 3 after lunch). Currently you find the draft
> > > notes at: https://neclab.titanpad.com/ICNRG-IETF92
> > >
> Before then it would be great to have some discussion on the mailing
> list. Especially to give those of you that are not present here in Dallas
> a chance to contribute.
> > >
> > > Basically we are looking for views on: What should ICNRG focus on?
> Which key issues are we missing? What should we maybe spend less effort
> on?
> > >
> > > Please feel free to express your views on this. Which topics do you
> want to add? Which do you think are the most important topics?
> > >
> > > You are encouraged to send your views directly to the mailing list,
> but if you prefer you can also send them directly to the chairs.
> > >
> > > Börje
> > >
> > >
> > >
> > > Personal: http://www.cl.cam.ac.uk/~as2330/ N4D Lab:
> > > http://www.cl.cam.ac.uk/~as2330/n4d
> >

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Wed, 25 Mar 2015 06:40:52 +0000

I think there are two possibilities here:

1/Enabling IP based legacy apps to run on an ICN based edge deployment

2/ICN based edge deployment with an IP based backhaul

Both the POINT and RIFE projects tackle this.

regards

On 24 March 2015 at 18:47, Papadimitriou, Dimitri (Dimitri) <
[email-masked]> wrote:

> Hello,
>
> Now that we have all links ;-) I would consider a more open question as of
> which role(s) IP may vs. must play in an ICN full vs. partial deployment,
> the latter could be further decomposed in localized (island) vs. sparse
> deployment. This shouldn't prevent investigating settings as those you
> outlined here below.
>
> It would also be interesting to nail down the minimum "where" (spatial)
> information locally required compared to the current situation based on the
> initial objective of a system able to cope simultaneously with terminal and
> information mobility by transferring the decision process to the "what"
> (object).
>
> Thanks,
> -dimitri.
>
>
>