Subject: Re: [icnrg] name-based app semantics vs. SPUD

From: Ken Calvert <[email-masked]>
Date: Wed, 25 Mar 2015 17:08:10 -0400

> From: Dirk Kutscher <[email-masked]>
> Subject: [icnrg] name-based app semantics vs. SPUD
> Date: 25 March 2015 at 10:51:22 EDT
> To: "[email-masked]" <[email-masked]>
> 
> 
> Hi,
> 
> For those who are currently in the SPUD session in the IETF, this is an interesting example to what extent you have to stretch Internet architecture and node requirements to achieve a subset of what ICN can do out of the box. :-)
> 
> https://datatracker.ietf.org/meeting/92/agenda/spud/
> 
> Best regards,
> Dirk

Hi Dirk - 

I'm not sure I follow.  Are you referring to the ability to evolve transport protocols?  Or to the particular WebRTC use case with the rather complicated protocol stack?

I agree with you on the latter, but I'm not so sure about the former.  IMHO the problem SPUD is trying to solve (more precisely, the folks experimenting with it are trying to solve) is really the ossification of the protocol stack that results from embedding assumptions about what "normal" traffic looks like in the infrastructure.  That, in turn, is a consequence of stakeholders needing to enforce their policies and not having any better way to do it.

Would ICN turn be better?  I believe the emphasis on object-level security, which is common to all the ICN proposals, is helpful.  But it's not clear to me (yet) that ICN provides everything needed for all stakeholders to enforce their policies. (Nor that it would be more resistant to ossification in the long run -- but of course it's way too early to know about that.)

thanks,

Ken

---

From: abdou darboe <[email-masked]>
Date: Thu, 26 Mar 2015 14:58:03 +0000 (UTC)

I am a Master's degree student at National Dong Hwa University (NDHU), I am doing my thesis research in Information/Content-Centric Networking (ICN/CCN) with research objective of maximizing Cache-hit ratio while minimizing content retrieval latency. I am using ICARUS SIM to perform my experiments but I am having a problem of extracting my results in a readable format for simple interpretation.
I tried several times to run this command: $ python scripts/printresults.py results.pickle > results.txt

from the scripts folder BUT this is what I always get

abdou@sdn-ccn:~/icarus/scripts$ python scripts/printresults.py results.pickle > results.txt
python: can't open file 'scripts/printresults.py': [Errno 2] No such file or directory

Can someone please help me with this issue.
Thank you all.

Abdou Darboe
Wireless Internet Service Engineering Lab
NDHU, Hualien.
Taiwan, ROC

     On Thursday, 26 March 2015, 3:28, "[email-masked]" <[email-masked]> wrote:

 ----- Forwarded Message -----

Send icnrg mailing list submissions to
    [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
    https://www.irtf.org/mailman/listinfo/icnrg
or, via email, send a message with subject or body 'help' to
    [email-masked]

You can reach the person managing the list at
    [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of icnrg digest..."

Today's Topics:

  1. Re: On Cache Deployment Strategy (Ibrahim ABDULLAHI)
  2. name-based app semantics vs. SPUD (Dirk Kutscher)
  3. Topics for discussion (Ken Calvert)
  4. Re: name-based app semantics vs. SPUD (Lixia Zhang)
Thanks so muc Cesar Bernardini,
I appreciate your timely response and suggestions. I and my research team shall take your advice and look up to the solutions suggested. 

On Wed, Mar 25, 2015 at 4:45 PM, Cesar Bernardini <[email-masked]> wrote:

Hi Ibrahim,

I have seen your e-mail and I decided to answer you, I am a postdoc student in the University of Trento in Italy. I am writing you from my french account from my PhD.

To study path redundancy and content redundancy, I will invite you to try the simulators ICARUS[1] and SocialCCNSim[0]. They are implemented in python and that's a good reason to simplify your first experiments. Other simulators are less flexible.

According to caching strategies, I will invite you to read: Cache Less For More, MPC: Most Popular Caching Strategy, Hash-routing Schemes for Information Centric Networking and a Dive into the caching performance of Content Centric Networking.

In the forthcoming days, my PhD thesis will be available and could be of your help.
I hope it helps

Bests,

[0] https://github.com/mesarpe/socialccnsim
[1] http://icarus-sim.github.io/

----- Mail original -----

> De: "Ibrahim ABDULLAHI" <[email-masked]>
> À: [email-masked], "i psaras" <[email-masked]>, "Börje Ohlman"
> <[email-masked]>, "Dirk Kutscher" <[email-masked]>
> Envoyé: Mardi 24 Mars 2015 03:52:13
> Objet: [icnrg] On Cache Deployment Strategy

> Hello all,
> What simulation tool could accept a good flexibility to deploy and carefully
> select cache-enabled routers on-path?
> Motivation to this was a good number of study in ICN caching that predicts
> the effects of path redundancy and content redundancy when data and
> interests are
> flooded in the network.
> ProbCache
> AssignCache
> Age-Based caching
> Cooperative cache
> Coordinated cache etc are good basis to refer to.

> Suggestions please.

> --
> ****************************************************************
> Ibrahim ABDULLAHI
> B.Sc (UDU), M.Sc (ABU )
> PhD Research
> ​er​
> ,
> InterNetworks Research Laboratory,
> School of Computing; College of Arts and Sciences,
> Universiti Utara Malaysia, UUM 06010 Sintok, Kedah, Darul Aman.
> M A L A Y S I A (+60169290804)
> [email-masked]
> ****************************************************************
> Department of Mathematics/Computer Science.
> Faculty of Natural Science, P.M.B 11
> Ibrahim Badamasi Babangida University, Lapai.
> Niger State. Nigeria.
> NIGERIA: (+2348035991532)
> [email-masked]
> ****************************************************************
> ****************************************************************

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

-- 
****************************************************************
Ibrahim ABDULLAHI B.Sc (UDU), M.Sc (ABU)
PhD Research Student, InterNetworks Research Laboratory,School of Computing; College of Arts and Sciences,Universiti Utara Malaysia, UUM 06010 Sintok, Kedah, Darul Aman.M A L A Y S I A (+60169290804)[email-masked] ****************************************************************Department of Mathematics/Computer Science.Faculty of Natural Science, P.M.B 11Ibrahim Badamasi Babangida University, Lapai. Niger State. Nigeria.NIGERIA: (+2348035991532) [email-masked]********************************************************************************************************************************Hi,

Best regards,
Dirk

Two topics I have not heard much about. (Pointers to stuff I missed are welcome.) In my view they are related.

i) Publisher-side interface.  It seems most of the presentations (since I started attending last year, anyway) focus on the "consumer" side.  What are the considerations/requirements/constraints for the content producer?  I have the impression that there is not much consensus on this.  The issue seems to affect namespace, routing, caching, and trust - and maybe in a more complicated way than on the retrieval side.

ii) Incentives and flow of compensation.  In today's Internet, packets are constrained to "follow the money", and that is pretty restrictive.  What is the business model for ICN providers?  Is it/should it be entangled with the content provider business model?  E.g., today I pay one price for cable service that includes compensation of the television content providers as well.  At least in the US, that has a lot of unpleasant (at least for me) side effects, like bundling that prevents me from "voting with my wallet" for/against content producers.
Should the business model look different for consumers and producers?  [How] should the services (namespace authority, route advertisement, long-term storage, forwarding, caching) be bundled.

Ken Calvert
Professor
Gartner Group Chair in Network Engineering
Computer Science, University of Kentucky

> On Mar 25, 2015, at 7:51 AM, Dirk Kutscher <[email-masked]> wrote:
> 
> Hi,
> 

agree.
and one can probably say the same about TAPS 
Here is the pointer to Marie-Jose's presentation slides at TAPS (as she mentioned during our Sunday meeting:
http://tools.ietf.org/agenda/92/slides/slides-92-taps-4.pdf

Here is the pointer to the rest of the TAPS WG session:
http://tools.ietf.org/wg/taps/agenda?item=agenda-92-taps.html

FYI,
Lixia

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Saino, Lorenzo" <[email-masked]>
Date: Thu, 26 Mar 2015 18:35:36 +0000

Hi Abdou,

You're having this problem because the Python interpreter cannot find the file 'scripts/printresults.py', likely because you are in the wrong directory.

Judging from your shell prompt, it appears that you are already in the "icarus/scripts" directory. Move back to the Icarus main directory and run the same command again. Also ensure that the "results.pickle" file is there.

Best regards and good luck with your research.

Lorenzo

P.S. If you have any further issues, I would imagine that a more suitable place to ask this kind of questions is the issues page of the Icarus project: https://github.com/icarus-sim/icarus/issues

________________________________
From: icnrg <[email-masked]> on behalf of abdou darboe <[email-masked]>
Sent: 26 March 2015 14:58
To: [email-masked]
Subject: Re: [icnrg] icnrg Digest, Vol 36, Issue 27

I tried several times to run this command:

$ python scripts/printresults.py results.pickle > results.txt

Abdou Darboe

----- Forwarded Message -----

Send icnrg mailing list submissions to
    [email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
    https://www.irtf.org/mailman/listinfo/icnrg
or, via email, send a message with subject or body 'help' to
    [email-masked]<mailto:[email-masked]>

You can reach the person managing the list at
    [email-masked]<mailto:[email-masked]>

Today's Topics:

On Wed, Mar 25, 2015 at 4:45 PM, Cesar Bernardini <[email-masked]<mailto:[email-masked]>> wrote:
Hi Ibrahim,

Bests,

----- Mail original -----

> À: [email-masked]<mailto:[email-masked]>, "i psaras" <[email-masked]<mailto:[email-masked]>>, "Börje Ohlman"
> <[email-masked]<mailto:[email-masked]>>, "Dirk Kutscher" <[email-masked]<mailto:[email-masked]>>

> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

> [email-masked]<mailto:[email-masked]>

--

Ibrahim ABDULLAHI

B.Sc (UDU), M.Sc (ABU)
PhD Research Student,

[email-masked]<mailto:[email-masked]>

Niger State. Nigeria.

[email-masked]<mailto:[email-masked]>

Hi,

Best regards,
Dirk

Ken Calvert
Professor

> On Mar 25, 2015, at 7:51 AM, Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi,
>

agree.

FYI,
Lixia

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg