Subject: [icnrg] On Cache Deployment Strategy

From: Ibrahim ABDULLAHI <[email-masked]>
Date: Tue, 24 Mar 2015 10:52:13 +0800

Hello all,
What simulation tool could accept a good flexibility to deploy and
carefully select cache-enabled routers on-path?
Motivation to this was a good number of study in ICN caching that predicts
the effects of path redundancy and content redundancy when data and
interests are
flooded in the network.
ProbCache
AssignCache
Age-Based caching
Cooperative cache
Coordinated cache etc are good basis to refer to.

Suggestions please.

-- 

******************************************************************

*Ibrahim ABDULLAHI*

*B.Sc (UDU), M.Sc (ABU)*
*PhD Research​er​, *

*InterNetworks Research Laboratory,*

*School of Computing; College of Arts and Sciences,*

*Universiti Utara Malaysia, UUM 06010 Sintok, Kedah, Darul Aman.*

*M A L A Y S I A (+60169290804)*

[email-masked] <[email-masked]> *

******************************************************************

*Department of Mathematics/Computer Science.*

*Faculty of Natural Science, P.M.B 11*

*Ibrahim Badamasi Babangida University, Lapai.*

*Niger State. Nigeria.*

*NIGERIA: (+2348035991532) *

[email-masked] <[email-masked]>*

******************************************************************

******************************************************************

---

From: Ibrahim ABDULLAHI <[email-masked]>
Date: Wed, 25 Mar 2015 17:52:28 +0800

Thanks so muc Cesar Bernardini,
I appreciate your timely response and suggestions. I and my research team
shall take your advice and look up to the solutions suggested.

On Wed, Mar 25, 2015 at 4:45 PM, Cesar Bernardini <[email-masked]
> wrote:

> Hi Ibrahim,
>
> I have seen your e-mail and I decided to answer you, I am a postdoc
> student in the University of Trento in Italy. I am writing you from my
> french account from my PhD.
>
> To study path redundancy and content redundancy, I will invite you to try
> the simulators ICARUS[1] and SocialCCNSim[0]. They are implemented in
> python and that's a good reason to simplify your first experiments. Other
> simulators are less flexible.
>
> According to caching strategies, I will invite you to read: Cache Less For
> More, MPC: Most Popular Caching Strategy, Hash-routing Schemes for
> Information Centric Networking and a Dive into the caching performance of
> Content Centric Networking.
>
> In the forthcoming days, my PhD thesis will be available and could be of
> your help.
> I hope it helps
>
> Bests,
>
> [0] https://github.com/mesarpe/socialccnsim
> [1] http://icarus-sim.github.io/
>
> ----- Mail original -----
>
> > De: "Ibrahim ABDULLAHI" <[email-masked]>
> > À: [email-masked], "i psaras" <[email-masked]>, "Börje Ohlman"
> > <[email-masked]>, "Dirk Kutscher" <[email-masked]>
> > Envoyé: Mardi 24 Mars 2015 03:52:13
> > Objet: [icnrg] On Cache Deployment Strategy
>
> > Hello all,
> > ****************************************************************
> > Ibrahim ABDULLAHI
> > B.Sc (UDU), M.Sc (ABU )
> > PhD Research
> > ​er​
> > ,
> > InterNetworks Research Laboratory,
> > School of Computing; College of Arts and Sciences,
> > Universiti Utara Malaysia, UUM 06010 Sintok, Kedah, Darul Aman.
> > M A L A Y S I A (+60169290804)
> > [email-masked]
> > ****************************************************************
> > Department of Mathematics/Computer Science.
> > Faculty of Natural Science, P.M.B 11
> > Ibrahim Badamasi Babangida University, Lapai.
> > Niger State. Nigeria.
> > NIGERIA: (+2348035991532)
> > [email-masked]
> > ****************************************************************
> > ****************************************************************
>
> > _______________________________________________
> > icnrg mailing list
> > [email-masked]
> > https://www.irtf.org/mailman/listinfo/icnrg
>

-- 

*Ibrahim ABDULLAHI*

*B.Sc (UDU), M.Sc (ABU)*
*PhD Research Student, *

*Niger State. Nigeria.*