Subject: [icnrg] Topics for discussion

From: Ken Calvert <[email-masked]>
Date: Wed, 25 Mar 2015 13:31:20 -0400

Two topics I have not heard much about. (Pointers to stuff I missed are welcome.) In my view they are related.

i) Publisher-side interface.  It seems most of the presentations (since I started attending last year, anyway) focus on the "consumer" side.  What are the considerations/requirements/constraints for the content producer?  I have the impression that there is not much consensus on this.  The issue seems to affect namespace, routing, caching, and trust - and maybe in a more complicated way than on the retrieval side.

ii) Incentives and flow of compensation.   In today's Internet, packets are constrained to "follow the money", and that is pretty restrictive.  What is the business model for ICN providers?  Is it/should it be entangled with the content provider business model?  E.g., today I pay one price for cable service that includes compensation of the television content providers as well.  At least in the US, that has a lot of unpleasant (at least for me) side effects, like bundling that prevents me from "voting with my wallet" for/against content producers.
Should the business model look different for consumers and producers?  [How] should the services (namespace authority, route advertisement, long-term storage, forwarding, caching) be bundled.

Ken Calvert
Professor
Gartner Group Chair in Network Engineering
Computer Science, University of Kentucky

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Wed, 25 Mar 2015 20:29:01 +0000

regarding economic models I would like to add --

as I mentioned earlier, the new EU RIFE project looks at using ICN as a
potential architecture for enabling affordable Internet access -- by
exploiting its flexibility for delivering content/services:

a brief snapshot can be found here -- we presented this during an IAB
workshop more than a year ago:
http://www.cl.cam.ac.uk/~as2330/docs/IAB-paper.pdf

we will be carrying out techno-economic modelling work via the project to
understand how all of this would work. We can definitely disseminate this
back to the ICNRG group..

regards

On 25 March 2015 at 17:31, Ken Calvert <[email-masked]> wrote:

> i) Publisher-side interface.  It seems most of the presentations (since I
> started attending last year, anyway) focus on the "consumer" side.  What
> are the considerations/requirements/constraints for the content producer?
> I have the impression that there is not much consensus on this.  The issue
> seems to affect namespace, routing, caching, and trust - and maybe in a
> more complicated way than on the retrieval side.
>
> ii) Incentives and flow of compensation.   In today's Internet, packets
> are constrained to "follow the money", and that is pretty restrictive.
> What is the business model for ICN providers?  Is it/should it be entangled
> with the content provider business model?  E.g., today I pay one price for
> cable service that includes compensation of the television content
> providers as well.  At least in the US, that has a lot of unpleasant (at
> least for me) side effects, like bundling that prevents me from "voting
> with my wallet" for/against content producers.
> Should the business model look different for consumers and producers?
> [How] should the services (namespace authority, route advertisement,
> long-term storage, forwarding, caching) be bundled.
>
> Ken Calvert
> Professor
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: "Trossen, Dirk" <[email-masked]>
Date: Wed, 25 Mar 2015 20:59:54 +0000

Ken,

As for (ii): the PURSUIT project (and even the earlier PSIRP project) did do incentive work, such as
- Incentive-compatible caching and peering in data-oriented networks, Rajahalme et al. http://dl.acm.org/citation.cfm?id=1544074
- D. Trossen, A. Kostopolous, Exploring the Tussle Space For Information-Centric Networking, Proceedings of TPRC, 2011
- D. Trossen, G. Biczok, Not Paying the Truck Driver: Differentiated Pricing for the Future Internet, ACM Workshop on Rearchitecting the Internet (ReArch) in conjunction with ACM CoNEXT, December 2010
- D. Trossen, A. Kostopolous, Techno-Economic Aspects of Information-Centric Networking, Journal for Information Policy Vol. 2, March 2012

There's also more in public project deliverables, to be found at http://wiki.fp7-pursuit.eu/uploads/5/5f/INFSO-ICT-257217_PURSUIT_D4.3_First_Report_on_Deployment_Incentives_and_Business_Models.pdf or older ones from the PSIRP project.

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.
Shoreditch Business Center
64 Great Eastern Street
London,  EC2A 3QR
T: +44 20 7749 9178
[email-masked]
www.InterDigital.com<http://www.interdigital.com>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Ken Calvert
Sent: 25 March 2015 17:31
To: [email-masked]
Subject: [icnrg] Topics for discussion

Ken Calvert
Professor
Gartner Group Chair in Network Engineering Computer Science, University of Kentucky

---

From: Ken Calvert <[email-masked]>
Date: Wed, 25 Mar 2015 17:18:12 -0400

Dirk and Arjuna - Thanks for the pointers! -- KC

Ken Calvert
Professor