Subject: [icnrg] Soliciting Open Source ICN Reference implementation

From: Dirk Kutscher <[email-masked]>
Date: Thu, 23 Jul 2015 16:02:25 +0000

Dear all,

In order to support the protocol development work in ICNRG, the chairs would like to see an Open Source reference implementations of our protocol specifications. We believe that such an implementation could be helpful for validating new protocol features, serving as a reference for interoperability tests with other implementations and enabling researchers to do experiments and application development with a "compliant" implementation.

We are thus soliciting volunteers for developing and maintaining such an implementation. In order to be useful for the purposes described, such an implementation should provide the following features:

- be (or become) up-to-date with respect to the specification work in ICNRG (currently https://tools.ietf.org/html/draft-irtf-icnrg-ccnxmessages-00 and https://tools.ietf.org/html/draft-irtf-icnrg-ccnxsemantics-00). 

- come with a suitable free software license such as Apache License 2.0 that allows users the freedom to use the software for any purpose, to distribute it, to modify it and to distribute modified versions -- without concerns for royalties.

- be hosted and maintained on a public, accepted platform

- follow an open model for contributions, i.e., principally allowing for accepting contributions from individuals or organizations regardless of project or research group affiliation.

Such a project could be done in distributed teams. The project should comprise at least one implementation in a broadly used programming language. We believe that reach and enabling productivity for development is more important than efficiency. Obviously we'd welcome a discussion of details.

It should be noted that an Open Source Software license does not exempt contributors and users from IPR that may be held on underlying ideas.

So, please think about this and let us know in case you interested to help with such a project. Of course, also let us know of any questions or comments.

Best regards,
Dirk, Börje, Dave (ICNRG chairs)

---

From: Dave Cottlehuber <[email-masked]>
Date: Thu, 23 Jul 2015 18:54:19 +0200

On Thu, 23 Jul 2015, at 06:02 PM, Dirk Kutscher wrote:
> Dear all,
> 
> In order to support the protocol development work in ICNRG, the chairs
> would like to see an Open Source reference implementations of our
> protocol specifications. We believe that such an implementation could be
> helpful for validating new protocol features, serving as a reference for
> interoperability tests with other implementations and enabling
> researchers to do experiments and application development with a
> "compliant" implementation.
> 
> We are thus soliciting volunteers for developing and maintaining such an
> implementation. In order to be useful for the purposes described, such an
> implementation should provide the following features:
> 
> - be (or become) up-to-date with respect to the specification work in
> ICNRG (currently
> https://tools.ietf.org/html/draft-irtf-icnrg-ccnxmessages-00 and
> https://tools.ietf.org/html/draft-irtf-icnrg-ccnxsemantics-00). 
> 
> - come with a suitable free software license such as Apache License 2.0
> that allows users the freedom to use the software for any purpose, to
> distribute it, to modify it and to distribute modified versions --
> without concerns for royalties.
> 
> - follow an open model for contributions, i.e., principally allowing for
> accepting contributions from individuals or organizations regardless of
> project or research group affiliation.
> 
> Such a project could be done in distributed teams. The project should
> comprise at least one implementation in a broadly used programming
> language. We believe that reach and enabling productivity for development
> is more important than efficiency. Obviously we'd welcome a discussion of
> details.
> 
> It should be noted that an Open Source Software license does not exempt
> contributors and users from IPR that may be held on underlying ideas.
> 
> So, please think about this and let us know in case you interested to
> help with such a project. Of course, also let us know of any questions or
> comments.
> 
> Best regards,

+1

I spoke with Börje this week and I'd be very interested in contributing
to an
Erlang (or even better, Elixir) implementation, under an ALv2 licence.
I'm very
new to the ICNRG project, but have experience with PPSP (RFC7574) which
is at least not completely dissimilar :-).

If there is sufficient widespread interest I would be happy to assist
bringing
this to the Apache Software Foundation as an incubator project; I am
already
involved with Apache CouchDB, and a foundation Member.

—
  Dave Cottlehuber
  Managing Director
  SkunkWerks, GmbH
  Firmenbuch 410811i

---

From: "Z.W. Yan" <[email-masked]>
Date: Wed, 29 Jul 2015 09:01:14 +0800

Hi, ALL,
With the wide deployment of NDN, secure and trustful content management architecture is needed 
in order to authenticate the producer of the content and authorize the publishers of the content.

I introduced the PKI in NDN to achieve these motivations and posted a rough draft:
https://www.ietf.org/internet-drafts/draft-yan-icnrg-cpki-00.txt

Do you think this work is necessary and the basic architecture makes sense?
If so, I will make this CPKI architecture more conprehensive.
BR,

2015-07-29 

Z.W. Yan

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 29 Jul 2015 02:06:03 +0100

On 29/07/15 02:01, Z.W. Yan wrote:
> With the wide deployment of NDN,

Sorry - where exactly is that wide deployment?

Some zmap or other measurements would be good if such statements
are to be made and believed.

(If you had said "relatively wide" I wouldn't have been triggered
to respond;-)

Thanks,
S.

---

From: "Z.W. Yan" <[email-masked]>
Date: Wed, 29 Jul 2015 09:38:47 +0800

Stephen, maybe "possible wide deployment in the future" is better.
:-)

2015-07-29 

Z.W. Yan 

发件人： Stephen Farrell 
发送时间： 2015-07-29  09:06:15 
收件人： Z.W. Yan; icnrg 
抄送： 
主题： Re: [icnrg] New Version Notification for draft-yan-icnrg-cpki-00.txt 
 
Sorry - where exactly is that wide deployment?
Some zmap or other measurements would be good if such statements
are to be made and believed.
(If you had said "relatively wide" I wouldn't have been triggered
to respond;-)
Thanks,
S.
_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Yingdi Yu <[email-masked]>
Date: Wed, 29 Jul 2015 16:16:08 -0400

Hi Zhiwei,

> On Jul 28, 2015, at 9:01 PM, Z.W. Yan <[email-masked]> wrote:
> 
> Hi, ALL,

Could you explain a little bit why you want to authorize publisher? My understanding is that data is signed by the original producer, so that it does not matter who publishes the data. 

> https://www.ietf.org/internet-drafts/draft-yan-icnrg-cpki-00.txt <https://www.ietf.org/internet-drafts/draft-yan-icnrg-cpki-00.txt>
Wonder if you have seen this paper, "SNAMP: Secure Namespace Mapping to Scale NDN Forwarding” (http://named-data.net/wp-content/uploads/2015/03/SNAMP-NDN-Scalability.pdf <http://named-data.net/wp-content/uploads/2015/03/SNAMP-NDN-Scalability.pdf>), which did something similar to what you described in the draft.

Yingdi

---

From: 延志伟 <[email-masked]>
Date: Thu, 30 Jul 2015 06:16:55 +0800 (GMT+08:00)

Yingdi,
To authorize the publishers is to make sure that the content is only published by authorized parties, in this way, the producer can manage the distribution of the content, as the copyright control.
BR,
zhiwei

在 2015-07-30 04:16:08，"Yingdi Yu" <[email-masked]> 写道：

>Wonder if you have seen this paper, "SNAMP: Secure Namespace Mapping to Scale NDN Forwarding” (http://named-data.net/wp-content/uploads/2015/03/SNAMP-NDN-Scalability.pdf), which did something similar to what you described in the draft.
>
>
>Yingdi