Subject: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

From: Jan Seedorf <[email-masked]>
Date: Mon, 20 Jul 2015 19:39:07 +0000

Dear all,

as presented today in the ICNRG session here at IETF-93 (https://www.ietf.org/proceedings/93/slides/slides-93-icnrg-6.pdf), we think that our draft on using ICN technologies for communication in the aftermath of a disaster (https://tools.ietf.org/html/draft-seedorf-icn-disaster-03) is quite mature; we have presented it multiple times at ICNRG and also improved the doc based on feedback received.

We think that the document could be a good output from the ICNRG, with the goal of an Informational RFC that outlines the use of ICN techniques for disaster aftermath communication, and discussing why and how ICN is very useful in such scenarios. So, what about adopting this document as RG item? Today in the session there was a hum with several people in favor and no objections. Are there any further opinions on the mailing list?

-          Jan

============================================================
Prof. Dr. Jan Seedorf
Senior Researcher
NEC Europe Ltd., NEC Laboratories Europe, Network Division Kurfuerstenanlage 36, D-69115 Heidelberg Tel.     +49 (0)6221 4342-221
Fax:     +49 (0)6221 4342-155
e-mail:  [email-masked]<mailto:[email-masked]>
============================================================
NEC Europe Ltd, Registered Office: Athene, Odyssey Business Park, West End  Road, London, HA4 6QE, GB, Registered in England 2832014

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Mon, 20 Jul 2015 22:15:11 +0100

I think this is a great draft addressing a pertinent problem. Should be
adopted.

Regards

On 20 July 2015 at 20:39, Jan Seedorf <[email-masked]> wrote:

>  Dear all,
>
>
>
> as presented today in the ICNRG session here at IETF-93 (
> https://www.ietf.org/proceedings/93/slides/slides-93-icnrg-6.pdf), we
> think that our draft on using ICN technologies for communication in the
> aftermath of a disaster (
> https://tools.ietf.org/html/draft-seedorf-icn-disaster-03) is quite
> mature; we have presented it multiple times at ICNRG and also improved the
> doc based on feedback received.
>
>
>
> We think that the document could be a good output from the ICNRG, with the
> goal of an Informational RFC that outlines the use of ICN techniques for
> disaster aftermath communication, and discussing why and how ICN is very
> useful in such scenarios. So, what about adopting this document as RG item?
> Today in the session there was a hum with several people in favor and no
> objections. Are there any further opinions on the mailing list?
>
>
>
> -          Jan
>
>
>
>
>
> NEC Europe Ltd., NEC Laboratories Europe, Network Division
> Kurfuerstenanlage 36, D-69115 Heidelberg Tel.     +49 (0)6221 4342-221
>
> e-mail:  [email-masked]
>
> NEC Europe Ltd, Registered Office: Athene, Odyssey Business Park, West
> End  Road, London, HA4 6QE, GB, Registered in England 2832014
>
>
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>
>

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: Matthias Waehlisch <[email-masked]>
Date: Mon, 20 Jul 2015 23:29:08 +0200

+1.

Cheers
  matthias

On Mon, 20 Jul 2015, Arjuna Sathiaseelan wrote:

> I think this is a great draft addressing a pertinent problem. Should be adopted.
> Regards
> 
>       as presented today in the ICNRG session here at IETF-93
>       (https://www.ietf.org/proceedings/93/slides/slides-93-icnrg-6.pdf), we think that our
>       draft on using ICN technologies for communication in the aftermath of a disaster
>       (https://tools.ietf.org/html/draft-seedorf-icn-disaster-03) is quite mature; we have
>       presented it multiple times at ICNRG and also improved the doc based on feedback
>       received.
> 
>        
> 
>       We think that the document could be a good output from the ICNRG, with the goal of an
>       Informational RFC that outlines the use of ICN techniques for disaster aftermath
>       communication, and discussing why and how ICN is very useful in such scenarios. So, what
>       about adopting this document as RG item? Today in the session there was a hum with
>       several people in favor and no objections. Are there any further opinions on the mailing
>       list?
> 
>        
> 
>       -          Jan
> 
>        
> 
>        
> 
>       NEC Europe Ltd, Registered Office: Athene, Odyssey Business Park, West End  Road,
>       London, HA4 6QE, GB, Registered in England 2832014
> 
>        
> 
> 

-- 
Matthias Waehlisch
.  Freie Universitaet Berlin, Inst. fuer Informatik, AG CST
.  Takustr. 9, D-14195 Berlin, Germany
.. mailto:[email-masked] .. http://www.inf.fu-berlin.de/~waehl
:. Also: http://inet.cpt.haw-hamburg.de .. http://www.link-lab.net

---

From: Alfredo Grieco <[email-masked]>
Date: Tue, 21 Jul 2015 01:41:51 +0200

+1. Alfredo
> Il giorno 20/lug/2015, alle ore 23:29, Matthias Waehlisch <[email-masked]> ha scritto:
> 
> +1.
> 
> Cheers
>  matthias
> 
> :. Also: http://inet.cpt.haw-hamburg.de .. http://www.link-lab.net_______________________________________________
> icnrg mailing list
> [email-masked]

-- 
Luigi Alfredo Grieco, PhD 
Associate Professor
Dep. of Electrical and Information Engineering (DEI)
Politecnico di Bari
Via Orabona, 4
70125 - Bari - Italy
Phone: +39 080 5963 911
url: telematics.poliba.it
mail: [email-masked]
linkedin: it.linkedin.com/in/alfredogrieco

---

From: BJTU <[email-masked]>
Date: Tue, 21 Jul 2015 07:13:25 +0200

+1. 

发自我的 iPhone

> 在 2015年7月20日，21:39，Jan Seedorf <[email-masked]> 写道：
> 
> Dear all,
>

---

From: David Oran <[email-masked]>
Date: Tue, 21 Jul 2015 10:16:45 +0200

+1 (with Chair hat off)
DaveO.

> On Jul 21, 2015, at 7:13 AM, BJTU <[email-masked]> wrote:
> 
> +1. 
> 
> 发自我的 iPhone
> 
>> We think that the document could be a good output from the ICNRG, with the goal of an Informational RFC that outlines the use of ICN objections. Are there any further opinions on the mailing list?
>> 
>>  
>> 
>> -          Jan
>> 
>>  
>> 
>>  
>>

---

From: MUSCARIELLO Luca IMT/OLN <[email-masked]>
Date: Tue, 21 Jul 2015 10:19:22 +0200

+1
Luca

On 07/20/2015 09:39 PM, Jan Seedorf wrote:
> (https://www.ietf.org/proceedings/93/slides/slides-93-icnrg-6.pdf), we 
> think that our draft on using ICN technologies for communication in 
> the aftermath of a disaster 
> (https://tools.ietf.org/html/draft-seedorf-icn-disaster-03) is quite 
> mature; we have presented it multiple times at ICNRG and also improved 
> the doc based on feedback received.
>
> We think that the document could be a good output from the ICNRG, with 
> the goal of an Informational RFC that outlines the use of ICN 
> techniques for disaster aftermath communication, and discussing why 
> and how ICN is very useful in such scenarios. So, what about adopting 
> this document as RG item? Today in the session there was a hum with 
> several people in favor and no objections. Are there any further 
> opinions on the mailing list?
>
> -Jan
>
> e-mail: [email-masked] <mailto:[email-masked]>
>

---

From: Georgios Karagiannis <[email-masked]>
Date: Tue, 21 Jul 2015 08:19:42 +0000

Hi all,

Please note that I support the adoption of this document as a RG item.

Best regards,
Georgios

From: icnrg [mailto:[email-masked]] On Behalf Of Jan Seedorf
Sent: 20 July 2015 21:39
To: [email-masked]
Subject: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Dear all,

-          Jan

---

From: Daniel Corujo <[email-masked]>
Date: Tue, 21 Jul 2015 09:22:19 +0100

+1

Best regards,

Daniel Corujo, Ph.D., Research Fellow
Universidade de Aveiro, Portugal	
http://re.vu/dcorujo
Advanced Telecommunications and Networks Group - http://atnog.av.it.pt
Follow us - @ATNoG_ITAv

> On 21 Jul 2015, at 09:19 , Georgios Karagiannis <[email-masked]> wrote:
> 
> Hi all,
>

---

From: <[email-masked]>
Date: Tue, 21 Jul 2015 08:25:08 +0000

Let’s go!   We’ve heard about this for some time and I agree that it seems to be pretty mature.  I think we should adopt.

Glenn

On Jul 20, 2015, at 9:39 PM, Jan Seedorf <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

-          Jan

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Joerg Ott <[email-masked]>
Date: Tue, 21 Jul 2015 11:48:16 +0300

Hi,

I happen to read email today during my vacation (bad idea), so
let me quickly jump in here:

I am not in Prague and I didn't see the presentation this time.
But I feel that this is a bit of a rushed decision here.

I surely agree with the basic ideas and the value of having such
a draft.

But The document isn't that substantial yet and, as I stated in an
earlier meeting, there has been a substantial amount of work in the
DTN community and I see nothing of this appropriately reflected
in the present draft.  Obviously, the draft isn't supposed to
be a summary what the DTN community did before, but exploring
a solution space here appears to warrant input and experience
from all sides.

So, I would put this off for now and explicitly reach out to
the DTN folks and then see if we can come up with something
more complete.  I believe this would benefit the research group
and the draft.  The draft should make the case on how the two
basic ideas could complement each other.

At this very point, also looking at the coverage of exactly
one research project, this is an individual effort that doesn't
suggest a broader consideration to come.

If you wanna adopt it right now, I would like to at least see
some demand towards the authors to do this reaching out.

Jörg

---

From: Gareth Tyson <[email-masked]>
Date: Tue, 21 Jul 2015 10:24:37 +0000

+1 A strong scenario!

---
Dr. Gareth Tyson,
CS 404 (Not Found),
Electronic Engineering and Computer Science,
Queen Mary University of London.

________________________________________
From: icnrg <[email-masked]> on behalf of Daniel Corujo <[email-masked]>
Sent: 21 July 2015 09:22
To: [email-masked]
Cc: Jan Seedorf
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

+1

Best regards,

---

From: "Trossen, Dirk" <[email-masked]>
Date: Tue, 21 Jul 2015 12:51:16 +0000

All,

I understand and agree with the sentiment of Joerg's response.

While the topic/scenario is not only very valuable but also presents itself as an interesting ICN scenario, there is indeed the aspect that an entire (DTN) community has worked and proposed solutions in this space, many of which sound rather similar to what the draft discusses (e.g., the 'data mules' come to mind here).

But that brings me to a possible extension that is not only about considering what an entire community has already worked on but possibly focus on the possible overlap/synergy at the architecture as well as solution level. As one example, the H2020 project RIFE is specifically targeting the 'unification' of DTN and ICN ideas, not only for disaster but also GAIA RG relevant scenarios. Such efforts show that thinking exists on how we could utilize the advances in both areas to not only advance solutions in this space but also possibly provide some form of architectural commonality.

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.
Shoreditch Business Center
64 Great Eastern Street
London,  EC2A 3QR
T: +44 207.749.9178
[email-masked]
www.InterDigital.com<http://www.interdigital.com>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

-----Original Message-----
From: Joerg Ott [mailto:[email-masked]]
Sent: 21 July 2015 09:48
To: Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Trossen, Dirk; Arjuna Sathiaseelan; Kevin Fall
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi,

I happen to read email today during my vacation (bad idea), so let me quickly jump in here:

I surely agree with the basic ideas and the value of having such a draft.

But The document isn't that substantial yet and, as I stated in an earlier meeting, there has been a substantial amount of work in the DTN community and I see nothing of this appropriately reflected in the present draft.  Obviously, the draft isn't supposed to be a summary what the DTN community did before, but exploring a solution space here appears to warrant input and experience from all sides.

So, I would put this off for now and explicitly reach out to the DTN folks and then see if we can come up with something more complete.  I believe this would benefit the research group and the draft.  The draft should make the case on how the two basic ideas could complement each other.

At this very point, also looking at the coverage of exactly one research project, this is an individual effort that doesn't suggest a broader consideration to come.

If you wanna adopt it right now, I would like to at least see some demand towards the authors to do this reaching out.

Jörg

On 21.07.2015 11:22, Daniel Corujo wrote:
>> NEC Europe Ltd, Registered Office: Athene, Odyssey Business Park,
>> West End  Road, London, HA4 6QE, GB, Registered in England 2832014
>>

---

From: <[email-masked]>
Date: Tue, 21 Jul 2015 13:07:37 +0000

+1

Jan Seedorf <[email-masked]> wrote:

Dear all,

-          Jan

---

From: Matthew Ford <[email-masked]>
Date: Tue, 21 Jul 2015 15:17:11 +0200

> On 21 Jul 2015, at 14:51, Trossen, Dirk <[email-masked]> wrote:
> 

+1

Soliciting feedback from GAIA RG as this work evolves makes good sense to me.

Mat

---

From: <[email-masked]>
Date: Tue, 21 Jul 2015 14:44:07 +0000

I don¹t think the document is ready for publication. It¹s probably missing
a lot of related work for example(DTN or otherwise).  However, this is not
the same as whether the document should be adopted by the RG.  All
criticism of the document would continue if the document becomes an RG
document.  If anything, it would (should?) increase.

If you think the document needs work, then volunteer for the work.

Let¹s adopt it. Then we can work on it, updated, publish it, and/or kill
it if we think it has no value.

Nacho

--
Nacho (Ignacio) Solis
Protocol Architect
Principal Scientist
Palo Alto Research Center (PARC)
+1(650)812-4458
[email-masked]

On 7/21/15, 10:48 AM, "Joerg Ott" <[email-masked]> wrote:

>>>aftermath of a disaster
>>>techniques for disaster aftermath communication, and discussing why and
>>>how ICN is very useful in such scenarios. So, what about adopting this
>>>document as RG item? Today in the session there was a hum with several
>>>people in favor and no objections. Are there any further opinions on
>>>the mailing list?
>>>
>>> -          Jan
>>>
>>>

---

From: Kostas Pentikousis <[email-masked]>
Date: Tue, 21 Jul 2015 21:42:52 +0200

Hi Jan,

| I don't think the document is ready for publication. It's probably missing a
| lot of related work for example(DTN or otherwise). 

I agree with Nacho. In fact, with only four references cited, including one listed as "normative" in an informational draft, this aspect of the document is particularly weak. RFC 7476 is clearly missing from the references list, although it includes an extensive section (2.7) on the DTN/ICN relationship. I think it would not be too hard to position this draft in relationship to the baseline scenarios document. Perhaps a -04 revision with better coverage of the "disaster scenarios" literature would be a better starting point for adoption.

| Let's adopt it. 

Second that too, although I think it still needs quite some work. In particular, Section 3 should consider and relate to the challenges not covered already by draft-irtf-icnrg-challenges. Section 4 should relate to RFC 7476 and include more references to peer-reviewed publications in this area. Uses cases from other RG or WG documents could be considered as well. Section 5 appears to me more like a design considerations (and therefore could be related to the challenges draft) as opposed to the current title of "Solution Design". Section 6 is of historical nature at times ("The recently formed GreenICN project") and, if anything, it should be part of a (to-be-done) literature review as opposed to a standalone section promoting the respective project.

Best regards,

Kostas

---

From: David Oran <[email-masked]>
Date: Wed, 22 Jul 2015 13:50:52 +0200

Right - adoption means we’re ready and willing to work on it together as an RG, as opposed to keeping it as an individual contribution. Nobody meant to imply it was “cooked” and ready for publication.

Those of you with technical comments and additional material and references should join in to improve the document.

Thanks, 
DaveO (chair hat on).

> On Jul 21, 2015, at 9:42 PM, Kostas Pentikousis <[email-masked]> wrote:
> 
> Hi Jan,
>

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 23 Jul 2015 09:39:54 +0000

Hi Dirk,

I saw your presentations here at IETF-93 / ICNRG on ICN/DTN intersection work with interest. We are happy if you want to help improving our draft, any concrete pointer to some existing DTN work that has similar ICN features as we require is appreciated. Having said that, I would like to keep the scope of our draft on disaster aftermath communication, as otherwise the scope might get to broad. But any comments from you on improving the draft in that respect are very welcome.

 - Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]] 
Sent: Dienstag, 21. Juli 2015 14:51
To: Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

All,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Joerg Ott [mailto:[email-masked]]
Sent: 21 July 2015 09:48
To: Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Trossen, Dirk; Arjuna Sathiaseelan; Kevin Fall
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi,

Jörg

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 23 Jul 2015 09:42:08 +0000

Dear Kostas,

thank you for those concrete pointers, that helps us a lot! We will incorporate that in the next revision of the draft.

 - Jan

-----Original Message-----
From: Kostas Pentikousis [mailto:[email-masked]] 
Sent: Dienstag, 21. Juli 2015 21:43
To: Jan Seedorf; [email-masked]
Subject: AW: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Jan,

| I don't think the document is ready for publication. It's probably 
| missing a lot of related work for example(DTN or otherwise).

| Let's adopt it. 

Best regards,

Kostas

---

From: "Trossen, Dirk" <[email-masked]>
Date: Thu, 23 Jul 2015 09:53:12 +0000

Hi Jan,

Arjuna, Joerg and I are currently working on a paper that outlines the intersection, among other things. While it is not specifically focused on disaster aftermath, challenged environments (in the context of global access) is still the key driver. Let me discuss with Arjuna and Joerg what parts of this work could be beneficial to include in the draft, either as a pointer but also through concrete text.

As for other pointers, we are in the process of finalizing the first deliverable in the mentioned RIFE project on use cases and requirements. Again, the scope is wider than disaster but nonetheless much of the requirements are likely to be useful when being seen in a narrower scenario only. The deliverable should be done by the end of July (minus the odd day due to increased vacation absence), so it might provide timely input once finished.

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Jan Seedorf [mailto:[email-masked]]
Sent: 23 July 2015 10:40
To: Trossen, Dirk; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Dirk,

- Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]]
Sent: Dienstag, 21. Juli 2015 14:51
To: Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

All,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Joerg Ott [mailto:[email-masked]]
Sent: 21 July 2015 09:48
To: Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Trossen, Dirk; Arjuna Sathiaseelan; Kevin Fall
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi,

Jörg

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 23 Jul 2015 09:57:48 +0000

Hi Dirk,

great, I am looking forward to that input and concrete text of course is also appreciated. I hope you do not get me wrong: we appreciate your input, I am just reluctant to broaden the scope of the draft to overall ICN/DTN intersection. But my understanding is that while you do work on the bigger picture, your input would relate to the disaster scenario we are considering just as well, so we are looking forward to it and will include it.

 - Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]] 
Sent: Donnerstag, 23. Juli 2015 11:53
To: Jan Seedorf; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Jan,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Jan Seedorf [mailto:[email-masked]]
Sent: 23 July 2015 10:40
To: Trossen, Dirk; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Dirk,

- Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]]
Sent: Dienstag, 21. Juli 2015 14:51
To: Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

All,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Joerg Ott [mailto:[email-masked]]
Sent: 21 July 2015 09:48
To: Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Trossen, Dirk; Arjuna Sathiaseelan; Kevin Fall
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi,

Jörg

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 23 Jul 2015 10:03:44 +0000

Dear Jörg,

thank you for your comments, I remember well talking to you at some ICNRG meeting after presenting our draft, where you gave me the same comments in person. While admittedly we may not have "reached out" to the DTN community that much, by no means we did ignore your valuable feedback. In fact, please have a look at my presentation at the last IETF (IETF-92) in the ICNRG, see https://www.ietf.org/proceedings/92/slides/slides-92-icnrg-1.pdf, in particular slide 4 (I do not know if you were there and saw the presentation). This is just to point out that we did take your feedback seriously and did look at prior DTN work. In the presentation, I pointed out that a lot of DTN work is out there, and some enhancements towards ICN-like features are going on in the DTN community. We just feel that for our particular scenario (disaster-aftermath communication), ICN may be a better starting point because it has many key features we need for our requirements and use cases built-in.

But indeed that is not reflected enough in the current doc, you are right. I will post a new version soon with some more text on the relationship with prior DTN work soon, and I am happy to work closer with you / the DTN community on improving the doc in that respect. Maybe we can set up a phone call with folks who are interested in the following weeks.

Btw: we (i.e. the GreenICN project) are not the only ones working on ICN for disaster communication, see e.g. http://www.eecs.qmul.ac.uk/~tysong/files/IEEE-Network14.pdf from Gareth, who is also working on similar stuff.

> If you wanna adopt it right now, I would like to at least see some demand towards the authors to do this reaching out.
Obviously, I leave it to the chairs to digest all the feedback received from the RG about adoption of our document, but speaking for the authors of our draft I can assure the RG that what you suggest above (and some people have expressed similar views on the mailing list) works well for us, i.e. adopting the document and the first homework from the RG is to reach out more to the DTN community and make the doc more complete in that respect. We will do that, I can assure you.

 - Jan

-----Original Message-----
From: Joerg Ott [mailto:[email-masked]]
Sent: Dienstag, 21. Juli 2015 10:48
To: Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Trossen, Dirk; Arjuna Sathiaseelan; Kevin Fall
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi,

Jörg

---

From: "Trossen, Dirk" <[email-masked]>
Date: Thu, 23 Jul 2015 10:09:59 +0000

Hi Jan,

No intention to broaden this to a sweeping architectural discussion on ICN/DTN ;-)

Let me go through the upcoming requirements list from our project and see what would fit nicely into the draft. Also, there are characteristics of ICN and DTN that would expand on the solution design section (which, at the moment, is a misleading section to me since you outline potential ICN, later DTN, aspects that might potentially be useful - it hardly amounts to a solution design), such as flexible demand/supply matching (brokerage in DTN, rendezvous in ICN), resource management across a range of infrastructures, support for on/off-path caches (I find the focus on on-path caching disturbing, also for the reasons discussed in the interims meeting) which is important for your data mules, mobility support (without the need for anchor points, which is an issue in disaster situations of course). Hence, my comments would be mainly on adding and possibly re-structuring that section a bit, plus adding some requirements that we might find from the mentioned ongoing project work.

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Jan Seedorf [mailto:[email-masked]]
Sent: 23 July 2015 10:58
To: Trossen, Dirk; Jan Seedorf; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Dirk,

- Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]]
Sent: Donnerstag, 23. Juli 2015 11:53
To: Jan Seedorf; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Jan,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Jan Seedorf [mailto:[email-masked]]
Sent: 23 July 2015 10:40
To: Trossen, Dirk; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Dirk,

- Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]]
Sent: Dienstag, 21. Juli 2015 14:51
To: Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

All,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Joerg Ott [mailto:[email-masked]]
Sent: 21 July 2015 09:48
To: Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Trossen, Dirk; Arjuna Sathiaseelan; Kevin Fall
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi,

Jörg

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 23 Jul 2015 12:57:11 +0100

Hello Dirk, all,
  Looking at all the comments, I was wondering whether it would be
worthwhile to write a draft that specifically focusses on the ICN/DTN
integration and probably leaving the disaster as an interesting usecase?

If thats the case, based on some of the ongoing efforts within the RIFE
project, I would propose to write a new draft with Dirk and Joerg to start
with..

Regards

On 23 July 2015 at 11:09, Trossen, Dirk <[email-masked]>
wrote:

> Let me go through the upcoming requirements list from our project and see
> what would fit nicely into the draft. Also, there are characteristics of
> ICN and DTN that would expand on the solution design section (which, at the
> moment, is a misleading section to me since you outline potential ICN,
> later DTN, aspects that might potentially be useful - it hardly amounts to
> a solution design), such as flexible demand/supply matching (brokerage in
> DTN, rendezvous in ICN), resource management across a range of
> infrastructures, support for on/off-path caches (I find the focus on
> on-path caching disturbing, also for the reasons discussed in the interims
> meeting) which is important for your data mules, mobility support (without
> the need for anchor points, which is an issue in disaster situations of
> course). Hence, my comments would be mainly on adding and possibly
> re-structuring that section a bit, plus adding some requirements that we
> might find from the mentioned ongoing project work.
>
> Best,
>
> Dirk
>
>
> Dirk Trossen
> Principal Engineer
> InterDigital UK, Inc.
> This e-mail is intended only for the use of the individual or entity to
> which it is addressed, and may contain information that is privileged,
> confidential and/or otherwise protected from disclosure to anyone other
> than its intended recipient. Unintended transmission shall not constitute
> waiver of any privilege or confidentiality obligation. If you received this
> communication in error, please do not review, copy or distribute it, notify
> me immediately by email, and delete the original message and any
> attachments. Unless expressly stated in this e-mail, nothing in this
> message or any attachment should be construed as a digital or electronic
> signature.
>
>
> great, I am looking forward to that input and concrete text of course is
> also appreciated. I hope you do not get me wrong: we appreciate your input,
> I am just reluctant to broaden the scope of the draft to overall ICN/DTN
> intersection. But my understanding is that while you do work on the bigger
> picture, your input would relate to the disaster scenario we are
> considering just as well, so we are looking forward to it and will include
> it.
>
> - Jan
>
> Arjuna, Joerg and I are currently working on a paper that outlines the
> intersection, among other things. While it is not specifically focused on
> disaster aftermath, challenged environments (in the context of global
> access) is still the key driver. Let me discuss with Arjuna and Joerg what
> parts of this work could be beneficial to include in the draft, either as a
> pointer but also through concrete text.
>
> As for other pointers, we are in the process of finalizing the first
> deliverable in the mentioned RIFE project on use cases and requirements.
> Again, the scope is wider than disaster but nonetheless much of the
> requirements are likely to be useful when being seen in a narrower scenario
> only. The deliverable should be done by the end of July (minus the odd day
> due to increased vacation absence), so it might provide timely input once
> finished.
>
> Best,
>
> Dirk
>
>
> Dirk Trossen
> Principal Engineer
> InterDigital UK, Inc.
> This e-mail is intended only for the use of the individual or entity to
> which it is addressed, and may contain information that is privileged,
> confidential and/or otherwise protected from disclosure to anyone other
> than its intended recipient. Unintended transmission shall not constitute
> waiver of any privilege or confidentiality obligation. If you received this
> communication in error, please do not review, copy or distribute it, notify
> me immediately by email, and delete the original message and any
> attachments. Unless expressly stated in this e-mail, nothing in this
> message or any attachment should be construed as a digital or electronic
> signature.
>
>
> I saw your presentations here at IETF-93 / ICNRG on ICN/DTN intersection
> work with interest. We are happy if you want to help improving our draft,
> any concrete pointer to some existing DTN work that has similar ICN
> features as we require is appreciated. Having said that, I would like to
> keep the scope of our draft on disaster aftermath communication, as
> otherwise the scope might get to broad. But any comments from you on
> improving the draft in that respect are very welcome.
>
> - Jan
>
> While the topic/scenario is not only very valuable but also presents
> itself as an interesting ICN scenario, there is indeed the aspect that an
> entire (DTN) community has worked and proposed solutions in this space,
> many of which sound rather similar to what the draft discusses (e.g., the
> 'data mules' come to mind here).
>
> But that brings me to a possible extension that is not only about
> considering what an entire community has already worked on but possibly
> focus on the possible overlap/synergy at the architecture as well as
> solution level. As one example, the H2020 project RIFE is specifically
> targeting the 'unification' of DTN and ICN ideas, not only for disaster but
> also GAIA RG relevant scenarios. Such efforts show that thinking exists on
> how we could utilize the advances in both areas to not only advance
> solutions in this space but also possibly provide some form of
> architectural commonality.
>
> Best,
>
> Dirk
>
>
> Dirk Trossen
> Principal Engineer
> InterDigital UK, Inc.
> This e-mail is intended only for the use of the individual or entity to
> which it is addressed, and may contain information that is privileged,
> confidential and/or otherwise protected from disclosure to anyone other
> than its intended recipient. Unintended transmission shall not constitute
> waiver of any privilege or confidentiality obligation. If you received this
> communication in error, please do not review, copy or distribute it, notify
> me immediately by email, and delete the original message and any
> attachments. Unless expressly stated in this e-mail, nothing in this
> message or any attachment should be construed as a digital or electronic
> signature.
>
>
> But The document isn't that substantial yet and, as I stated in an earlier
> meeting, there has been a substantial amount of work in the DTN community
> and I see nothing of this appropriately reflected in the present draft.
> Obviously, the draft isn't supposed to be a summary what the DTN community
> did before, but exploring a solution space here appears to warrant input
> and experience from all sides.
>
> So, I would put this off for now and explicitly reach out to the DTN folks
> and then see if we can come up with something more complete.  I believe
> this would benefit the research group and the draft.  The draft should make
> the case on how the two basic ideas could complement each other.
>
> At this very point, also looking at the coverage of exactly one research
> project, this is an individual effort that doesn't suggest a broader
> consideration to come.
>
> If you wanna adopt it right now, I would like to at least see some demand
> towards the authors to do this reaching out.
>
> Jörg
>
> the goal of an Informational RFC that outlines the use of ICN techniques
> for disaster aftermath communication, and discussing why and how ICN is
> very useful in such scenarios. So, what about adopting this document as RG
> item? Today in the session there was a hum with several people in favor and
> no objections. Are there any further opinions on the mailing list?
> >>
> >> -          Jan
> >>
> >>

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 23 Jul 2015 09:32:24 +0000

Dear Jörg,

 - Jan

-----Original Message-----
From: Joerg Ott [mailto:[email-masked]] 
Sent: Dienstag, 21. Juli 2015 10:48
To: Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Trossen, Dirk; Arjuna Sathiaseelan; Kevin Fall
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi,

Jörg

---

From: Kostas Pentikousis <[email-masked]>
Date: Mon, 27 Jul 2015 13:58:56 +0200

| Right - adoption means we’re ready and willing to work on it together as an
| RG, as opposed to keeping it as an individual contribution. Nobody meant to
| imply it was “cooked” and ready for publication.

That's correct, hence my suggestions for improvement.

| Those of you with technical comments and additional material and references
| should join in to improve the document.

It will be a pleasure.

Best regards,

Kostas

---

From: Jan Seedorf <[email-masked]>
Date: Tue, 28 Jul 2015 10:13:48 +0000

Hi Dirk,

we are looking forward to your comments and will incorporate them into the draft. If you want to provide actual text you suggest to include in the draft, that would be appreciated as well.

Thanks,
Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]] 
Sent: Donnerstag, 23. Juli 2015 12:10
To: Jan Seedorf; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Jan,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Jan Seedorf [mailto:[email-masked]]
Sent: 23 July 2015 10:58
To: Trossen, Dirk; Jan Seedorf; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Dirk,

- Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]]
Sent: Donnerstag, 23. Juli 2015 11:53
To: Jan Seedorf; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Jan,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Jan Seedorf [mailto:[email-masked]]
Sent: 23 July 2015 10:40
To: Trossen, Dirk; Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi Dirk,

- Jan

-----Original Message-----
From: Trossen, Dirk [mailto:[email-masked]]
Sent: Dienstag, 21. Juli 2015 14:51
To: Joerg Ott; Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Arjuna Sathiaseelan; Kevin Fall
Subject: RE: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

All,

Best,

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.

-----Original Message-----
From: Joerg Ott [mailto:[email-masked]]
Sent: 21 July 2015 09:48
To: Daniel Corujo; [email-masked]
Cc: Jan Seedorf; Trossen, Dirk; Arjuna Sathiaseelan; Kevin Fall
Subject: Re: [icnrg] RG adoption of draft-seedorf-icn-disaster-03

Hi,

Jörg