Subject: [icnrg] Announcing CCN-lite 0.3.0

From: [email-masked]
Date: Wed, 8 Jul 2015 06:10:42 +0200 (CEST)

Dear ICN research community,

we are pleased to announce CCN-lite v0.3. The source code is on GitHub, 
see the link below, where you can also find precompiled binaries for 
Debian/Ubuntu, Redhat, Android and RFduino.

Over the past 6 months, CCN-lite has progressed in several ways:

- demonstrated interoperability with now-stabilized CCNx1.0,
   which can run side-by-side with NDN in a single CCN-lite relay

- OMNeT++ integration is back, as it has been requested many times

- new platforms and transport:
   . Arduino and RFduino
   . Android and Bluetooth Low Energy

- new functionality: "begin-end" fragmentation for CCNx1.0 and NDN

- improved build quality for Ubuntu and OSX

- improved READMEs allover the release, easy tutorials

- Named Function Networking (NFN) over NDN now has Python bindings
   to make the publishing of named functions easier.

   (The SCALA access is still available as an independent release
   and provides a more complete integration.)

Note that not all features of the individual ICN protocol suite are 
implemented.

If you want to include CCN-lite in your project plans, here is a 
tentative roadmap for release CCN-lite 0.4 over the coming six months:

- manifests
- security (key mgmt, signed computations and trust schematas)
- data access control
- better selector support for NDN
- RIOT re-integration

Enjoy release 0.3, enhance it and let us know what you did with 
CCN-lite!

The CCN-lite team in Basel

URLs:
    https://github.com/cn-uofbasel/ccn-lite/releases/tag/0.3.0
    http://www.ccn-lite.net/
    http://www.named-functions.net/
    http://www.icn-names.net/

---

From: Dirk Kutscher <[email-masked]>
Date: Wed, 8 Jul 2015 07:50:55 +0000

Hi Christian,

Great news -- thanks.

Can you briefly state whether this is compliant with 

https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxmessages/ and
https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxsemantics/

Thanks,
Dirk

> -----Original Message-----
> From: icnrg [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Mittwoch, 8. Juli 2015 06:11
> To: [email-masked]
> Subject: [icnrg] Announcing CCN-lite 0.3.0
> 
> we are pleased to announce CCN-lite v0.3. The source code is on GitHub, see
> the link below, where you can also find precompiled binaries for
> If you want to include CCN-lite in your project plans, here is a tentative
> roadmap for release CCN-lite 0.4 over the coming six months:
> 
> - manifests
> Enjoy release 0.3, enhance it and let us know what you did with CCN-lite!
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: [email-masked]
Date: Wed, 8 Jul 2015 13:02:05 +0200 (CEST)

Hi Dirk,

yes - it is my understanding that the interop test of CCN-lite against 
the METIS forwarder of PARC was testing compliance with the mentioned 
documents. We remotely accessed their server, they accessed our setup. 
One can also include

https://datatracker.ietf.org/doc/draft-mosko-icnrg-ccnxchunking/

to the list (although not an ICNRG document): fetching chunked content 
worked from both ends.

The disclaimer: Coverage is partial, both regarding the scope of tests 
as well as the set of features described in the documents, so it's a 
first step.

best, christian

---

From: Cedric Westphal <[email-masked]>
Date: Wed, 8 Jul 2015 19:21:28 +0000

Hi,

The attached CFP for a special session on ICN & IoT is of relevant interest to this community, I believe. Text version below. The deadline will probably be extended by a week or so...
Best,

Cedric.

-----------------------------

IEEE Consumer Communications & Networking Conference (CCNC)
Held in conjunction with the International Consumer Electronics Show, Las Vegas, NV, USA 
January 09-12, 2016

Call for Papers for Content Centric Internet of Things (CCIoT)

Scope and Motivation:
Content-Centric Networking (CCN) and Named Data Networking (NDN) have recently emerged as a promising Future Internet architecture that aims to cope with the increasing demand for highly scalable and efficient information dissemination. Moving away from the Internet's legacy host-to-host communication model, CCN/NDN promises a new host-to-data communication model, by leveraging named data, name-based routing and in-network storage for caching. At the same time, the rise of the Internet of Things (IoT), with its rich set of challenges and requirements placed upon the current Internet, provide an interesting ground for showcasing the contribution and performance of CCN mechanisms. 
This special session calls for recent research, practical experiences, and development lessons on the intersection of the paradigms of CCN and IoT. The objective is to promote the integration of Content Centric Networking and Internet of Things by addressing the unique problems in IoT, such as mobility, interference of wireless channel, limitation of storage and battery, security and privacy. Novel applications, practical experience and solutions on deploying CCN over IoT are also welcome. 
Main Topics of Interest:
The Special Session on Content Centric Internet of Things (CCIoT) seeks original contributions in the following topical areas, plus others that are not explicitly listed but are closely related:
*	Content-centric network architecture for IoT
*	RFID-based naming strategy
*	Information publish/subscribe mechanism for data collection
*	Routing in wireless CCN
*	Resource management such as power, computing, storage, bandwidth, and user interface
*	Context-aware networking for smart home, health care, transportation, etc.
*	Novel application, prototype or solution in consumer networks with CCN
*	Security, privacy, and trust in CCN over IoT
*	Contextual communication in IoT applications
We encourage submissions of high-quality technical papers reporting original research that has not been previously published, and is not currently submitted for consideration elsewhere. To ensure high quality of the contributions, all papers submitted to this special session will be reviewed using the same procedure and criteria as regular papers (please refer to the main conference CFP when preparing your submissions). All paper submissions are handled through EDAS, and follow the technical program submission and review schedule. Papers accepted for this special session are included in the conference proceedings as part of the technical track and published in the conference proceedings including IEEE Xplore. At least one author for each accepted paper must register for the conference and present the paper during the Special Session.

Session Co-Chairs:
Cedric Westphal, Futurewei Technologies & UCSC
Haiyong Xie, USTC & CAEIT Innovation Center
Technical Program Committee
Yanhua Li, Worcester Polytechnic Institute, USA
Jin Wang, Soochow University, China
Ravi Ravindran, Huawei US Research Labs (Futurewei Technologies), USA
Xinwen Zhang, Samsung Telecom America, USA
Yanyong Zhang, Rutgers University, USA
Dirk Kutscher, NEC Laboratories Europe, Germany
Giovanna Carofiglio, CISCO, France
Luca Muscariello, Orange Labs, France Telecom, France

IMPORTANT DATES
Special Session papers due: July 10, 2015
Acceptance notification: September 4, 2015
Final camera ready: November 2, 2015