Subject: [icnrg] Interim slides

From: Börje Ohlman <[email-masked]>
Date: Sat, 3 Oct 2015 21:50:16 +0000

http://www.ietf.org/proceedings/interim/2015/10/03/icnrg/proceedings.html

Börje

---

From: Ravi Ravindran <[email-masked]>
Date: Mon, 5 Oct 2015 03:26:44 +0000

We couldn’t get to discuss this proposal to merge the two ICN-IoT drafts yesterday at the interim due to time. The proposal is to merge the overlap requirements from the https://tools.ietf.org/html/draft-lindgren-icnrg-efficientiot-03 into https://tools.ietf.org/html/draft-zhang-iot-icn-challenges-02 , to produce a merged ICN-IoT requirements  focused working group draft. The details of the merger is in the slides.

Please let us know if it is OK to proceed with this so that we can present the merged version of the  draft at Yokohama.

Regards,
Ravi

From: icnrg [mailto:[email-masked]] On Behalf Of Börje Ohlman
Sent: Saturday, October 03, 2015 2:50 PM
To: icnrg
Subject: [icnrg] Interim slides

Börje

---

From: Antonella Molinaro <[email-masked]>
Date: Mon, 5 Oct 2015 16:03:59 +0200

dear Ravi, all

i'd like to share with you the link to a related work on ICN-IoT
co-authored with some colleagues from ICNRG and about to be published in
IEEE Network

here you can find the pre-publication version from ResearchGate:
https://www.researchgate.net/publication/282442518_Information-Centric_Networking_for_the_Internet_of_Things_Challenges_and_Opportunities

we welcome comments and are available for contribution to the new draft /
research cooperation

Regards,

Antonella

2015-10-05 5:26 GMT+02:00 Ravi Ravindran <[email-masked]>:

>
>
> We couldn’t get to discuss this proposal to merge the two ICN-IoT drafts
> yesterday at the interim due to time. The proposal is to merge the overlap
> requirements from the *https://tools.ietf.org/html/draft-lindgren-icnrg-efficientiot-03
> <https://tools.ietf.org/html/draft-lindgren-icnrg-efficientiot-03> *into *https://tools.ietf.org/html/draft-zhang-iot-icn-challenges-02
> <https://tools.ietf.org/html/draft-zhang-iot-icn-challenges-02> *, to
> produce a merged ICN-IoT requirements  focused working group draft. The
> details of the merger is in the slides.
>
>
>
> Please let us know if it is OK to proceed with this so that we can present
> the merged version of the  draft at Yokohama.
>
>
>
> Regards,
>
> Ravi
>
>
>
>
>
>
>
> *From:* icnrg [mailto:[email-masked]] *On Behalf Of *Börje Ohlman
> *Sent:* Saturday, October 03, 2015 2:50 PM
> *To:* icnrg
> *Subject:* [icnrg] Interim slides
>
>
>
>
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>
>

---

From: Ravi Ravindran <[email-masked]>
Date: Mon, 5 Oct 2015 17:15:38 +0000

Thanks for referring us to the work Antonella.

Please feel free to mail me with other relevant work in the ICN-IoT space, or something that you folks feel has not been captured  well in the requirement/challenges discussion in the draft.

Regards,
Ravi

From: Antonella Molinaro [mailto:[email-masked]]
Sent: Monday, October 05, 2015 6:54 AM
To: Ravi Ravindran; Dirk Kutscher; BÃ¶rje Ohlman; [email-masked]; [email-masked]
Subject: Re: [icnrg] Merging the ICN-IoT drafts

dear Ravi, all

i'd like to share with you the link to a related work on ICN-IoT co-authored with some colleagues from ICNRG and about to be published in IEEE Network

we welcome comments and are available for contribution to the new draft / research cooperation

Regards,

Antonella

At 05:26 05/10/2015, Ravi Ravindran wrote:

We couldnâ€™t get to discuss this proposal to merge the two ICN-IoT drafts yesterday at the interim due to time. The proposal is to merge the overlap requirements from the https://tools.ietf.org/html/draft-lindgren-icnrg-efficientiot-03 into https://tools.ietf.org/html/draft-zhang-iot-icn-challenges-02 , to produce a merged ICN-IoT requirements  focused working group draft. The details of the merger is in the slides.

Regards,
Ravi

From: icnrg [ mailto:[email-masked]] On Behalf Of BÃ¶rje Ohlman
Sent: Saturday, October 03, 2015 2:50 PM
To: icnrg
Subject: [icnrg] Interim slides

BÃ¶rje

---

From: Börje Ohlman <[email-masked]>
Date: Wed, 7 Oct 2015 06:48:25 +0000

Ravi,

I’m really sorry that we did not get time to discuss this during the interim. The reason was a misunderstanding between the chairs and due to bad time management from our side. Sorry about that.

I fully support what you propose in the slides and I don’t expect my co-chairs to have any objections. Either way, these are two individual drafts and you as authors are free to do whatever you like with them. But what I would recommend you to do is to send the slides to the mailing list and ask for feedback and then go ahead and make your planned merge taking any received feedback into account.

Best regards,
Börje

On 5 okt 2015, at 05:26, Ravi Ravindran <[email-masked]<mailto:[email-masked]>> wrote:

Regards,
Ravi

Börje

<icnrg_new_iot_draft-v1.1.pptx>

---

From: Dirk Kutscher <[email-masked]>
Date: Wed, 7 Oct 2015 08:17:17 +0000

Hi Ravi,

thanks for the proposal. (No need to send the slides to the list again.)

Let’s collect some feedback on the list during the next days.

Looking forward to following up on this in Yokohama.

Dirk

From: Börje Ohlman [mailto:[email-masked]]
Sent: Mittwoch, 7. Oktober 2015 08:48
To: Ravi Ravindran
Cc: Dirk Kutscher; [email-masked]; Laura Hill; Anders Lindgren
Subject: Re: Merging the ICN-IoT drafts

Ravi,

Best regards,
Börje

Regards,
Ravi

Börje

---

From: Ravi Ravindran <[email-masked]>
Date: Wed, 7 Oct 2015 17:07:44 +0000

Hi Dirk,

I think what Borje meant is the technical details of the merged version, we are still working on that and will be ready only close the Yokohama meeting. I’ll wait for the response from the list to see if the community sees value in presenting this draft as an RG item in the next Yokohama meeting, or we do another iteration of the ‘zhang’ draft with the merged content, and propose it formally for adoption at Yokohama.

Regards,
Ravi

From: Dirk Kutscher [mailto:[email-masked]]
Sent: Wednesday, October 07, 2015 1:17 AM
To: Börje Ohlman; Ravi Ravindran
Cc: [email-masked]; Laura Hill; Anders Lindgren
Subject: RE: Merging the ICN-IoT drafts

Hi Ravi,

Dirk

Ravi,

Best regards,
Börje

Regards,
Ravi

Börje

---

From: Mark Stapp <[email-masked]>
Date: Wed, 7 Oct 2015 16:31:29 -0400

I was a little confused about Ravi's email. is there a proposal that an 
un-seen draft will appear as an RG document?

I'm not a big fan of these omnibus "requirements" things in general. I 
don't usually find them very useful when considering protocol details, 
they go out-of-date quickly, and it's not clear to me that they actually 
help to focus or guide RG work. I'm ok with such a thing, though, if the 
chairs and the RG want it. but I wouldn't support something un-reviewed 
just popping out as an RG document.

Thanks,
Mark

On 10/7/15 1:07 PM, Ravi Ravindran wrote:
> Hi Dirk,
>
> I think what Borje meant is the technical details of the merged version,
> we are still working on that and will be ready only close the Yokohama
> meeting. I’ll wait for the response from the list to see if the
> community sees value in presenting this draft as an RG item in the next
> Yokohama meeting, or we do another iteration of the ‘zhang’ draft with
> the merged content, and propose it formally for adoption at Yokohama.
>
> Regards,
>
> Ravi
>
> *From:*Dirk Kutscher [mailto:[email-masked]]
> *Sent:* Wednesday, October 07, 2015 1:17 AM
> *To:* Börje Ohlman; Ravi Ravindran
> *Cc:* [email-masked]; Laura Hill; Anders Lindgren
> *Subject:* RE: Merging the ICN-IoT drafts
>
> Hi Ravi,
>

---

From: Anders Lindgren <[email-masked]>
Date: Wed, 7 Oct 2015 22:51:01 +0200

Hi Mark,

I think that the best way forward is that we (the authors of the two drafts to be merged) create the new set of drafts as outlined in the slides Ravi sent out and submit those as individual draft submissions. Adoption of the merged draft as RG document can then be discussed in Yokohama when others have had a chance to look at it and review. 
We do however invite people to have a look at the proposed structure outlined in the slide set and provide us with any early feedback you may have (of course also including your thoughts on whether or not you think that working towards a document will be a good thing or not for the RG to do). 

Cheers, 

/Anders

Sent from my iPhone

> On 7 Oct 2015, at 22:31, Mark Stapp <[email-masked]> wrote:
> 
> I was a little confused about Ravi's email. is there a proposal that an un-seen draft will appear as an RG document?
> 
> I'm not a big fan of these omnibus "requirements" things in general. I don't usually find them very useful when considering protocol details, they go out-of-date quickly, and it's not clear to me that they actually help to focus or guide RG work. I'm ok with such a thing, though, if the chairs and the RG want it. but I wouldn't support something un-reviewed just popping out as an RG document.
> 
> Thanks,
> Mark
>

---

From: Dirk Kutscher <[email-masked]>
Date: Thu, 8 Oct 2015 07:45:37 +0000

Hi Anders and all,

thanks for the clarification -- yes, we'd need an individual submission first and then discuss about adoption.

Best regards,
Dirk

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Anders Lindgren
Sent: Mittwoch, 7. Oktober 2015 22:51
To: Mark Stapp
Cc: [email-masked]
Subject: Re: [icnrg] Merging the ICN-IoT drafts

Hi Mark,

Cheers, 

/Anders

Sent from my iPhone

>> I think what Borje meant is the technical details of the merged 
>> version, we are still working on that and will be ready only close 
>> the Yokohama meeting. I’ll wait for the response from the list to see 
>> if the community sees value in presenting this draft as an RG item in 
>> the next Yokohama meeting, or we do another iteration of the ‘zhang’ 
>> draft with the merged content, and propose it formally for adoption at Yokohama.
>> 
>> Regards,
>> 
>> Ravi
>>