Subject: [icnrg] Information Centric Networking in the IoT: Experiments with NDN in the Wild

From: Dirk Kutscher <[email-masked]>
Date: Thu, 5 Nov 2015 01:19:20 +0000

This is the paper I mentioned at the ICNRG meeting today:

http://conferences2.sigcomm.org/acm-icn/2014/papers/p77.pdf

Dirk

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 5 Nov 2015 01:44:17 +0000

Thanks Dirk.

The paper is a good start but, based on my quick reading, it is incomplete.

It does not describe a complete scenario. It compares RPL + 6lowpan against CCN-lite. What I am looking for is a scenario where you use an application. For example, in the described setup I could imagine a lighting scenario may be appropriate. This would at least have IPSO/CoAP/DTLS/UDP in there as well. It would also have sensors (such as a presence sensor) together with actuators.

The multihop mesh networking scenario is also a bit more complex than many of the deployed IoT scenarios. So, it might make sense to start with something simpler, such as a device talking over Bluetooth Smart with another device, or a device communicating with the cloud (whereby the device is using some radio technology, such as WiFi, LoRa, IEEE 802.15.4 to talk to a gateway that is connected to a wired infrastructure).

Ciao
Hannes

From: Dirk Kutscher [mailto:[email-masked]]
Sent: 05 November 2015 10:19
To: [email-masked]
Cc: Hannes Tschofenig
Subject: Information Centric Networking in the IoT: Experiments with NDN in the Wild

Dirk

________________________________

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Thu, 5 Nov 2015 10:59:30 +0900

Hi Hannes,

> The paper is a good start but, based on my quick reading, it is incomplete.

Yep, of course it is. Last year, this was a first step towards 
"real-world" experimental evaluations of ICN-IoT building blocks. I 
believe there is a bunch of work needed to understand how a realistic 
IoT environment interrelates with ICN protocol primitives in multihop 
scenarios.

We can stepwise work our way up to real applications and complex 
deployment scenarios. However, the basics still seem good enough for 
surprises and justify more work.

Cheers,
  Thomas

> It does not describe a complete scenario. It compares RPL + 6lowpan
> against CCN-lite. What I am looking for is a scenario where you use an
> application. For example, in the described setup I could imagine a
> lighting scenario may be appropriate. This would at least have
> IPSO/CoAP/DTLS/UDP in there as well. It would also have sensors (such as
> a presence sensor) together with actuators.
>
> The multihop mesh networking scenario is also a bit more complex than
> many of the deployed IoT scenarios. So, it might make sense to start
> with something simpler, such as a device talking over Bluetooth Smart
> with another device, or a device communicating with the cloud (whereby
> the device is using some radio technology, such as WiFi, LoRa, IEEE
> 802.15.4 to talk to a gateway that is connected to a wired infrastructure).
>
> Ciao
> Hannes
>
> *From:*Dirk Kutscher [mailto:[email-masked]]
> *Sent:* 05 November 2015 10:19
> *To:* [email-masked]
> *Cc:* Hannes Tschofenig
> *Subject:* Information Centric Networking in the IoT: Experiments with
> NDN in the Wild
>
> ------------------------------------------------------------------------
>
> -- IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy
> the information in any medium. Thank you.

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °