Subject: [icnrg] Performance Analysis of ICN for IoT

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 5 Nov 2015 01:51:11 +0000

Hi all,

In the meeting today I was wondering about ongoing performance investigations to determine the benefits of ICN for IoT.

A recent ISOC publication on IoT describes a couple of IoT communication patterns, see
http://www.internetsociety.org/sites/default/files/ISOC-IoT-Overview-20151022.pdf

These categories are useful to build testbed setups that reflect common IoT deployments.

Dirk already posted one such paper to the list. If you have others please let me know.
This will help me answer the question whether ICN for IoT is just a different way of doing things or whether it is actually better.

Ciao
Hannes

________________________________

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 5 Nov 2015 02:25:14 +0000

Hi Alex,

Thanks for your quick response.

Maybe such an analysis reveals that ICN is not suitable for certain communication models in use today and that might be an interesting insight as well.

Here are the communication models we were able to identify in RFC 7452:
* Device-to-Device Communication Pattern
* Device-to-Cloud Communication Pattern
* Device-to-Gateway Communication Pattern
* Back-End Data Sharing Pattern
There has to be a way to support the distribution of data that is frequently changing (such as sensor readings), and to interact with actuators. Some developers also offer meta-data along with the data. Meta-data is static. Sensor readings are typically quite small but, if you add application layer security to it, it will most likely be larger than the MTU size of the widely used low power radio networks. There are also larger data items that are transmitted, namely firmware/software updates.

Authorization related use cases have been collected in this document:
https://tools.ietf.org/html/draft-ietf-ace-usecases-10

Here is a document that talks a bit about the lighting use case and the authorization requirements. Lighting is interesting since you have a multicast use case there (with low latency requirements) and also a mesh network using IEEE 802.15.4:
https://tools.ietf.org/html/draft-somaraju-ace-multicast-00

Ciao
Hannes

On 11/05/2015 02:52 AM, Alex Afanasyev wrote:
> Hi Hannes,
>
> I would like to point out that "performance" analysis mat not
> feasible today or ever.  If exactly the same IoT
> implementation/pattern was possible in IP, then there wouldn't be a
> need for ICN.  ICN really brings unique capabilities to IoT, which
> may not be comparable at all.
>
> It could be possible to do qualitative evaluation of the ICN IoT
> approach, though I would refrain from making conclusions from
> quantitative evaluations.  Although having a decent number
> optimizations, the current implementations don't have years of
> engineering and tweaking.  In those cases that can be implemented
> using IP, no real conclusions can be made from the observed numbers.
>
> --- Alex
>
>> On Nov 5, 2015, at 10:26 AM, Hannes Tschofenig
>> <[email-masked]> wrote:
>>
>> In the meeting today I was wondering about ongoing performance
>> investigations to determine the benefits of ICN for IoT.
>>
These categories are useful to build testbed setups that reflect common
>> IoT deployments.
>>
>> If you are aware of already published results please let me know.
>>
>> Ciao Hannes
>>
>>
>> _______________________________________________ icnrg mailing list
>> [email-masked] https://www.irtf.org/mailman/listinfo/icnrg