Subject: Re: [icnrg] "Inter-Network Naming, Addressing, and Routing"

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Mon, 2 Nov 2015 02:18:53 +0000

> On Nov 1, 2015, at 2:52 PM 11/1/15, Lixia Zhang <[email-masked]> wrote:
> 
> for people in today's ICNRG informal meeting: here is the pointer to this old paper that DaveO mentioned:
> http://www.postel.org/ien/pdf/ien019.pdf

Well, if you want to root around in dusty old papers, there's a follow-up paper "Inter-Network Naming, Addressing, and Routing" [Sho78], quoted in an obscure TR by an unknown PhD student in "Overloading of Names in Distributed Systems" [CoDr85].

[Sho78] Shoch, J. F., Inter-Network Naming, Addressing, and Routing, Proc. IEEE Computer Soc. Int. Conf. (COMPCON), Wash. D.C., Sep. 1978, 72-79.

[CoDr85] Comer, D. E. and R. Droms, Overloading of Names in Distributed Systems, Purdue University TR-85-531, Oct. 1985.

> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Ravi Ravindran <[email-masked]>
Date: Tue, 3 Nov 2015 01:22:05 +0000

https://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-Y.3033-201401-I!!PDF-E&type=items

This is the ITU document I was referring to in the interim meeting, which defines certain ICN terminologies. This is coming back to the discussion where it was said that ID/Locator in the past had been used in a certain context, and with ICN we don't need that distinction, also leading to the proposal for a "clarification" document about what these terms mean in ICN, and what they are not. Such a document could potentially cover more:
-	 ICN Engineering versus Architectural Design Choices
-	 Network requirements on Names
-	 Name Management/Assignment
-	 etc.	

Regards,
Ravi