Subject: [icnrg] CCNx key exchange protocol writeup

From: <[email-masked]>
Date: Mon, 2 Nov 2015 12:45:40 +0000

All,

Here is a writeup of the CCNx key exchange protocol to be presented on Thursday. Comments and criticism about the design or document are most welcome.

Best,
Chris

--
Christopher Wood

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 3 Nov 2015 18:33:57 +0900

I'm still digesting the content of the draft, but I wanted to comment on the title, which may be highly misleading, since it purports to be a key global key exchange protocol between any two CCN forwarders. I don't think this is true, as it assumes the the two forwarders being adjacent (I.e. no intermediate forwarder). It would be a lot clearer to state that it's  in fact a "neighbor" key bootstrap for the "adjacency" between a pair of CCN forwarders (and incidentally it is pairwise and not a group key agreement protocol for a broadcast channel).

If I'm wrong and it is in fact global, what would you use it for?

If I'm right II think it really needs a new title.

___________________________
iDevice - please excuse typos.

> On Nov 2, 2015, at 9:45 PM, <[email-masked]> <[email-masked]> wrote:
> 
> All,
> 
> <draft-wood-icnrg-ccnxkeyexchange.txt>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: <[email-masked]>
Date: Tue, 3 Nov 2015 09:39:05 +0000

Dave,

It should be between any two peers (end systems), not specific to forwarders.  The peers do not need to be neighbors.  Two forwarders, of course, could use it to exchange keys.

This is used when two peers want to use symmetric keys to protect a communication.  For example, my on-line banking.

Could you point us to what makes it look like it is between two forwarders so we can fix that?

Thanks,
Marc

________________________________
From: icnrg [[email-masked]] on behalf of David R. Oran [[email-masked]]
Sent: Tuesday, November 03, 2015 6:33 PM
To: Wood, Christopher <[email-masked]>
Cc: [email-masked]
Subject: Re: [icnrg] CCNx key exchange protocol writeup

On Nov 2, 2015, at 9:45 PM, <[email-masked]<mailto:[email-masked]>> <[email-masked]<mailto:[email-masked]>> wrote:

All,

Best,
Chris

--
Christopher Wood
<draft-wood-icnrg-ccnxkeyexchange.txt>
_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: David Oran <[email-masked]>
Date: Tue, 3 Nov 2015 18:57:25 +0900

Sorry - I misread a whole bunch of it.
What about the original problem of securing inter-forwarder traffic?

> On Nov 3, 2015, at 6:39 PM, [email-masked] wrote:
> 
> Dave,
>

---

From: <[email-masked]>
Date: Tue, 3 Nov 2015 11:16:56 +0000

Dave,

We only have 1-way authentication sketched out (producer to consumer), but 2-way authentication is on the to-do list.  I think once we get 2-way done, then inter-forwarder keys would be fine.  They could also skip a few of the optional steps, as they would not need to rename the session in round 2 or use the move token in round 3.

Marc

________________________________________
From: icnrg [[email-masked]] on behalf of David Oran [[email-masked]]
Sent: Tuesday, November 03, 2015 6:57 PM
To: Mosko, Marc <[email-masked]>
Cc: [email-masked]; Wood, Christopher <[email-masked]>
Subject: Re: [icnrg] CCNx key exchange protocol writeup

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 4 Nov 2015 02:08:02 +0000

"Intended status: Standards Track" is obviously not possible and should be corrected.

Lars