Subject: [icnrg] FW: New Version Notification for draft-zhang-icnrg-icniot-requirements-00.txt

From: Ravi Ravindran <[email-masked]>
Date: Wed, 4 Nov 2015 04:22:23 +0000

Here is the merged ICN-IoT requirements/challenges draft for discussion tomorrow.

Regards,
Ravi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, November 04, 2015 1:19 PM
To: Dipankar Raychadhuri; Yanyong Zhang; Emmanuel Baccelli; Jeff Burke; Luigi Alfredo Grieco; Ravi Ravindran; Anders Lindgren; GQ Wang; Olov Schelen; Bengt Ahlgren
Subject: New Version Notification for draft-zhang-icnrg-icniot-requirements-00.txt

A new version of I-D, draft-zhang-icnrg-icniot-requirements-00.txt
has been successfully submitted by Ravishankar Ravindran and posted to the
IETF repository.

Name:		draft-zhang-icnrg-icniot-requirements
Revision:	00
Title:		Requirements and Challenges for IoT over ICN
Document date:	2015-11-03
Group:		Individual Submission
Pages:		36
URL:            https://www.ietf.org/internet-drafts/draft-zhang-icnrg-icniot-requirements-00.txt
Status:         https://datatracker.ietf.org/doc/draft-zhang-icnrg-icniot-requirements/
Htmlized:       https://tools.ietf.org/html/draft-zhang-icnrg-icniot-requirements-00

Abstract:
   The Internet of Things (IoT) promises to connect billions of objects
   to the Internet.  After deploying many stand-alone IoT systems in
   different domains, the current trend is to develop a common, "thin
   waist" of protocols forming a horizontal unified, defragmented IoT
   platform.  Such a platform will make objects accessible to
   applications across organizations and domains.  Towards this goal,
   quite a few proposals have been made to build a unified host-centric
   IoT platform as an overlay on top of today's host-centric Internet.
   However, there is a fundamental mismatch between the host-centric
   nature of todays Internet and the information-centric nature of the
   IoT system.  To address this mismatch, we propose to build a common
   set of protocols and services, which form an IoT platform, based on
   the Information Centric Network (ICN) architecture, which we call
   ICN-IoT.  ICN-IoT leverages the salient features of ICN, and thus
   provides seamless mobility support, scalability, and efficient
   content and service delivery.

   This draft describes representative IoT requirements and ICN
   challenges to realize a unified ICN-IoT framework.  Towards this, we
   first identify a list of important requirements which a unified IoT
   architecture should have to support tens of billions of objects, then
   we discuss how the current IP-IoT overlay fails to meet these
   requirements, followed by discussion on suitability of ICN for IoT.

   Though we see most of the IoT requirements can be met by ICN, we
   discuss specific challenges ICN has to address to satisfy them.  Then
   we provide discussion of popular IoT scenarios including the "smart"
   home, campus, grid, transportation infrastructure, healthcare,
   Education, and Entertainment for completeness, as specific scenarios
   requires appropriate design choices and architectural considerations
   towards developing an ICN-IoT solution.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Ravi Ravindran <[email-masked]>
Date: Thu, 5 Nov 2015 01:49:08 +0000

Hi All,

We presented the merged icn-iot draft today, and proposed it for adoption as a RG work item. For the details on the draft history and its goals and changes please refer to the attached slides. 

We would like communities feedback on this proposal.

Regards,
Ravi

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Ravi Ravindran
Sent: Wednesday, November 04, 2015 1:22 PM
To: [email-masked]
Subject: [icnrg] FW: New Version Notification for draft-zhang-icnrg-icniot-requirements-00.txt

Regards,
Ravi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, November 04, 2015 1:19 PM
To: Dipankar Raychadhuri; Yanyong Zhang; Emmanuel Baccelli; Jeff Burke; Luigi Alfredo Grieco; Ravi Ravindran; Anders Lindgren; GQ Wang; Olov Schelen; Bengt Ahlgren
Subject: New Version Notification for draft-zhang-icnrg-icniot-requirements-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg