Subject: [icnrg] New Version Notification for draft-zhang-icnrg-icniot-requirements-01.txt

From: Ravi Ravindran <[email-masked]>
Date: Sat, 23 Apr 2016 00:05:05 +0000

Dear All,

Based on the comments from the mailing list we have updated the ICN-IoT requirements draft.

Following are the updates to the draft:

1. Sections 2.10&5.6 have been updated based on Yuansong's contributions and references.

2. Sections 3.2&2.9 have been updated to address Akbar's comments.

3. A new Section 2.13 on IoT platform management challenge has been added, and Sections 2.3,5.7&6.3 have been updated to address Thomas's comments.

4. Sections 2.5&6.4 have been updated to address Bastiaan's comments.

More comments are welcome for improving this contribution.

Regards,
Ravi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, April 22, 2016 4:59 PM
To: Dipankar Raychadhuri; Yanyong Zhang; Emmanuel Baccelli; Jeff Burke; Ravi Ravindran; GQ Wang; Olov Schelen; Bengt Ahlgren; Luigi Alfredo Grieco
Subject: New Version Notification for draft-zhang-icnrg-icniot-requirements-01.txt

A new version of I-D, draft-zhang-icnrg-icniot-requirements-01.txt
has been successfully submitted by Ravishankar Ravindran and posted to the
IETF repository.

Name:		draft-zhang-icnrg-icniot-requirements
Revision:	01
Title:		Requirements and Challenges for IoT over ICN
Document date:	2016-04-22
Group:		Individual Submission
Pages:		39
URL:            https://www.ietf.org/internet-drafts/draft-zhang-icnrg-icniot-requirements-01.txt
Status:         https://datatracker.ietf.org/doc/draft-zhang-icnrg-icniot-requirements/
Htmlized:       https://tools.ietf.org/html/draft-zhang-icnrg-icniot-requirements-01
Diff:           https://www.ietf.org/rfcdiff?url2=draft-zhang-icnrg-icniot-requirements-01

Abstract:
   The Internet of Things (IoT) promises to connect billions of objects
   to the Internet.  After deploying many stand-alone IoT systems in
   different domains, the current trend is to develop a common, "thin
   waist" of protocols forming a horizontal unified, defragmented IoT
   platform.  Such a platform will make objects accessible to
   applications across organizations and domains.  Towards this goal,
   quite a few proposals have been made to build a unified host-centric
   IoT platform as an overlay on top of today's host-centric Internet.
   However, there is a fundamental mismatch between the host-centric
   nature of todays Internet and the information-centric nature of the
   IoT system.  To address this mismatch, we propose to build a common
   set of protocols and services, which form an IoT platform, based on
   the Information Centric Network (ICN) architecture, which we call
   ICN-IoT.  ICN-IoT leverages the salient features of ICN, and thus
   provides seamless mobility support, security, scalability, and
   efficient content and service delivery.

   This draft describes representative IoT requirements and ICN
   challenges to realize a unified ICN-IoT framework.  Towards this, we
   first identify a list of important requirements which a unified IoT
   architecture should have to support tens of billions of objects, then
   we discuss how the current IP-IoT overlay fails to meet these
   requirements, followed by discussion on suitability of ICN for IoT.

   Though we see most of the IoT requirements can be met by ICN, we
   discuss specific challenges ICN has to address to satisfy them.  Then
   we provide discussion of popular IoT scenarios including the "smart"
   home, campus, grid, transportation infrastructure, healthcare,
   Education, and Entertainment for completeness, as specific scenarios
   requires appropriate design choices and architectural considerations
   towards developing an ICN-IoT solution.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dirk Kutscher <[email-masked]>
Date: Mon, 25 Apr 2016 08:38:45 +0000

Thanks, Ravi.

We talked about adopting this one as an RG document. 

https://tools.ietf.org/html/draft-zhang-icnrg-icniot-requirements-01

Can we get some opinions from people who have read it (and that are not in the authors group)?

We would like to understand whether people think that this is in a mature enough state and whether it's sufficiently comprehensive to be adopted as an RG document and moved towards Informational RFC publication later.

Thanks,
Dirk

> From: icnrg [mailto:[email-masked]] On Behalf Of Ravi Ravindran
> Sent: Samstag, 23. April 2016 02:05
> To: [email-masked]
> Subject: [icnrg] New Version Notification for draft-zhang-icnrg-icniot-
> requirements-01.txt
> 
> Dear All,
> 
> 3. A new Section 2.13 on IoT platform management challenge has been added,
> and Sections 2.3,5.7&6.3 have been updated to address Thomas's comments.
> 
> To: Dipankar Raychadhuri; Yanyong Zhang; Emmanuel Baccelli; Jeff Burke; Ravi
> Ravindran; GQ Wang; Olov Schelen; Bengt Ahlgren; Luigi Alfredo Grieco
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Rahman, Akbar" <[email-masked]>
Date: Mon, 25 Apr 2016 20:05:28 +0000

Hi Dirk/Ravi,

I read the update and was satisfied that my comments were addressed.  I support adopting it as an RG document.

Best Regards,

Akbar

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Dirk Kutscher
Sent: Monday, April 25, 2016 4:39 AM
To: Ravi Ravindran <[email-masked]>; [email-masked]
Subject: Re: [icnrg] New Version Notification for draft-zhang-icnrg-icniot-requirements-01.txt

Thanks, Ravi.

Thanks,
Dirk

> Subject: [icnrg] New Version Notification for
> draft-zhang-icnrg-icniot- requirements-01.txt
>
> Dear All,
>
> 3. A new Section 2.13 on IoT platform management challenge has been
> added, and Sections 2.3,5.7&6.3 have been updated to address Thomas's comments.
>
> To: Dipankar Raychadhuri; Yanyong Zhang; Emmanuel Baccelli; Jeff
> Burke; Ravi Ravindran; GQ Wang; Olov Schelen; Bengt Ahlgren; Luigi
> Alfredo Grieco
> Subject: New Version Notification for
> draft-zhang-icnrg-icniot-requirements-
> 01.txt
>
>
> has been successfully submitted by Ravishankar Ravindran and posted to
> the IETF repository.
>
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>