Subject: Re: [icnrg] next stepd for draft-zhang-icnrg-icniot-requirements

From: Dirk Kutscher <[email-masked]>
Date: Fri, 16 Sep 2016 16:00:07 +0000

Hi all,

This may have fallen between the cracks during the summer break - so this is a friendly reminder:

Please let us have your opinion on how to pursue with this draft. Do you support adopting it as an RG document?

Thanks,
Chairs

From: Dirk Kutscher
Sent: Montag, 8. August 2016 17:33
To: [email-masked]
Subject: next stepd for draft-zhang-icnrg-icniot-requirements

Hi all,

at the Berlin meeting, we concluded that we'd use the mailing list to agree on next steps for draft-zhang-icnrg-icniot-requirements [1].

In case you don't remember, this draft is the result of a merger of draft-zhang-iot-icn-challenges-02 [2] and draft-lindgren-icnrg-efficientiot-03 [3], focusing on the scenario, requirements and challenges aspects of both input drafts.

After the merger, the authors have submitted another version, reflecting some community feedback.

Please see https://www.ietf.org/proceedings/96/slides/slides-96-icnrg-3.pdf for a summary of the genesis and the current content.

The chairs would like to get an understanding whether the ICNRG has an interest in pursuing this draft as a RG activity ("adoption"). We normally do this for drafts where there is a critical mass of interested people that would like to see this progressing within ICNRG and eventually be published as an (in this case, Informational)  RFC. This would also require a critical mass of people that would be interested to spend cycles for reviewing the draft and future revisions.

Could you please let us know whether you think this draft a) should be adopted as a RG item and b) whether you'd be able to help reviewing it?

Thanks,
Börje, Dave, Dirk (ICNRG chairs)

[1] https://datatracker.ietf.org/doc/draft-zhang-icnrg-icniot-requirements/
[2] https://tools.ietf.org/html/draft-zhang-iot-icn-challenges-02
[3] https://datatracker.ietf.org/doc/draft-lindgren-icnrg-efficientiot/03/

---

From: Lixia Zhang <[email-masked]>
Date: Sat, 17 Sep 2016 08:54:06 -0700

> On Sep 16, 2016, at 9:00 AM, Dirk Kutscher <[email-masked]> wrote:
> 
> Hi all,
>  
> This may have fallen between the cracks during the summer break – so this is a friendly reminder:
>  

I just had a quick look over the draft: it seems to me that this draft still left lots rooms for improvements, not the least is its treatment on security.  The current draft seems reflecting the common mindset that security is something one has to mention, not that security is an integral component in all aspects of a system.

Section 2: would it be more appropriate to move security from section 2.8 to section 2.2, right after naming?  given security needs crypto protection, crypto is directly related to identities

Section 4 on Advantages of using ICN for IoT has no mentioning about security.

Section 5, like section 2, puts security discussions much later after  other subjects that may be felt more familiar with, like name resolution, caching and storage, routing/forwarding, etc.--aren't al these components need security as well?
There seem also discussions on trust that seems separate from security ...

Another comment is a wish: the draft looks really abstract/motherhood-and-applepie to me, I wonder whether it would be possible to ground the description with some specific examples.

my 2 cents from a *super* quick flip through (so please take with a big grain of salt!)

Lixia
  <>From: Dirk Kutscher 
> To: [email-masked] <mailto:[email-masked]>
> at the Berlin meeting, we concluded that we’d use the mailing list to agree on next steps for draft-zhang-icnrg-icniot-requirements [1].
>  
> In case you don’t remember, this draft is the result of a merger of draft-zhang-iot-icn-challenges-02 [2] and draft-lindgren-icnrg-efficientiot-03 [3], focusing on the scenario, requirements and challenges aspects of both input drafts.
>  
> Please see https://www.ietf.org/proceedings/96/slides/slides-96-icnrg-3.pdf <https://www.ietf.org/proceedings/96/slides/slides-96-icnrg-3.pdf> for a summary of the genesis and the current content.
>  
> The chairs would like to get an understanding whether the ICNRG has an interest in pursuing this draft as a RG activity (“adoption”). We normally do this for drafts where there is a critical mass of interested people that would like to see this progressing within ICNRG and eventually be published as an (in this case, Informational)  RFC. This would also require a critical mass of people that would be interested to spend cycles for reviewing the draft and future revisions.
>  
> Could you please let us know whether you think this draft a) should be adopted as a RG item and b) whether you’d be able to help reviewing it?
>  
> Thanks,
> [1] https://datatracker.ietf.org/doc/draft-zhang-icnrg-icniot-requirements/ <https://datatracker.ietf.org/doc/draft-zhang-icnrg-icniot-requirements/>
> [2] https://tools.ietf.org/html/draft-zhang-iot-icn-challenges-02 <https://tools.ietf.org/html/draft-zhang-iot-icn-challenges-02>
> [3] https://datatracker.ietf.org/doc/draft-lindgren-icnrg-efficientiot/03/ <https://datatracker.ietf.org/doc/draft-lindgren-icnrg-efficientiot/03/>
>  
>  
> _______________________________________________
> icnrg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/icnrg <https://www.irtf.org/mailman/listinfo/icnrg>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Sat, 17 Sep 2016 12:05:49 -0400

I agree with Lixia. This needs more focus. Security is yes weak and should not be an afterthought. But I think the justification of ICN for IOT needs more in-depth descriptions and use cases. I can see many reasons to use ICN in IOT (flexibility in caching, storage and retrieval, naming abstraction, abstracted functionalities) but almost as many reasons not too (added complexity, lack of backward compatibility, firmware development in sensor networks) etc. A few solid examples and I would say solid implementations comparing the advantages of ICN vs. current implementations would be great. Our houses are already filled with IOT apps; how will ICN make them better?

I am not saying the draft is bad. Just that it needs more work before truly reflecting the gains that ICN will bring to IOT.

Marie-José

> On Sep 17, 2016, at 11:54 AM, Lixia Zhang <[email-masked]> wrote:
> 
> 
>> On Sep 16, 2016, at 9:00 AM, Dirk Kutscher <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi all,
>>  
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Cedric Westphal <[email-masked]>
Date: Mon, 19 Sep 2016 20:29:37 +0000

I agree with Lixia and Marie-Jose that this draft would benefit from being worked on by the  RG. I support adoption as a WG document.
Best,

C.

From: icnrg [mailto:[email-masked]] On Behalf Of Marie-Jose Montpetit
Sent: Saturday, September 17, 2016 9:06 AM
To: Lixia Zhang
Cc: [email-masked]; Dirk Kutscher
Subject: Re: [icnrg] next stepd for draft-zhang-icnrg-icniot-requirements

Marie-José

On Sep 17, 2016, at 11:54 AM, Lixia Zhang <[email-masked]<mailto:[email-masked]>> wrote:

On Sep 16, 2016, at 9:00 AM, Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Lixia

From: Dirk Kutscher
Sent: Montag, 8. August 2016 17:33
To: [email-masked]<mailto:[email-masked]>
Subject: next stepd for draft-zhang-icnrg-icniot-requirements

Hi all,

Thanks,

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Gennaro Boggia <[email-masked]>
Date: Wed, 21 Sep 2016 10:33:41 +0200

I agree with the previous comments and I support the adoption of it as
a WG document

Best Regards
Gennaro

--
Gennaro Boggia, PhD
Associate Professor
DEI - Politecnico di Bari
v. Orabona 4
70125 Bari (Italy)
Tel. +39 080 5963913
Fax +39 080 5963410
Skype: g.boggia
e-mail: [email-masked]; [email-masked]
web: http://telematics.poliba.it/boggia

2016-09-19 22:29 GMT+02:00 Cedric Westphal <[email-masked]>:
> I agree with Lixia and Marie-Jose that this draft would benefit from being
> worked on by the  RG. I support adoption as a WG document.
>
> Best,
>
>
>
> C.
>
>
>
> I agree with Lixia. This needs more focus. Security is yes weak and should
> not be an afterthought. But I think the justification of ICN for IOT needs
> more in-depth descriptions and use cases. I can see many reasons to use ICN
> in IOT (flexibility in caching, storage and retrieval, naming abstraction,
> abstracted functionalities) but almost as many reasons not too (added
> complexity, lack of backward compatibility, firmware development in sensor
> networks) etc. A few solid examples and I would say solid implementations
> comparing the advantages of ICN vs. current implementations would be great.
> Our houses are already filled with IOT apps; how will ICN make them better?
>
>
>
> I am not saying the draft is bad. Just that it needs more work before truly
> reflecting the gains that ICN will bring to IOT.
>
>
>
> Marie-José
>
>
>
>
>
>
>
> I just had a quick look over the draft: it seems to me that this draft still
> left lots rooms for improvements, not the least is its treatment on
> security.  The current draft seems reflecting the common mindset that
> security is something one has to mention, not that security is an integral
> component in all aspects of a system.
>
>
>
> Section 2: would it be more appropriate to move security from section 2.8 to
> section 2.2, right after naming?  given security needs crypto protection,
> crypto is directly related to identities
>
>
>
> Section 5, like section 2, puts security discussions much later after  other
> subjects that may be felt more familiar with, like name resolution, caching
> and storage, routing/forwarding, etc.--aren't al these components need
> security as well?
>
> Another comment is a wish: the draft looks really
> abstract/motherhood-and-applepie to me, I wonder whether it would be
> possible to ground the description with some specific examples.
>
>
>
> at the Berlin meeting, we concluded that we’d use the mailing list to agree
> on next steps for draft-zhang-icnrg-icniot-requirements [1].
>
>
>
> In case you don’t remember, this draft is the result of a merger of
> draft-zhang-iot-icn-challenges-02 [2] and
> draft-lindgren-icnrg-efficientiot-03 [3], focusing on the scenario,
> requirements and challenges aspects of both input drafts.
>
>
>
> Please see https://www.ietf.org/proceedings/96/slides/slides-96-icnrg-3.pdf
> for a summary of the genesis and the current content.
>
>
>
> The chairs would like to get an understanding whether the ICNRG has an
> interest in pursuing this draft as a RG activity (“adoption”). We normally
> do this for drafts where there is a critical mass of interested people that
> would like to see this progressing within ICNRG and eventually be published
> as an (in this case, Informational)  RFC. This would also require a critical
> mass of people that would be interested to spend cycles for reviewing the
> draft and future revisions.
>
>
>
> Could you please let us know whether you think this draft a) should be
> adopted as a RG item and b) whether you’d be able to help reviewing it?
>
>
>
> Thanks,
>

---

From: "Moustafa, Hassnaa" <[email-masked]>
Date: Sat, 24 Sep 2016 00:30:04 +0000

I support the adoption of this draft as a WG document. This draft is a very good basis and be a very useful guideline for ICN deployment for IOT. And the comments below are so useful to consider. It would be also of value to show examples for delay sensitive applications in IOT and how ICN can be a better solution.

Thanks
Hassnaa

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Gennaro Boggia
Sent: Wednesday, September 21, 2016 1:34 AM
To: Cedric Westphal <[email-masked]>
Cc: Dirk Kutscher <[email-masked]>; Marie-Jose Montpetit <[email-masked]>; [email-masked]; Lixia Zhang <[email-masked]>
Subject: Re: [icnrg] next stepd for draft-zhang-icnrg-icniot-requirements

I agree with the previous comments and I support the adoption of it as a WG document

Best Regards
Gennaro

2016-09-19 22:29 GMT+02:00 Cedric Westphal <[email-masked]>:
> I agree with Lixia and Marie-Jose that this draft would benefit from 
> being worked on by the  RG. I support adoption as a WG document.
>
> Best,
>
>
>
> C.
>
>
>
> I agree with Lixia. This needs more focus. Security is yes weak and 
> should not be an afterthought. But I think the justification of ICN 
> for IOT needs more in-depth descriptions and use cases. I can see many 
> reasons to use ICN in IOT (flexibility in caching, storage and 
> retrieval, naming abstraction, abstracted functionalities) but almost 
> as many reasons not too (added complexity, lack of backward 
> compatibility, firmware development in sensor
> networks) etc. A few solid examples and I would say solid 
> implementations comparing the advantages of ICN vs. current implementations would be great.
> I am not saying the draft is bad. Just that it needs more work before 
> truly reflecting the gains that ICN will bring to IOT.
>
>
>
> Marie-José
>
>
>
>
>
>
>
> Please let us have your opinion on how to pursue with this draft. Do 
> you support adopting it as an RG document?
>
>
>
> I just had a quick look over the draft: it seems to me that this draft 
> still left lots rooms for improvements, not the least is its treatment 
> on security.  The current draft seems reflecting the common mindset 
> that security is something one has to mention, not that security is an 
> integral component in all aspects of a system.
>
>
>
> Section 2: would it be more appropriate to move security from section 
> 2.8 to section 2.2, right after naming?  given security needs crypto 
> protection, crypto is directly related to identities
>
>
>
> Section 5, like section 2, puts security discussions much later after  
> other subjects that may be felt more familiar with, like name 
> resolution, caching and storage, routing/forwarding, etc.--aren't al 
> these components need security as well?
>
> at the Berlin meeting, we concluded that we’d use the mailing list to 
> agree on next steps for draft-zhang-icnrg-icniot-requirements [1].
>
>
>
> Please see 
> https://www.ietf.org/proceedings/96/slides/slides-96-icnrg-3.pdf
> interest in pursuing this draft as a RG activity (“adoption”). We 
> normally do this for drafts where there is a critical mass of 
> interested people that would like to see this progressing within ICNRG 
> and eventually be published as an (in this case, Informational)  RFC. 
> This would also require a critical mass of people that would be 
> interested to spend cycles for reviewing the draft and future revisions.
>
>
>
> [1] 
> https://datatracker.ietf.org/doc/draft-zhang-icnrg-icniot-requirements
> /
>
> [3] 
> https://datatracker.ietf.org/doc/draft-lindgren-icnrg-efficientiot/03/
>
>
>
>
>