Subject: [icnrg] ICN applied to the IoT

From: "Aisling O' Driscoll" <[email-masked]>
Date: Tue, 12 Sep 2017 12:21:14 +0100

Hi all,

I'm new to the mailing list so greetings!

I'm attending the ACM ICN conference in 2 weeks so looking forward to
meeting many of you there.

I recently joined the academic staff in the Department to Computer Science
in University College Cork (Ireland) and am interested in investigating ICN,
particularly its application within the IoT. My background is in network
communication protocols, specifically geo-routing and location service
protocol design for ad-hoc networks.

This is an area that is new to me but one that I'm interested in exploring.
If I anyone has any suggestions/opportunities for the best way to connect in
with existing work in this space or is searching for an able and interested
person to further explore some of the existing research challenges please
let me know.

Best regards,

Aisling O' Driscoll.

---

From: Nikos Fotiou <[email-masked]>
Date: Tue, 12 Sep 2017 14:25:59 +0300

Hi Aisling,
During the ACM ICN conference we will have an interesting demo on the benefits of running CoAP over ICN. See you there :)

Best,
Nikos

> On 12 Sep 2017, at 14:21, Aisling O' Driscoll <[email-masked]> wrote:
> 
> Hi all,
> 
> I’m new to the mailing list so greetings!
> 
> I’m attending the ACM ICN conference in 2 weeks so looking forward to meeting many of you there.
> 
> I recently joined the academic staff in the Department to Computer Science in University College Cork (Ireland) and am interested in investigating ICN, particularly its application within the IoT. My background is in network communication protocols, specifically geo-routing and location service protocol design for ad-hoc networks.
> 
> This is an area that is new to me but one that I’m interested in exploring. If I anyone has any suggestions/opportunities for the best way to connect in with existing work in this space or is searching for an able and interested person to further explore some of the existing research challenges please let me know.
> 
> Best regards,
> 
> Aisling O’ Driscoll.
> 
>  
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Cenk Gündoğan <[email-masked]>
Date: Tue, 12 Sep 2017 14:05:40 +0200

Hi Aisling,

> meeting many of you there.

we will steer the full-day tutorial [1] @ACM ICN 17 and---amongst other
things---participants will learn about minimal CCNx/NDN forwarder
implementations like CCN-lite and NDN-RIOT running on
resource-constrained IoT hardware (~64K RAM and possibly below).
Especially if you plan on performing experiments that go beyond
simulations and emulations, then our RIOT [2] based track will be of
interest to you. We also will provide a primer on how to deploy RIOT
based ICN applications in large-scale using the IoTLab testbed [3].

[1] http://conferences.sigcomm.org/acm-icn/2017/tutorial-ndn-ccnlite-riot.html
[2] https://riot-os.org/
[3] https://www.iot-lab.info/

> person to further explore some of the existing research challenges please

Well, there certainly is some existing work around. If you happen to
have any questions regarding RIOT+ICN then I will be glad to answer
them as well as I can (:

Cheers,
Cenk

-- 
Cenk Gündoğan

Hamburg University of Applied Sciences
Dept. of Computer Science / Internet Technologies Group
Berliner Tor 7, 20099 Hamburg, Germany
Fon: +49 40 42875 - 8426
Mail: [email-masked]
Web: https://www.inet.haw-hamburg.de/

---

From: [email-masked]
Date: Tue, 12 Sep 2017 14:34:22 +0200

Am 12.09.2017 14:05, schrieb Cenk Gündoğan:
> [1] 
> http://conferences.sigcomm.org/acm-icn/2017/tutorial-ndn-ccnlite-riot.html
> [2] https://riot-os.org/

..and there is a Riot Summit in advance to the conference: 
http://summit.riot-os.org/2017

> have any questions regarding RIOT+ICN then I will be glad to answer

Cheers,
Claudio

---

From: "Aisling O' Driscoll" <[email-masked]>
Date: Tue, 12 Sep 2017 14:15:24 +0100

Hi all,

Thanks for the replies so far – I look forward to meeting you and am knee deep reading papers :) The below is most certainly included. 

A high level question for you (hopefully not unintentionally contentious)…

There seems to be a school of thought that adoption of ICN (whatever architecture that may be) may never come about because of the amount of effort and money already invested in TCP/IP. A more optimistic view is that the deployment will most likely being a hybrid ICN over IP with a slow phase out over 20-30 years. 

Extending this to the IoT, I would foresee that a hybrid stack isn’t feasible as the goal is to lighten the stack not increase its complexity which may not be feasible for resource constrained devices. So does sufficient quantitative evidence exist to provide a very strong and compelling motivation for why IoT should transition from the CoAP/UDP/RPL/IPv6/6LoWPAN/802.15.4 stack to an ICN approach in terms of network performance benefits or is the argument that IoT is still relatively in its infancy and thus a clean slate approach is still feasible given that ICN is naturally a better fit without providing a strong migration argument? I do note that some quantitative evaluation was conducted in a sub-section in a paper “ICN in the IoT: Experiments with NDN in the Wild” (really interesting paper).

It seems like there is significantly further work to be done to provide quantitative motivation. Is this a fair observation? I’d be interested to hear your opinions.

Best,
Aisling

-----Original Message-----
From: Anders Lindgren [mailto:[email-masked]] 
Sent: Tuesday 12 September 2017 12:38
To: Aisling O' Driscoll
Cc: [email-masked]
Subject: Re: [icnrg] ICN applied to the IoT

Hi Aisling,

Please consider having a look at our internet draft "Design Considerations for Applying ICN to IoT” https://tools.ietf.org/id/draft-zhang-icnrg-icniot-01.html that is currently being worked on by several people in the research group.
We would appreciate any comments and feedback you have on the document.

Best regards,

/Anders

> 12 sep. 2017 kl. 13:21 skrev Aisling O' Driscoll <[email-masked]>:
> 
> Hi all,
>

---

From: "Aisling O' Driscoll" <[email-masked]>
Date: Tue, 12 Sep 2017 14:30:07 +0100

Thanks Cenk for the pointers. I have already signed up to IoTLab testbed and am also signed up for the day long tutorial so very interested to see the below.

Aisling.

-----Original Message-----
From: Cenk Gündoğan [mailto:[email-masked]] 
Sent: Tuesday 12 September 2017 13:06
To: [email-masked]
Subject: Re: [icnrg] ICN applied to the IoT

Hi Aisling,

> meeting many of you there.

we will steer the full-day tutorial [1] @ACM ICN 17 and---amongst other things---participants will learn about minimal CCNx/NDN forwarder implementations like CCN-lite and NDN-RIOT running on resource-constrained IoT hardware (~64K RAM and possibly below).
Especially if you plan on performing experiments that go beyond simulations and emulations, then our RIOT [2] based track will be of interest to you. We also will provide a primer on how to deploy RIOT based ICN applications in large-scale using the IoTLab testbed [3].

> I recently joined the academic staff in the Department to Computer 
> Science in University College Cork (Ireland) and am interested in 
> investigating ICN, particularly its application within the IoT. My 
> background is in network communication protocols, specifically 
> geo-routing and location service protocol design for ad-hoc networks.
> 
> If I anyone has any suggestions/opportunities for the best way to 
> connect in with existing work in this space or is searching for an 
> able and interested person to further explore some of the existing 
> research challenges please let me know.
> 

Well, there certainly is some existing work around. If you happen to have any questions regarding RIOT+ICN then I will be glad to answer them as well as I can (:

Cheers,
Cenk

--
Cenk Gündoğan

Hamburg University of Applied Sciences
Dept. of Computer Science / Internet Technologies Group Berliner Tor 7, 20099 Hamburg, Germany
Fon: +49 40 42875 - 8426
Mail: [email-masked]
Web: https://www.inet.haw-hamburg.de/

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 12 Sep 2017 13:41:42 +0000

Hi Aisling,

We have been looking at the possible ICN migration paths in

https://tools.ietf.org/html/draft-rahman-icnrg-deployment-guidelines-03

I think many of the questions that you asked are addressed there.  Any feedback on the list would be much appreciated as the draft as slated for WG adoption after getting some more review feedback.

/Akbar

<http://ir.interdigital.com/File/Index?KeyFile=37447876>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Aisling O' Driscoll
Sent: Tuesday, September 12, 2017 9:15 AM
To: 'Anders Lindgren' <[email-masked]>
Cc: [email-masked]
Subject: Re: [icnrg] ICN applied to the IoT

Hi all,

Best,
Aisling

-----Original Message-----
From: Anders Lindgren [mailto:[email-masked]]
Sent: Tuesday 12 September 2017 12:38
To: Aisling O' Driscoll
Cc: [email-masked]
Subject: Re: [icnrg] ICN applied to the IoT

Hi Aisling,

Best regards,

/Anders

---

From: Ravi Ravindran <[email-masked]>
Date: Tue, 12 Sep 2017 17:47:40 +0000

Hi Aisling,

These are two ICN-IoT drafts under discussion in the group right now:

ICN-IoT Design Considerations draft:
https://tools.ietf.org/html/draft-zhang-icnrg-icniot-01

ICN-IoT Architecture draft:
https://tools.ietf.org/html/draft-zhang-icnrg-icniot-architecture-01

Do share your comments on them.

Regards,
Ravi

-----Original Message-----
From: icnrg [mailto:[email-masked]] On Behalf Of Aisling O' Driscoll
Sent: Tuesday, September 12, 2017 6:30 AM
To: 'Cenk Gündoğan' <[email-masked]>; [email-masked]
Subject: Re: [icnrg] ICN applied to the IoT

Aisling.

-----Original Message-----
From: Cenk Gündoğan [mailto:[email-masked]]
Sent: Tuesday 12 September 2017 13:06
To: [email-masked]
Subject: Re: [icnrg] ICN applied to the IoT

Hi Aisling,

Cheers,
Cenk

--
Cenk Gündoğan

---

From: "Thomas C. Schmidt" <[email-masked]>
Date: Tue, 12 Sep 2017 19:51:47 +0200

Also hi,

there is a third regarding pub-sub in the IoT:

  * http://tools.ietf.org/html/draft-gundogan-icnrg-pub-iot

Shortly, there will follow a draft on 802.14.5 convergence (also 
draft-gundogan ...) - watch for it.

Cheers,
  Thomas

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                   Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany °
° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452 °
° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409 °

---

From: Anders Lindgren <[email-masked]>
Date: Tue, 12 Sep 2017 11:38:01 +0000

Hi Aisling,

Best regards,

/Anders