Subject: [icnrg] I-D Action: draft-irtf-icnrg-ccnxsemantics-07.txt

From: [email-masked]
Date: Mon, 19 Mar 2018 08:38:38 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Information-Centric Networking RG of the IRTF.

        Title           : CCNx Semantics
        Authors         : Marc Mosko
                          Ignacio Solis
                          Christopher A. Wood
	Filename        : draft-irtf-icnrg-ccnxsemantics-07.txt
	Pages           : 35
	Date            : 2018-03-19

Abstract:
   This document describes the core concepts of the Content Centric
   Networking (CCNx) architecture and presents a network protocol based
   on two messages: Interests and Content Objects.  It specifies the set
   of mandatory and optional fields within those messages and describes
   their behavior and interpretation.  This architecture and protocol
   specification is independent of a specific wire encoding.

   The protocol also uses a Control message called an InterestReturn,
   whereby one system can return an Interest message to the previous hop
   due to an error condition.  This indicates to the previous hop that
   the current system will not respond to the Interest.

   This document is a product of the Information Centric Networking
   research group (ICNRG).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxsemantics/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-icnrg-ccnxsemantics-07
https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-ccnxsemantics-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-ccnxsemantics-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Luca Muscariello <[email-masked]>
Date: Tue, 20 Mar 2018 19:23:32 +0100

I think we need to double check the new paragraph that provides a
description of the differences with NDN.
We need help from NDN team to get information about the differences as
recent updates to the NDN system
might affect this paragraph.

Personally I would remove it, but I understand that it comes from an
explicit request of a reviewer.

On Mon, Mar 19, 2018 at 4:38 PM, <[email-masked]> wrote:

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>

---

From: Luca Muscariello <[email-masked]>
Date: Tue, 20 Mar 2018 22:45:57 +0100

the new  section

12. Security Considerations
is good. Just a typo in this section that affects both drafts

diff --git a/src/draft-irtf-icnrg-ccnxmessages.xml
b/src/draft-irtf-icnrg-ccnxmessages.xml
index 017017d..88b6fbe 100644
--- a/src/draft-irtf-icnrg-ccnxmessages.xml
+++ b/src/draft-irtf-icnrg-ccnxmessages.xml
@@ -1990,7 +1990,7 @@
                One key exchange specification is <xref
target="ccnxke">CCNxKE</xref>  <xref target="mobile"/>,
                which is similar to the
                TLS 1.3 key exchange except it is over the CCNx layer 3
messages.  Trust is beyond the scope of
-               a layer-3 protocol protocol and left to applications or
application frameworks.
+               a layer-3 protocol and left to applications or application
frameworks.

---

From: Luca Muscariello <[email-masked]>
Date: Tue, 20 Mar 2018 22:48:19 +0100

And side question:
Why is this section replicated in both drafts?
A reviewer's request?

On Tue, Mar 20, 2018 at 10:45 PM, Luca Muscariello <
[email-masked]> wrote:

> diff --git a/src/draft-irtf-icnrg-ccnxmessages.xml b/src/draft-irtf-icnrg-
> ccnxmessages.xml

---

From: <[email-masked]>
Date: Tue, 20 Mar 2018 21:55:10 +0000

Both drafts need a security considerations section.  It seemed there were three options: (1) do a document specific section in each, (2) do it all in semantics and have messages reference it, (3) do the same section in both documents.

I went with option #3. If one of the other options makes more sense (or some 4th option I didn’t consider), I’m willing to update to that approach.

Marc

On Mar 20, 2018, at 2:48 PM, Luca Muscariello <[email-masked]<mailto:[email-masked]>> wrote:

And side question:

On Tue, Mar 20, 2018 at 10:45 PM, Luca Muscariello <[email-masked]<mailto:[email-masked]>> wrote:
the new  section

diff --git a/src/draft-irtf-icnrg-ccnxmessages.xml b/src/draft-irtf-icnrg-ccnxmessages.xml
index 017017d..88b6fbe 100644
--- a/src/draft-irtf-icnrg-ccnxmessages.xml
+++ b/src/draft-irtf-icnrg-ccnxmessages.xml
@@ -1990,7 +1990,7 @@
                One key exchange specification is <xref target="ccnxke">CCNxKE</xref>  <xref target="mobile"/>,
                which is similar to the
                TLS 1.3 key exchange except it is over the CCNx layer 3 messages.  Trust is beyond the scope of
-               a layer-3 protocol protocol and left to applications or application frameworks.
+               a layer-3 protocol and left to applications or application frameworks.

On Mon, Mar 19, 2018 at 4:38 PM, <[email-masked]<mailto:[email-masked]>> wrote:

        Title           : CCNx Semantics
        Authors         : Marc Mosko
                          Ignacio Solis
                          Christopher A. Wood

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: <[email-masked]>
Date: Tue, 20 Mar 2018 21:58:23 +0000

Thanks for the feedback.  I’m willing to remove the section on the differences (which I tried to limit to the layer 3 differences) and just leave it as a citation to other work derived from the original CCNx 0.x protocol.  I’ll wait to see if there’s more feedback on this, then suggest some updated text.

Marc

On Mar 20, 2018, at 11:23 AM, Luca Muscariello <[email-masked]<mailto:[email-masked]>> wrote:

I think we need to double check the new paragraph that provides a description of the differences with NDN.
We need help from NDN team to get information about the differences as recent updates to the NDN system
might affect this paragraph.

Personally I would remove it, but I understand that it comes from an explicit request of a reviewer.

        Title           : CCNx Semantics
        Authors         : Marc Mosko
                          Ignacio Solis
                          Christopher A. Wood

Abstract:

---

From: Luca Muscariello <[email-masked]>
Date: Tue, 20 Mar 2018 23:18:51 +0100

If they need to have a security section, option 3 is the best one.

On Tue, Mar 20, 2018 at 10:55 PM, <[email-masked]> wrote:

> Both drafts need a security considerations section.  It seemed there were
> three options: (1) do a document specific section in each, (2) do it all in
> semantics and have messages reference it, (3) do the same section in both
> documents.
>
> I went with option #3. If one of the other options makes more sense (or
> some 4th option I didn’t consider), I’m willing to update to that approach.
>
> Marc
>
> On Mar 20, 2018, at 2:48 PM, Luca Muscariello <[email-masked]>
> wrote:
>
> And side question:

---

From: Luca Muscariello <[email-masked]>
Date: Tue, 20 Mar 2018 23:24:35 +0100

After the recent modifications to the NDN architecture there is a chance
that the differences would reduce to an almost empty set.
To avoid to submit a 08 version that might miss these recent updates in
NDN, I would remove all that an just leave a citation.

And BTW, thank you for the work done Marc.

On Tue, Mar 20, 2018 at 10:58 PM, <[email-masked]> wrote:

> Thanks for the feedback.  I’m willing to remove the section on the
> differences (which I tried to limit to the layer 3 differences) and just
> leave it as a citation to other work derived from the original CCNx 0.x
> protocol.  I’ll wait to see if there’s more feedback on this, then suggest
> some updated text.
>
> Marc
>
> On Mar 20, 2018, at 11:23 AM, Luca Muscariello <[email-masked]>
> wrote:
>

---

From: Lixia Zhang <[email-masked]>
Date: Sun, 25 Mar 2018 18:09:03 -0700

> Thanks for the feedback.  I’m willing to remove the section on the differences (which I tried to limit to the layer 3 differences) and just leave it as a citation to other work derived from the ori…

sorry for this belated reply: assuming you are still waiting for feedback,
- I assume the above refers to paragraphs 3 & 4 in introduction?
- if so, I suggest they be removed as the description does not seem accurate or correct

(one example: "A forwarding strategy must be implemented at each forwarder. On a match, a forwarder returns the entire response (e.g. several kilobytes to megabytes of data) hop-by-hop to the requester" ???)

> 
>> On Mar 20, 2018, at 11:23 AM, Luca Muscariello <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> On Mon, Mar 19, 2018 at 4:38 PM, <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxsemantics/ <https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccnxsemantics/>
>> 
>> https://tools.ietf.org/html/draft-irtf-icnrg-ccnxsemantics-07 <https://tools.ietf.org/html/draft-irtf-icnrg-ccnxsemantics-07>
>> https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-ccnxsemantics-07 <https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-ccnxsemantics-07>
>> 
>> https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-ccnxsemantics-07 <https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-ccnxsemantics-07>
>> 
>> 
>> until the htmlized version and diff are available attools.ietf.org <http://tools.ietf.org/>.
>> 
>> ftp://ftp.ietf.org/internet-drafts/ <ftp://ftp.ietf.org/internet-drafts/>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/icnrg <https://www.irtf.org/mailman/listinfo/icnrg>
>> 
>

---

From: Christopher Wood <[email-masked]>
Date: Mon, 26 Mar 2018 16:01:06 +0000

> - if so, I suggest they be removed as the description does not seem

FWIW, offering comparison text seems to be the right approach. If the text
is inaccurate, corrections or pointers to *up to date* documentation are
welcome.

Best,
Chris

---

From: Lixia Zhang <[email-masked]>
Date: Mon, 26 Mar 2018 13:50:51 -0700

> On Mar 26, 2018, at 9:01 AM, Christopher Wood <[email-masked]> wrote:
> 
> On Sun, Mar 25, 2018 at 6:09 PM Lixia Zhang <[email-masked] <mailto:[email-masked]>> wrote:
> On Mar 20, 2018, at 2:58 PM, [email-masked] <mailto:[email-masked]> wrote:
>> 
> FWIW, offering comparison text seems to be the right approach. If the text is inaccurate, corrections or pointers to *up to date* documentation are welcome. 
> 
> Best,
> Chris

Personally I do not believe the comparison material belonging to this document which is titled CCNx semantics.
I see the need for a comparison document.

Lixia