Subject: [icnrg] Implementation of Named-Data Networking for Wireless Networks

From: Paulo Mendes <[email-masked]>
Date: Fri, 2 Mar 2018 14:55:19 +0000

Dear all

Yesterday we released V1.0 of NDN-OPP (NDN Android for opportunistic wireless networks) and V1.0 of Oi! (a short message app that works on top of NDN Android and NDN-OPP).  This work is being done in the EU project UMOBILE.

NDN-OPP extends NFD for operation in wireless multi-hop networks with intermittent connectivity. V1.0 provides direct wireless communication based on Wi-Fi direct (new Face) and is able of exploiting available open wireless access points.

Oi! is a short message application that works on top of NDN Android and NDN-OPP. In the latter case Oi! makes usage of the push communication models implemented in NDN-OPP that allows messages to be forwarded to local authorities and pushed to nearby users (in emergency cases).

Links to Code + Technical Reports + APKs:

A) NDN-OPP

- Code on Github: https://github.com/COPELABS-SITI/ndn-opp/tree/version-1.0 <https://github.com/COPELABS-SITI/ndn-opp/tree/version-1.0>
- Technical Report: http://siti2.ulusofona.pt:8085/xmlui/handle/20.500.11933/742 <http://siti2.ulusofona.pt:8085/xmlui/handle/20.500.11933/742>
- Application on Google Play: https://play.google.com/store/apps/details?id=pt.ulusofona.copelabs.ndn <https://play.google.com/store/apps/details?id=pt.ulusofona.copelabs.ndn>

B) Oi!

- Code on Github: https://github.com/COPELABS-SITI/Oi <https://github.com/COPELABS-SITI/Oi>
- Technical Report: http://siti2.ulusofona.pt:8085/xmlui/handle/20.500.11933/743 <http://siti2.ulusofona.pt:8085/xmlui/handle/20.500.11933/743>
- Application on Google Play: https://play.google.com/store/apps/details?id=pt.ulusofona.copelabs.oi <https://play.google.com/store/apps/details?id=pt.ulusofona.copelabs.oi>

Just try it… Feedback is most welcomed.

NDN-OPP V1.0 is being used to implement the Dabber routing protocol (draft-mendes-icnrg-dabber-00), which will be presented in ICNRG meeting in London.

Melhores Cumprimentos / Best Regards / Mit freundlichen Grüßen
------------------------------------------------
Paulo Mendes, Ph.D
Coordinator SITI group @ COPELABS (http://siti.ulusofona.pt)
Director of NEMPS PhD program (http://nemps.ulusofona.pt <http://nemps.ulusofona.pt/>)
Associated Professor at University Lusofona, Portugal

http://www.paulomilheiromendes.com <http://www.paulomilheiromendes.com/>
Tel: +351 217 50 50 22

---

From: Paulo Mendes <[email-masked]>
Date: Sun, 18 Mar 2018 13:56:54 +0000

Dear all

Last Friday, the implementations of NDN for opportunistic wireless networks (NDN-OPP) and the NDN-based short message application (Oi!) were upgraded.

You can find the new apps in Google Play and code in GitHub (links below).

Major changes are:

A) Oi! application

- Country Code has been added to the user configuration aiming to reduce the mismatch between the ID of the user and the ID coming in a session request (INT packet). Complementary, it was added a filter to only allow the setup of communication sessions with the contacts that have registered country code in your Android contact list.This update improves the behaviour of the app, but it is still not ideal. Work in progress in order to devise a distributed ID management scheme.

- The live-time of the Interests generated by Oi! was increased to accommodate the Wi-Fi direct scanning interval, aiming to improve the operation in connectionless mode.

B) NDN-Opp:

- The stability of the connectionless communication mode was improved with a better management of the TXT record acknowledgement.

A) NDN-OPP

- Code on Github: https://github.com/COPELABS-SITI/ndn-opp/tree/version-1.0
- Technical Report: http://siti2.ulusofona.pt:8085/xmlui/handle/20.500.11933/742
- Application on Google Play: https://play.google.com/store/apps/details?id=pt.ulusofona.copelabs.ndn

B) Oi!

- Code on Github: https://github.com/COPELABS-SITI/Oi
- Technical Report: http://siti2.ulusofona.pt:8085/xmlui/handle/20.500.11933/743
- Application on Google Play: https://play.google.com/store/apps/details?id=pt.ulusofona.copelabs.oi

> On 02 Mar 2018, at 14:55, Paulo Mendes <[email-masked]> wrote:
> 
> Dear all
> 
> Coordinator SITI group @ COPELABS (http://siti.ulusofona.pt <http://siti.ulusofona.pt/>)