Subject: [icnrg] A call from the Decentralized Web Summit

From: [email-masked]
Date: Thu, 2 Aug 2018 18:41:11 +0200 (CEST)

Dear community,

I'm currently attending the "Decentralized Web Summit" in San Francisco [1]. It is --or would be-- highly relevant to this group. Although I have a paper accepted for ICN'2018 that looks into distributed apps over ICN, I have to say that what I see here easily outpaces this. Two small examples:

Secure Scuttlebutt (SSB, [2]) says about itself: "SSB is hostless". It has a 8KB MTU, they are based on replicated repos and use hashes as data names. To me it's a prototytpical "app-level ICN".

Perkeeper is a peer-to-peer blob store, see [3]. Quote: "Perkeep (née Camlistore) is a set of open source formats, protocols, and software for modeling, storing, searching, sharing and synchronizing data in the post-PC era." That's would fit ICN's mission of interconnecting repos, right?

Then there are the many secure, chat-like services (Matrix, status.im, Briar, stealthy.im), some come with a userbase of 1.4 Mio users, all following a decentralized approach where host names are irrelevant, identity is not linked to DNS, they build their own trust (and signing) infrastructures ... as we propose in ICN.

I tried to sell ICN, NDN, the Boston conference. It seems that some people had heard about ICN (Van was present at a panel of the 1. Decentralied Web Summit) but they turned away as there was nothing tangible to use. Named Function seemed to be something that has no been on their radar, though.

Why I say all this: People ARE doing data-centric apps, there IS a fierce energy to redo the web and major players (including Tim Berners-Lee with SOLID, W3C and Microsoft and many others adopting DID (Distributed IDs) etc) are involved. But they still use the IP stack. I think that the ICN community MUST engage with a lot of energy with this crowd as this crowd will plow away and will not wait for us.

One important point of contact and of intersection is the packet format, unsurprisingly. But I sense that we as ICN community are not seeing the big ships that are already sailing or are about to take off in this area.  Sure, JOSE (RFC 7515 and many others) is not a suitable network-level packet format, but this is not easily said for COSE (RFC8152, based on the CBOR encoding). And just a two months ago, MLS got chartered (Message Layer Security), see [4], this will be huge.

These formats are or will become the standard against which distributed app writers will program. It is unthinkable that a second, lower ICN-layer format with exactly the same aim and semantics will be able to survive. I therefore strongly suggest to have a look at these standards, to either adopt stuff like COSE, or heavily meddle with the upcoming MLS. Which means to talk with the app writers that are preparing the next web.

Now the sessions resume, currently an interview with Whitfield Diffie.

A wake-up call? I take this more positively: Just wanted to point out an opportunity that we cannot afford to miss.

best, christian

[1] https://decentralizedweb.net/
[2] https://ssbc.github.io/secure-scuttlebutt/
[3] https://perkeep.org/
[4] https://datatracker.ietf.org/wg/mls/about/

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 03 Aug 2018 12:23:11 +0200

Hi Christian,

thanks for the note!

Decentralized web has been on our radar (I think I posted a pointer to the 1st summit here), and it's great to hear that there is more decentralized application development going on.

This is indeed highly interesting and relevant. A significant factor in the decentralization discussion seems to be the possibility to flexibly establish and manage trust.

The decentralized web community and the related apps seem to approach this from the application layer (re-using establish protocols or using them in new ways).

The ICN community has (in general) worked on ways to make the network more useful for applications, i.e. designing a network layer that is more amenable to efficient, secure, decentralized communication.

Some ICN research efforts are also shifting the traditional boundaries between network and application layer (you could argue that using a named data abstraction is a first step in this direction): manifests,  remote method invocation, data set synchronization, and the data structure ideas that you mentioned.

Also people are working on ICN applications such as video distribution, AR, edge computing that could be characterized as web applications. Sometimes these developments suggest that an ICN-supported web could help to overcome current silos in connecting computation ("edge computing") -- and to make in-network functions elements of a more decentralized web.

Indeed, it should be interesting to compare this to thoughts of the web/app community, but also to expose relevant ICN work more in these community.

On a positive note, one could make the point that a better network layer as discussed above also enables us to make better design choices on the app layer. The best way to prove that may be to develop apps that can demonstrate that point.

In any case, I'd be happy to discuss this more.

Thanks again for bringing it up -- enjoy the rest of the conference.

Best regards,

Dirk

P.S.: I'd like a Xanadu espresso. ;-)

Am 02.08.2018 18:41 schrieb [email-masked]:

Dear community,

best, christian

[3] https://perkeep.org/

_______________________________________________

icnrg mailing list

[email-masked]

https://www.irtf.org/mailman/listinfo/icnrg