Subject: Re: [icnrg] Moving NRS documents to RG documents

From: Ravi Ravindran <[email-masked]>
Date: Fri, 3 Aug 2018 17:11:12 +0000

I support adoption of these documents as RG item, we also had argued for the need of differentiating application identifiers and network identifiers in the ICN layer particularly to support routing and mobility functions in https://tools.ietf.org/html/draft-azgin-icnrg-ni-02, among other usages it may serve.

Regards,
Ravi

From: icnrg [mailto:[email-masked]] On Behalf Of Cedric Westphal
Sent: Friday, July 27, 2018 1:37 AM
To: Lixia Zhang <[email-masked]>
Cc: icnrg <[email-masked]>
Subject: Re: [icnrg] Moving NRS documents to RG documents

Hi Lixia,

Comments in line.

C.

From: icnrg [mailto:[email-masked]] On Behalf Of Lixia Zhang
Sent: Thursday, July 26, 2018 8:40 AM
To: Börje Ohlman
Cc: icnrg; David Oran; Dirk Kutscher
Subject: Re: [icnrg] Moving NRS documents to RG documents

On Jul 24, 2018, at 2:38 AM, Börje Ohlman <[email-masked]<mailto:[email-masked]>> wrote:

Based on the discussion at the ICNRG meeting in Montreal the chairs would like to propose to move the following documents to RG documents.

  *   Requirements for Name Resolution Service in ICN - https://datatracker.ietf.org/doc/draft-jhong-icnrg-nrs-requirements/
  *   Architectural Considerations of ICN using Name Resolution Service - https://datatracker.ietf.org/doc/draft-hong-icnrg-icnnrs/

The main motivation is that the discussion on the pros and cons of using Name Resolution Systems (NRS) is a recurring topic in the RG. We think these documents are a good way to document the discussion and preserve it for future reference.
It can be noted that NRS is a critical component in some ICN architectures, e.g. DONA, PSIRP/PURSUITE, NetInf, Mobility First and IDNet.

I wonder whether the chairs could help clarify
1/ which of the above mentioned projects are still being actively pursued?

CW: the projects may not be actively pursued and may have evolved into new projects. The issue of name resolution is still critical.

2/ If some of then are no longer being actively pursued, what may be perceived benefits to this set of stopped projects from adopting the above documents.

CW: I do not think that the point of RG adoption is to provide benefits to stopped projects! Rather, it is to discuss the issue of name resolution. These previous projects do provide some light on the issue, however.

3/ step up a level: do we have a common ICN architecture framework?  or we have a set of such frameworks?

CW: I don’t think there is a common ICN architecture framework, but there are some overarching principles. One such principle is addressing common by name, and with this comes the issue of name resolution.

Best,

C.

Disclaimer: I have not read the above 2 documents and I missed all the discussions on these documents.

We would like to hear from the list if the ICNRG at large agrees with this assessment.
To be clear, we do *not* think these documents, in their current state, are ready for publication or a RG last call. What we propose is to move them to become RG documents and to make NRS architectural considerations and potential NRS requirements a RG work item. Next steps will be to further evolve these documents to make them the reference we need for future discussions. The goal should not be to define or prescribe how NRS should be used in ICN, but rather document design options, pros and cons with the use of NRS and to describe/document existing NRS implementations and the experience from using them.

I feel a bit confused: if NRS is not perceived as an important piece in ICN architecture, then why should this ICNRG spend its time and efforts on this?

Llxiia

---

From: "Wissingh, B.F. (Bastiaan)" <[email-masked]>
Date: Fri, 10 Aug 2018 07:30:04 +0000

+1, I’m also in favor of adopting this work as RG work, as I agree that the concept of NR is quite important for ICN and I think this would be a good way to gather requirements in a ‘central’ place.

I’ve read both drafts, and agree with Luca that they need more work, however I’m willing to help out with improving the drafts.

Best,
Bastiaan

Van: icnrg <[email-masked]> namens Luca Muscariello <[email-masked]>
Datum: zondag 29 juli 2018 15:37
Aan: "[email-masked]" <[email-masked]>
CC: icnrg <[email-masked]>, Lixia Zhang <[email-masked]>
Onderwerp: Re: [icnrg] Moving NRS documents to RG documents

I agree that the topic is important and central to this RG, as Cedric said, and in favour of the adoption.
However I think that the first draft, which I read, needs quite a lot of work to present requirements of NRS in the different use cases mentioned therein,  in particular in terms of details and applicability.
But I'm sure this lack of work is an additional reason for this draft to be adopted by the RG.

I did not read the second draft yet.

Luca

On Fri, Jul 27, 2018 at 10:37 AM Cedric Westphal <[email-masked]<mailto:[email-masked]>> wrote:
Hi Lixia,

Comments in line.

C.

From: icnrg [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lixia Zhang
Sent: Thursday, July 26, 2018 8:40 AM
To: Börje Ohlman
Cc: icnrg; David Oran; Dirk Kutscher
Subject: Re: [icnrg] Moving NRS documents to RG documents

Best,

C.

We would like to hear from the list if the ICNRG at large agrees with this assessment.
To be clear, we do *not* think these documents, in their current state, are ready for publication or a RG last call.. What we propose is to move them to become RG documents and to make NRS architectural considerations and potential NRS requirements a RG work item. Next steps will be to further evolve these documents to make them the reference we need for future discussions. The goal should not be to define or prescribe how NRS should be used in ICN, but rather document design options, pros and cons with the use of NRS and to describe/document existing NRS implementations and the experience from using them.

Llxiia

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

---

From: "Kim, Sung-Yeon" <[email-masked]>
Date: Fri, 17 Aug 2018 04:53:39 +0000

+1, I also agree to move this topic to RG since the NRS is important topic and it needs to work actively.

Best,
Sung-Yeon

From: icnrg [mailto:[email-masked]] On Behalf Of Wissingh, B.F. (Bastiaan)
Sent: Friday, August 10, 2018 4:30 PM
To: icnrg <[email-masked]>
Subject: Re: [icnrg] Moving NRS documents to RG documents

Best,
Bastiaan

Van: icnrg <[email-masked]<mailto:[email-masked]>> namens Luca Muscariello <[email-masked]<mailto:[email-masked]>>
Datum: zondag 29 juli 2018 15:37
Aan: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: icnrg <[email-masked]<mailto:[email-masked]>>, Lixia Zhang <[email-masked]<mailto:[email-masked]>>
Onderwerp: Re: [icnrg] Moving NRS documents to RG documents

Luca

Comments in line.

C.

Best,

C.

Llxiia

This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.
[Banner]
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.