Subject: Re: [icnrg] Moving NRS documents to RG documents

From: "Ved Kafle" <[email-masked]>
Date: Wed, 5 Sep 2018 18:26:38 +0900

I support the work for "NRS in ICN" as it is an important issue to be addressed to make a globally scalable ICN network. Although the current versions are incomplete and contain several unclear statements, they can be adopted as RG drafts to progress through collective efforts.

Best regards,

Ved Kafle

From: icnrg [mailto:[email-masked]] On Behalf Of Borje Ohlman
Sent: Tuesday, July 24, 2018 6:39 PM
To: icnrg
Cc: David R Oran; Dirk Kutscher
Subject: [icnrg] Moving NRS documents to RG documents

Based on the discussion at the ICNRG meeting in Montreal the chairs would like to propose to move the following documents to RG documents. 

*	Requirements for Name Resolution Service in ICN - https://datatracker.ietf.org/doc/draft-jhong-icnrg-nrs-requirements/
*	Architectural Considerations of ICN using Name Resolution Service - https://datatracker.ietf.org/doc/draft-hong-icnrg-icnnrs/

The main motivation is that the discussion on the pros and cons of using Name Resolution Systems (NRS) is a recurring topic in the RG. We think these documents are a good way to document the discussion and preserve it for future reference.

It can be noted that NRS is a critical component in some ICN architectures, e.g. DONA, PSIRP/PURSUITE, NetInf, Mobility First and IDNet.

We would like to hear from the list if the ICNRG at large agrees with this assessment. 

To be clear, we do *not* think these documents, in their current state, are ready for publication or a RG last call. What we propose is to move them to become RG documents and to make NRS architectural considerations and potential NRS requirements a RG work item. Next steps will be to further evolve these documents to make them the reference we need for future discussions. The goal should not be to define or prescribe how NRS should be used in ICN, but rather document design options, pros and cons with the use of NRS and to describe/document existing NRS implementations and the experience from using them.

    Börje, Dave & Dirk

---

From: Börje Ohlman <[email-masked]>
Date: Wed, 12 Sep 2018 09:30:12 +0000

Hi All,

After reviewing the comments that have been made on the list to our proposal to move the NRS documents, mentioned below, to RG document we (the ICNRG chairs) have decided to do so. We found the comments overwhelmingly positive. There were some discussion on the topic initiated by Lixia. Our views are well in line with the response posted by Cedric and see no need to comment further on this topic.

As stated in the original message we don’t see that these documents are ready for RG last call, but we think they will provide a good basis for further work on the NRS topic in the RG. For those interested in the topic please provide feedback and discussion on the mailing list. Also please feel free to contact the authors directly if you like to actively contribute to the documents.

Börje, Dave & Dirk

On 24 Jul 2018, at 11:38, Börje Ohlman <[email-masked]<mailto:[email-masked]>> wrote:

    Börje, Dave & Dirk