Subject: Re: [icnrg] Status and possible adoption of "CCNinfo: Discovering Content and Network Information in Content-Centric Networks" as an ICNRG work item

From: "Dirk Kutscher" <[email-masked]>
Date: Tue, 18 Sep 2018 15:08:56 +0200

Hello ICNRG,

now that the summer break is over for all of us, it would be great if 
more people could weigh in on the question as to whether ICNRG should 
adopt this work as RG work item or not.

As Dave mentioned, the general sense (including the chairs’ view) was 
that this was substantial and important work. However, we (chairs) 
should not decide on this by ourselves.

We would thus really like to ask more people to have a look at the draft 
and share their views on the adoption question.

We definitely need some indication of general interest if we want to 
dedicate more ICNRG cycles to this in the future (this is was adoption 
implies).

Thanks,
Dirk, Börje, Dave

On 31 Jul 2018, at 17:09, David R. Oran wrote:

> Hello ICNRGers,
>
> Hope you have all recovered from our meetings in Montreal and that 
> summer is going well. Of course, the work never stops, so the chairs 
> would like to grab your attention on an important piece of of our ICN 
> protocol advancement - CCInfo.
>
> Those of you who were in Montreal will recall that we had an update 
> presentation on the status of CCInfo. The document is 
> https://datatracker.ietf.org/doc/draft-asaeda-icnrg-ccninfo/ and the 
> update presentation is in 
> https://datatracker.ietf.org/meeting/102/materials/slides-102-icnrg-ccinfo-draft-update-hitoshi-aseada-given-by-daveo-00.
>
> We only had time for a brief discussion, but the general sense 
> (supported by the chairs) was that this was substantial and important 
> work, since it is a documented and implemented tool for 
> instrumentation and management of CCN (and by extension, NDN). It was 
> split off from the earlier ping/traceroute drafts since there were 
> strong arguments that all of them were needed as elements of our ICN 
> tooling.
>
> Given the potential importance, the chairs would like to move this 
> work toward RG adoption and eventual publication. However, not enough 
> participants have reviewed the work; this is a plea to do so over the 
> next few weeks and provide feedback to the authors and chairs. Not 
> exactly light summer reading, but it is quite interesting 
> intellecutally.
>
> We would like to get to a decision about adoption by the end of 
> August, so please weigh in.
>
> One final note. CCInfo is a comprehensive tool, but we still need ping 
> and traceroute as lighter weight tooling. Those drafts have expired 
> and need to be resurrected. Are there any volunteers for picking up 
> this work (including the original authors)?
>
> Thanks and regards,
>
> DaveO (for Dirk an Börje).
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Mayutan A." <[email-masked]>
Date: Wed, 19 Sep 2018 08:50:12 +0200

I believe that this is useful work and would like to see it adopted.

---

From: Rute Sofia <[email-masked]>
Date: Wed, 19 Sep 2018 13:26:06 +0100

Hello Dirk, Börje, David,

I second the adoption as a RG work item.

I am interested in contributing; as always this is dependent on 
availability :). Also, is there code (proof-of-concept) for ccninfo?

BR

Rute

On 09/18/2018 02:08 PM, Dirk Kutscher wrote:
> We would thus really like to ask more people to have a look at the 
> draft and share their views on the adoption question.
>
>> One final note. CCInfo is a comprehensive tool, but we still need 
>> ping and traceroute as lighter weight tooling. Those drafts have 
>> expired and need to be resurrected. Are there any volunteers for 
>> picking up this work (including the original authors)?
>>
>> Thanks and regards,
>>

-- 
----
*Senior Researcher/Associate Professor*
COPELABS, Universidade Lusófona de Humanidades e Tecnologias
http://copelabs.ulusofona.pt

---

From: Hitoshi Asaeda <[email-masked]>
Date: Thu, 20 Sep 2018 16:39:10 +0200

Hello Rute,

Thanks for your interest in ccninfo.
We've developed the code, and will announce it at or just before the next IETF/IRTF.
(BTW, the usage of the ccninfo command is already mentioned at the appendix in the draft.)

Regards,

Hitoshi

> On 2018/09/19, at 14:26, Rute Sofia <[email-masked]> wrote:
> 
> I am interested in contributing; as always this is dependent on availability :). Also, is there code (proof-of-concept) for ccninfo?
> BR
> 
> Rute
>> now that the summer break is over for all of us, it would be great if more people could weigh in on the question as to whether ICNRG should adopt this work as RG work item or not. 
>> 
>> As Dave mentioned, the general sense (including the chairs’ view) was that this was substantial and important work. However, we (chairs) should not decide on this by ourselves. 
>> 
>> We would thus really like to ask more people to have a look at the draft and share their views on the adoption question. 
>> 
>> We definitely need some indication of general interest if we want to dedicate more ICNRG cycles to this in the future (this is was adoption implies). 
>> 
>> Thanks, 
>> Dirk, Börje, Dave 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>>> Hope you have all recovered from our meetings in Montreal and that summer is going well. Of course, the work never stops, so the chairs would like to grab your attention on an important piece of of our ICN protocol advancement - CCInfo. 
>>> 
>>> Those of you who were in Montreal will recall that we had an update presentation on the status of CCInfo. The document is https://datatracker.ietf.org/doc/draft-asaeda-icnrg-ccninfo/ and the update presentation is in https://datatracker.ietf.org/meeting/102/materials/slides-102-icnrg-ccinfo-draft-update-hitoshi-aseada-given-by-daveo-00.
>>> 
>>> We only had time for a brief discussion, but the general sense (supported by the chairs) was that this was substantial and important work, since it is a documented and implemented tool for instrumentation and management of CCN (and by extension, NDN). It was split off from the earlier ping/traceroute drafts since there were strong arguments that all of them were needed as elements of our ICN tooling. 
>>> 
>>> Given the potential importance, the chairs would like to move this work toward RG adoption and eventual publication. However, not enough participants have reviewed the work; this is a plea to do so over the next few weeks and provide feedback to the authors and chairs. Not exactly light summer reading, but it is quite interesting intellecutally. 
>>> 
>>> We would like to get to a decision about adoption by the end of August, so please weigh in. 
>>> 
>>> One final note. CCInfo is a comprehensive tool, but we still need ping and traceroute as lighter weight tooling. Those drafts have expired and need to be resurrected. Are there any volunteers for picking up this work (including the original authors)? 
>>> 
>>> Thanks and regards, 
>>> 
> Senior Researcher/Associate Professor

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 27 Sep 2018 13:20:06 +0000

+1

Agreed that it would be a good draft to be adopted by the RG.

Best Regards,

Akbar

From: icnrg [mailto:[email-masked]] On Behalf Of Mayutan A.
Sent: Wednesday, September 19, 2018 2:50 AM
To: [email-masked]
Subject: Re: [icnrg] Status and possible adoption of "CCNinfo: Discovering Content and Network Information in Content-Centric Networks" as an ICNRG work item

On Tue, Sep 18, 2018 at 3:22 PM Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:
Hello ICNRG,

Thanks,
Dirk, Börje, Dave

On 31 Jul 2018, at 17:09, David R. Oran wrote:

> [email-masked]<mailto:[email-masked]>

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg
[Banner]
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.