Subject: Re: [icnrg] possible adoption of "ICN Adaptation to LowPAN Networks (ICN LoWPAN)"

From: "Mayutan A." <[email-masked]>
Date: Tue, 2 Oct 2018 19:14:48 +0200

I read the draft and I believe that this will be quite useful. I would
therefore like to see it adopted.

On Wed, Sep 26, 2018 at 7:55 PM Dirk Kutscher <[email-masked]> wrote:

> Hi ICNRG,
>
> Those of you who have been at the ICNRG Interim at MIT on Monday will
> remember Cenk’s presentation on the ICN LowPAN work
> (
> https://datatracker.ietf.org/meeting/interim-2018-icnrg-03/materials/slides-interim-2018-icnrg-03-sessa-icn-lowpan).
>
> The corresponding Internet Draft
> (https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnlowpan/)
> defines a convergence layer for CCNx/NDN over IEEE 802.15.4 networks.
>
> This work has been presented a few times in past ICNRG meetings in the
> past and has evolved nicely.
>
> At the Interim, we brought up the question of adopting this work as a RG
> work item. Feedback so far has been positive so that we would now like
> to get more views on that on the mailing list.
>
> As a bit of background: the specification in this draft has been
> implemented in IoT prototypes and seems to provide attractive features
> including stateless and stateful compression and could enable
> connectivity between (very) constrained networks with gateways and the
> rest of an ICN Internet, possibly avoiding some of the problems of
> 6lowpan (IPv6 over LowPAN).
>
> Given the potential importance of the work for supporting networking in
> constrained environments, the chairs do think this work would be a good
> candidate for an ICNRG work item (with the objective of publishing it as
> an Experimental RFC).
>
> We would like to get a decision on this in about two weeks, so please
> share your opinions by the end of October 14th.
>
> (Reminder: we are looking for statements indicating support for adoption
> or concerns for adopting it at this time).
>
> Thanks and best regards,
>
> Dirk (for Börje and Dave)
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>

---

From: "Dirk Kutscher" <[email-masked]>
Date: Thu, 04 Oct 2018 14:22:50 +0200

Hi all,

Friendly reminder that we need feedback from the group on this.

Thanks,
Dirk

On 26 Sep 2018, at 19:54, Dirk Kutscher wrote:

> (https://datatracker.ietf.org/meeting/interim-2018-icnrg-03/materials/slides-interim-2018-icnrg-03-sessa-icn-lowpan). 
> At the Interim, we brought up the question of adopting this work as a 
> RG work item. Feedback so far has been positive so that we would now 
> like to get more views on that on the mailing list.
>
> Given the potential importance of the work for supporting networking 
> in constrained environments, the chairs do think this work would be a 
> good candidate for an ICNRG work item (with the objective of 
> publishing it as an Experimental RFC).
>
> (Reminder: we are looking for statements indicating support for 
> adoption or concerns for adopting it at this time).
>
> Thanks and best regards,
>

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 4 Oct 2018 08:33:42 -0400

I am all for it.

Marie-Jose Montpetit, Ph.D.
[email-masked]
[email-masked]
+1-781-526-2661
@SocialTVMIT

> On Oct 4, 2018, at 8:22 AM, Dirk Kutscher <[email-masked]> wrote:
> 
> Hi all,
> 
>> Those of you who have been at the ICNRG Interim at MIT on Monday will remember Cenk’s presentation on the ICN LowPAN work (https://datatracker.ietf.org/meeting/interim-2018-icnrg-03/materials/slides-interim-2018-icnrg-03-sessa-icn-lowpan). The corresponding Internet Draft (https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnlowpan/) defines a convergence layer for CCNx/NDN over IEEE 802.15.4 networks.
>> 
>> This work has been presented a few times in past ICNRG meetings in the past and has evolved nicely.
>> 
>> At the Interim, we brought up the question of adopting this work as a RG work item. Feedback so far has been positive so that we would now like to get more views on that on the mailing list.
>> 
>> As a bit of background: the specification in this draft has been implemented in IoT prototypes and seems to provide attractive features including stateless and stateful compression and could enable connectivity between (very) constrained networks with gateways and the rest of an ICN Internet, possibly avoiding some of the problems of 6lowpan (IPv6 over LowPAN).
>> 
>> Given the potential importance of the work for supporting networking in constrained environments, the chairs do think this work would be a good candidate for an ICNRG work item (with the objective of publishing it as an Experimental RFC).
>> 
>> We would like to get a decision on this in about two weeks, so please share your opinions by the end of October 14th.
>> 
>> (Reminder: we are looking for statements indicating support for adoption or concerns for adopting it at this time).
>> 
>> Thanks and best regards,
>>

---

From: Jan Seedorf <[email-masked]>
Date: Thu, 4 Oct 2018 12:59:56 +0200

+1, definitely useful work in the ICN-IoT space

  - Jan

On 02.10.18 19:14, Mayutan A. wrote:
> On Wed, Sep 26, 2018 at 7:55 PM Dirk Kutscher <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi ICNRG,
>
>     adoption
>     [email-masked] <mailto:[email-masked]>

---

From: Alessandro Bassi <[email-masked]>
Date: Thu, 4 Oct 2018 14:54:28 +0200

I also support

—alex

Sent from my iPad

> On Oct 4, 2018, at 2:33 PM, Marie-Jose Montpetit <[email-masked]> wrote:
> 
> I am all for it.
>

---

From: "Milan Stolic (mistolic)" <[email-masked]>
Date: Thu, 4 Oct 2018 13:14:31 +0000

+1

Thanks,
Milan

From: icnrg <[email-masked]> On Behalf Of Alessandro Bassi
Sent: Thursday, October 4, 2018 7:54 AM
To: Marie-Jose Montpetit <[email-masked]>
Cc: icnrg <[email-masked]>; Dirk Kutscher <[email-masked]>
Subject: Re: [icnrg] possible adoption of "ICN Adaptation to LowPAN Networks (ICN LoWPAN)"

I also support

—alex

Sent from my iPad

On Oct 4, 2018, at 2:33 PM, Marie-Jose Montpetit <[email-masked]<mailto:[email-masked]>> wrote:
I am all for it.

Marie-Jose Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
+1-781-526-2661
@SocialTVMIT

On Oct 4, 2018, at 8:22 AM, Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thanks,
Dirk

Hi ICNRG,

Thanks and best regards,

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Luca Muscariello <[email-masked]>
Date: Thu, 4 Oct 2018 16:09:14 +0200

+1 for adoption
Luca

On Thu, Oct 4, 2018 at 3:15 PM Milan Stolic (mistolic) <[email-masked]>
wrote:

> +1
>
>
>
> Thanks,
>
> Milan
>
>
>
> *From:* icnrg <[email-masked]> *On Behalf Of *Alessandro Bassi
> *Sent:* Thursday, October 4, 2018 7:54 AM
> *To:* Marie-Jose Montpetit <[email-masked]>
> *Cc:* icnrg <[email-masked]>; Dirk Kutscher <[email-masked]>
> *Subject:* Re: [icnrg] possible adoption of "ICN Adaptation to LowPAN
> Networks (ICN LoWPAN)"
>
>
>
> I also support
>
>
>
> —alex
>
>
>
> Sent from my iPad
>
>
> remember Cenk’s presentation on the ICN LowPAN work (
> The corresponding Internet Draft (
> https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnlowpan/) defines
> a convergence layer for CCNx/NDN over IEEE 802.15.4 networks.
>
> work item. Feedback so far has been positive so that we would now like to
> get more views on that on the mailing list.
>
> including stateless and stateful compression and could enable connectivity
> between (very) constrained networks with gateways and the rest of an ICN
> Internet, possibly avoiding some of the problems of 6lowpan (IPv6 over
> LowPAN).
>
> candidate for an ICNRG work item (with the objective of publishing it as an
> Experimental RFC).
>

---

From: Cedric Adjih <[email-masked]>
Date: Thu, 4 Oct 2018 16:30:20 +0200 (CEST)

Hello, I am also strongly for adoption by the RG 
-- Cedric 

> De: "Luca Muscariello" <[email-masked]>
> À: [email-masked]
> Cc: "Marie-Jose Montpetit" <[email-masked]>, "icnrg" <[email-masked]>,
> "Dirk Kutscher" <[email-masked]>, "Alessandro Bassi"
> <[email-masked]>
> Envoyé: Jeudi 4 Octobre 2018 16:09:14
> Objet: Re: [icnrg] possible adoption of "ICN Adaptation to LowPAN Networks (ICN
> LoWPAN)"

> On Thu, Oct 4, 2018 at 3:15 PM Milan Stolic (mistolic) < [
> mailto:[email-masked] | [email-masked] ] > wrote:

>> From: icnrg < [ mailto:[email-masked] | [email-masked] ] > On
>> Behalf Of Alessandro Bassi
>> To: Marie-Jose Montpetit < [ mailto:[email-masked] |
>> [email-masked] ] >
>> Cc: icnrg < [ mailto:[email-masked] | [email-masked] ] >; Dirk Kutscher < [
>> mailto:[email-masked] | [email-masked] ] >

>> On Oct 4, 2018, at 2:33 PM, Marie-Jose Montpetit < [
>> mailto:[email-masked] | [email-masked] ] > wrote:

>>> [ mailto:[email-masked] | [email-masked] ]

>>> [ mailto:[email-masked] | [email-masked] ]

>>>> On Oct 4, 2018, at 8:22 AM, Dirk Kutscher < [ mailto:[email-masked] |
>>>> [email-masked] ] > wrote:

>>>>> Those of you who have been at the ICNRG Interim at MIT on Monday will remember
>>>>> Cenk’s presentation on the ICN LowPAN work ( [
>>>>> https://datatracker.ietf.org/meeting/interim-2018-icnrg-03/materials/slides-interim-2018-icnrg-03-sessa-icn-lowpan
>>>>> |
>>>>> https://datatracker.ietf..org/meeting/interim-2018-icnrg-03/materials/slides-interim-2018-icnrg-03-sessa-icn-lowpan
>>>>> ] ). The corresponding Internet Draft ( [
>>>>> https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnlowpan/ |
>>>>> https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnlowpan/ ] ) defines a
>>>>> convergence layer for CCNx/NDN over IEEE 802.15.4 networks.

>>>>> At the Interim, we brought up the question of adopting this work as a RG work
>>>>> item. Feedback so far has been positive so that we would now like to get more
>>>>> views on that on the mailing list.

>>>>> As a bit of background: the specification in this draft has been implemented in
>>>>> IoT prototypes and seems to provide attractive features including stateless and
>>>>> stateful compression and could enable connectivity between (very) constrained
>>>>> networks with gateways and the rest of an ICN Internet, possibly avoiding some
>>>>> of the problems of 6lowpan (IPv6 over LowPAN).

>>>> [ mailto:[email-masked] | [email-masked] ]
>>>> [ https://www.irtf.org/mailman/listinfo/icnrg |
>>>> https://www.irtf.org/mailman/listinfo/icnrg ]

>>> [ mailto:[email-masked] | [email-masked] ]
>>> [ https://www.irtf.org/mailman/listinfo/icnrg |
>>> https://www.irtf.org/mailman/listinfo/icnrg ]

>> [ mailto:[email-masked] | [email-masked] ]
>> [ https://www.irtf.org/mailman/listinfo/icnrg |
>> https://www.irtf.org/mailman/listinfo/icnrg ]

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 08 Oct 2018 19:09:29 +0200

Thank you all for your feedback.

Based on the positive feedback from the group, the chairs have decided 
to adopt this document as well.

@Authors, please submit a new version as draft-icnrg-ccnlowpan at a 
convenient time (ideally before the cutoff deadline for IETF-103).

Thanks,

Dirk, Börje, Dave

On 4 Oct 2018, at 16:30, Cedric Adjih wrote:

>>> Subject: Re: [icnrg] possible adoption of "ICN Adaptation to LowPAN 
>>> Networks
>>> (ICN LoWPAN)"
>
>>> I also support
>
>>> —alex
>
>>> Sent from my iPad
>
>>>>>> This work has been presented a few times in past ICNRG meetings 
>>>>>> in the past and
>>>>>> has evolved nicely.
>
>>>>>> implemented in
>>>>>> We would like to get a decision on this in about two weeks, so 
>>>>>> please share your
>>>>>> opinions by the end of October 14th.
>