Subject: [icnrg] I-D Action: draft-irtf-icnrg-ccninfo-00.txt

From: [email-masked]
Date: Mon, 08 Oct 2018 03:39:19 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Information-Centric Networking RG of the IRTF.

        Title           : CCNinfo: Discovering Content and Network Information in Content-Centric Networks
        Authors         : Hitoshi Asaeda
                          Xun Shao
	Filename        : draft-irtf-icnrg-ccninfo-00.txt
	Pages           : 33
	Date            : 2018-10-07

Abstract:
   This document describes a mechanism named "CCNinfo" that discovers
   information about the network topology and in-network cache in
   Content-Centric Networks (CCN).  CCNinfo investigates: 1) the CCN
   routing path information per name prefix, device name, and function/
   application, 2) the Round-Trip Time (RTT) between content forwarder
   and consumer, and 3) the states of in-network cache per name prefix.
   In addition, it discovers a gateway that supports different protocols
   such as CCN and Named-Data Networks (NDN).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-icnrg-ccninfo/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-icnrg-ccninfo-00
https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-ccninfo-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 08 Oct 2018 12:44:14 +0200

Hi everyone,

Thanks to the authors for resubmitting this draft as a research group 
draft. This is now an ICNRG draft, i.e., let’s work together on moving 
this forward.

One other note in this context: CCInfo is a comprehensive tool, but we 
still need ping and traceroute as lighter weight tooling. Those drafts 
have expired and need to be resurrected. Are there any volunteers for 
picking up this work (including the original authors)?

Best regards,

Dirk, Börje, Dave

On 8 Oct 2018, at 12:39, [email-masked] wrote:

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Spyridon (Spyros) Mastorakis" <[email-masked]>
Date: Mon, 8 Oct 2018 06:14:36 -0700

Hi Dirk,

Dave Oran and I resurrected the ping and traceroute drafts about a month ago:

https://tools.ietf.org/html/draft-mastorakis-icnrg-icnping-03 <https://tools.ietf.org/html/draft-mastorakis-icnrg-icnping-03>
https://tools.ietf.org/html/draft-mastorakis-icnrg-icntraceroute-03 <https://tools.ietf.org/html/draft-mastorakis-icnrg-icntraceroute-03>

Comments are welcome.

Thanks,

Spyridon (Spyros) Mastorakis
Personal Website: http://cs.ucla.edu/~mastorakis/ <http://cs.ucla.edu/~mastorakis/>
Internet Research Laboratory
Computer Science Department
UCLA

> On Oct 8, 2018, at 3:44 AM, Dirk Kutscher <[email-masked]> wrote:
> 
> Hi everyone,
> 
> Thanks to the authors for resubmitting this draft as a research group draft. This is now an ICNRG draft, i.e., let’s work together on moving this forward.
> 
> One other note in this context: CCInfo is a comprehensive tool, but we still need ping and traceroute as lighter weight tooling. Those drafts have expired and need to be resurrected. Are there any volunteers for picking up this work (including the original authors)?
> 
> Best regards,
> 
> Dirk, Börje, Dave
> 
> 
>

---

From: Dirk Kutscher <[email-masked]>
Date: Mon, 08 Oct 2018 15:17:59 +0200

Hi Spyros,

Yes, of course -- thanks for the reminder!

Best regards,

Dirk

Am 08.10.2018 15:14 schrieb "Spyridon (Spyros) Mastorakis" <[email-masked]>:

Hi Dirk,

https://tools.ietf.org/html/draft-mastorakis-icnrg-icnping-03

https://tools.ietf.org/html/draft-mastorakis-icnrg-icntraceroute-03

Comments are welcome.

Thanks,

Spyridon (Spyros) Mastorakis
Personal Website: http://cs.ucla.edu/~mastorakis/
Internet Research Laboratory
Computer Science Department
UCLA

Hi everyone,

Best regards,

Dirk, Börje, Dave

Abstract: