Subject: Re: [icnrg] Status and possible adoption of "CCNinfo: Discovering Content and Network Information in Content-Centric Networks" as an ICNRG work item

From: "Ved Kafle" <[email-masked]>
Date: Mon, 1 Oct 2018 17:41:10 +0900

I read the draft and found it very useful for ICN/CCN community, especially network developers and operators, to trace name prefix paths and gateways, which are different from the traditional IP network paths.

The content is also quite rich as it includes the detail descriptions of relevant message formats and behaviors/actions of involved entities.

I agree for its adoption as an RG draft.

Ved Kafle

From: icnrg [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Thursday, September 27, 2018 10:20 PM
To: [email-masked]
Subject: Re: [icnrg] Status and possible adoption of "CCNinfo: Discovering Content and Network Information in Content-Centric Networks" as an ICNRG work item

+1

Agreed that it would be a good draft to be adopted by the RG.

Best Regards,

Akbar

From: icnrg [mailto:[email-masked]] On Behalf Of Mayutan A.
Sent: Wednesday, September 19, 2018 2:50 AM
To: [email-masked]
Subject: Re: [icnrg] Status and possible adoption of "CCNinfo: Discovering Content and Network Information in Content-Centric Networks" as an ICNRG work item

I believe that this is useful work and would like to see it adopted.

On Tue, Sep 18, 2018 at 3:22 PM Dirk Kutscher <[email-masked]> wrote:

Hello ICNRG,

now that the summer break is over for all of us, it would be great if 
more people could weigh in on the question as to whether ICNRG should 
adopt this work as RG work item or not.

As Dave mentioned, the general sense (including the chairs’ view) was 
that this was substantial and important work. However, we (chairs) 
should not decide on this by ourselves.

We would thus really like to ask more people to have a look at the draft 
and share their views on the adoption question.

We definitely need some indication of general interest if we want to 
dedicate more ICNRG cycles to this in the future (this is was adoption 
implies).

Thanks,
Dirk, Börje, Dave

On 31 Jul 2018, at 17:09, David R. Oran wrote:

> Hello ICNRGers,
>
> Hope you have all recovered from our meetings in Montreal and that 
> summer is going well. Of course, the work never stops, so the chairs 
> would like to grab your attention on an important piece of of our ICN 
> protocol advancement - CCInfo.
>
> Those of you who were in Montreal will recall that we had an update 
> presentation on the status of CCInfo. The document is 
> https://datatracker.ietf.org/doc/draft-asaeda-icnrg-ccninfo/ and the 
> update presentation is in 
> https://datatracker.ietf.org/meeting/102/materials/slides-102-icnrg-ccinfo-draft-update-hitoshi-aseada-given-by-daveo-00.
>
> We only had time for a brief discussion, but the general sense 
> (supported by the chairs) was that this was substantial and important 
> work, since it is a documented and implemented tool for 
> instrumentation and management of CCN (and by extension, NDN). It was 
> split off from the earlier ping/traceroute drafts since there were 
> strong arguments that all of them were needed as elements of our ICN 
> tooling.
>
> Given the potential importance, the chairs would like to move this 
> work toward RG adoption and eventual publication. However, not enough 
> participants have reviewed the work; this is a plea to do so over the 
> next few weeks and provide feedback to the authors and chairs. Not 
> exactly light summer reading, but it is quite interesting 
> intellecutally.
>
> We would like to get to a decision about adoption by the end of 
> August, so please weigh in.
>
> One final note. CCInfo is a comprehensive tool, but we still need ping 
> and traceroute as lighter weight tooling. Those drafts have expired 
> and need to be resurrected. Are there any volunteers for picking up 
> this work (including the original authors)?
>
> Thanks and regards,
>
> DaveO (for Dirk an Börje).
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

Image removed by sender. Banner

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 01 Oct 2018 15:40:48 +0200

Thanks, everyone.

 From the chairs’ point of view there is sufficient interest and 
support for adopting this Internet Draft as an ICNRG work item.

Authors, please re-submit the draft as draft-icnrg-ccninfo-00.

Thanks,
Chairs (Börje, Dave, Dirk)

On 1 Oct 2018, at 10:41, Ved Kafle wrote:

> I read the draft and found it very useful for ICN/CCN community, 
> especially network developers and operators, to trace name prefix 
> paths and gateways, which are different from the traditional IP 
> network paths.
>
> The content is also quite rich as it includes the detail descriptions 
> of relevant message formats and behaviors/actions of involved 
> entities.
>
>
>
> Subject: Re: [icnrg] Status and possible adoption of "CCNinfo: 
> Discovering Content and Network Information in Content-Centric 
> Networks" as an ICNRG work item
>
>
>
> +1
>
>
>
> Subject: Re: [icnrg] Status and possible adoption of "CCNinfo: 
> Discovering Content and Network Information in Content-Centric 
> Networks" as an ICNRG work item
>
>
>
> This e-mail is intended only for the use of the individual or entity 
> to which it is addressed, and may contain information that is 
> privileged, confidential and/or otherwise protected from disclosure to 
> anyone other than its intended recipient. Unintended transmission 
> shall not constitute waiver of any privilege or confidentiality 
> obligation. If you received this communication in error, please do not 
> review, copy or distribute it, notify me immediately by email, and 
> delete the original message and any attachments. Unless expressly 
> stated in this e-mail, nothing in this message or any attachment 
> should be construed as a digital or electronic signature.