Subject: Re: [icnrg] Soliciting feedback on: Internet Protocol Tunneling over Content Centric Mobile Networks (draft-white-icnrg-ipoc-01)

From: "Thomas C. Schmidt" <[email-masked]>
Date: Thu, 15 Nov 2018 14:38:54 +0100

Hi all,

just in brief: I would support adopting this document.

Best,
  Thomas

On 15/11/2018 14:18, Dirk Kutscher wrote:
> Hi ICNRG,
> 
> At the ICNRG meeting last week, we brought up the question of next steps 
> for https://datatracker.ietf.org/doc/draft-white-icnrg-ipoc/ .
> 
> Abstract (as a reminder):
> 
> This document describes a protocol that enables tunneling of Internet
> Protocol traffic over a Content Centric Network (CCN) or a Named Data
> Network (NDN). The target use case for such a protocol is to provide
> an IP mobility plane for mobile networks that might otherwise use IP-
> over-IP tunneling, such as the GPRS Tunneling Protocol (GTP) used by
> the Evolved Packet Core in LTE networks (LTE-EPC). By leveraging the
> elegant, built-in support for mobility provided by CCN or NDN, this
> protocol achieves performance on par with LTE-EPC, equivalent
> efficiency, and substantially lower implementation and protocol
> complexity. Furthermore, the use of CCN/NDN for this purpose paves
> the way for the deployment of ICN native applications on the mobile
> network.
> 
> This work has been presented at earlier meetings and has received good 
> feedback at those times.
> 
> The chairs think that the draft describes an interesting approach 
> towards working with ICN and IP and operator networks and provides a 
> specification that could enable more experimentation.
> 
> We’d like to collect some opinions from the group about possible next 
> steps (for example, adopting it as RG for later publishing it as an 
> ICNRG product). As usual, adopting a draft in ICNRG does not mean 
> endorsing it as the single best way of solving a particular problem.
> 
> Normally, we’d adopt drafts that are of interest to ICNRG participants 
> and that people would like to see published.
> 
> So, please let us know what you think:
> 
>   * Would you like to see this work adopted?
>   * Do you have technical comments or suggestions? 
> 
> Thanks,
> Börje, Dave, Dirk
> 

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                  Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group   20099 Hamburg, Germany °
° http://inet.haw-hamburg.de/members/schmidt      Fon: +49-40-42875-8452 °

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Thu, 15 Nov 2018 08:39:35 -0500

Same here.

mjm
Marie-Jose Montpetit, Ph.D.
[email-masked]
[email-masked]
+1-781-526-2661
@SocialTVMIT

> On Nov 15, 2018, at 8:38 AM, Thomas C. Schmidt <[email-masked]> wrote:
> 
> Hi all,
> 
>> At the ICNRG meeting last week, we brought up the question of next steps for https://datatracker.ietf.org/doc/draft-white-icnrg-ipoc/ .
>> This work has been presented at earlier meetings and has received good feedback at those times.
>> The chairs think that the draft describes an interesting approach towards working with ICN and IP and operator networks and provides a specification that could enable more experimentation.
>> We’d like to collect some opinions from the group about possible next steps (for example, adopting it as RG for later publishing it as an ICNRG product). As usual, adopting a draft in ICNRG does not mean endorsing it as the single best way of solving a particular problem.
>> Normally, we’d adopt drafts that are of interest to ICNRG participants and that people would like to see published.
>>  * Do you have technical comments or suggestions? Thanks,
>> Börje, Dave, Dirk
> 
> -- 
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Greg White <[email-masked]>
Date: Mon, 26 Nov 2018 16:26:18 +0000

Thank you to those who have indicated support for adoption of the IPoC draft.

For those who are interested, one of the authors presented a paper on IPoC at the SIGCOMM NEAT workshop in August.
https://susm.it/files/ipoc_sigcomm_neat.pdf

The ndnSIM implementation (used for the performance evaluation in the paper) is available at:
https://github.com/named-data/IPoC

Also, I wrote a blog post recently on IPoC:
https://www.cablelabs.com/ipoc-a-new-core-networking-protocol-for-5g-networks

Thanks again,
Greg

From: icnrg <[email-masked]> on behalf of Marie-Jose Montpetit <[email-masked]>
Date: Thursday, November 15, 2018 at 6:39 AM
To: "Thomas C. Schmidt" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [icnrg] Soliciting feedback on: Internet Protocol Tunneling over Content Centric Mobile Networks (draft-white-icnrg-ipoc-01)

Same here.

mjm
Marie-Jose Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
+1-781-526-2661
@SocialTVMIT

On Nov 15, 2018, at 8:38 AM, Thomas C. Schmidt <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Best,
Thomas

Hi ICNRG,
At the ICNRG meeting last week, we brought up the question of next steps for https://datatracker.ietf.org/doc/draft-white-icnrg-ipoc/ ..

--

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg