Subject: [icnrg] Next steps on the 4G/LTE Draft

From: "David R. Oran" <[email-masked]>
Date: Wed, 07 Nov 2018 13:51:29 +0700

At the ICNRG Interim meeting at IETF 103, we got an update status on 
https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/

This document is reaching a mature state and the chairs would like to 
get a sense from the RG participants on two questions:

1. Do you think this is ready for an RG last call, and if not, what 
additions/changes you would like to see to move it forward.

2. Do you think the appropriate target for this particular set of work 
is the “Informational” or “Experimental RFC track. It seems to 
fall somewhat in a grey area between the two.

Please reply to the list. We would like to have feedback by the end of 
next week or so (November 17).

Dave, Dirk, & Börje.

---

From: Luca Muscariello <[email-masked]>
Date: Wed, 7 Nov 2018 10:08:51 +0100

Hi,

A few comments to the document:

The motivation of this document seems weak. E.g. Why should I do all these
changes? Worth the pain?
Please find below a paper that may help to motivate that a little bit.

The following paper is also a good citation and the author of this draft
should compare
at least with Sec V of it, where several deployment options where proposed
including encapsulation in IP and GTP-U extension headers. This draft HAS
to compare with those solutions. Beware that those solutions were
Alcatel-Lucent IPR and should be Nokia IPR now.
There might be Orange SA IPR as well. If necessary I could check myself.

Until that comparison is not made, I feel this draft SHOULD NOT go through
a final call.

G. Carofiglio, M. Gallo, L. Muscariello and D. Perino, "Scalable mobile
backhauling via information-centric networking," *The 21st IEEE
International Workshop on Local and Metropolitan Area Networks*, Beijing,
2015, pp. 1-6.

Minor:
This text is either wrong or inaccurate. Or maybe, it is so short that is
prone to misguided interpretation.

       An alternative approach to implement ICN over IP is provided in
       Hybrid ICN [HICN], which implements ICN over IP by mapping of ICN
       names to the IPv4/IPv6 addresses.

HTH

Luca

On Wed, Nov 7, 2018 at 7:51 AM David R. Oran <[email-masked]> wrote:

> This document is reaching a mature state and the chairs would like to get
> a sense from the RG participants on two questions:
>
>    1.
>
>    Do you think this is ready for an RG last call, and if not, what
>    2.
>    Do you think the appropriate target for this particular set of work is
>    the “Informational” or “Experimental RFC track. It seems to fall somewhat
>    in a grey area between the two.
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>

---

From: "Trossen, Dirk" <[email-masked]>
Date: Thu, 15 Nov 2018 15:48:47 +0000

Hi Luca,

The abstract provides a number of aspects for wanting to utilize ICN in 4G/LTE networks, such as “ICN has an inherent capability for multicast, anchorless mobility, security and it is optimized for data delivery using local caching at the edge.” – I agree that being brief, given that it’s in the abstract, but similar to what the paper discusses as opportunities. Furthermore, there’s a possible argument to be made that 4G/LTE will be around for some time to come, including being introduced in a number of markets as new deployments even – but should this be part of a technical draft?

I’m a bit confused by the ‘HAS to compare with those solutions’ comment. Do you expect a functional comparison, a reference to the (brief) discussion in Section V on possible deployments, …?

As for the HICN statement, I see your point on a possible misunderstanding (albeit it’s clear to me) – would you have a proposed improved formulation that avoids any such misunderstanding?

What is not clear to me though if your comment is meant as an opposition to the validity of the solution described in the draft and its adoption specifically?

Best,

Dirk

From: icnrg [mailto:[email-masked]] On Behalf Of Luca Muscariello
Sent: 07 November 2018 09:09
To: Oran, Dave <[email-masked]>
Cc: icnrg <[email-masked]>
Subject: Re: [icnrg] Next steps on the 4G/LTE Draft

Hi,

The motivation of this document seems weak. E.g. Why should I do all these changes? Worth the pain?
Please find below a paper that may help to motivate that a little bit.

The following paper is also a good citation and the author of this draft should compare
at least with Sec V of it, where several deployment options where proposed including encapsulation in IP and GTP-U extension headers. This draft HAS to compare with those solutions. Beware that those solutions were Alcatel-Lucent IPR and should be Nokia IPR now.
There might be Orange SA IPR as well. If necessary I could check myself.

Until that comparison is not made, I feel this draft SHOULD NOT go through a final call.

G. Carofiglio, M. Gallo, L. Muscariello and D. Perino, "Scalable mobile backhauling via information-centric networking," The 21st IEEE International Workshop on Local and Metropolitan Area Networks, Beijing, 2015, pp. 1-6.

Minor:
This text is either wrong or inaccurate. Or maybe, it is so short that is prone to misguided interpretation.

HTH

Luca

On Wed, Nov 7, 2018 at 7:51 AM David R. Oran <[email-masked]<mailto:[email-masked]>> wrote:

At the ICNRG Interim meeting at IETF 103, we got an update status on https://datatracker.ietf..org/doc/draft-irtf-icnrg-icn-lte-4g/<https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/>

This document is reaching a mature state and the chairs would like to get a sense from the RG participants on two questions:

  1.  Do you think this is ready for an RG last call, and if not, what additions/changes you would like to see to move it forward.

  1.  Do you think the appropriate target for this particular set of work is the “Informational” or “Experimental RFC track. It seems to fall somewhat in a grey area between the two.

Please reply to the list. We would like to have feedback by the end of next week or so (November 17).

Dave, Dirk, & Börje.
_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Rahman, Akbar" <[email-masked]>
Date: Fri, 16 Nov 2018 03:57:09 +0000

Hi Dave,

>1.  Do you think this is ready for an RG last call, and if not, what additions/changes you would like to see to move it forward.

Yes, I think it is ready for an RG last call after update of the self-identified open item in https://tools.ietf.org/html/draft-irtf-icnrg-icn-lte-4g-02#section-6
“We are currently evaluating the ICN deployment options, described in section 4<https://tools.ietf.org/html/draft-irtf-icnrg-icn-lte-4g-02#section-4>, using LTE gateway software and ICN simulator.”

It would be nice to get a quick update of the conclusions of this investigation after which time I think it would be ready for the RG last call.  (I note that we have discussed this draft in multiple IETF meetings as well as having several off line technical reviews).

>2.  Do you think the appropriate target for this particular set of work is the “Informational” or “Experimental RFC track. It seems to fall somewhat in a grey area between the two.
I would vote for Informational track as most of the protocol changes seem 3GPP specific.

Best Regards,

Akbar

From: icnrg [mailto:[email-masked]] On Behalf Of Oran, Dave
Sent: Wednesday, November 7, 2018 1:51 AM
To: icnrg <[email-masked]>
Subject: [icnrg] Next steps on the 4G/LTE Draft

At the ICNRG Interim meeting at IETF 103, we got an update status on https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/

Dave, Dirk, & Börje.

[Banner]
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.