Subject: [icnrg] Cefore software platform

From: Hitoshi Asaeda <[email-masked]>
Date: Thu, 8 Nov 2018 14:13:37 +0700

Folks,

Today I talked about the CCNinfo draft at the ICNRG meeting.
During my talk, I also introduced "Cefore", which is a software platform enabling CCN communications using CCNx-1.0 messages.
Cefore consists of a packet forwarding daemon (cefnetd), a daemon managing content store (csmgrd), and other tools/utilities such as CCNinfo. It is *not* software *only* implementing CCNinfo.

Cefore is an open source with BSD-like license.
If you are interested in it, you can download it from; https://cefore.net. (The web page is very much under construction, sorry about that, but you can also download the user guide from "Instruction" page.)
This link is also mentioned in the ICNRG's wiki page.

The development is still ongoing and there are many incomplete functions at this moment for sure, but it'd be great if some of you can enjoy working/studying with this software.

Regards,

Hitoshi Asaeda

---

From: "Dirk Kutscher" <[email-masked]>
Date: Fri, 09 Nov 2018 16:51:02 +0100

Thanks, Hitoshi.

That’s great news, and we would like to learn more about it at future 
meetings.

Best regards,
Dirk

On 8 Nov 2018, at 8:13, Hitoshi Asaeda wrote:

> During my talk, I also introduced "Cefore", which is a software 
> platform enabling CCN communications using CCNx-1.0 messages.
> Cefore consists of a packet forwarding daemon (cefnetd), a daemon 
> managing content store (csmgrd), and other tools/utilities such as 
> CCNinfo. It is *not* software *only* implementing CCNinfo.
>
> If you are interested in it, you can download it from; 
> https://cefore.net. (The web page is very much under construction, 
> sorry about that, but you can also download the user guide from 
> "Instruction" page.)
> The development is still ongoing and there are many incomplete 
> functions at this moment for sure, but it'd be great if some of you 
> can enjoy working/studying with this software.
>
> Regards,
>
> Hitoshi Asaeda
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg