Subject: [icnrg] Last Call: Information-Centric Networking (ICN): CCN and NDN Terminology

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 11 Feb 2019 16:50:41 +0100

Hello ICNRG,

Thanks, Bastiaan for submitting the update.

The ICNRG chairs would like to last-call this draft now: 
https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/

Please read it and provide comments until Monday, February 25, 16:00 CET 
(10:00 EST, 07:00 PST).

Comments could take forms such as

- OK to publish
- Suggesting some modifications
- Objection to publish

Thanks,
Dirk, Börje, Dave

On 8 Feb 2019, at 12:02, Wissingh, B.F. (Bastiaan) wrote:

> Hi ICNRG'ers,
>
> As suggested during the previous meeting, I've updated the Terminology 
> draft by removing section 3.8, containing terms not specifically 
> related to either CCN or NDN. Hopefully this brings the document in a 
> state where we could go for a RG last call.
>
> So I would encourage people to perform a review of the document before 
> the upcoming ICNRG meeting in Prague.
>
> Thanks,
> Bastiaan
>
>
> B.F. (Bastiaan) Wissingh MSc
> Research Scientist Media Networking
> Department of Networks
> T +31 (0)88 866 42 52
> M +31 (0)65 280 35 59
> E [email-masked]
> Location <http://www.tno.nl/locaties/DHA>
>
>
>  <http://www.tno.nl/>
> This message may contain information that is not intended for you. If 
> you are not the addressee or if this message was sent to you by 
> mistake, you are requested to inform the sender and delete the 
> message. TNO accepts no liability for the content of this e-mail, for 
> the manner in which you use it and for damage of any kind resulting 
> from the risks inherent to the electronic transmission of messages.
>
> -----------------------------
>
> Op 08-02-19 11:52 heeft [email-masked] 
> <[email-masked]> geschreven:
>
>
>     A new version of I-D, draft-irtf-icnrg-terminology-02.txt
>     has been successfully submitted by Bastiaan Wissingh and posted to 
> the
>     IETF repository.
>
>     Name:		draft-irtf-icnrg-terminology
>     Revision:	02
>     Title:		Information-Centric Networking (ICN): CCN and NDN 
> Terminology
>     Document date:	2019-02-08
>     Group:		icnrg
>     Pages:		17
>     URL:            
> https://www.ietf.org/internet-drafts/draft-irtf-icnrg-terminology-02.txt
>     Status:         
> https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/
>     Htmlized:       
> https://tools.ietf.org/html/draft-irtf-icnrg-terminology-02
>     Htmlized:       
> https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-terminology
>     Diff:           
> https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-terminology-02
>
>     Abstract:
>        Information Centric Networking (ICN) is a new paradigm where 
> network
>        communications are accomplished by requesting named content, 
> instead
>        of sending packets to destination addresses.  Named Data 
> Networking
>        (NDN) and Content-Centric Networking (CCN) are two prominent 
> ICN
>        architectures.  This document provides an overview of the 
> terminology
>        and definitions that have been used in describing concepts in 
> these
>        two projects.  While there are other ICN architectures, they 
> are not
>        part of the NDN and CCN vision and as such are out of scope for 
> this
>        document.
>
>
>
>
>     Please note that it may take a couple of minutes from the time of 
> submission
>     until the htmlized version and diff are available at 
> tools.ietf.org.
>
>     The IETF Secretariat
>
>
>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Akbar Rahman <[email-masked]>
Date: Wed, 13 Feb 2019 05:36:12 +0000

Hi Dirk,

I vote for “OK to publish”.  Thanks to the authors for all their effort.  I think it is a useful document which will be complementary to explaining the terms/concepts of the CCNx protocol documents going to publication.

(My only editorial type comment was that I was surprised to see that there was no “Security Considerations” section in the document.  I thought it was part of the standard IETF template.  Of course, it can be set to Null as typically in the case of a terminology document.  But no big deal either way.)

Best Regards,

Akbar

From: icnrg <[email-masked]> On Behalf Of Dirk Kutscher
Sent: Monday, February 11, 2019 10:51 AM
To: Wissingh, B.F. <bastiaan.wissingh=[email-masked]>
Cc: [email-masked]
Subject: [icnrg] Last Call: Information-Centric Networking (ICN): CCN and NDN Terminology

Hello ICNRG,

The ICNRG chairs would like to last-call this draft now: https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-irtf-icnrg-terminology%2F&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651656450&sdata=YkMD2V1tAxMkt8OrDG%2BHN3GvHrmNQY9ylD5jEdRLg8Y%3D&reserved=0>

Please read it and provide comments until Monday, February 25, 16:00 CET (10:00 EST, 07:00 PST).

  *   OK to publish
  *   Suggesting some modifications
  *   Objection to publish

Thanks,
Dirk, Börje, Dave

Hi ICNRG'ers,

As suggested during the previous meeting, I've updated the Terminology draft by removing section 3.8, containing terms not specifically related to either CCN or NDN. Hopefully this brings the document in a state where we could go for a RG last call.

So I would encourage people to perform a review of the document before the upcoming ICNRG meeting in Prague.

Thanks,
Bastiaan

B.F. (Bastiaan) Wissingh MSc
Research Scientist Media Networking
Department of Networks
T +31 (0)88 866 42 52
M +31 (0)65 280 35 59
E [email-masked]<mailto:[email-masked]>
Location <http://www.tno.nl/locaties/DHA<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.tno.nl%2Flocaties%2FDHA&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651666450&sdata=zzOwdRPTEPdWravLFNVxhsC7s8y1TJErVhtcgdxa8lQ%3D&reserved=0>>

<http://www.tno.nl/<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.tno.nl%2F&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651666450&sdata=JEcZ9C6aWbIKiHZF93esqR4Ok20TeE8EWVIhe4n9FQY%3D&reserved=0>>
This message may contain information that is not intended for you. If you are not the addressee or if this message was sent to you by mistake, you are requested to inform the sender and delete the message. TNO accepts no liability for the content of this e-mail, for the manner in which you use it and for damage of any kind resulting from the risks inherent to the electronic transmission of messages.

Op 08-02-19 11:52 heeft [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> geschreven:

A new version of I-D, draft-irtf-icnrg-terminology-02.txt
has been successfully submitted by Bastiaan Wissingh and posted to the
IETF repository.

Name: draft-irtf-icnrg-terminology
Revision: 02
Title: Information-Centric Networking (ICN): CCN and NDN Terminology
Document date: 2019-02-08
Group: icnrg
Pages: 17
URL: https://www.ietf.org/internet-drafts/draft-irtf-icnrg-terminology-02.txt<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Finternet-drafts%2Fdraft-irtf-icnrg-terminology-02.txt&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651676458&sdata=XmVH2Pjt1Rcm8UZj5ZDQ67Nuqh3OO%2FSB9zfyvtFnsz0%3D&reserved=0>
Status: https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-irtf-icnrg-terminology%2F&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651676458&sdata=h6EF5dYNq%2BJFecnDX3%2BY9sEbL7GIRqzzGVrkFKxiMss%3D&reserved=0>
Htmlized: https://tools.ietf.org/html/draft-irtf-icnrg-terminology-02<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-irtf-icnrg-terminology-02&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651686467&sdata=dM4CkrSDzpTLYqZbQCj0%2BpknCTte28opui3tpCtxyjU%3D&reserved=0>
Htmlized: https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-terminology<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-irtf-icnrg-terminology&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651696488&sdata=FW0fi6u76JkGehD8qvi6TpRzhnNij0N3976jGc8FpUk%3D&reserved=0>
Diff: https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-terminology-02<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-irtf-icnrg-terminology-02&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651696488&sdata=WmegBkh%2FDbJbN4wXqWi3crAa6XCtePXbLDNZ3joo2eI%3D&reserved=0>

Abstract:
Information Centric Networking (ICN) is a new paradigm where network
communications are accomplished by requesting named content, instead
of sending packets to destination addresses. Named Data Networking
(NDN) and Content-Centric Networking (CCN) are two prominent ICN
architectures. This document provides an overview of the terminology
and definitions that have been used in describing concepts in these
two projects. While there are other ICN architectures, they are not
part of the NDN and CCN vision and as such are out of scope for this
document.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Ficnrg&data=02%7C01%7Cakbar.rahman%40interdigital.com%7C596b222abd894d2582ea08d69038b9bf%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636854970651706492&sdata=HkztFSPgXfYKJqo17eyMKI6%2BvHOqzau2TajQimeDWyw%3D&reserved=0>

[Banner]

[Banner] [Banner]
This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

---

From: Junxiao Shi <[email-masked]>
Date: Wed, 13 Feb 2019 22:58:44 -0500

Dear folks

I don't believe I have voting rights, but I notice a few errors in the
document (revision 02).

Section 2
Figure 2 is missing.

Section 3.3 "Interest aggregation" entry
Typo in "Interest suppresion", should be "Interest suppression".
The term "Interest suppression" is undefined.
It's unclear what "multiple identical Interest packets" means. According to
the definition of "Interest packet" in section 3.4, an Interest packet may
have "additional information to facilitate forwarding" (e.g. Nonce) and
these fields do not normally prevent aggregation. Thus, it's better to
write "multiple Interest packets with same Name and additional
restrictions".

Section 3.5 "Packet ID" entry
A common alias of this term is "implicit digest", as seen in NDN Packet
Format spec.

Section 3.6 "Fragmentation" entry
Fragmentation splits not only data packets, but also Interest packets and
Interest Nack packets, to fit a smaller MTU. Thus, change "data packet" to
"Packet" or "PDU" (as defined in section 2).

Section 4.5
Entries such as "Interest match in FIB (longest prefix match)" seem out of
place.

Yours, Junxiao

---

From: "Dirk Kutscher" <[email-masked]>
Date: Thu, 14 Feb 2019 10:30:45 +0100

> I don't believe I have voting rights, but I notice a few errors in the

Hi Junxiao,

thanks — we don’t do voting — so I’m sure the authors do 
appreciate your comments.

Others, please have a look as well.

Best regards,
Dirk

---

From: "Wissingh, B.F. (Bastiaan)" <[email-masked]>
Date: Mon, 25 Feb 2019 08:44:53 +0000

Hi Akbar,

Thanks for the feedback, we’re planning to make a next (and hopefully final) revision before the upcoming meeting in Prague, so we’ll take it into account and add the section as you suggested!

Best regards,
Bastiaan

Van: Akbar Rahman <[email-masked]>
Datum: woensdag 13 februari 2019 06:36
Aan: "Kutscher, Dirk" <[email-masked]>, Bastiaan Wissingh <[email-masked]>
CC: "[email-masked]" <[email-masked]>
Onderwerp: RE: [icnrg] Last Call: Information-Centric Networking (ICN): CCN and NDN Terminology

Hi Dirk,

Best Regards,

Akbar

Hello ICNRG,

  *   OK to publish

Thanks,
Dirk, Börje, Dave

Hi ICNRG'ers,

Thanks,
Bastiaan

Abstract:

The IETF Secretariat

---

From: "Wissingh, B.F. (Bastiaan)" <[email-masked]>
Date: Mon, 25 Feb 2019 08:47:26 +0000

Hi Junxiao,

Thank you for the thorough review of the document, as Dirk mentioned, very much appreciated! We'll incorporated your comments in the next version.

Best regards,
Bastiaan

    
    Hi Junxiao,

    
    Best regards,
    Dirk