Subject: [icnrg] I-D Action: draft-irtf-icnrg-disaster-04.txt

From: [email-masked]
Date: Wed, 20 Feb 2019 07:54:55 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Information-Centric Networking RG of the IRTF.

        Title           : Research Directions for Using ICN in Disaster Scenarios
        Authors         : Jan Seedorf
                          Mayutan Arumaithurai
                          Atsushi Tagami
                          K. Ramakrishnan
                          Nicola Blefari Melazzi
	Filename        : draft-irtf-icnrg-disaster-04.txt
	Pages           : 18
	Date            : 2019-02-20

Abstract:
   Information Centric Networking (ICN) is a new paradigm where the
   network provides users with named content, instead of communication
   channels between hosts.  This document outlines some research
   directions for Information Centric Networking with respect to
   applying ICN approaches for coping with natural or human-generated,
   large-scale disasters.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-icnrg-disaster/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-icnrg-disaster-04
https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-disaster-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-disaster-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jan Seedorf <[email-masked]>
Date: Wed, 20 Feb 2019 17:27:19 +0100

Dear Marie-Jose and Vincent,

thanks a lot for the good comments you gave on our document. Sorry for 
taking so long to address these. We just published a new version, that I 
think addresses your key comments (you each had quite a few, I think we 
addressed all of the important ones). You can see a diff here:

https://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=draft-irtf-icnrg-disaster-04.txt

The main changes are:

-- all typos fixed

-- Both of you commented that the document reads like there are no more 
open issues (which is clearly not the case); since this was a key 
comment from both of you that you both mentioned several times, we 
deemed this as the most important issue. We clarified this in the text 
and added a new subsection "Open Issues" that should clarify that while 
initial, promising solutions have been proposed by researchers there is 
still quite some work to do and several issues remain open

-- Several clarifications in the text on "source/object authentication 
and content integrity" and on "content-based security" (thanks to 
Vincent, indeed some of the text we had was not clear and probably 
misleading to someone outside the ICN community)

--Clarifications on blockchain-based approaches and why those are 
probably not suitable for the scenarios considered in the doc (indeed 
Blockchain comes to mind when talking about decentralised trust, good 
comment from Marie-Jose, thanks!)

-- Clarification on natural disasters being predictable (indeed the old 
text was misleading, comment from Marie-Jose)

-- Added text in open issues section that exact requirements on what ICN 
deployment degree is needed before and after a disaster is an open issue 
(you both had comments in this direction)

-- Section 3.3. ICN vs. DTN (comment from Marie-Jose): the whole section 
is to argue that starting from ICN is not a bad idea, but clearly both 
ICN and DTN features are useful (we added a sentence in the end to 
clarify this); also, we added an open issue in the new open issues 
section that how to best/optimally combine ICN/DTN is an open issue.

Comments we did not address (yet, i.e. we are open to talking about them):

-- AM/FM radio broadcast comment from Vincent (it is surely a good idea)

-- IP-over-ICN (section 3.2, comment from Marie-Jose): We see the issue 
you raise; in fact, the IP-over-ICN approach was not initially in the 
draft but has been added after comments received from the RG; the RG 
should decide on this (I will raise this point when presenting in Prague)

I will present on how we addressed your comments in detail at IETF in 
Prague. I hope we can discuss there on-site if you think we have 
addressed your comments adequately (of course feedback on this list is 
welcome to!).

  - Jan

On 20.02.19 16:54, [email-masked] wrote:
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Wed, 20 Feb 2019 12:20:18 -0500

Thank you for addressing my comments. I will be in Prague and plan to attend the ICNRG (both the Sunday meeting and the regular meeting).

mjm
Marie-Jose Montpetit, Ph.D.
[email-masked]
[email-masked]
+1-781-526-2661
@SocialTVMIT

> On Feb 20, 2019, at 11:27 AM, Jan Seedorf <[email-masked]> wrote:
> 
> thanks a lot for the good comments you gave on our document. Sorry for taking so long to address these. We just published a new version, that I think addresses your key comments (you each had quite a few, I think we addressed all of the important ones). You can see a diff here:
> 
> -- Both of you commented that the document reads like there are no more open issues (which is clearly not the case); since this was a key comment from both of you that you both mentioned several times, we deemed this as the most important issue. We clarified this in the text and added a new subsection "Open Issues" that should clarify that while initial, promising solutions have been proposed by researchers there is still quite some work to do and several issues remain open
> 
> -- Several clarifications in the text on "source/object authentication and content integrity" and on "content-based security" (thanks to Vincent, indeed some of the text we had was not clear and probably misleading to someone outside the ICN community)
> 
> --Clarifications on blockchain-based approaches and why those are probably not suitable for the scenarios considered in the doc (indeed Blockchain comes to mind when talking about decentralised trust, good comment from Marie-Jose, thanks!)
> 
> -- Clarification on natural disasters being predictable (indeed the old text was misleading, comment from Marie-Jose)
> 
> -- Added text in open issues section that exact requirements on what ICN deployment degree is needed before and after a disaster is an open issue (you both had comments in this direction)
> 
> -- Section 3.3. ICN vs. DTN (comment from Marie-Jose): the whole section is to argue that starting from ICN is not a bad idea, but clearly both ICN and DTN features are useful (we added a sentence in the end to clarify this); also, we added an open issue in the new open issues section that how to best/optimally combine ICN/DTN is an open issue.
> 
> -- IP-over-ICN (section 3.2, comment from Marie-Jose): We see the issue you raise; in fact, the IP-over-ICN approach was not initially in the draft but has been added after comments received from the RG; the RG should decide on this (I will raise this point when presenting in Prague)
> 
> I will present on how we addressed your comments in detail at IETF in Prague. I hope we can discuss there on-site if you think we have addressed your comments adequately (of course feedback on this list is welcome to!).
> 
>  - Jan
>