Subject: [icnrg] Planning for Prague

From: "David R. Oran" <[email-masked]>
Date: Mon, 04 Mar 2019 11:12:57 -0500

The chairs have uploaded draft agendas for the Sunday Interim and Friday 
main meetings to the meeting materials area on the data tracker, and to 
the ICNRG Wiki:

https://datatracker.ietf.org/meeting/interim-2019-icnrg-02/session/icnrg
https://datatracker.ietf.org/meeting/104/session/icnrg
https://trac.ietf.org/trac/irtf/wiki/icnrg

These have planned slot lengths but not exact timing. Please check that 
your proposed items made it onto the agenda and we didn’t miss 
anything. We still have some space for more items both days so please 
propose things that would be of sufficient interest to dedicate 
in-person time to. We plan to have the agendas fully baked by Monday 
March 18.

For those of you giving presentations please remember to send the 
presentation materials to the chairs for review and upload well in 
advance of the meeting.

Note that we will have remote presentation capability for the Friday 
main meeting but as usual have not planned it for the Sunday Interim.

Also the chairs once again remind folks:

- please register for the interim meeting on the Wiki (or email the 
chairs to do it for you)

- we are still looking for a break sponsor for Sunday’s interim. If 
nobody steps up there won’t be coffee of break snacks!

---

From: Dirk Trossen <[email-masked]>
Date: Mon, 11 Mar 2019 13:45:15 +0000

Chairs, all,

We have recently uploaded an update to “Enabling ICN in 3GPP’s 5G NextGen Core Architecture”, available at https://www.ietf.org/internet-drafts/draft-ravi-icnrg-5gc-icn-03.txt. The main updates relate to adding a new Section 6, outlining the use of 5GLAN (of FS_VERT_LAN as called in 3GPP) for an IPoICN deployment, as well as refreshing some aspects in Section 5 (ICN over unstructured PDUs).

Any comments to this updated draft are very welcome on this list. In addition, we would also like to request a slot in the ICNRG meeting for giving a direct brief update to the community.

Please let me know if this would be possible.

Best,

Dirk

From: icnrg <[email-masked]> On Behalf Of David R. Oran
Sent: 04 March 2019 16:13
To: ICNRG <[email-masked]>
Subject: [icnrg] Planning for Prague

The chairs have uploaded draft agendas for the Sunday Interim and Friday main meetings to the meeting materials area on the data tracker, and to the ICNRG Wiki:

https://datatracker.ietf.org/meeting/interim-2019-icnrg-02/session/icnrg<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2Finterim-2019-icnrg-02%2Fsession%2Ficnrg&data=02%7C01%7Cdirk.trossen%40interdigital.com%7C6ed98b48d6ac4e81e3ee08d6a0bc4f24%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636873127975537110&sdata=mTKmosBiRQGRjphei1TPc%2Bzb5PfIHqJBRhJOL1bfN48%3D&reserved=0>
https://datatracker.ietf.org/meeting/104/session/icnrg<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F104%2Fsession%2Ficnrg&data=02%7C01%7Cdirk.trossen%40interdigital.com%7C6ed98b48d6ac4e81e3ee08d6a0bc4f24%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636873127975547111&sdata=%2F0mZfkxUiqb1kdvr9NNET%2FHVyN%2Bb1I4RgsJAAh1Faf8%3D&reserved=0>
https://trac.ietf.org/trac/irtf/wiki/icnrg<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Firtf%2Fwiki%2Ficnrg&data=02%7C01%7Cdirk.trossen%40interdigital.com%7C6ed98b48d6ac4e81e3ee08d6a0bc4f24%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636873127975547111&sdata=Vwo%2FfmPtiGAbq0SbKYImHlxEGoN2H4GazSjeRkEXF60%3D&reserved=0>

These have planned slot lengths but not exact timing. Please check that your proposed items made it onto the agenda and we didn’t miss anything. We still have some space for more items both days so please propose things that would be of sufficient interest to dedicate in-person time to. We plan to have the agendas fully baked by Monday March 18.

For those of you giving presentations please remember to send the presentation materials to the chairs for review and upload well in advance of the meeting.

Note that we will have remote presentation capability for the Friday main meeting but as usual have not planned it for the Sunday Interim.

  *   please register for the interim meeting on the Wiki (or email the chairs to do it for you)
  *   we are still looking for a break sponsor for Sunday’s interim. If nobody steps up there won’t be coffee of break snacks!

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 12 Mar 2019 08:52:02 -0400

Since the 5G specs are still in flux how do you plan to deal with that?

Also, while there is a lot of work in this I am still looking for the reason for putting ICN inside the 5G core with all the complexities it incurs instead of just using the 5G bit transport service and build ICN above it. Not sure making the architecture so complicated is helping promoting ICN. 

I am looking for less complexity not more.

But that’s my view and I may be wrong.

mjm

Marie-Jose Montpetit, Ph.D.
[email-masked]
[email-masked]
+1-781-526-2661
@SocialTVMIT

> On Mar 11, 2019, at 9:45 AM, Dirk Trossen <[email-masked]> wrote:
> 
> Chairs, all,
>  
> We have recently uploaded an update to “Enabling ICN in 3GPP’s 5G NextGen Core Architecture”, available at https://www.ietf.org/internet-drafts/draft-ravi-icnrg-5gc-icn-03.txt <https://www.ietf.org/internet-drafts/draft-ravi-icnrg-5gc-icn-03.txt>. The main updates relate to adding a new Section 6, outlining the use of 5GLAN (of FS_VERT_LAN as called in 3GPP) for an IPoICN deployment, as well as refreshing some aspects in Section 5 (ICN over unstructured PDUs).
>  
> From: icnrg <[email-masked] <mailto:[email-masked]>> On Behalf Of David R. Oran
> To: ICNRG <[email-masked] <mailto:[email-masked]>>
> https://datatracker.ietf.org/meeting/interim-2019-icnrg-02/session/icnrg <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2Finterim-2019-icnrg-02%2Fsession%2Ficnrg&data=02%7C01%7Cdirk.trossen%40interdigital.com%7C6ed98b48d6ac4e81e3ee08d6a0bc4f24%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636873127975537110&sdata=mTKmosBiRQGRjphei1TPc%2Bzb5PfIHqJBRhJOL1bfN48%3D&reserved=0>
> https://datatracker.ietf.org/meeting/104/session/icnrg <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fmeeting%2F104%2Fsession%2Ficnrg&data=02%7C01%7Cdirk.trossen%40interdigital.com%7C6ed98b48d6ac4e81e3ee08d6a0bc4f24%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636873127975547111&sdata=%2F0mZfkxUiqb1kdvr9NNET%2FHVyN%2Bb1I4RgsJAAh1Faf8%3D&reserved=0>
> https://trac.ietf.org/trac/irtf/wiki/icnrg <https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Firtf%2Fwiki%2Ficnrg&data=02%7C01%7Cdirk.trossen%40interdigital.com%7C6ed98b48d6ac4e81e3ee08d6a0bc4f24%7Ce351b779f6d54e50856880e922d180ae%7C0%7C0%7C636873127975547111&sdata=Vwo%2FfmPtiGAbq0SbKYImHlxEGoN2H4GazSjeRkEXF60%3D&reserved=0>
> please register for the interim meeting on the Wiki (or email the chairs to do it for you)
> we are still looking for a break sponsor for Sunday’s interim. If nobody steps up there won’t be coffee of break snacks!
> _______________________________________________
> icnrg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/icnrg <https://www.irtf.org/mailman/listinfo/icnrg>

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 12 Mar 2019 12:57:06 +0000

Marie-Jose,

There are two aspects in the draft, namely the integration of ICN as part of the 5G core (which in itself advocates the integration of non-IP PDUs) and the usage of 5GC and 5GLAN to run IPoICN (or native ICN) over it, i.e., running an ICN-based service (here HTTP/IPoverICN) on top of what is a distributed, cellular-based LAN. The latter is mainly along the lines of what you are advocating. But as said, it’s about contrasting both possibilities.

The flux in 5G is true to some extent but we are relying on work that’s (at this level) been handed from SA2 to normative phases as well as aspects that are around since Rel15. But I do agree that some things will need update (which we have in Section 5) or being described in a way that gets around the ‘flux’.

Best,

Dirk

From: Marie-Jose Montpetit <[email-masked]>
Sent: 12 March 2019 12:52
To: Dirk Trossen <[email-masked]>
Cc: Oran, Dave <[email-masked]>; ICNRG <[email-masked]>
Subject: Re: [icnrg] Planning for Prague

mjm

Marie-Jose Montpetit, Ph.D.
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
+1-781-526-2661
@SocialTVMIT

On Mar 11, 2019, at 9:45 AM, Dirk Trossen <[email-masked]<mailto:[email-masked]>> wrote:

Chairs, all,

Best,

Dirk

From: icnrg <[email-masked]<mailto:[email-masked]>> On Behalf Of David R. Oran
Sent: 04 March 2019 16:13
To: ICNRG <[email-masked]<mailto:[email-masked]>>
Subject: [icnrg] Planning for Prague

  *   please register for the interim meeting on the Wiki (or email the chairs to do it for you)
  *   we are still looking for a break sponsor for Sunday’s interim. If nobody steps up there won’t be coffee of break snacks!
_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Börje Ohlman <[email-masked]>
Date: Wed, 20 Mar 2019 12:15:29 +0000

The agendas for Prague are now available at our Wiki, the datatracker and below. Please let us know if we missed something or if you have specific requests for timings.

We are still looking for someone to sponsor refreshments for the Sunday interim (Prague is a relatively cheap place for this…).

Finally, please register for the interim meeting on the Wiki (or email the chairs to do it for you).

Looking forward to seeing you in Prague,

Börje

On 4 Mar 2019, at 17:12, David R. Oran <[email-masked]<mailto:[email-masked]>> wrote:

—————————

ICNRG Interim Meeting @ IETF 104 Prague, 24 Mar 2019<https://trac.ietf.org/trac/irtf/wiki/icnrg#ICNRGInterimMeetingIETF104Prague24Mar2019>

  *   Date: Sunday, 24 Mar 2019
  *   Time: 09:30-17:00
  *   Location: Hilton Prague (IETF Venue)
  *   Room: Karlin III
  *   Etherpad for notes: ​http://etherpad.tools.ietf.org/p/notes-ietf-104-icnrg<http://etherpad.tools.ietf.org/p/notes-ietf-104-icnrg>
  *   Meeting Materials: ​https://datatracker.ietf.org/meeting/interim-2019-icnrg-02/session/icnrg<https://datatracker.ietf.org/meeting/interim-2019-icnrg-02/session/icnrg>

Agenda proposals for our ICNRG meetings in Prague are invited. Please send your proposals to the mailing list or directly to the chairs.

For our upcoming interim meeting on March 24th in Prague, we suggest to have In-Network Computing as a featured topic, i.e., we are especially inviting contributions on ICN and In-Network Computing for that meeting We also plan to revisit our ongoing development of management tools. (there is still be room for other topics).

Draft Agenda, ICNRG Interim 2019-1 Prague, Sunday March 24

  *   Chairs Intro: Agenda Bashing, Minutes taker, Bluesheets, Status (15 min)
     *   ACM ICN 2019 Announcements
     *   Plan for the day
  *   Keyword-based naming for IoT - Onur Ascigil (25 Mins)
  *   Pub-Sub with ICN - Thomas Schmidt (30 mins)
  *   Efficient Blockchain access via ICN - Niels van Adrichem (30 min)
  *   Finalizing Disaster Draft - Jan Seedorf (15 mins)
  *   NRS Documents Update - Jungha Hong (20 mins)
  *   NDN Tools Overview, Status, and future plans - Jeff Thompson (30 mins)
  *   NFN Update - Christian Tschudin (30 minutes)
  *   Broadcast-inly communication models - Christian Tschudin (30 mins)
  *   Summary of Berkeley CFN workshop - Cedric Westphal (30 mins)
  *   Discussion of management tools (60 mins):
     *   Introduction - Dave Oran (10 mins)
     *   Ping & Traceroute - Dave Oran (10 mins)
     *   CCNinfo - Hitoshi Asaeda (20 mins)
     *   Associated technical issues/questions on Interest steering we hope to get a discussion on where the various tools are useful, how to combine them, what is missing, and how we get real measurement experience to guide future work.

———————————

ICNRG regular meeting @ IETF 104 Prague, 23 Mar 2019 - 29 Mar 2019<https://trac.ietf.org/trac/irtf/wiki/icnrg#ICNRGregularmeetingIETF104Prague23Mar2019-29Mar2019>

  *   Date: Friday March 29
  *   Time: 10:50-12:50
  *   Location: Hilton Prague (IETF Venue)
  *   Room: Congress Hall I
  *   Etherpad for notes: ​http://etherpad.tools.ietf.org/p/notes-ietf-104-icnrg<http://etherpad.tools.ietf.org/p/notes-ietf-104-icnrg>
  *   Notes taker: TBD
  *   Meeting Materials: ​https://datatracker.ietf.org/meeting/104/session/icnrg<https://datatracker.ietf.org/meeting/104/session/icnrg>

Regular meeting Agenda: ¶

  *   Chairs Intro: Agenda Bashing, Minutes taker, Bluesheets, Status (15 min)
     *   Summary of Sunday Interim
     *   CCNx Drafts to RFC editor
     *   Deployment Draft finished IRSG poll
     *   ACM ICN 2019 Announcements
  *   ICNLowPAN Update - Cenk Gündoğan (15 mins)
  *   Enabling ICN in 3GPP’s 5G NextGen?<https://trac.ietf.org/trac/irtf/wiki/NextGen> Core Architecture Update - Dirk Trossen (15 Mins)
  *   Finalizing the Terminology Draft - Bastiaan Wissingh (15 mins)
  *   QoS Treatments - Anil Jangam [remote] (25 mins)
  *   Refresher on Flow Classification [tentative] - Dave Oran (15 mins)
  *   EU Open Call for Next Gen Internet ​https://www.ngi.eu/<https://www.ngi.eu/> (10 mins)
  *   Chairs Wrapup: (10 min)
     *   Planning for next ICNRG meetings
     *   Interim at IETF 105 Montreal?
     *   IETF 104 in Prague