Subject: [icnrg] CCNx Selectors draft

From: "Mosko, Marc <[email-masked]>" <[email-masked]>
Date: Wed, 8 May 2019 21:17:50 +0000

All,

In making final edits to the CCNx specifications, I found that we cited the CCNx Selectors draft from a github website, as the version there had some updates not found in the original expired draft.  I've made a few more edits and submitted the updated selectors draft to IETF so the CCNx spec can reference it from there and not use my personal github.

This document has not been considered for acceptance as an RG document.  If there is sufficient interest in working out a good discovery protocol that operates over CCNx, I'd like to talk about that.  This Selectors draft is meant to be a proof-of-concept that sticks pretty closely to the original CCNx 0.x mechanism.

Marc

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 08 May 2019 17:24:58 -0400

On 8 May 2019, at 17:17, Mosko, Marc wrote:

> All,
>
> In making final edits to the CCNx specifications, I found that we 
> cited the CCNx Selectors draft from a github website, as the version 
> there had some updates not found in the original expired draft.  I've 
> made a few more edits and submitted the updated selectors draft to 
> IETF so the CCNx spec can reference it from there and not use my 
> personal github.
>
> This document has not been considered for acceptance as an RG 
> document.  If there is sufficient interest in working out a good 
> discovery protocol that operates over CCNx, I'd like to talk about 
> that.  This Selectors draft is meant to be a proof-of-concept that 
> sticks pretty closely to the original CCNx 0.x mechanism.
>
ICRGers: please review this.
Marc, any chance you could present in Montreal, even if it has to be 
remote?

> Marc
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

DaveO

---

From: "Mosko, Marc <[email-masked]>" <[email-masked]>
Date: Wed, 8 May 2019 22:04:51 +0000

Yes, I should be able to present one way or another in Montreal.

There was a little talk about discovery protocols on the ndn-interest mailing list by some ICNRG members.  It would be good to have a session about discovery more generally than this draft and talk about what makes better sense.  I think that having discovery operate above the forwarder level (where there's more resources) opens up a lot more options than the name segment-by-name segment operation of the original selectors.

Marc

________________________________________
From: David R. Oran <[email-masked]>
Sent: Wednesday, May 8, 2019 2:24 PM
To: Mosko, Marc <[email-masked]>
Cc: icnrg
Subject: Re: [icnrg] CCNx Selectors draft

DaveO