Subject: Re: [icnrg] Adoption of draft-white-icnrg-ipoc as an ICNRG Draft

From: "Thomas C. Schmidt" <[email-masked]>
Date: Wed, 24 Jul 2019 14:09:52 -0400

Hi,

I've participated in several presentations and had a (rather light) look 
at the document.

 From this, I believe the document addresses an important work and 
should be adopted.

Still I have a couple of immediate remarks that might bring up some 
additional thinking or work on this subject.

The draft states in its abstract:
   "By leveraging the
    elegant, built-in support for mobility provided by CCN or NDN, this
    protocol achieves performance on par with LTE-EPC, equivalent
    efficiency, and substantially lower implementation and protocol
    complexity."
Unfortunately, I could not find any substantiation nor justification for 
this claim, neither in the document nor in references.

As this is a research group document, I would further encourage to 
include a comparative discussion with Mobile IPv6 (RFC 6275) and - as 
the ICN approach is more closely related to Multicast - with Multicast 
Mobility (see RFC 5757).

Cheers,
  Thomas

On 24/07/2019 11:11, David R. Oran wrote:
> Folks,
> 
> At the ICNRG Interim meeting before IETF 105, the chairs proposed we
> adopt the IPOC work as a Research Group draft for progression. There was
> support for this at the meeting, so we are issuing this call on the list
> to confirm this decision. If we hear no objections by Friday July 26, we
> will adopt the draft. No need for ACKs; only NACK if anyone has
> objections to this course of action.
> 
> The current draft is at
> https://datatracker.ietf.org/doc/draft-white-icnrg-ipoc/.
> 
> Many thanks,
> 
> DaveO, Börje, and Dirk.
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
> 

-- 

Prof. Dr. Thomas C. Schmidt
° Hamburg University of Applied Sciences                  Berliner Tor 7 °
° Dept. Informatik, Internet Technologies Group   20099 Hamburg, Germany °
° http://inet.haw-hamburg.de/members/schmidt      Fon: +49-40-42875-8452 °

---

From: Greg White <[email-masked]>
Date: Wed, 24 Jul 2019 19:16:16 +0000

Thanks Thomas.  

Justification for that claim is provided in the SIGCOMM paper (which I had intended to add to the References list).
https://dl.acm.org/citation.cfm?id=3229575
I will update the References to include this paper.

We'll have a look at the two RFCs you mentioned and see if we can come up with a good comparison.  Would you be willing to review and comment on  that text once we've got something? 

-Greg

On 7/24/19, 2:10 PM, "icnrg on behalf of Thomas C. Schmidt" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    

    
    Cheers,
      Thomas

    --