Subject: [icnrg] Interop testing?

From: "Mosko, Marc <[email-masked]>" <[email-masked]>
Date: Tue, 23 Jul 2019 16:23:24 +0000

Now that we have the RFCs out, do we want to have a round of interop / conformance testing? 
 My idea is that there would be separate client library tests and forwarder tests.

For the forwarder tests, we would generate some test vectors of Interests and Content Objects and expected results (i.e. should fail or should succeed).  We could then write test rigs for each implementation (cicn, ccn-lite, cefore, etc.), connect them in topologies and run various consumers & publishers.  It may be that a single test rig could be used for all implementations.  For example, use a ccn-lite forwarder (A) and cicn (B) with a test rig (T) connected T-A-B-A-B-T.

For client library tests, I'm not sure what would be a good way to do that.  There's a few ideas, but I'd like to hear what people think of this.

Marc

---

From: Börje Ohlman <[email-masked]>
Date: Tue, 23 Jul 2019 12:54:14 -0400

Sounds like a good idea. Maybe we should go for doing a hackathon in Singapore instead of an interim meeting. 

     Börje 

> 23 juli 2019 kl. 12:23 skrev Mosko, Marc <[email-masked]> <[email-masked]>:
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Marie-Jose Montpetit <[email-masked]>
Date: Tue, 23 Jul 2019 13:17:16 -0400

Hackatons are cool :)

Marie-José Montpetit, Ph.D.
Research Affiliate, MIT Media Laboratory
[email-masked]
[email-masked]

On July 23, 2019 at 12:54:14 PM, Börje Ohlman ([email-masked]) wrote:

> For the forwarder tests, we would generate some test vectors of Interests
> and Content Objects and expected results (i.e. should fail or should
> succeed). We could then write test rigs for each implementation (cicn,
> ccn-lite, cefore, etc.), connect them in topologies and run various
> consumers & publishers. It may be that a single test rig could be used for
> all implementations. For example, use a ccn-lite forwarder (A) and cicn (B)
> with a test rig (T) connected T-A-B-A-B-T.
>
> For client library tests, I'm not sure what would be a good way to do
> that. There's a few ideas, but I'd like to hear what people think of this.
>
> Marc
>