Subject: [icnrg] Possible adoption of "Enabling ICN in 3GPP's 5G NextGen Core Architecture" (draft-ravi-icnrg-5gc-icn-04)

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 16 Sep 2019 20:36:07 +0200

Hi ICNRG,

At the ICNRG meeting at IETF-105 in Montreal, we discussed the possible 
adoption of https://datatracker.ietf.org/doc/draft-ravi-icnrg-5gc-icn/ .

During the meeting, no objection was raised, but not many people had 
read the latest version of the draft. As usual, we would like to follow 
up on the mailing list, so we are looking for statements indicating 
support for adoption or concerns against it from people who are 1) not 
co-authors and 2) have read the latest version.

Thanks and best regards,

Chairs

---

From: Cedric Westphal <[email-masked]>
Date: Thu, 19 Sep 2019 18:18:08 +0000

Hi Dirk,

I support adoption of this draft. It is a very interesting discussion on how to enable ICN over the 5G architecture.

A couple editorial comments:

  *   “where 5G technology is considered as one of the promising alternatives.” -> alternative to what?
  *   “realtime” -> real time or real-time
  *   “application- bound identifier and name resolution split principle considered for the ICN is shown to handle host mobility quite efficiently” -> unclear sentence. Maybe: “ICN uses a split between the application identifier and the name resolution that is known to handle host mobility efficiently”
  *   “design principals” -> “design principles”
  *   “utilize API design” -> “an API design”

Best,

C.

---------- Forwarded message ---------
From: Dirk Kutscher <[email-masked]<mailto:[email-masked]>>
Date: Mon, Sep 16, 2019 at 11:36 AM
Subject: [icnrg] Possible adoption of "Enabling ICN in 3GPP's 5G NextGen Core Architecture" (draft-ravi-icnrg-5gc-icn-04)
To: ICNRG <[email-masked]<mailto:[email-masked]>>

Hi ICNRG,

At the ICNRG meeting at IETF-105 in Montreal, we discussed the possible
adoption of https://datatracker.ietf.org/doc/draft-ravi-icnrg-5gc-icn/<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ravi-icnrg-5gc-icn%2F&data=02%7C01%7Ccedric.westphal%40futurewei.com%7C1278917ce119463ea73a08d73c5fa868%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637044253849499323&sdata=y6MacrSUa056iZsRKSGr5O3t%2BqDRdY31fgGR4ECr0aE%3D&reserved=0> .

Thanks and best regards,

Chairs

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg<https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Ficnrg&data=02%7C01%7Ccedric.westphal%40futurewei.com%7C1278917ce119463ea73a08d73c5fa868%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637044253849499323&sdata=vaqzel4d%2BDaViQaXlm5LsUCXhcA8HpqUBI3KGzA4IOM%3D&reserved=0>

---

From: Ravi Ravindran <[email-masked]>
Date: Thu, 19 Sep 2019 19:44:20 -0700

Thanks Cedric, we will address the corrections in the next review.

Regards
Ravi

On Thu, Sep 19, 2019, 11:18 Cedric Westphal <[email-masked]
wrote:

> Hi Dirk,
>
>
>
> I support adoption of this draft. It is a very interesting discussion on
> how to enable ICN over the 5G architecture.
>
>
>
>    - “where 5G technology is considered as one of the promising
>    alternatives.” -> alternative to what?
>    - “realtime” -> real time or real-time
>    - “application- bound identifier and name resolution split principle
>    considered for the ICN is shown to handle host mobility quite efficiently”
>    -> unclear sentence. Maybe: “ICN uses a split between the application
>    identifier and the name resolution that is known to handle host mobility
>    efficiently”
>    - “design principals” -> “design principles”
>    - “utilize API design” -> “an API design”
>
>
>
> Best,
>
>
>
> C.
>
>
>
>
>
> From: *Dirk Kutscher* <[email-masked]>
> Subject: [icnrg] Possible adoption of "Enabling ICN in 3GPP's 5G NextGen
> Core Architecture" (draft-ravi-icnrg-5gc-icn-04)
> To: ICNRG <[email-masked]>
>
>
>
> Hi ICNRG,
>
> adoption of https://datatracker.ietf.org/doc/draft-ravi-icnrg-5gc-icn/
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ravi-icnrg-5gc-icn%2F&data=02%7C01%7Ccedric.westphal%40futurewei.com%7C1278917ce119463ea73a08d73c5fa868%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637044253849499323&sdata=y6MacrSUa056iZsRKSGr5O3t%2BqDRdY31fgGR4ECr0aE%3D&reserved=0>
> .
>
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
> <https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.irtf.org%2Fmailman%2Flistinfo%2Ficnrg&data=02%7C01%7Ccedric.westphal%40futurewei.com%7C1278917ce119463ea73a08d73c5fa868%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637044253849499323&sdata=vaqzel4d%2BDaViQaXlm5LsUCXhcA8HpqUBI3KGzA4IOM%3D&reserved=0>
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg
>

---

From: Ruidong Li <[email-masked]>
Date: Wed, 25 Sep 2019 16:22:00 +0900

Hi Dirk,

I support the adoption of this draft. This draft shows the method to 
enable ICN in 5GC, which is important and necessary.

Some editorial comments are provided as follows:

  * using centralized routing using ... --> using centralized routing
    with ...
  * "MME" occurred as abbreviation without full name
  * design principles that allows it ... --> design principles that
    allow it ...
  * IP application utilize ... --> IP applications utilize ...

Best Regards,
Ruidong Li

On 2019/09/17 3:36, Dirk Kutscher wrote:
> Hi ICNRG,
>
> At the ICNRG meeting at IETF-105 in Montreal, we discussed the 
> possible adoption of 
> https://datatracker.ietf.org/doc/draft-ravi-icnrg-5gc-icn/ .
>
> read the latest version of the draft. As usual, we would like to 
> follow up on the mailing list, so we are looking for statements 
> indicating support for adoption or concerns against it from people who 
> are 1) not co-authors and 2) have read the latest version.
>
> Thanks and best regards,
>
> Chairs
>

-- 
Ruidong Li,
Senior Researcher, Network System Research Institute,
National Institute of Information and Communications Technology (NICT), Japan
Email: [email-masked]  [email-masked]