Subject: Re: [icnrg] [nwcrg] I-D Action: draft-irtf-nwcrg-nwc-ccn-reqs-02.txt

From: Kazuhisa Matsuzono <[email-masked]>
Date: Fri, 20 Sep 2019 18:06:49 +0900

Dear NWCRG community,

We've just uploaded the new draft incorporating the feedback we received.
We are looking forward to further comments if any.
A brief list of updates which specifies the modified Section and the 
content is below:
<Sec. 1 Introduction>
* Move the sentences regarding NC transport mechanism (coherent/non- 
coherent NC) from Sec. 3 to Sec. 1.

<Sec. 2.2 NDN/CCN Background>
* Add two references, CCNx and NDN packet format.

<Sec. 4.1 Content Naming>
* Add a pointer to the other section since the naming considerations 
appears later, and remove some duplicated sentences.
* Move the sentence regarding compression techniques from 4.2.3 Router 
Operation to 4.1 Content Naming.

<Sec. 4.2.4 Publisher Operation>
*Add one benefit in such end-to-end

<Sec. 4.3 In-network Caching>
* Regarding the security consideration for caching, add the pointer to 
Sec. 4.5 Security and Privacy.

<Sec. 4.4 Seamless Mobility>
* Remove "rate adaptation" since the subsection pertains to seamless 
mobility.

<Sec. 5.2 Rate and Congestion Control>
* adds the sentence regarding seamless mobility.

<Sec. 5.4 Routing Scalability>
* Added a challenge regarding getting linearly independent content.

Thank you.

Kazuhisa

On 2019/09/20 18:00, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> This draft is a work item of the Coding for efficient NetWork 
> Communications Research Group RG of the IRTF.
>
> Title : Network Coding for Content-Centric Networking / Named Data 
> Networking: Requirements and Challenges
> Authors : Kazuhisa Matsuzono
> Hitoshi Asaeda
> Cedric Westphal
> Filename : draft-irtf-nwcrg-nwc-ccn-reqs-02.txt
> Pages : 19
> Date : 2019-09-20
>
> Abstract:
> This document describes the current research outcomes regarding
> Network Coding (NC) for Content-Centric Networking (CCN) / Named Data
> Networking (NDN), and clarifies the requirements and challenges for
> applying NC into CCN/NDN.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-irtf-nwcrg-nwc-ccn-reqs/
>
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-irtf-nwcrg-nwc-ccn-reqs-02
> https://datatracker.ietf.org/doc/html/draft-irtf-nwcrg-nwc-ccn-reqs-02
>
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-irtf-nwcrg-nwc-ccn-reqs-02
>
>
> Please note that it may take a couple of minutes from the time of 
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> nwcrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nwcrg
>

_______________________________________________
nwcrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nwcrg

---

From: "David R. Oran" <[email-masked]>
Date: Fri, 20 Sep 2019 08:50:20 -0400

This draft, while being progress in NWCRG, is equally of importance to 
ICNRG. Please review it and provide feedback on the NWCRG list (copy 
ICNRG as well for those who don’t subscribe to NWCRG).

Also note the email I redirected earlier today from the authors 
outlining the recent changes in the draft.

Thanks to all!

DaveO

Forwarded message:

> From: [email-masked]
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-irtf-nwcrg-nwc-ccn-reqs-02.txt
> Date: Fri, 20 Sep 2019 02:00:28 -0700
>
>         Title           : Network Coding for Content-Centric 
> Networking / Named Data Networking: Requirements and Challenges
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt