Subject: Re: [icnrg] I-D Action: draft-irtf-icnrg-icn-lte-4g-04.txt

From: "Reed, Martin J" <[email-masked]>
Date: Wed, 2 Oct 2019 12:27:19 +0000

Hi.

I support draft-irtf-icnrg-icn-lte-4g-04.txt

Minor suggested changes:

 Expand CUPS on first use in section 4.1

 With this major architecture change, User Plane Function -> With this major architecture change, a User Plane Function

 TCL can use a number of mechanisms for the selection of transport. -> The TCL can use a number of mechanisms for the selection of transport.

 On other hand, PGW shall -> On other hand, the PGW shall

 At the end of point 3 in Section 4.2  it says

 "Detailed user plane deployment use cases are described in
 Section 4.4.  Application conveys the preference to the TCL,
 which in turn sends the ICN data packets using the IP transport. “

 I would suggest removing the last sentence as it is explained fully in 4.4.1 and the context
 is not clear at the end of Section 4.2, else this last sentence needs a little more context.

Regards,

Martin

Dr. M.J. Reed                                         Room:       1NW.4.18
School of Computer Science and Electronic Engineering
Tel:+44 (0)1206 872479            FAX:+44 (0)1206 872900
University of Essex, Colchester CO4 3SQ, UK
Email [email-masked]<mailto:[email-masked]>
Web: http://csee.essex.ac.uk/staff/mjreed
Doodle meetme: http://doodle.com/martinjreed

On 10 Sep 2019, at 12:38, [email-masked]<mailto:[email-masked]> wrote:

Send icnrg mailing list submissions to
[email-masked]<mailto:[email-masked]>

To subscribe or unsubscribe via the World Wide Web, visit
https://www.irtf.org/mailman/listinfo/icnrg
or, via email, send a message with subject or body 'help' to
[email-masked]

You can reach the person managing the list at
[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of icnrg digest..."
Today's Topics:

  1. ACM ICN: Early bird registration extended (Matthias Waehlisch)
  2. I-D Action: draft-irtf-icnrg-icn-lte-4g-04.txt
     ([email-masked])
  3. Re: I-D Action: draft-irtf-icnrg-icn-lte-4g-04.txt
     (Anil Jangam (anjangam))
  4. Re: New Version Notification for
     draft-irtf-icnrg-terminology-05.txt (B?rje Ohlman)

From: Matthias Waehlisch <[email-masked]>
Subject: [icnrg] ACM ICN: Early bird registration extended
Date: 10 September 2019 at 00:10:43 BST
To: ICNRG <[email-masked]>
Message-Id: <alpine.WNT.2.00.1909091600200.16312@mw-x1>

**
Due to multiple requests the deadline of early registration has been
extended to September 13, 2019. Check
https://conferences.sigcomm.org/acm-icn/2019/registration.php
**

Futher updates include details about the keynote, panels, and sessions.

              CALL FOR PARTICIPATION

ACM Conference on Information-Centric Networking 2019
 Macau, SAR China, September 24-26, 2019
 https://conferences.sigcomm.org/acm-icn/2019/

The organizing committee is delighted to invite you to the 6th ACM
conference on Information-Centric Networking (ICN), to be held in Macao,
SAR China from September 24-26, 2019.  ACM ICN 2019 is focusing on
significant research contributions to ICN as broadly defined, and
featuring paper presentations, posters, and demonstrations.

**Change of Venue**

In contrast to previous announcements, ICN '19 is moved to Macau
University in Macau due to the continuing concerns regarding events in
Hong Kong.

**Keynote**

The keynote will be given by Dave Clark: "ICNs, Internets, and the
future of Networking".

**Program**

15 papers presented in single-track sessions:

Session: Applications

* Secure Scuttlebutt: An Information-Centric Protocol for Subjective and Decentralised Community Applications
* InterServer Game State Synchronisation using Named Data Networking
* Decentralised and Secure Multimedia Sharing Application over Named Data Networking

Session: Architectures and Infrastructure (1h 30m)

* Enabling ICN in the Internet Protocol: Analysis and Evaluation of the Hybrid-ICN Architecture
* Compute First Networking: Distributed Computing meets ICN
* Towards Peer-to-Peer Content Retrieval Markets: Enhancing IPFS with ICN

Session: Name Spaces

* NDN-CNL: A Hierarchical Namespace API for Named Data Networking
* The Missing Piece: On Namespace Management in NDN and How DNSSEC Might Help
* Space Analysis: Verification of Named Data Network Data Planes

Session: Caching

* On the power of in-network caching in the Hadoop Distributed File System
* Easy as ABC: A Lightweight Centrality-Based Caching Strategy for Information-Centric IoT

Session: Protocol enhancements

* Learned Building a Secure, Network Measurement Framework using Basic NDN
* NDN-ABS: Attribute-Based Signature Scheme for Named Data Networking
* Mesh under the Microscope: How much ICN is Inside?
* More for Less: The Surprising Benefits of QoS Management in Constrained NDN Networks

2 panels: "Industry Applications of ICN" Panel about "The Values of
Decentralization".

12 posters and demos about emerging topics.

4 half-day tutorials on
 * Service-based Routing at the Edge
 * TouchNDN: Visual Programming of Data-centric Video
 * Building IoT Systems over Named Data Networking
 * The InterPlanetary File System (IPFS)

Note that participating in the tutorials is covered by the conference
fees.

More details: https://conferences.sigcomm.org/acm-icn/2019/program.php

** Registration**

https://conferences.sigcomm.org/acm-icn/2019/registration.php

**Side Events*

Travel once and enjoy multiple events in addition to ACM ICN:

 * September 23: Hands-on workshop that explores how Future Internet
 will impact dynamic media artworks and multimedia systems. Creating
 Distributed Media Experiences with TouchDesigner and NDN.

 * September 27: Interim meeting of the IRTF ICN Research Group.

From: [email-masked]
Subject: [icnrg] I-D Action: draft-irtf-icnrg-icn-lte-4g-04.txt
Date: 10 September 2019 at 06:38:47 BST
To: <[email-masked]>
Cc: [email-masked]
Reply-To: [email-masked]
Message-Id: <[email-masked]>

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Information-Centric Networking RG of the IRTF.

       Title           : Native Deployment of ICN in LTE, 4G Mobile Networks
       Authors         : Prakash Suthar
                         Milan Stolic
                         Anil Jangam
                         Dirk Trossen
                         Ravishankar Ravindran
Filename        : draft-irtf-icnrg-icn-lte-4g-04.txt
Pages           : 37
Date            : 2019-09-09

Abstract:
  LTE, 4G mobile networks use IP based transport for control plane to
  establish the data session and user plane for actual data delivery.
  In existing architecture, IP transport used in user plane is not
  optimized for data transport, which leads to an inefficient data
  delivery.  IP unicast routing from server to clients is used for
  delivery of multimedia content to User Equipment (UE), where each
  user gets a separate stream.  From bandwidth and routing perspective
  this approach is inefficient.  Multicast and broadcast technologies
  have emerged recently for mobile networks, but their deployments are
  very limited or at an experimental stage due to complex architecture
  and radio spectrum issues.  ICN is a rapidly emerging technology with
  built-in features for efficient multimedia data delivery, however
  majority of the work is focused on fixed networks.  The main focus of
  this draft is on native deployment of ICN in cellular mobile networks
  by using ICN in 3GPP protocol stack.  ICN has an inherent capability
  for multicast, anchorless mobility, security and it is optimized for
  data delivery using local caching at the edge.  The proposed
  approaches in this draft allow ICN to be enabled natively over the
  current LTE stack comprising of PDCP/RLC/MAC/PHY or in a dual stack
  mode (along with IP) help optimize the mobile networks by leveraging
  the inherent benefits of ICN.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-irtf-icnrg-icn-lte-4g-04
https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-icn-lte-4g-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-icn-lte-4g-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

From: "Anil Jangam (anjangam)" <[email-masked]>
Subject: Re: [icnrg] I-D Action: draft-irtf-icnrg-icn-lte-4g-04.txt
Date: 10 September 2019 at 07:00:26 BST
To: "[email-masked]" <[email-masked]>
Cc: Akbar Rahman <[email-masked]>, Luca Muscariello <[email-masked]>
Message-Id: <[email-masked]>

Dear Friends,

We have uploaded an update to our draft incorporating all the feedback we received so far.
Specifically, we worked offline with reviewers (CC'ed), discussed their feedback and incorporated it.

We are looking forward to further comments, if any.
We also request chairs to guide us further on progression of this draft.

Thank you,
/anil.

   A New Internet-Draft is available from the on-line Internet-Drafts directories.
   This draft is a work item of the Information-Centric Networking RG of the IRTF.

           Title           : Native Deployment of ICN in LTE, 4G Mobile Networks
           Authors         : Prakash Suthar
                             Milan Stolic
                             Anil Jangam
                             Dirk Trossen
                             Ravishankar Ravindran
    Filename        : draft-irtf-icnrg-icn-lte-4g-04.txt
    Pages           : 37
    Date            : 2019-09-09

   Abstract:
      LTE, 4G mobile networks use IP based transport for control plane to
      establish the data session and user plane for actual data delivery.
      In existing architecture, IP transport used in user plane is not
      optimized for data transport, which leads to an inefficient data
      delivery.  IP unicast routing from server to clients is used for
      delivery of multimedia content to User Equipment (UE), where each
      user gets a separate stream.  From bandwidth and routing perspective
      this approach is inefficient.  Multicast and broadcast technologies
      have emerged recently for mobile networks, but their deployments are
      very limited or at an experimental stage due to complex architecture
      and radio spectrum issues.  ICN is a rapidly emerging technology with
      built-in features for efficient multimedia data delivery, however
      majority of the work is focused on fixed networks.  The main focus of
      this draft is on native deployment of ICN in cellular mobile networks
      by using ICN in 3GPP protocol stack.  ICN has an inherent capability
      for multicast, anchorless mobility, security and it is optimized for
      data delivery using local caching at the edge.  The proposed
      approaches in this draft allow ICN to be enabled natively over the
      current LTE stack comprising of PDCP/RLC/MAC/PHY or in a dual stack
      mode (along with IP) help optimize the mobile networks by leveraging
      the inherent benefits of ICN.

   The IETF datatracker status page for this draft is:
   https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/

   There are also htmlized versions available at:
   https://tools.ietf.org/html/draft-irtf-icnrg-icn-lte-4g-04
   https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-icn-lte-4g-04

   A diff from the previous version is available at:
   https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-icn-lte-4g-04

   Please note that it may take a couple of minutes from the time of submission
   until the htmlized version and diff are available at tools.ietf.org.

   Internet-Drafts are also available by anonymous FTP at:
   ftp://ftp.ietf.org/internet-drafts/

   _______________________________________________
   icnrg mailing list
   [email-masked]
   https://www.irtf.org/mailman/listinfo/icnrg

From: Börje Ohlman <[email-masked]>
Subject: Re: [icnrg] New Version Notification for draft-irtf-icnrg-terminology-05.txt
Date: 10 September 2019 at 12:37:55 BST
To: icnrg <[email-masked]>
Cc: Colin Perkins <[email-masked]>, [email-masked], David R Oran <[email-masked]>
Message-Id: <[email-masked]>

If you have any comments or objections to this please send them to the list by the end of this week.
If there are non I will ask Colin to put this to a final IRTF poll in the beginning of next week.

Börje

On 7 Sep 2019, at 14:25, David R. Oran <[email-masked]<mailto:[email-masked]>> wrote:

This posting is a revision of the ICN Terminology draft with changes resulting from the IRSG review. Attached please find the comments by Marie-Jose Montpetit (the IRSG Reviewer) and responses noting the associated changes.

In addition to the specific comment responses, a bit of text was added to improve the document in preparation for final IRTF poll. These are:

  *   expanded text to fill our two use cases that had eclipses rather than actual fleshed out information.
  *   an acknowledgements section was added

Please check this over to ensure the support indicated ion the RG last call still stands. Börje is acting as Shepherd so this is now in his hands to assess readiness for final IRTF Poll.

Thanks again to the IRSG, particularly Marie-Jose, for the review, and to the ICNRG for its support of this work.

DaveO.

On 7 Sep 2019, at 8:17, [email-masked]<mailto:[email-masked]> wrote:

A new version of I-D, draft-irtf-icnrg-terminology-05.txt
has been successfully submitted by David Oran and posted to the
IETF repository.

Name: draft-irtf-icnrg-terminology
Revision: 05
Title: Information-Centric Networking (ICN): CCNx and NDN Terminology
Document date: 2019-09-07
Group: icnrg
Pages: 18
URL:  https://www.ietf.org/internet-drafts/draft-irtf-icnrg-terminology-05.txt
Status:  https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/
Htmlized:  https://tools.ietf.org/html/draft-irtf-icnrg-terminology-05
Htmlized:  https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-terminology
Diff:  https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-terminology-05

Abstract:
Information Centric Networking (ICN) is a novel paradigm where
network communications are accomplished by requesting named content,
instead of sending packets to destination addresses. Named Data
Networking (NDN) and Content-Centric Networking (CCNx) are two
prominent ICN architectures. This document provides an overview of
the terminology and definitions that have been used in describing
concepts in these two implementations of ICN. While there are other
ICN architectures, they are not part of the NDN and CCNx concepts and
as such are out of scope for this document. This document is a
product of the Information-Centric Networking Research Group (ICNRG).

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

DaveO

<Marie-Jose Monpetit review with responses.txt>_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Anil Jangam (anjangam)" <[email-masked]>
Date: Wed, 2 Oct 2019 18:18:14 +0000

Thank you Martin for your feedback. We will wait for some more and put a consolidated update.

Thank you,
/anil.

icnrg on behalf of Reed, Martin J [email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]> 10/2/19, 5:28 AM

Hi.

Minor suggested changes:

Regards,

Martin

**

              CALL FOR PARTICIPATION

**Change of Venue**

**Keynote**

**Program**

Session: Applications

Session: Name Spaces

Session: Caching

4 half-day tutorials on

** Registration**

**Side Events*

Abstract:

Dear Friends,

Thank you,
/anil.

   Abstract:

Börje

·         expanded text to fill our two use cases that had eclipses rather than actual fleshed out information.
·         an acknowledgements section was added