Subject: Re: [icnrg] I-D Action: draft-irtf-icnrg-ipoc-01.txt

From: Greg White <[email-masked]>
Date: Mon, 10 Feb 2020 23:41:28 +0000

All,

A few days ago, we submitted an update to the ICNRG IPoC draft.  This update addresses the comments that we've received from the RG since last August, please review and consider whether this is ready for last call.

The substantive changes were:
- replaced instances of "CCN" with "CCNx"
- added a paragraph in the Introduction to give more context
- added a paragraph in the Introduction that compares IPoC to MIPv6
- added a paragraph in the Introduction that discusses support for IP multicast
- completed the Security Considerations section

You can view the diff via the link below.
 
Best Regards,
Greg

On 1/31/20, 4:18 PM, "icnrg on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

    A New Internet-Draft is available from the on-line Internet-Drafts directories.
    This draft is a work item of the Information-Centric Networking RG of the IRTF.
    
            Title           : Internet Protocol Tunneling over Content Centric Mobile Networks
            Authors         : Greg White
                              Susmit Shannigrahi
                              Chengyu Fan
    	Filename        : draft-irtf-icnrg-ipoc-01.txt
    	Pages           : 15
    	Date            : 2020-01-31
    
    Abstract:
       This document describes a protocol that enables tunneling of Internet
       Protocol traffic over a Content Centric Network (CCNx) or a Named
       Data Network (NDN).  The target use case for such a protocol is to
       provide an IP mobility plane for mobile networks that might otherwise
       use IP-over-IP tunneling, such as the GPRS Tunneling Protocol (GTP)
       used by the Evolved Packet Core in LTE networks (LTE-EPC).  By
       leveraging the elegant, built-in support for mobility provided by
       CCNx or NDN, this protocol achieves performance on par with LTE-EPC,
       equivalent efficiency, and substantially lower implementation and
       protocol complexity [Shannigrahi].  Furthermore, the use of CCNx/NDN
       for this purpose paves the way for the deployment of ICN native
       applications on the mobile network.

    The IETF datatracker status page for this draft is:
    https://datatracker.ietf.org/doc/draft-irtf-icnrg-ipoc/
    
    There are also htmlized versions available at:
    https://tools.ietf.org/html/draft-irtf-icnrg-ipoc-01
    https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-ipoc-01
    
    A diff from the previous version is available at:
    https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-ipoc-01

    Please note that it may take a couple of minutes from the time of submission
    until the htmlized version and diff are available at tools.ietf.org.
    
    Internet-Drafts are also available by anonymous FTP at:
    ftp://ftp.ietf.org/internet-drafts/
    
    _______________________________________________
    icnrg mailing list
    [email-masked]
    https://www.irtf.org/mailman/listinfo/icnrg

---

From: "David R. Oran" <[email-masked]>
Date: Fri, 14 Feb 2020 09:33:49 -0500

<chair hat off>
I reread the updated draft, concentrating on the diffs and it looks good 
to go to me. I therefore as an individual assess this as ready for ICNRG 
Last Call.

DaveO.

On 10 Feb 2020, at 18:41, Greg White wrote:

> All,
>
> A few days ago, we submitted an update to the ICNRG IPoC draft.  This 
> update addresses the comments that we've received from the RG since 
> last August, please review and consider whether this is ready for last 
> call.
>
> On 1/31/20, 4:18 PM, "icnrg on behalf of [email-masked]" 
> <[email-masked] on behalf of [email-masked]> wrote:
>
>

DaveO