Subject: [icnrg] reference needed for Interest-Interest

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 09 Mar 2020 14:21:40 +0100

Hello everyone,

I’m looking for a reference for the “Interest-Interest-Data” 
scheme (that has been proposed as a PUSH surrogate).

Thanks,
Dirk

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 09 Mar 2020 15:11:11 +0100

https://conferences.sigcomm.org/sigcomm/2011/papers/icn/p56.pdf

from ICN-2011 describes the approach and its potential problems.

Let me know if you have a better (seminal) reference.

Thanks,
Dirk

On 9 Mar 2020, at 14:21, Dirk Kutscher wrote:

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Mosko, Marc <[email-masked]>" <[email-masked]>
Date: Mon, 9 Mar 2020 17:23:52 +0000

The interest-interest-data semantics have been around in CCNx since the very early days.  It is the CCNx 0.x repository StartWrite command (https://github.com/ProjectCCNx/ccnx/blob/master/doc/technical/RepoProtocol.txt).  A producer sends an Interest to the repo asking that it fetch data from the producer.  The Repo sends an acknowledgement ContentObject and also starts fetching the data via normal interest-data exchanges.

The main issue with this approach is (a) the producer cannot tell which interests are from the repo and which are from another consumer, and (b) there is no "finished" notification, so the client must poll the repo to see if it has everything.  Both (a) and (b) mean the producer cannot easily discard the content as it does not know when the repo is done saving it.  A client can check if a particular segment is in the repository via the CheckedStartWrite command, though this is done segment-by-segment so is not particularly efficient.

The early Voice over CCNx (2009) paper used an Interest-Data exchange to kickoff bi-directional Interest-Data/Interest-Data exchanges in a different namespace.

The paper "CCNx 1.0 Bidirectional Streams " [https://arxiv.org/abs/1707.04738] extends the VoCCNx approach to a more robust repository protocol.   The document was originally published in 2013 or so as a tech report with the early CCNx 1.0 papers.

Marc

On 3/9/20, 7:12 AM, "icnrg on behalf of Dirk Kutscher" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Thanks,
    Dirk

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 09 Mar 2020 19:41:41 +0100

Marc,

Thanks!

Dirk

On 9 Mar 2020, at 18:23, Mosko, Marc wrote:

> The interest-interest-data semantics have been around in CCNx since 
> the very early days.  It is the CCNx 0.x repository StartWrite command 
> (https://github.com/ProjectCCNx/ccnx/blob/master/doc/technical/RepoProtocol.txt). 
>  A producer sends an Interest to the repo asking that it fetch data 
> from the producer.  The Repo sends an acknowledgement ContentObject 
> and also starts fetching the data via normal interest-data exchanges.
>
> The main issue with this approach is (a) the producer cannot tell 
> which interests are from the repo and which are from another consumer, 
> and (b) there is no "finished" notification, so the client must poll 
> the repo to see if it has everything.  Both (a) and (b) mean the 
> producer cannot easily discard the content as it does not know when 
> the repo is done saving it.  A client can check if a particular 
> segment is in the repository via the CheckedStartWrite command, though 
> this is done segment-by-segment so is not particularly efficient.
>
> The early Voice over CCNx (2009) paper used an Interest-Data exchange 
> to kickoff bi-directional Interest-Data/Interest-Data exchanges in a 
> different namespace.
>
> The paper "CCNx 1.0 Bidirectional Streams " 
> [https://arxiv.org/abs/1707.04738] extends the VoCCNx approach to a 
> more robust repository protocol.   The document was originally 
> published in 2013 or so as a tech report with the early CCNx 1.0 
> papers.
>
> Marc
>
> On 3/9/20, 7:12 AM, "icnrg on behalf of Dirk Kutscher" 
> <[email-masked] on behalf of [email-masked]> wrote:
>