Subject: [icnrg] Status from Chairs and actions for the ICNRG participants in preparation for Interim meeting on April 20

From: "David R. Oran" <[email-masked]>
Date: Fri, 20 Mar 2020 09:46:56 -0400

While the COVID19 situation is upon us, we wish everybody health and 
safety. It is incumbent on us, however, to point out that you may now 
have more quality time for ICNRG work, and we would certainly appreciate 
any effort you can put in to advance our relatively large active work 
plan.

###First, some status updates:###

- Börje Ohlman, who has been our co-chair since the inception of ICNRG, 
has decided to step down as his group’s focus at Ericsson Research has 
vectored into other areas. Dirk and I offer our eternal thanks for the 
great job Börje has done over the years, and wish him the best. 
Hopefully, he will still be around the IRTF/IETF and he’ll be able to 
apply his steady hand to some exciting new work. Dirk Kutscher and Dave 
Oran plan to continue indefinitely, and hopefully we will be able to 
keep up with the load and be responsive to the needs of ICNRG going 
forward.

- The NRS documents 
(https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrs-requirements/ and 
https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrsarch-considerations/), 
having successfully passed last call and been updated from last call 
comments. They are in the hands of the IRTF chair to start the IRSG 
review cycle.

- We have adopted two important management documents as ICNRG work 
items. Please review the new RG official versions that have just been 
posted:
	- https://datatracker.ietf.org/doc/draft-irtf-icnrg-icnping/
	- https://datatracker.ietf.org/doc/draft-irtf-icnrg-icntraceroute/

- A number of documents are in active RFC editor processing for 
publication:
	- 
https://datatracker.ietf.org/doc/draft-irtf-icnrg-deployment-guidelines/
	- https://datatracker.ietf.org/doc/draft-irtf-icnrg-disaster/
	- https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/

- The chairs decided “Considerations in the development of a QoS 
Architecture for CCNx-like ICN protocols” 
(https://datatracker.ietf.org/doc/draft-oran-icnrg-qosarch/) should be 
published as an individual contribution and hence will be sent to the 
IRSG for review, bypassing formal RG last call.

- “Native Deployment of ICN in LTE, 4G Mobile Networks” 
(https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/) finished 
IRSG review and has some comments from the IRTF chair that need to be 
addressed. Once that’s done we should be able to send that on to the 
RFC editor for publication.

- “ICN Adaptation to LowPAN Networks (ICN LoWPAN)” 
(https://datatracker.ietf.org/doc/draft-irtf-icnrg-icnlowpan/) has 
gotten wide support and we will be issuing an RG Last Call for it in the 
coming days. Please look for the last call announcement and 
**re-review** this important document.

- The IP-over-ICN document 
(https://datatracker.ietf.org/doc/draft-irtf-icnrg-ipoc/) is ready for 
ICNRG Last Call. Look for the announcement later today or tomorrow.

###Second, please take time to review the these active RG documents##
We hope to move them forward toward last call if appropriate, and have 
scheduled time to discuss updates at the Interim meeting on April 20.

- We recently adopted “Enabling ICN in 3GPP's 5G NextGen Core 
Architecture” 
(https://datatracker.ietf.org/doc/draft-irtf-icnrg-5gc-icn/) as an ICNRG 
working draft. **Please review** so we can discuss moving this forward.

###Third, please take time to review the these active individual 
contributions and weigh in on whether they should be adopted as ICNRG 
working drafts.##

- QoS Treatments in ICN using Disaggregated Name Components 
(https://datatracker.ietf.org/doc/draft-anilj-icnrg-dnc-qos-icn/) needs 
wider review. Only DaveO has provided any review so far.

- “Internet Services over ICN in 5G LAN Environments” 
(https://datatracker.ietf.org/doc/draft-trossen-icnrg-internet-icn-5glan/) 
**needs review**.

- “Path Steering in CCNx and NDN” 
(https://datatracker.ietf.org/doc/draft-oran-icnrg-pathsteering/) 
**needs review and assessment of suitability to adopt as an ICNRG 
working draft**.

- “Maintaining CCNx or NDN flow balance with highly variable data 
object sizes” 
(https://datatracker.ietf.org/doc/draft-oran-icnrg-flowbalance/) **needs 
review and assessment of suitability to adopt as an ICNRG working 
draft**.

- “Flow Classification in Information Centric Networking” 
(https://datatracker.ietf.org/doc/draft-moiseenko-icnrg-flowclass/) 
**needs review and assessment of suitability to adopt as an ICNRG 
working draft**.

- “Hop-by-Hop Authentication in Content-Centric Networking/Named Data 
Networking” (https://datatracker.ietf.org/doc/draft-li-icnrg-hopauth/) 
**needs review and assessment of suitability to adopt as an ICNRG 
working draft**.

- “An Alternative Delta Time encoding for CCNx using Interval Time 
from RFC5497” 
(https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnx-timetlv/) 
**needs review and assessment of suitability to adopt as an ICNRG 
working draft**.

- “Requirements and Challenges for User-level Service Managements of 
IoT Network by utilizing Artificial Intelligence” 
(https://datatracker.ietf.org/doc/draft-choi-icnrg-aiot/) **needs 
initial review**.

###Fourth, we have started planning logistics and agenda for our Interim 
virtual meeting on April 20.###

So, please **propose agenda items**, consider **giving a talk** on one 
of the discussion topic areas identified for the interim meeting, and 
**register for the interim as customary** (by editing the Wiki page at 
https://trac.ietf.org/trac/irtf/wiki/icnrg).

Thanks for not treating this as TL;DR and actually getting to the end!!

Your ever-vigilant Chairs, Dirk and DaveO.

---

From: "Vera Li" <[email-masked]>
Date: Thu, 26 Mar 2020 09:34:16 +0800

Dear ICNRGers and Chairs,

I am writing to prove that I  have more quality time on the research work since my Y7 had studied online, on daily schedule,  from Google classroom since last week.

I have been discussing with Dirk and other contributors from InterDigital in this Month and clarified few points which confused me for few months. 

And I just attach the version we discussed for your convenience to review. 

Thanks for your time in advance for sharing your knowledge again.

Look forward to talking more in our virtual meeting on 20th-Apr.

Regards,

Vera

发件人: David R. Oran [mailto:[email-masked]] 
发送时间: 2020年3月20日 21:47
收件人: ICNRG
主题: [icnrg] Status from Chairs and actions for the ICNRG participants in preparation for Interim meeting on April 20

While the COVID19 situation is upon us, we wish everybody health and safety. It is incumbent on us, however, to point out that you may now have more quality time for ICNRG work, and we would certainly appreciate any effort you can put in to advance our relatively large active work plan.

First, some status updates:

*         Börje Ohlman, who has been our co-chair since the inception of ICNRG, has decided to step down as his group’s focus at Ericsson Research has vectored into other areas. Dirk and I offer our eternal thanks for the great job Börje has done over the years, and wish him the best. Hopefully, he will still be around the IRTF/IETF and he’ll be able to apply his steady hand to some exciting new work. Dirk Kutscher and Dave Oran plan to continue indefinitely, and hopefully we will be able to keep up with the load and be responsive to the needs of ICNRG going forward.

*         The NRS documents ( <https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrs-requirements/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrs-requirements/ and  <https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrsarch-considerations/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrsarch-considerations/), having successfully passed last call and been updated from last call comments. They are in the hands of the IRTF chair to start the IRSG review cycle.

*         We have adopted two important management documents as ICNRG work items. Please review the new RG official versions that have just been posted:

*	 <https://datatracker.ietf.org/doc/draft-irtf-icnrg-icnping/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-icnping/
*	 <https://datatracker.ietf.org/doc/draft-irtf-icnrg-icntraceroute/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-icntraceroute/

*         A number of documents are in active RFC editor processing for publication:

*	 <https://datatracker.ietf.org/doc/draft-irtf-icnrg-deployment-guidelines/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-deployment-guidelines/
*	 <https://datatracker.ietf.org/doc/draft-irtf-icnrg-disaster/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-disaster/
*	 <https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/

*         The chairs decided “Considerations in the development of a QoS Architecture for CCNx-like ICN protocols” ( <https://datatracker.ietf.org/doc/draft-oran-icnrg-qosarch/> https://datatracker.ietf.org/doc/draft-oran-icnrg-qosarch/) should be published as an individual contribution and hence will be sent to the IRSG for review, bypassing formal RG last call.

*         “Native Deployment of ICN in LTE, 4G Mobile Networks” ( <https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/) finished IRSG review and has some comments from the IRTF chair that need to be addressed. Once that’s done we should be able to send that on to the RFC editor for publication.

*         “ICN Adaptation to LowPAN Networks (ICN LoWPAN)” ( <https://datatracker.ietf.org/doc/draft-irtf-icnrg-icnlowpan/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-icnlowpan/) has gotten wide support and we will be issuing an RG Last Call for it in the coming days. Please look for the last call announcement and re-review this important document.

*         The IP-over-ICN document ( <https://datatracker.ietf.org/doc/draft-irtf-icnrg-ipoc/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-ipoc/) is ready for ICNRG Last Call. Look for the announcement later today or tomorrow.

Second, please take time to review the these active RG documents

We hope to move them forward toward last call if appropriate, and have scheduled time to discuss updates at the Interim meeting on April 20.

*	We recently adopted “Enabling ICN in 3GPP's 5G NextGen Core Architecture” ( <https://datatracker.ietf.org/doc/draft-irtf-icnrg-5gc-icn/> https://datatracker.ietf.org/doc/draft-irtf-icnrg-5gc-icn/) as an ICNRG working draft. Please review so we can discuss moving this forward.

Third, please take time to review the these active individual contributions and weigh in on whether they should be adopted as ICNRG working drafts.

*         QoS Treatments in ICN using Disaggregated Name Components ( <https://datatracker.ietf.org/doc/draft-anilj-icnrg-dnc-qos-icn/> https://datatracker.ietf.org/doc/draft-anilj-icnrg-dnc-qos-icn/) needs wider review. Only DaveO has provided any review so far.

*         “Internet Services over ICN in 5G LAN Environments” ( <https://datatracker.ietf.org/doc/draft-trossen-icnrg-internet-icn-5glan/> https://datatracker.ietf.org/doc/draft-trossen-icnrg-internet-icn-5glan/) needs review.

*         “Path Steering in CCNx and NDN” ( <https://datatracker.ietf.org/doc/draft-oran-icnrg-pathsteering/> https://datatracker.ietf.org/doc/draft-oran-icnrg-pathsteering/) needs review and assessment of suitability to adopt as an ICNRG working draft.

*         “Maintaining CCNx or NDN flow balance with highly variable data object sizes” ( <https://datatracker.ietf.org/doc/draft-oran-icnrg-flowbalance/> https://datatracker.ietf.org/doc/draft-oran-icnrg-flowbalance/) needs review and assessment of suitability to adopt as an ICNRG working draft.

*         “Flow Classification in Information Centric Networking” ( <https://datatracker.ietf.org/doc/draft-moiseenko-icnrg-flowclass/> https://datatracker.ietf.org/doc/draft-moiseenko-icnrg-flowclass/) needs review and assessment of suitability to adopt as an ICNRG working draft.

*         “Hop-by-Hop Authentication in Content-Centric Networking/Named Data Networking” ( <https://datatracker.ietf.org/doc/draft-li-icnrg-hopauth/> https://datatracker.ietf.org/doc/draft-li-icnrg-hopauth/) needs review and assessment of suitability to adopt as an ICNRG working draft.

*         “An Alternative Delta Time encoding for CCNx using Interval Time from RFC5497” ( <https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnx-timetlv/> https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnx-timetlv/) needs review and assessment of suitability to adopt as an ICNRG working draft.

*         “Requirements and Challenges for User-level Service Managements of IoT Network by utilizing Artificial Intelligence” ( <https://datatracker.ietf.org/doc/draft-choi-icnrg-aiot/> https://datatracker.ietf.org/doc/draft-choi-icnrg-aiot/) needs initial review.

Fourth, we have started planning logistics and agenda for our Interim virtual meeting on April 20.

So, please propose agenda items, consider giving a talk on one of the discussion topic areas identified for the interim meeting, and register for the interim as customary (by editing the Wiki page at  <https://trac.ietf.org/trac/irtf/wiki/icnrg> https://trac.ietf.org/trac/irtf/wiki/icnrg).

---

From: "David R. Oran" <[email-masked]>
Date: Fri, 27 Mar 2020 09:22:41 -0400

Thanks for the note - sorry I missed this on my email.
ICNRG folks - please review the latest draft!

On 26 Mar 2020, at 4:57, Milheiro Mendes, Paulo Jorge wrote:

> Hi David, Dirk,
>
> It seems that you forgot the Dabber draft in the list of active 
> individual
> contributions:
> https://datatracker.ietf.org/doc/draft-mendes-icnrg-dabber/
>
> This draft is listed in the ICNRG datatracker documents web page.
>
> The draft is now on v4, and we will start its implementation after 
> revising
> the spec once more.. Being the only proposal for an ICN routing 
> protocol
> for wireless opportunistic networks, I would appreciate if this draft 
> is
> added to the list of individual drafts that may be adopted as ICNRG 
> working
> draft.
>
> Cheers
> Paulo
>
>
> On Fri, Mar 20, 2020 at 2:47 PM David R. Oran <[email-masked]> 
> wrote:
>
>> have
>> more quality time for ICNRG work, and we would certainly appreciate 
>> any
>> effort you can put in to advance our relatively large active work 
>> plan.
>>    Börje Ohlman, who has been our co-chair since the inception of 
>> ICNRG,
>> Hopefully,
>>    he will still be around the IRTF/IETF and he’ll be able to apply 
>> his steady
>>    hand to some exciting new work. Dirk Kutscher and Dave Oran plan 
>> to
>>    continue indefinitely, and hopefully we will be able to keep up 
>> with the
>>    load and be responsive to the needs of ICNRG going forward.
>>    -
>>
>>    The NRS documents (
>>    https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrs-requirements/
>>    and
>>    comments. They are in the hands of the IRTF chair to start the 
>> IRSG review
>>    cycle.
>>    -
>>
>>    We have adopted two important management documents as ICNRG work
>> https://datatracker.ietf.org/doc/draft-irtf-icnrg-icntraceroute/
>>    -
>>
>>    A number of documents are in active RFC editor processing for
>>    publication:
>>    -
>> https://datatracker.ietf.org/doc/draft-irtf-icnrg-terminology/
>>    -
>>
>>    The chairs decided “Considerations in the development of a QoS
>>    Architecture for CCNx-like ICN protocols” (
>>    https://datatracker.ietf.org/doc/draft-oran-icnrg-qosarch/) should 
>> be
>>    published as an individual contribution and hence will be sent to 
>> the IRSG
>>    for review, bypassing formal RG last call.
>>    -
>>
>>    “Native Deployment of ICN in LTE, 4G Mobile Networks” (
>>    https://datatracker.ietf.org/doc/draft-irtf-icnrg-icn-lte-4g/)
>>    finished IRSG review and has some comments from the IRTF chair 
>> that need to
>>    be addressed. Once that’s done we should be able to send that on 
>> to the RFC
>>    editor for publication.
>>    -
>>
>>    “ICN Adaptation to LowPAN Networks (ICN LoWPAN)” (
>>    https://datatracker.ietf.org/doc/draft-irtf-icnrg-icnlowpan/) has
>> *re-review*
>>    this important document.
>>    The IP-over-ICN document (
>>    https://datatracker.ietf.org/doc/draft-irtf-icnrg-ipoc/) is ready 
>> for
>>    Architecture” (
>>    https://datatracker.ietf.org/doc/draft-irtf-icnrg-5gc-icn/) as an
>>    ICNRG working draft. *Please review* so we can discuss moving this
>>    forward.
>>
>> Third, please take time to review the these active individual
>> working drafts.
>>    QoS Treatments in ICN using Disaggregated Name Components (
>>    https://datatracker.ietf.org/doc/draft-anilj-icnrg-dnc-qos-icn/) 
>> needs
>>    “Internet Services over ICN in 5G LAN Environments” (
>>    https://datatracker.ietf.org/doc/draft-trossen-icnrg-internet-icn-5glan/)
>>    *needs review*.
>>    -
>>
>>    “Path Steering in CCNx and NDN” (
>>    https://datatracker.ietf.org/doc/draft-oran-icnrg-pathsteering/) 
>> *needs
>> draft*
>>    .
>>    “Maintaining CCNx or NDN flow balance with highly variable data 
>> object
>>    sizes” 
>> (https://datatracker.ietf.org/doc/draft-oran-icnrg-flowbalance/)
>>    *needs review and assessment of suitability to adopt as an ICNRG
>>    working draft*.
>>    -
>>
>>    “Flow Classification in Information Centric Networking” (
>>    https://datatracker.ietf.org/doc/draft-moiseenko-icnrg-flowclass/) 
>> *needs
>> draft*
>>    .
>>    “Hop-by-Hop Authentication in Content-Centric Networking/Named 
>> Data
>>    Networking” 
>> (https://datatracker.ietf.org/doc/draft-li-icnrg-hopauth/) *needs
>> draft*
>>    .
>>    “An Alternative Delta Time encoding for CCNx using Interval Time 
>> from
>>    RFC5497” (
>>    https://datatracker.ietf.org/doc/draft-gundogan-icnrg-ccnx-timetlv/) 
>> *needs
>> draft*
>>    .
>>    “Requirements and Challenges for User-level Service Managements 
>> of IoT
>>    Network by utilizing Artificial Intelligence” (
>>    https://datatracker.ietf.org/doc/draft-choi-icnrg-aiot/) *needs
>>    initial review*.
>>
>> So, please *propose agenda items*, consider *giving a talk* on one of 
>> the
>> discussion topic areas identified for the interim meeting, and 
>> *register
>> for the interim as customary* (by editing the Wiki page at
>> _______________________________________________
>> icnrg mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/icnrg
>>
>
>
> -- 
>
> *Paulo Mendes, Ph.D*
>
> Senior Scientistic Wireless Communications
>
> Central Research and Technology, XRC
>
> *Airbus*
> The information in this e-mail is confidential. The contents may not 
> be disclosed or used by anyone other than the addressee. Access to 
> this e-mail by anyone else is unauthorised.
> If you are not the intended recipient, please notify Airbus 
> immediately and delete this e-mail.
> Airbus cannot accept any responsibility for the accuracy or 
> completeness of this e-mail as it has been sent over public networks. 
> If you have any concerns over the content of this message or its 
> Accuracy or Integrity, please contact Airbus immediately.
> All outgoing e-mails from Airbus are checked using regularly updated 
> virus scanning software but you should take whatever measures you deem 
> to be appropriate to ensure that this message and any attachments are 
> virus free.

DaveO