Subject: [icnrg] Comments on reflexive draft

From: Ken Calvert <[email-masked]>
Date: Wed, 8 Apr 2020 11:16:34 -0400

Gents - Overall it reads really well and does a great motivating the proposal.  And obviously feel free to ignore any suggestions.

1. Introduction

6th paragraph: "built on top of on reliable" [delete 2nd "on"]

3. Overview of the Reflexive Forwarding Design

Bullet 1. ("The Reflexive Interest needs..."): "This name is what the originating consumer will use to match against the Data object ... it wishes the producer to fetch..."  I found this construction a bit confusing; suggest something like "this name (or an extension) will refer to the Data object(s) the originating consumer prepares to send to the producer..."  That also avoids the anthropomorphism ("wishes").

Bullet 2. ("There has to be a FIB..."):  Suggest "At each forwarder along the path from producer to consumer, a FIB entry must match (LNPM) this name...".
Also "deign" -> design, later in the paragraph.

Bullet 3. ("There has to be coupling...")  "...this accomplished by the way..." -> this is accomplished by the way

4. Naming of Reflexive Interests

1st paragraph: "...enough information in their initial Interest" -> enough information in its initial Interest
Also, "...enough state must be provided by the consumer..." - I found this a bit confusing.  The forwarder creates the state, from info provided by the consumer.  Suggest "enough information must be available for the forwarders to construct a FIB entry...", or just change "state" to "information".

[I have some additional thoughts about the content of this section, but will send them separately.]

7.1 Achieving Remote Method ...

2nd paragraph: "computating" -> computing

8.1.2 Interactions with Interest Lifetime

4th paragraph: "...a reflexive Interest arrives from upstream matching the..." - suggest deleting "from upstream", it's not clearly defined and doesn't seem necessary.

last paragraph: "While the above approach..." - this sentence is garbled, the first clause seems to be missing a predicate.

last sentence: "Interest-Datsa exchange" -> Interest-Data exchange

Cheers,

Ken

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 08 Apr 2020 11:47:15 -0400

On 8 Apr 2020, at 11:16, Ken Calvert wrote:

> Gents - Overall it reads really well and does a great motivating the 
> proposal.  And obviously feel free to ignore any suggestions.
>
> 1. Introduction
>
Fixed.

> Bullet 1. ("The Reflexive Interest needs..."): "This name is what the 
> originating consumer will use to match against the Data object ... it 
> wishes the producer to fetch..."  I found this construction a bit 
> confusing; suggest something like "this name (or an extension) will 
> refer to the Data object(s) the originating consumer prepares to send 
> to the producer..."  That also avoids the anthropomorphism ("wishes").
>
Got it, although I prefer to avoid using the term “send” since it 
introduces a push-like mental model. How about
“This name is what the originating consumer will use to match against 
the Data object (or objects - more on this later) that the producer may 
request by issuing the Reflexive Interest.”

> Bullet 2. ("There has to be a FIB..."):  Suggest "At each forwarder 
> along the path from producer to consumer, a FIB entry must match 
> (LNPM) this name...".
Close - how about “At each forwarder along the inverse path from 
producer to consumer, a FIB entry must be present that matches this name 
via LNPM,…”.

> Also "deign" -> design, later in the paragraph.
Got it.

>
> Bullet 3. ("There has to be coupling...")  "...this accomplished by 
> the way..." -> this is accomplished by the way
>
Fixed.

> 1st paragraph: "...enough information in their initial Interest" -> 
> enough information in its initial Interest
Fixed.

> Also, "...enough state must be provided by the consumer..." - I found 
> this a bit confusing.  The forwarder creates the state, from info 
> provided by the consumer.  Suggest "enough information must be 
> available for the forwarders to construct a FIB entry...", or just 
> change "state" to "information".
>
I made the simpler change of “state” to “information”

> but will send them separately.]
Looking forward to it!

> 2nd paragraph: "computating" -> computing
Fixed.

> 4th paragraph: "...a reflexive Interest arrives from upstream matching 
> the..." - suggest deleting "from upstream", it's not clearly defined 
> and doesn't seem necessary.
>
Ok, deleted.

> last paragraph: "While the above approach..." - this sentence is 
> garbled, the first clause seems to be missing a predicate.
>
yes, added “…avoids the timeout problem,”

> last sentence: "Interest-Datsa exchange" -> Interest-Data exchange
Fixed.

> Ken
These will show up in -01, which we’ll issue in a few days after 
waiting to see what other comments surface form other ICNRG’ers.

DaveO