Subject: [icnrg] Fwd: New Version Notification for draft-oran-icnrg-reflexive-forwarding-00.txt

From: "David R. Oran" <[email-masked]>
Date: Thu, 02 Apr 2020 11:50:13 -0400

ICNRGers,

Dirk Kutscher and I have formalized the reflexive forwarding scheme we 
developed for RICE 
(https://conferences.sigcomm.org/acm-icn/2018/proceedings/icn18-final9.pdf), 
expanded it to cover more use cases (e.g. IoT sensors) and spelled out 
the whole scheme in detail including algorithms and encoding in the 
Internet Draft we just submitted.

It should work equally well for both CCNx and NDN and has concrete 
encoding for CCNx, although we need some help from the NDN team on what 
the best packet encoding ought to be in NDN for the new TLV we define.

Since this is a fairly major change/enhancement to the CCNx forwarding 
model, it really needs a close review to help us figure out:

- Are we crazy?
- Is the complexity/functionality tradeoff appropriate?
- Did we miss anything, particularly any corner cases we should have 
considered
- Which of the alternative approaches to backward/forward compatibility 
we describe seems the right one?
- Are there more use cases that we ought to document? We were hoping to 
have one or two to include for state synchronization, but have deferred 
that for now in the interest of getting the spec out for review.

We’d like to talk about this at the ICNRG Interim meeting on April 20, 
so p[lease sets aside some time to read/eview/think about between now 
and then.

Many thanks!

Dirk & DaveO.

Forwarded message:

> From: [email-masked]
> To: Dave Oran <[email-masked]>, David Oran 
> <[email-masked]>, Dirk Kutscher <[email-masked]>
> Subject: New Version Notification for 
> draft-oran-icnrg-reflexive-forwarding-00.txt
> Date: Thu, 02 Apr 2020 07:37:32 -0700
>
> A new version of I-D, draft-oran-icnrg-reflexive-forwarding-00.txt
> has been successfully submitted by Dave Oran and posted to the
> IETF repository.
>
> Name:		draft-oran-icnrg-reflexive-forwarding
> Revision:	00
> Title:		Reflexive Forwarding for CCNx and NDN Protocols
> Document date:	2020-04-02
> Group:		Individual Submission
> Pages:		30
> URL:            
> https://www.ietf.org/internet-drafts/draft-oran-icnrg-reflexive-forwarding-00.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-oran-icnrg-reflexive-forwarding/
> Htmlized:       
> https://tools.ietf.org/html/draft-oran-icnrg-reflexive-forwarding-00
> Htmlized:       
> https://datatracker.ietf.org/doc/html/draft-oran-icnrg-reflexive-forwarding
>
>
> Abstract:
>    Current Information-Centric Networking protocols such as CCNx and 
> NDN
>    have a wide range of useful applications in content retrieval and
>    other scenarios that depend only on a robust two-way exchange in 
> the
>    form of a request and response (represented by an _Interest-Data
>    exchange_ in the case of the two protocols noted above).  A number 
> of
>    important applications however, require placing large amounts of 
> data
>    in the Interest message, and/or more than one two-way handshake.
>    While these can be accomplished using independent Interest-Data
>    exchanges by reversing the roles of consumer and producer, such
>    approaches can be both clumsy for applications and problematic from 
> a
>    state management, congestion control, or security standpoint.  This
>    specification proposes a _Reflexive Forwarding_ extension to the 
> CCNx
>    and NDN protocol architectures that eliminates the problems 
> inherent
>    in using independent Interest-Data exchanges for such applications.
>    It updates RFC8569 and RFC8609.
>
>
>
>
> Please note that it may take a couple of minutes from the time of 
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 3 Apr 2020 13:04:59 +0900

Hi,

I've not read this draft and this may be a knee-jerk reply (or early to begin with this discussion), but why does this draft potentially request "updating" RFC8569 and 8609?

This proposal may be with insightful thoughts and useful for some applications. But why it needs to update the current bible, 8569 and 8609, we took much time to formalize them?
I know ICNRG is RG and not working in an SDO and it is not so sensitive to update any documents compared with IETF WGs, but except the case for correcting errors these RFCs should not be easily updated in the current situation.

In the near (or not far) future we may want to try to move this RG to WG. What we need to do now for making ICN research and engineering work more common or visible is to provide interesting/effective ICN services/applications not only in "a" research community but in different communities or preferably market. The chance to update RFC8569 and 8609 should come when this RG becomes WG at earliest, IMO.

In summary, my comment is it is better to consider the technical benefit without assuming the update of these RFCs.
Thanks.

Regards,

Hitoshi

> On Apr 3, 2020, at 0:50, David R. Oran <[email-masked]> wrote:
> 
> ICNRGers,
> 
> Dirk Kutscher and I have formalized the reflexive forwarding scheme we developed for RICE (https://conferences.sigcomm.org/acm-icn/2018/proceedings/icn18-final9.pdf), expanded it to cover more use cases (e.g. IoT sensors) and spelled out the whole scheme in detail including algorithms and encoding in the Internet Draft we just submitted.
> 
> It should work equally well for both CCNx and NDN and has concrete encoding for CCNx, although we need some help from the NDN team on what the best packet encoding ought to be in NDN for the new TLV we define.
> 
> Since this is a fairly major change/enhancement to the CCNx forwarding model, it really needs a close review to help us figure out:
> 
> 	• Are we crazy?
> 	• Is the complexity/functionality tradeoff appropriate?
> 	• Did we miss anything, particularly any corner cases we should have considered
> 	• Which of the alternative approaches to backward/forward compatibility we describe seems the right one?
> 	• Are there more use cases that we ought to document? We were hoping to have one or two to include for state synchronization, but have deferred that for now in the interest of getting the spec out for review.
> We’d like to talk about this at the ICNRG Interim meeting on April 20, so p[lease sets aside some time to read/eview/think about between now and then.
> 
> Many thanks!
> 
> Dirk & DaveO.
> 
> Forwarded message:
> 
> To: Dave Oran <[email-masked]>, David Oran <[email-masked]>, Dirk Kutscher <[email-masked]>
> Subject: New Version Notification for draft-oran-icnrg-reflexive-forwarding-00.txt
> URL: https://www.ietf.org/internet-drafts/draft-oran-icnrg-reflexive-forwarding-00.txt
> Status: https://datatracker.ietf.org/doc/draft-oran-icnrg-reflexive-forwarding/
> Htmlized: https://tools.ietf.org/html/draft-oran-icnrg-reflexive-forwarding-00
> Htmlized: https://datatracker.ietf.org/doc/html/draft-oran-icnrg-reflexive-forwarding
> 
> 
> Abstract:
> Current Information-Centric Networking protocols such as CCNx and NDN
> other scenarios that depend only on a robust two-way exchange in the
> exchange_ in the case of the two protocols noted above). A number of
> important applications however, require placing large amounts of data
> approaches can be both clumsy for applications and problematic from a
> specification proposes a _Reflexive Forwarding_ extension to the CCNx
> and NDN protocol architectures that eliminates the problems inherent
> Please note that it may take a couple of minutes from the time of submission
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Dirk Kutscher" <[email-masked]>
Date: Fri, 03 Apr 2020 12:26:30 +0200

Hi Hitoshi-san,

thanks for the message.

Yes, the statement would be easier to understand after having read the 
draft.

The point is that the draft specifies new forwarding behavior, and the 
Reflexive Forwarding Scheme would (most likely) only work if all 
forwarders implemented that.

So, one of the meta questions here is how the community wants to address 
evolvability, and we think that this proposal would also be good for 
triggering that.

Responding to your concerns, I understand what you are saying.

One perspective here could be that it's also relevant to investigate how 
ICN can deal with protocol evolution in a non-disruptive way.

Looking forward to your thoughts on that.

Best regards,
Dirk

On 3 Apr 2020, at 6:04, Hitoshi Asaeda wrote:

> Hi,
>
> I've not read this draft and this may be a knee-jerk reply (or early 
> to begin with this discussion), but why does this draft potentially 
> request "updating" RFC8569 and 8609?
>
> This proposal may be with insightful thoughts and useful for some 
> applications. But why it needs to update the current bible, 8569 and 
> 8609, we took much time to formalize them?
> I know ICNRG is RG and not working in an SDO and it is not so 
> sensitive to update any documents compared with IETF WGs, but except 
> the case for correcting errors these RFCs should not be easily updated 
> in the current situation.
>
> In the near (or not far) future we may want to try to move this RG to 
> WG. What we need to do now for making ICN research and engineering 
> work more common or visible is to provide interesting/effective ICN 
> services/applications not only in "a" research community but in 
> different communities or preferably market. The chance to update 
> RFC8569 and 8609 should come when this RG becomes WG at earliest, IMO.
>
> In summary, my comment is it is better to consider the technical 
> benefit without assuming the update of these RFCs.
> Thanks.
>
> Regards,
>
> Hitoshi
>
>
>
>> Dirk Kutscher and I have formalized the reflexive forwarding scheme 
>> we developed for RICE 
>> expanded it to cover more use cases (e.g. IoT sensors) and spelled 
>> out the whole scheme in detail including algorithms and encoding in 
>> the Internet Draft we just submitted.
>>
>> encoding for CCNx, although we need some help from the NDN team on 
>> what the best packet encoding ought to be in NDN for the new TLV we 
>> define.
>>
>> Since this is a fairly major change/enhancement to the CCNx 
>> forwarding model, it really needs a close review to help us figure 
>> out:
>>
>> 	• Are we crazy?
>> 	• Which of the alternative approaches to backward/forward 
>> compatibility we describe seems the right one?
>> 	• Are there more use cases that we ought to document? We were 
>> hoping to have one or two to include for state synchronization, but 
>> have deferred that for now in the interest of getting the spec out 
>> for review.
>> We’d like to talk about this at the ICNRG Interim meeting on April 
>> 20, so p[lease sets aside some time to read/eview/think about between 
>> now and then.
>>
>> Many thanks!
>>
>> Dirk & DaveO.
>>
>> Forwarded message:
>>