Subject: [icnrg] Review, draft-irtf-icnrg-icnping-00

From: Rute Sofia <[email-masked]>
Date: Tue, 12 May 2020 12:48:52 +0000

Dear Spyridon, Jim, Ilya, Ralph and Dave,

So here is my review concerning the ICN Ping protocol draft. Overall this is a must. On this version, there is still the need to consolidate definitions and to explain additional aspects concerning the protocol operation (which right now is more focused on the different proposed packet formats).

................................................
List of definitions would be helpful:

-          Content object

-          Producer application/application (sometimes you refer to it as content, others as application)

-          Unit of named data

-          Named data...

-          Define RTT for ICN environments...

-          Sender and name of the sender (it would be also good to have a consolidated version, where a single term would refer to an entity; sometimes we have sender, others producer. Same thing for consumer/client).

-          Border forwarder.

1.       Introduction

Reachability of names - reachability of data sources?

"This document proposes protocol mechanisms for a ping equivalent in

   ICN networks.  A non-normative appendix suggests useful properties

   for an ICN ping client application, analogous to IP ping, that

   originates echo requests and process echo replies.
"  -- would suggest considering other term for "ICN networks", and also specifically state here that you are proposing ping adaptations for CCNx and NDN.

3.       Ping functionality challenges in ICN

"ICN protocols (e.g., NDN and CCNx)" - in ICN paradigms or simply ICN.

"An Interest is forwarded across
   the network based on its name"-an Interest is forwarded across the network based on the Name prefix it carries?

"IP-based ping was built as an add-on on top of an already existing

   network architecture"-understand what is meant, but this seems to be half sentence. Ping is a measurement tool.

"in the network layer protocol" - in the network layers?

"ICN Interests do not have source addresses " - neither destination addresses. Perhaps it is relevant to state that ICN is not host oriented...

"Test the reachability of an application - test the reachability of a producer?

"

4.       ICN Ping echo CCNx Packet formats

-          You first state here that you propose echo requests and echo replies; however, these are also mentioned before in section 3. Even though readers are most likely acquainted with these notions, it would assist the reading in first specifying the 2 formats, before mentioning them in section 3.

5.       ICN Ping for NDN

"The name of an echo request" - the name prefix carried by an echo request consists of the string to be pinged, ...

"  The "Paremeters" - typo

6.       Forwarder Handling
Section 6 would benefit from having a scheme explaining the reception by a forwarder of an echo request and respective echo reply.

In terms of the protocol functionality, a few questions which do not seem to be covered in this version:

-          How many echo requests/replies does the protocol require to compute the RTT?

-          Path steering is mentioned, but an ICN ping will most likely also handle the computation of RTT based on having Interests sent by different paths. How is this handled, what is then the definition of RTT?

Best Regards,

Rute Sofia

--
fortiss · Landesforschungsinstitut des Freistaats Bayern
An-Institut Technische Universität München
Guerickestraße 25
80805 München
Germany
Tel.: +49 (89) 3603522 170
Fax: +49 (89) 3603522 50
E-Mail: [email-masked]<mailto:[email-masked]>
https://www.fortiss.org/

Amtsgericht München: HRB: 176633
USt-IdNr.: DE263907002, Steuer-Nr.: 143/237/25900
Rechtsform: gemeinnützige GmbH
Sitz der Gesellschaft: München
Geschäftsführer: Dr. Harald Rueß, Thomas Vallon
Vorsitzender des Aufsichtsrats: Dr. Manfred Wolter

---

From: Spyridon Mastorakis <[email-masked]>
Date: Tue, 12 May 2020 14:41:21 +0000

Dear Rute,

Thank you very much for your review. We will keep you posted as we address your comments and we will also get back to you with answers to your questions.

Thanks,
Spyros

Spyridon (Spyros) Mastorakis
Assistant Professor
Computer Science Department
University of Nebraska, Omaha
Peter Kiewit Institute Room 175A
https://sites.google.com/site/spyridonmastorakis

On May 12, 2020, at 7:48 AM, Rute Sofia <[email-masked]<mailto:[email-masked]>> wrote:

So here is my review concerning the ICN Ping protocol draft. Overall this is a must. On this version, there is still the need to consolidate definitions and to explain additional aspects concerning the protocol operation (which right now is more focused on the different proposed packet formats)..

…………………………………………
List of definitions would be helpful:
-          Content object
-          Producer application/application (sometimes you refer to it as content, others as application)
-          Unit of named data
-          Named data…
-          Define RTT for ICN environments…
-          Sender and name of the sender (it would be also good to have a consolidated version, where a single term would refer to an entity; sometimes we have sender, others producer. Same thing for consumer/client).
-          Border forwarder.

1.       Introduction

Reachability of names – reachability of data sources?

“This document proposes protocol mechanisms for a ping equivalent in

“  -- would suggest considering other term for “ICN networks”, and also specifically state here that you are proposing ping adaptations for CCNx and NDN.

“ICN protocols (e.g., NDN and CCNx)” – in ICN paradigms or simply ICN.

“An Interest is forwarded across

   the network based on its name”—an Interest is forwarded across the network based on the Name prefix it carries?

“IP-based ping was built as an add-on on top of an already existing

   network architecture“—understand what is meant, but this seems to be half sentence. Ping is a measurement tool.

“in the network layer protocol” – in the network layers?

“ICN Interests do not have source addresses “ – neither destination addresses. Perhaps it is relevant to state that ICN is not host oriented…

“Test the reachability of an application – test the reachability of a producer?

“

5.       ICN Ping for NDN

“The name of an echo request” – the name prefix carried by an echo request consists of the string to be pinged, …

“  The "Paremeters" – typo

6.       Forwarder Handling

Best Regards,

Rute Sofia

_______________________________________________
icnrg mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/icnrg