Subject: [icnrg] Review, draft-trossen-icnrg-ip-icn-5glan

From: Rute Sofia <[email-masked]>
Date: Tue, 12 May 2020 14:12:53 +0000

Dear Dirk, Chan, all,

here is a review for the draft (Internet Services over ICN in 5G LAN Environments
)

https://datatracker.ietf.org/doc/draft-trossen-icnrg-internet-icn-5glan/?include_text=1

The draft is well written, so not much to add. Just a few additional comments and some minor typos detected. As described, the current proposal is targeted to  anycast or multicast transmission. What about N to M, which is supported in ICN and relevant to environments such as IoT?

Specifically,
Introduction:

"Through such replacement of IP routing with ICN routing, we

   capitalize on several ICN capabilities:
" - IMO it would be best to write down something as through ICN integration...

-          5GC is used but not yet defined, so replace with  5G-NextGen Core (5GC)

-          MEC is an architecture, so the definition should be more clear about it (currently, it starts with MEC is located at the edge of the network; the edge today is more than an eNodeB, so the definition needs to be made more objective).

-          One aspect that is missing IMO is the possibility to assist T2T communication. The integration of IoT and 5G benefits from a Pub/Sub approach such as the one in ICN.

-          Terminology: client/consumer/receiver; server/producer/sender should be added
3. again an IoT example would be relevant here.
5.1

"To realize the flat device nature," - to support the flat network nature?

Best Regards,

Rute Sofia

--
fortiss · Landesforschungsinstitut des Freistaats Bayern
An-Institut Technische Universität München
Guerickestraße 25
80805 München
Germany
Tel.: +49 (89) 3603522 170
Fax: +49 (89) 3603522 50
E-Mail: [email-masked]<mailto:[email-masked]>
https://www.fortiss.org/

Amtsgericht München: HRB: 176633
USt-IdNr.: DE263907002, Steuer-Nr.: 143/237/25900
Rechtsform: gemeinnützige GmbH
Sitz der Gesellschaft: München
Geschäftsführer: Dr. Harald Rueß, Thomas Vallon
Vorsitzender des Aufsichtsrats: Dr. Manfred Wolter

---

From: Dirk Trossen <[email-masked]>
Date: Tue, 12 May 2020 14:15:32 +0000

Dear Rute,

Many thanks for the review, which is very useful. I'll discuss the progress of the draft with the author team and hope we can progress further.

Best,

Dirk

From: Rute Sofia [mailto:[email-masked]]
Sent: 12 May 2020 16:13
To: Dirk Trossen <[email-masked]>; [email-masked]
Subject: Review, draft-trossen-icnrg-ip-icn-5glan

Dear Dirk, Chan, all,

Specifically,
Introduction:

Best Regards,

Rute Sofia