Subject: Re: [icnrg] I-D Action: draft-irtf-icnrg-icnlowpan-09.txt

From: Colin Perkins <[email-masked]>
Date: Wed, 25 Nov 2020 20:36:45 +0000

Thanks, Cenk, for updating the draft.

Looking at the changes since -08, my belief is that they address Carsten’s IRSG review comments. Carsten, please say now if that’s not the case.

ICNRG chairs: there have been some significant changes since RG last call. Can you please confirm that these are okay, before this draft moves ahead.

Thanks,
Colin

> On 30 Oct 2020, at 13:00, Cenk Gündoğan <mail=2Bietf=[email-masked]> wrote:
> 
> Fellow ICN researchers,
> 
> this version (-09) is a refresh of the draft which was about to
> expire.  It further addresses issues and comments that came up during
> the IRSG review.  A summary of changes can be found on the mailing
> list; in this thread [1].
> 
> [1] https://mailarchive.ietf.org/arch/msg/icnrg/CrkbTQ6cqvoPCNqTpN0G1VYAjBw/ <https://mailarchive.ietf.org/arch/msg/icnrg/CrkbTQ6cqvoPCNqTpN0G1VYAjBw/>
> 
> Cheers,
> Cenk
> 
> On Fri, Oct 30 2020 at 13:57 +0100, [email-masked] <mailto:[email-masked]> wrote:
> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the Information-Centric Networking RG of the IRTF.
>> 
>>        Title           : ICN Adaptation to LoWPAN Networks (ICN LoWPAN)
>>        Authors         : Cenk Gundogan
>>                          Thomas C. Schmidt
>>                          Matthias Waehlisch
>>                          Christopher Scherb
>>                          Claudio Marxer
>>                          Christian Tschudin
>> 	Filename        : draft-irtf-icnrg-icnlowpan-09.txt
>> 	Pages           : 52
>> 	Date            : 2020-10-30
>> 
>> Abstract:
>>   This document defines a convergence layer for CCNx and NDN over IEEE
>>   802.15.4 LoWPAN networks.  A new frame format is specified to adapt
>>   CCNx and NDN packets to the small MTU size of IEEE 802.15.4.  For
>>   that, syntactic and semantic changes to the TLV-based header formats
>>   are described.  To support compatibility with other LoWPAN
>>   technologies that may coexist on a wireless medium, the dispatching
>>   scheme provided by 6LoWPAN is extended to include new dispatch types
>>   for CCNx and NDN.  Additionally, the fragmentation component of the
>>   6LoWPAN dispatching framework is applied to ICN chunks.  In its
>>   second part, the document defines stateless and stateful compression
>>   schemes to improve efficiency on constrained links.  Stateless
>>   compression reduces TLV expressions to static header fields for
>>   common use cases.  Stateful compression schemes elide state local to
>>   the LoWPAN and replace names in data packets by short local
>>   identifiers.
>> 
>>   This document is a product of the IRTF Information-Centric Networking
>>   Research Group (ICNRG).
>> 
>> 
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-irtf-icnrg-icnlowpan/
>> 
>> There are also htmlized versions available at:
>> https://tools.ietf.org/html/draft-irtf-icnrg-icnlowpan-09
>> https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-icnlowpan-09
>> 
>> A diff from the previous version is available at:
>> https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-icnlowpan-09
>> 
>> 
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> 
>> _______________________________________________
>> icnrg mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/icnrg <https://www.irtf.org/mailman/listinfo/icnrg>
> 
> --
> Cenk Gündoğan
> 
> Hamburg University of Applied Sciences
> Dept. of Computer Science / Internet Technologies Group
> Berliner Tor 7, 20099 Hamburg, Germany
> Fon: +49 40 42875 - 8426
> Mail: [email-masked] <mailto:[email-masked]>
> Web: https://www.inet.haw-hamburg.de/ <https://www.inet.haw-hamburg.de/>
> 
> _______________________________________________
> icnrg mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/icnrg <https://www.irtf.org/mailman/listinfo/icnrg>

---

From: "David R. Oran" <[email-masked]>
Date: Thu, 26 Nov 2020 10:05:22 -0500

On 25 Nov 2020, at 15:36, Colin Perkins wrote:

> Looking at the changes since -08, my belief is that they address 
> Carsten’s IRSG review comments. Carsten, please say now if that’s 
> not the case.
>
> ICNRG chairs: there have been some significant changes since RG last 
> call. Can you please confirm that these are okay, before this draft 
> moves ahead.
>
Dirk and I briefly went over the draft, and it looks OK to us. So, 
please move it forward.
Thanks,
Dave & Dirk.

> Thanks,
> Colin
>
>
>> On 30 Oct 2020, at 13:00, Cenk Gündoğan 
>> <mail=2Bietf=[email-masked]> wrote:
>>
>> Fellow ICN researchers,
>>
>> [1] 
>> https://mailarchive.ietf.org/arch/msg/icnrg/CrkbTQ6cqvoPCNqTpN0G1VYAjBw/ 
>> <https://mailarchive.ietf.org/arch/msg/icnrg/CrkbTQ6cqvoPCNqTpN0G1VYAjBw/>
>>
>> Cheers,
>> Cenk
>>
>>> https://www.irtf.org/mailman/listinfo/icnrg 
>>> <https://www.irtf.org/mailman/listinfo/icnrg>
>>
>> --
>> Cenk Gündoğan
>>
>> https://www.irtf.org/mailman/listinfo/icnrg 
>> <https://www.irtf.org/mailman/listinfo/icnrg>

> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

DaveO

---

From: Colin Perkins <[email-masked]>
Date: Thu, 26 Nov 2020 22:15:29 +0000

> On 26 Nov 2020, at 15:05, David R. Oran <[email-masked]> wrote:
> Dirk and I briefly went over the draft, and it looks OK to us. So, please move it forward.

Thanks – assuming there are no objections from the group, I’ll move this forward on Monday.

Colin