Subject: [icnrg] Resolving the ballot comments on draft-oran-icnrg-qosarch

From: "David R. Oran" <[email-masked]>
Date: Thu, 19 Nov 2020 13:31:33 -0500

I believe this version addresses all the IRSG ballot comments and 
contains new text specifically around my responses to Mallory & 
Spencer’s comments on the ballot (and which we informally resolved via 
email).

If so, this should be ready for progression to IESG conflict review and 
RFC editor processing. Thanks to everybody who read and commented on 
this!

I’ve attached a diff from the prior version in case you want to review 
the changes only.

DaveO

Forwarded message:

> From: [email-masked]
> To: David Oran <[email-masked]>, Dave Oran 
> <[email-masked]>
> Subject: New Version Notification for draft-oran-icnrg-qosarch-06.txt
> Date: Thu, 19 Nov 2020 10:26:59 -0800
>
> A new version of I-D, draft-oran-icnrg-qosarch-06.txt
> has been successfully submitted by Dave Oran and posted to the
> IETF repository.
>
> Name:		draft-oran-icnrg-qosarch
> Revision:	06
> Title:		Considerations in the development of a QoS Architecture for 
> CCNx-like ICN protocols
> Document date:	2020-11-19
> Group:		icnrg
> Pages:		29
> URL:            
> https://www.ietf.org/archive/id/draft-oran-icnrg-qosarch-06.txt
> Status:         
> https://datatracker.ietf.org/doc/draft-oran-icnrg-qosarch/
> Html:           
> https://www.ietf.org/archive/id/draft-oran-icnrg-qosarch-06.html
> Htmlized:       
> https://tools.ietf.org/html/draft-oran-icnrg-qosarch-06
> Diff:           
> https://www.ietf.org/rfcdiff?url2=draft-oran-icnrg-qosarch-06
>
> Abstract:
>    This is a position paper.  It documents the author's personal views
>    on how Quality of Service (QoS) capabilities ought to be 
> accommodated
>    in ICN protocols like CCNx or NDN which employ flow-balanced
>    Interest/Data exchanges and hop-by-hop forwarding state as their
>    fundamental machinery.  It argues that such protocols demand a
>    substantially different approach to QoS from that taken in TCP/IP,
>    and proposes specific design patterns to achieve both 
> classification
>    and differentiated QoS treatment on both a flow and aggregate 
> basis.
>    It also considers the effect of caches in addition to memory, CPU 
> and
>    link bandwidth as a resource that should be subject to explicitly
>    unfair resource allocation.  The proposed methods are intended to
>    operate purely at the network layer, providing the primitives 
> needed
>    to achieve both transport and higher layer QoS objectives.  It
>    explicitly excludes any discussion of Quality of Experience (QoE)
>    which can only be assessed and controlled at the application layer 
> or
>    above.
>
>    This document is not a product of the IRTF Information-Centric
>    Networking Research Group (ICNRG) but has been through formal last
>    call and has the support of the participants in the research group
>    for publication as an individual submission.
>
>
>
>
> Please note that it may take a couple of minutes from the time of 
> submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat

---

From: Colin Perkins <[email-masked]>
Date: Wed, 25 Nov 2020 20:57:00 +0000

Thanks, Dave.

I also believe the IRSG comments have been addressed. If anyone disagrees with that statement, and thinks this draft is not ready to progress, please comment now. If there are no objections by 4 December, I’ll send this draft for IESG conflict review.

Colin

> On 19 Nov 2020, at 18:31, David R. Oran <[email-masked]> wrote:
> 
> I believe this version addresses all the IRSG ballot comments and contains new text specifically around my responses to Mallory & Spencer’s comments on the ballot (and which we informally resolved via email).
> 
> If so, this should be ready for progression to IESG conflict review and RFC editor processing. Thanks to everybody who read and commented on this!
> 
> I’ve attached a diff from the prior version in case you want to review the changes only.
> 
> 
> 
> DaveO
> 
> Forwarded message:
> 
>> To: David Oran <[email-masked]>, Dave Oran <[email-masked]>
>> Title:		Considerations in the development of a QoS Architecture for CCNx-like ICN protocols
>> URL:            https://www.ietf.org/archive/id/draft-oran-icnrg-qosarch-06.txt
>> Status:         https://datatracker.ietf.org/doc/draft-oran-icnrg-qosarch/
>> Html:           https://www.ietf.org/archive/id/draft-oran-icnrg-qosarch-06.html
>> Htmlized:       https://tools.ietf.org/html/draft-oran-icnrg-qosarch-06
>> Diff:           https://www.ietf.org/rfcdiff?url2=draft-oran-icnrg-qosarch-06
>> 
>> Abstract:
>>   on how Quality of Service (QoS) capabilities ought to be accommodated
>>   and proposes specific design patterns to achieve both classification
>>   and differentiated QoS treatment on both a flow and aggregate basis.
>>   It also considers the effect of caches in addition to memory, CPU and
>>   operate purely at the network layer, providing the primitives needed
>>   which can only be assessed and controlled at the application layer or
>>   above.
>> 
>> Please note that it may take a couple of minutes from the time of submission
> <qosarch-06-05diff.txt>

-- 
Colin Perkins
https://csperkins.org/