Subject: [icnrg] Encoding for Robust Immutable Storage (ERIS)

From: pukkamustard <[email-masked]>
Date: Thu, 10 Dec 2020 17:23:30 +0100

Hello ICNRG,

I'd like to request feedback and comments on a proposal I have 
been
working on: Encoding for Robust Immutable Storage (ERIS)
(http://purl.org/eris).

ERIS defines how an arbirtary sequence of bytes can be encoded 
into a
set of uniformly sized, encrypted and content-addressed blocks, 
such
that the original content can only be decoded given a short 
identifier.
This is done by splitting content into blocks and building a 
Merkle
tree.

Encodings like ERIS are common in protocols such as BitTorrent, 
Freenet,
GNUNet, et. al. The goal of ERIS is to define an encoding that is
independant of underlying storage and transport layer - make 
content
referencable regardles of how it is stored or transported.

This work has been very much inspired by ideas from the ICN 
community
and I hope to eventually use NFD for transporting blocks of ERIS 
encoded
content.

I'd be very happy for your comments and thoughts.

Best regards,
pukkamustard

---

From: "Dirk Kutscher" <[email-masked]>
Date: Fri, 18 Dec 2020 13:15:10 +0100

Hi,

> I'd like to request feedback and comments on a proposal I have been

thanks for the link.

I didn't have a chance to check all the details yet, but here are two 
pointers for you (not sure you are already aware):

1. Manifests for File-like collections
	* https://tools.ietf.org/html/draft-irtf-icnrg-flic-02
     * 
https://datatracker.ietf.org/meeting/interim-2020-icnrg-04/materials/slides-interim-2020-icnrg-04-sessa-recap-of-recent-flic-discussion-00

2. RFC 6920: Naming Things with Hashes
     * https://tools.ietf.org/html/rfc6920
     * URI scheme for specifying hashes in URIs with algorithm agility 
and different representation formats

> This work has been very much inspired by ideas from the ICN community

That's a great idea. I am sure you have noticed that ICN has optional 
encryption of DATA messages.

If you are interested, I think it could be useful to understand how your 
application (confidential, censorship-resistant content-based 
communication) could be mapped to ICN.

Best regards,
Dirk

> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg