Subject: [icnrg] Review of "Architectural Considerations of ICN using Name Resolution Service"

From: "Christopher Wood" <[email-masked]>
Date: Mon, 11 Jan 2021 06:54:29 -0800

Document: draft-irtf-icnrg-nrsarch-considerations-05

The summary of the review is: Ready with issues

Comments: 

Given that this is a considerations document for ICNRG, I think the level of detail is probably fine here. My biggest concern is the lack of discussion around NRS mapping management. The document states:

   When an NRS is utilized in an ICN architecture, security threats may
   increase in various aspects...

And then briefly describes "Name Space Management." It states that producer authentication is required, but I would like to see some more discussion there. In particular, is authentication required for only insertion into the NRS? What about updates or removal? (Something like BEAD [1] might help deal with deletion.)

On a related topic, how do clients (resolvers) know if they received the most up-to-date version of an NRS mapping? Should these be stored in cacheable content objects, or in new protocol messages that are not cached? This relates to the discussion around mobility, and I'm not sure how much detail you want to add here. Maybe just mentioning the possibility of stale content as a consideration will suffice.

Lastly, how a NRS impacts client behavior seems a bit unclear at the moment. This document seems to suggest that names can only map to other NDOs, and not, for example, prefixes. Should it be possible to query the NRS with a name prefix, and the NRS performs LPM to return the mapped value? What are the implications for clients if they can query by prefix? Should they always query the NRS before sending an interest for a name?

I hope this helps.

Best,
Chris

[1] https://arxiv.org/pdf/1512.07311.pdf

---

From: Colin Perkins <[email-masked]>
Date: Fri, 15 Jan 2021 18:35:15 +0000

Chris – Thank you for the review!

It seems there’s some discussion, and possibly a revised draft, needed to address these comments, before the draft can proceed in the publication process.

Colin

> On 11 Jan 2021, at 14:54, Christopher Wood <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: "Dirk Kutscher" <[email-masked]>
Date: Mon, 18 Jan 2021 10:19:57 +0100

Thanks, Chris!

What do the authors think?

Dirk

On 15 Jan 2021, at 19:35, Colin Perkins wrote:

> It seems there’s some discussion, and possibly a revised draft, 
> needed to address these comments, before the draft can proceed in the 
> publication process.
>
> Colin
>
>
>> Given that this is a considerations document for ICNRG, I think the 
>> level of detail is probably fine here. My biggest concern is the lack 
>> of discussion around NRS mapping management. The document states:
>>
>> And then briefly describes "Name Space Management." It states that 
>> producer authentication is required, but I would like to see some 
>> more discussion there. In particular, is authentication required for 
>> only insertion into the NRS? What about updates or removal? 
>> (Something like BEAD [1] might help deal with deletion.)
>>
>> On a related topic, how do clients (resolvers) know if they received 
>> the most up-to-date version of an NRS mapping? Should these be stored 
>> in cacheable content objects, or in new protocol messages that are 
>> not cached? This relates to the discussion around mobility, and I'm 
>> not sure how much detail you want to add here. Maybe just mentioning 
>> the possibility of stale content as a consideration will suffice.
>>
>> Lastly, how a NRS impacts client behavior seems a bit unclear at the 
>> moment. This document seems to suggest that names can only map to 
>> other NDOs, and not, for example, prefixes. Should it be possible to 
>> query the NRS with a name prefix, and the NRS performs LPM to return 
>> the mapped value? What are the implications for clients if they can 
>> query by prefix? Should they always query the NRS before sending an 
>> interest for a name?
>>
>> I hope this helps.
>>
>> Best,
>> Chris
>>
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: Jungha Hong <[email-masked]>
Date: Tue, 19 Jan 2021 13:58:08 +0900 (KST)

Dear Chris,

Thanks for your valuable comments.
We will try to improve the draft soon by clarifying the issues identified in the comments as much as possible. 

Thanks,
Jungha Hong

-----Original Message-----
From:  "Dirk Kutscher" <[email-masked]>
To:     "Colin Perkins" <[email-masked]>; 
Cc:     "Christopher Wood" <[email-masked]>;   <[email-masked]>;   <[email-masked]>; 
Sent:  2021-01-18 (월) 18:20:18 (UTC+09:00)
Subject: Re: [icnrg] [irsg] Review of "Architectural Considerations of ICN using Name Resolution Service"

Thanks, Chris!

Dirk