Subject: Re: [icnrg] [irsg] Review of "Architectural Considerations of ICN using Name Resolution Service"

From: Colin Perkins <[email-masked]>
Date: Mon, 5 Apr 2021 18:03:57 +0100

Thank you for updating the draft.

Chris – can you confirm if these changes address your concerns?

Thanks,
Colin

> On 13 Feb 2021, at 07:58, Jungha Hong <[email-masked]> wrote:
> 
> Dear Chris,
> 
> Thanks a lot for the review.
> 
> The revised document, draft-irtf-icnrg-nrsarch-considerations-06 has been just submitted. 
> We tried to address your comments as much as possible. 
> (https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-nrsarch-considerations-06)
> 
> Please take a look at our responses explained in-line below and let us know again if anything is unclear.
> 
> Thanks,
> Jungha Hong 
> 
> 
> -----Original Message-----
> From:  "Christopher Wood" <[email-masked]>
> To:      <[email-masked]>;   <[email-masked]>;   <[email-masked]>; 
> Cc:    
> Sent:  2021-01-11 (월) 23:55:08 (UTC+09:00)
> Subject: Review of "Architectural Considerations of ICN using Name Resolution Service"
> 
> Document: draft-irtf-icnrg-nrsarch-considerations-05
> 
> The summary of the review is: Ready with issues
> 
> Comments: 
> 
> Given that this is a considerations document for ICNRG, I think the level of detail is probably fine here. My biggest concern is the lack of discussion around NRS mapping management. The document states:
> 
>   When an NRS is utilized in an ICN architecture, security threats may
>   increase in various aspects...
> 
> And then briefly describes "Name Space Management." It states that producer authentication is required, but I would like to see some more discussion there. In particular, is authentication required for only insertion into the NRS? What about updates or removal? (Something like BEAD [1] might help deal with deletion.)
> 
> [Editor’s response and revision]
> Authentication is required for all insertion and update of mapping records. We have added text to clarify this point in Section 8 (mainly in NRS protocol and message security.) The update includes the substitution and deletion. 
> 
> On a related topic, how do clients (resolvers) know if they received the most up-to-date version of an NRS mapping? Should these be stored in cacheable content objects, or in new protocol messages that are not cached? This relates to the discussion around mobility, and I'm not sure how much detail you want to add here. Maybe just mentioning the possibility of stale content as a consideration will suffice.
> 
> [Editor’s response and revision]
> As the approaches used in mobility management, we may consider assigning validity time or a lifetime of each mapping record. The lifetime can be renewed only by the authoritative producer or node while the cached mapping records get erased after the lifetime expires unless a lifetime extension indication is obtained from the authoritative producer. This description has been added to the first and last bullets in Section 5.1.  
> 
> Lastly, how a NRS impacts client behavior seems a bit unclear at the moment. This document seems to suggest that names can only map to other NDOs, and not, for example, prefixes. Should it be possible to query the NRS with a name prefix, and the NRS performs LPM to return the mapped value? What are the implications for clients if they can query by prefix? Should they always query the NRS before sending an interest for a name?
> 
> [Editor’s response and revision]
> In this document, we have assumed that name (in general) can be mapped to routable prefixes, locators, alias names, or off-path-cache pointers (in various Sections, e.g. 2, 5). We have not assumed any specific key for searching mapping records. Moreover, we have not mentioned the search key matching procedure. Clients can query by a prefix if the NRS system supports it. Clients are not required to always query the NRS before sending an interest for a named content if the ICN architecture allows ICN routers to perform name resolution. This statement has been written in Section 2 (NRS resolver, NRS client) and Section 5.1 (Name resolution).
> 
> I hope this helps.
> 
> Best,
> Chris
> 
> [1] https://arxiv.org/pdf/1512.07311.pdf
> 
> _______________________________________________
> icnrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/icnrg

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 21 Apr 2021 07:11:43 -0700

> Chris – can you confirm if these changes address your concerns?

Indeed it does -- thanks!

Best,
Chris