Subject: [icnrg] Stephen Farrell's No Objection on draft-irtf-icnrg-nrs-requirements-05: (with COMMENT)

From: Stephen Farrell via Datatracker <[email-masked]>
Date: Tue, 13 Jul 2021 16:07:17 -0700

Stephen Farrell has entered the following ballot position for
draft-irtf-icnrg-nrs-requirements-05: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrs-requirements/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I have a nit and a question that doesn't need to be answered:-)

Nit: The intro says "uniquely identified by IP address" but
anycast exists and doesn't match that (and multicast wouldn't
really either.)

Question: I don't understand how an NRS can do access control
in any realistic context. (The reason that doesn't need to be
answered is that I don't think there really is an answer that
works.) That definitely ought not block the document though.

---

From: Jungha Hong <[email-masked]>
Date: Wed, 14 Jul 2021 13:31:10 +0900 (KST)

Dear Stephen Farrell,

Thanks for your ballot and comments!

We will delete "uniquely" from "uniquely identified by IP address".

On access control, 
this document describes "The NRS system may support access control...." along with two implementation methods (a reference monitor and encryption-based techniques).
It seems good enough since this document provides the NRS design considerations (not requirements or solutions), 

Thanks,
Jungha Hong

-----Original Message-----
From:  "Stephen Farrell via Datatracker" <[email-masked]>
To:     "The IRSG" <[email-masked]>; 
Cc:      <[email-masked]>;   <[email-masked]>;   <[email-masked]>;   <[email-masked]>; 
Sent:  2021-07-14 (수) 08:07:46 (UTC+09:00)
Subject: [icnrg] Stephen Farrell's No Objection on draft-irtf-icnrg-nrs-requirements-05: (with COMMENT)

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg