Subject: [icnrg] I-D Action: draft-irtf-icnrg-nrsarch-considerations-07.txt

From: [email-masked]
Date: Wed, 15 Dec 2021 20:02:56 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Information-Centric Networking RG of the IRTF.

        Title           : Architectural Considerations of ICN using Name Resolution Service
        Authors         : Jungha Hong
                          Tae-Wan You
                          Ved Kafle
	Filename        : draft-irtf-icnrg-nrsarch-considerations-07.txt
	Pages           : 13
	Date            : 2021-12-15

Abstract:
   This document describes architectural considerations and implications
   related to the use of a Name Resolution Service (NRS) in Information-
   Centric Networking (ICN).  It explains how the ICN architecture can
   change when an NRS is utilized and how its use influences the ICN
   routing system.  This document is a product of the Information-
   Centric Networking Research Group (ICNRG).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrsarch-considerations/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-nrsarch-considerations-07

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-nrsarch-considerations-07

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Jungha Hong <[email-masked]>
Date: Fri, 17 Dec 2021 03:01:25 +0900 (KST)

Dear Colin,

We addressed all comments received during the ballot and submitted the updated document. 
We are sorry for taking so long. 

@Melinda Shore
Thanks for your comment. 
Yes, the authenticity of the namespace is in consideration. The paragraph has been revised to clarify this issue.

@Mirja Kühlewind
Thanks for the comment. 
(1) This document describes considerations from the perspective of ICN architecture and routing systems when using an NRS in ICN.
Its companion document (RFC9138) focuses on NRS itself as a service or a system in ICN. 
(2) FIB has been spelled out where it appears for the first time.
(3) Yes, DNS may be used as an NRS. However, the requirements of frequent updates of NRS records due to the creations of a lot of new NDOs and changes 
in their locations in the network need to be considered. This statement has been inserted in Section 2.

@Stephen Farrell
Thanks for the comment. 
(1) Yes, we have revised the first sentence in the "Security" bullet in Section 4 and deleted the last sentence.
(2) Yes, in the security consideration section, we have added text to mention the QNAME minimization type of approach 
to the privacy protection of the NRS name resolution process and Passive DNS type of function for storing and analyzing 
the history of name resolution data to uncover potential security incidents or discover malicious NRS components.

Thanks,
Jungha Hong

-----Original Message-----
From:  "" <[email-masked]>
To:      <[email-masked]>; 
Cc:      <[email-masked]>; 
Sent:  2021-12-16 (목) 13:03:20 (UTC+09:00)
Subject: [icnrg] I-D Action: draft-irtf-icnrg-nrsarch-considerations-07.txt

Abstract:

_______________________________________________
icnrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/icnrg

---

From: Colin Perkins <[email-masked]>
Date: Thu, 16 Dec 2021 18:26:32 +0000

Dear Jungha,

Thank you for updating the draft, and for the detailed response to the comments. I will give a few days for people to review the changes, then if there are no objections send this for IESG conflict review early next week.

Colin

> On 16 Dec 2021, at 18:01, Jungha Hong <[email-masked]> wrote:
> 
> Dear Colin,
> 
> From:  "" <[email-masked] <mailto:[email-masked]>>
> To:      <[email-masked] <mailto:[email-masked]>>; 
> Cc:      <[email-masked] <mailto:[email-masked]>>; 
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/icnrg <https://www.irtf.org/mailman/listinfo/icnrg>

-- 
Colin Perkins
https://csperkins.org/

---

From: Melinda Shore <[email-masked]>
Date: Thu, 16 Dec 2021 12:14:24 -0900

> Yes, the authenticity of the namespace is in consideration. The paragraph has been revised to clarify this issue.

Looks good - many thanks!

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Jungha Hong <[email-masked]>
Date: Fri, 17 Dec 2021 18:45:49 +0900 (KST)

Dear Colin,

Thanks for taking care of it.

Jungha Hong

-----Original Message-----
From: "Colin Perkins" &lt;[email-masked]&gt;
To: "Jungha Hong" &lt;[email-masked]&gt;;
Cc: "The IRSG" &lt;[email-masked]&gt;; &lt;[email-masked]&gt;; &lt;[email-masked]&gt;; &lt;[email-masked]&gt;;
Sent: 2021-12-17 (금) 03:27:00 (UTC+09:00)
Subject: Re: [icnrg] I-D Action: draft-irtf-icnrg-nrsarch-considerations-07.txt

Dear Jungha,

Colin

On 16 Dec 2021, at 18:01, Jungha Hong &lt;[email-masked] mailto:[email-masked]&gt; wrote:
Dear Colin,We addressed all comments received during the ballot and submitted the updated document.&nbsp;We are sorry for taking so long.&nbsp;@Melinda ShoreThanks for your comment.&nbsp;Yes, the authenticity of the namespace is in consideration. The paragraph has been revised to clarify this issue.@Mirja KühlewindThanks for the comment.&nbsp;(1) This document describes considerations from the perspective of ICN architecture and routing systems when using an NRS in ICN.Its companion document (RFC9138) focuses on NRS itself as a service or a system in ICN.&nbsp;(2) FIB has been spelled out where it appears for the first time.(3) Yes, DNS may be used as an NRS. However, the requirements of frequent updates of NRS records due to the creations of a lot of new NDOs and changes&nbsp;in their locations in the network need to be considered. This statement has been inserted in Section 2.@Stephen FarrellThanks for the comment.&nbsp;(1) Yes, we have revised the first sentence in the "Security" bullet in Section 4 and deleted the last sentence.(2) Yes, in the security consideration section, we have added text to mention the QNAME minimization type of approach&nbsp;to the privacy protection of the NRS name resolution process and Passive DNS type of function for storing and analyzing&nbsp;the history of name resolution data to uncover potential security incidents or discover malicious NRS components.Thanks,Jungha Hong-----Original Message-----From: &nbsp;"" &lt;[email-masked] mailto:[email-masked]&gt;To: &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&lt;[email-masked] mailto:[email-masked]&gt;;&nbsp;Cc: &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&lt;[email-masked] mailto:[email-masked]&gt;;&nbsp;Sent: &nbsp;2021-12-16 (목) 13:03:20 (UTC+09:00)Subject: [icnrg] I-D Action: draft-irtf-icnrg-nrsarch-considerations-07.txtA New Internet-Draft is available from the on-line Internet-Drafts directories.This draft is a work item of the Information-Centric Networking RG of the IRTF.&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Title &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: Architectural Considerations of ICN using Name Resolution Service&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Authors &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: Jungha Hong&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Tae-Wan You&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Ved KafleFilename &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: draft-irtf-icnrg-nrsarch-considerations-07.txtPages &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: 13Date &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: 2021-12-15Abstract:&nbsp;&nbsp;This document describes architectural considerations and implications&nbsp;&nbsp;related to the use of a Name Resolution Service (NRS) in Information-&nbsp;&nbsp;Centric Networking (ICN). &nbsp;It explains how the ICN architecture can&nbsp;&nbsp;change when an NRS is utilized and how its use influences the ICN&nbsp;&nbsp;routing system. &nbsp;This document is a product of the Information-&nbsp;&nbsp;Centric Networking Research Group (ICNRG).The IETF datatracker status page for this draft is:https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrsarch-considerations/ https://datatracker.ietf.org/doc/draft-irtf-icnrg-nrsarch-considerations/There is also an htmlized version available at:https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-nrsarch-considerations-07 https://datatracker.ietf.org/doc/html/draft-irtf-icnrg-nrsarch-considerations-07A diff from the previous version is available at:https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-nrsarch-considerations-07 https://www.ietf.org/rfcdiff?url2=draft-irtf-icnrg-nrsarch-considerations-07Internet-Drafts are also available by rsync at rsync.ietf.org http://rsync.ietf.org::internet-drafts_______________________________________________icnrg mailing [email-masked] mailto:[email-masked]://www.irtf.org/mailman/listinfo/icnrg https://www.irtf.org/mailman/listinfo/icnrg

--&nbsp;Colin Perkinshttps://csperkins.org/ https://csperkins.org/