Subject: [Id-event] Fwd: New Version Notification for draft-hunt-idevent-token-01.txt

From: Phil Hunt <[email-masked]>
Date: Fri, 8 Apr 2016 15:55:30 -0300

In this update to draft-hunt-idevent-token, William Denniss and John Bradley proposed to generalize the event uri format to be any URI rather than just URN. An example was also added for OIDC Logout (non-normative - since the core spec won’t have normative events just examples).  Thanks William for revising the text.

I think we may have to add some text around event type URIs. For example, suggesting that fragments could be use to distinguish individual events that may be specified in a parent specification.  E.g. So while Logout might define only one event, a RISC or SCIM events spec will define many.  Also, IETF has multiple paths to its RFCs and the change to numbering. Not sure what will be best for SCIM events in this regard - maybe using urn’s works best for IETF specs?  Guidance greatly welcomed!

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-hunt-idevent-token-01.txt
> Date: April 8, 2016 at 3:46:24 PM GMT-3
> To: "William Denniss" <[email-masked]>, "Phil Hunt" <[email-masked]>, "Morteza Ansari" <[email-masked]>
> 
> 
> A new version of I-D, draft-hunt-idevent-token-01.txt
> has been successfully submitted by Phil Hunt and posted to the
> IETF repository.
> 
> Name:		draft-hunt-idevent-token
> Revision:	01
> Title:		Identity Event Token
> Document date:	2016-04-08
> Group:		Individual Submission
> Pages:		14
> URL:            https://www.ietf.org/internet-drafts/draft-hunt-idevent-token-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-hunt-idevent-token/
> Htmlized:       https://tools.ietf.org/html/draft-hunt-idevent-token-01
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-hunt-idevent-token-01
> 
> Abstract:
>   This specification defines an Identity Event token which may be
>   distributed via a protocol such as HTTP.  An identity event token is
>   based on the JSON Web Token and may be optionally signed and/or
>   encrypted.  It describes a statement of fact that may be shared by an
>   event publisher with registered subscribers.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: John Bradley <[email-masked]>
Date: Fri, 8 Apr 2016 18:43:41 -0300

I asked the RFC editor about best practice for using URI, but she didn’t know off hand.  I will have to check into it some more.  Perhaps the only option for RFC is to use URN but that seems a bit limiting.

Other people like W3C and OIDF don’t seem to have a problem with URI for namespaces.

John B.
> On Apr 8, 2016, at 3:55 PM, Phil Hunt <[email-masked]> wrote:
> 
>> From: [email-masked] <mailto:[email-masked]>
>> To: "William Denniss" <[email-masked] <mailto:[email-masked]>>, "Phil Hunt" <[email-masked] <mailto:[email-masked]>>, "Morteza Ansari" <[email-masked] <mailto:[email-masked]>>
>> 
>> 
>> URL:            https://www.ietf.org/internet-drafts/draft-hunt-idevent-token-01.txt <https://www.ietf.org/internet-drafts/draft-hunt-idevent-token-01.txt>
>> Status:         https://datatracker.ietf.org/doc/draft-hunt-idevent-token/ <https://datatracker.ietf.org/doc/draft-hunt-idevent-token/>
>> Htmlized:       https://tools.ietf.org/html/draft-hunt-idevent-token-01 <https://tools.ietf.org/html/draft-hunt-idevent-token-01>
>> Diff:           https://www.ietf.org/rfcdiff?url2=draft-hunt-idevent-token-01 <https://www.ietf.org/rfcdiff?url2=draft-hunt-idevent-token-01>
>> 
>> Abstract:
>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>> 
>> The IETF Secretariat
>> 
> 
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event

---

From: Nick Roy <[email-masked]>
Date: Fri, 8 Apr 2016 21:53:35 +0000

URIs in the form of URL have the additional possible benefit of housing documentation at the URL used for the namespace, that is, they are resolvable.

Nick

From: Id-event <[email-masked]<mailto:[email-masked]>> on behalf of John Bradley <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 8, 2016 at 3:43 PM
To: Phil Hunt <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Id-event] Fwd: New Version Notification for draft-hunt-idevent-token-01.txt

John B.
On Apr 8, 2016, at 3:55 PM, Phil Hunt <[email-masked]<mailto:[email-masked]>> wrote:

Phil

@independentid
www.independentid.com<http://www.independentid.com/>
[email-masked]<mailto:[email-masked]>

Begin forwarded message:

From: [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-hunt-idevent-token-01.txt
Date: April 8, 2016 at 3:46:24 PM GMT-3
To: "William Denniss" <[email-masked]<mailto:[email-masked]>>, "Phil Hunt" <[email-masked]<mailto:[email-masked]>>, "Morteza Ansari" <[email-masked]<mailto:[email-masked]>>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

_______________________________________________
Id-event mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/id-event

---

From: John Bradley <[email-masked]>
Date: Fri, 8 Apr 2016 19:00:05 -0300

Exactly.

It also makes it posable for a university or someone to crate a local namespace without jumping through a IANA hoop that they wouldn’t do.

It is way better to have developers use a URI in there own namespace than make up unregistered URN that are going to collide.

You know they will:)

John B.

> On Apr 8, 2016, at 6:53 PM, Nick Roy <[email-masked]> wrote:
> 
> From: Id-event <[email-masked] <mailto:[email-masked]>> on behalf of John Bradley <[email-masked] <mailto:[email-masked]>>
> To: Phil Hunt <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> On Apr 8, 2016, at 3:55 PM, Phil Hunt <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/id-event <https://www.ietf.org/mailman/listinfo/id-event>
>

---

From: Phil Hunt <[email-masked]>
Date: Fri, 8 Apr 2016 19:04:29 -0300

That is why we are considering it. However it doesn’t work well for IETF since there are multiple ways of referencing the same RFC.

This would lead to processing complexity and confusion by subscribers as they might not recognize the difference between say:
https://tools.ietf.org/html/rfc6749 <https://tools.ietf.org/html/rfc6749>
https://tools.ietf.org/pdf/rfc6749.pdf <https://tools.ietf.org/pdf/rfc6749.pdf>
https://datatracker.ietf.org/doc/rfc6749/ <https://datatracker.ietf.org/doc/rfc6749/>
and
https://tools.ietf.org/rfc/rfc6749.txt <https://tools.ietf.org/rfc/rfc6749.txt>

So while the “txt” is considered normative, you can see why some developers wanting to generate events might be as confused and send something the subscriber can’t automatically recognize.

Phil

@independentid

---

From: Phil Hunt <[email-masked]>
Date: Fri, 8 Apr 2016 19:08:23 -0300

I should add, that within reason, I think it is ok for different organizations to use what they prefer to use editorially. So I see no issue with IETF specs using urns while others might use an http referenced spec.  That’s why we opened it up a bit.

Phil

@independentid

> On Apr 8, 2016, at 7:04 PM, Phil Hunt <[email-masked]> wrote:
> 
>> On Apr 8, 2016, at 6:53 PM, Nick Roy <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Nick Roy <[email-masked]>
Date: Fri, 8 Apr 2016 22:13:45 +0000

Seems like that is a document namespacing issue that should be pretty straightforward for IETF to resolve.  Is Heather aware that this is a need?

Nick

From: Phil Hunt <[email-masked]<mailto:[email-masked]>>
Date: Friday, April 8, 2016 at 4:04 PM
To: Nick Roy <[email-masked]<mailto:[email-masked]>>
Cc: John Bradley <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Id-event] Fwd: New Version Notification for draft-hunt-idevent-token-01.txt

This would lead to processing complexity and confusion by subscribers as they might not recognize the difference between say:
https://tools.ietf.org/html/rfc6749
https://tools.ietf.org/pdf/rfc6749.pdf
https://datatracker.ietf.org/doc/rfc6749/
and
https://tools.ietf.org/rfc/rfc6749.txt

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>

On Apr 8, 2016, at 6:53 PM, Nick Roy <[email-masked]<mailto:[email-masked]>> wrote:

Nick

John B.

Phil

@independentid

Begin forwarded message:

Abstract:

The IETF Secretariat

---

From: John Bradley <[email-masked]>
Date: Fri, 8 Apr 2016 20:06:28 -0300

The spec needs to say what the URI is.  The problem is you don't know the
name of the spec untill it is done.

There must be a way to do it.  We just need to find the person who knows.
There is a expired ID on the topic.
On Apr 8, 2016 7:04 PM, "Phil Hunt" <[email-masked]> wrote:

> That is why we are considering it. However it doesn’t work well for IETF
> since there are multiple ways of referencing the same RFC.
>
> This would lead to processing complexity and confusion by subscribers as
> they might not recognize the difference between say:
> So while the “txt” is considered normative, you can see why some
> developers wanting to generate events might be as confused and send
> something the subscriber can’t automatically recognize.
>
> Phil
>
> @independentid
> www.independentid.com
> [email-masked]
>
>
>
>
>
> URIs in the form of URL have the additional possible benefit of housing
> documentation at the URL used for the namespace, that is, they are
> resolvable.
>
> Nick
>
> From: Id-event <[email-masked]> on behalf of John Bradley <
> [email-masked]>
> To: Phil Hunt <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> I asked the RFC editor about best practice for using URI, but she didn’t
> know off hand.  I will have to check into it some more.  Perhaps the only
> option for RFC is to use URN but that seems a bit limiting.
>
> In this update to draft-hunt-idevent-token, William Denniss and John
> Bradley proposed to generalize the event uri format to be any URI rather
> than just URN. An example was also added for OIDC Logout (non-normative -
> since the core spec won’t have normative events just examples).  Thanks
> William for revising the text.
>
> I think we may have to add some text around event type URIs. For example,
> suggesting that fragments could be use to distinguish individual events
> that may be specified in a parent specification.  E.g. So while Logout
> might define only one event, a RISC or SCIM events spec will define many.
> Also, IETF has multiple paths to its RFCs and the change to numbering. Not
> sure what will be best for SCIM events in this regard - maybe using urn’s
> works best for IETF specs?  Guidance greatly welcomed!
>
> Phil
>
> @independentid
> www.independentid.com
> [email-masked]
>
>
>
>
>
> Begin forwarded message:
>
> *From: [email-masked]
> *Subject: **New Version Notification for draft-hunt-idevent-token-01.txt*
> *Date: *April 8, 2016 at 3:46:24 PM GMT-3
> *To: *"William Denniss" <[email-masked]>, "Phil Hunt" <
> [email-masked]>, "Morteza Ansari" <[email-masked]>
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-hunt-idevent-token-01.txt
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-hunt-idevent-token-01
>
> Abstract:

---

From: "Phil Hunt (IDM)" <[email-masked]>
Date: Fri, 8 Apr 2016 22:54:04 -0300

I think I know a way. 

Phil

> On Apr 8, 2016, at 20:06, John Bradley <[email-masked]> wrote:
> 
> The spec needs to say what the URI is.  The problem is you don't know the name of the spec untill it is done. 
> 
> There must be a way to do it.  We just need to find the person who knows.  There is a expired ID on the topic. 
>>> From: Id-event <[email-masked]> on behalf of John Bradley <[email-masked]>