Subject: [Id-event] Review of latest SET draft

From: William Denniss <[email-masked]>
Date: Fri, 2 Sep 2016 16:29:51 -0700

The draft is looking very good, and it's great to see some consensus
building.

My only major comment is on page 5 in the section that starts "A SET has
the following structure:". I'm not a fan of the terminology "outer JSON
structure" and "SET envelope" which makes it sound more complicated than it
is, and I'm not sure reflects the recent changes where it's OK again to
have a top-level sub, etc. Can we simply refer to these as "top level JWT
claims"?  The third bullet point on the "event payload" seems fine.

I'd be happy to propose an edit of that language that refers to these
claims in typical JWT parlance.

Other minor nit:

In section 2.1, "Core SET claims" most claims start with "As defined by…"
yet 'iss' and 'aud' do not. Let's be consistent and add "As defined by..."
to those too.

---

From: Phil Hunt <[email-masked]>
Date: Fri, 2 Sep 2016 16:53:50 -0700

+1.  I think the text could be improved. Would welcome a proposal.

The other nits, I’ll pick up.

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On Sep 2, 2016, at 4:29 PM, William Denniss <[email-masked]> wrote:
> 
> The draft is looking very good, and it's great to see some consensus building.
> 
> My only major comment is on page 5 in the section that starts "A SET has the following structure:". I'm not a fan of the terminology "outer JSON structure" and "SET envelope" which makes it sound more complicated than it is, and I'm not sure reflects the recent changes where it's OK again to have a top-level sub, etc. Can we simply refer to these as "top level JWT claims"?  The third bullet point on the "event payload" seems fine.
> 
> I'd be happy to propose an edit of that language that refers to these claims in typical JWT parlance.
> 
> Other minor nit:
> 
> In section 2.1, "Core SET claims" most claims start with "As defined by…" yet 'iss' and 'aud' do not. Let's be consistent and add "As defined by..." to those too.
> 
> _______________________________________________
> Id-event mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/id-event